win2000服务器设置全攻略

《win2000服务器设置全攻略》由 中华电脑书库 收集整理，版权归原作者所有。仅供学习、研究、交流之用。如果需要用作商业用途请和原作者联系。更多书籍请访问:
http://www.pcbookcn.com

点击这里开始阅读

首页 | 域名注册 | 虚拟主机 | 企业邮局 | 网站推广 | 智能建站 | 技术支持 | 客户留言
透明网络 是国际域名一级注册商，新网优秀代理，美国NAC、HE数据中心合作伙伴……
透明网络和首信、环讯、广东银联以及各大银行全面合作，能支持20多家银行的60余种银行卡的 在线实时支付，您足不出户就能安全、方便、快截的购买我们的产品。在线支付中心
国际域名： 最低60元/年 送自主管理系统！ >>查看管理界面
个人特惠套餐：50M HTML空间+国际域名+3个信箱=180元/年
个人经济套餐： 60M+国际域名+5个信箱+ASP/ACCESS/CGI/FSO支持=245元/年
企业基础套餐：150M+国际域名+5个信箱+ASP/ACCESS/CGI/FSO支持=330元/年
企业高级套餐：500M+国际域名+5个信箱+ASP/ACCESS/CGI/FSO支持+聊天室支持=940元/年
250M空间+PHP+MYSQL(无限制)+管理系统+国际域名=375元/年 （此款主机可按月付费）
500M空间+PHP+MYSQL(无限制)+管理系统+国际域名=675元/年 （此款主机可按月付费）
基本型邮局/100M邮箱空间+最多能开20个信箱/推广价：130元/年
增强型邮局I/300M邮箱空间+最多能开60个信箱/推广价：280元/年
增强型邮局II/500M邮箱空间+/最多能开100个信箱/推广价：420元/年
商用型邮局I/1G邮箱空间+最多能开200个信箱/推广价：650元/年
商用型邮局II/2.5G邮箱空间+最多能开500个信箱/推广价：1400元/年
专用型邮局I/5G邮箱空间+最多能开1000个信箱/推广价：3500元/年
专用型邮局II/9G邮箱空间+最多能开1800个信箱/推广价：4900元/年
新浪普通型登陆： 260元/年 （市场价为：300元/年） >>查看市场价
搜狐普通型登陆： 260元/年 （市场价为：300元/年） >>查看市场价
网易普通型登陆： 450元/年 （市场价为：500元/年） >>查看市场价
新浪推广型登陆： 2200元/年 （市场价为：2500元/年） >>查看市场价
搜狐推广型登陆： 2200元/年 （市场价为：2500元/年） >>查看市场价
网易推广型登陆： 2200元/年 （市场价为：2500元/年） >>查看市场价
百度竞价排名：9.5折
3721网络实名：450元/年 （市场价：500元/年） >>查看市场价


win2000服务器设置全攻略

win2000服务器设置全攻略（一） | win2000服务器设置全攻略（二十一）
win2000服务器设置全攻略（二） | win2000服务器设置全攻略（二十二）
win2000服务器设置全攻略（三） | win2000服务器设置全攻略（二十三）
win2000服务器设置全攻略（四） | win2000服务器设置全攻略（二十四）
win2000服务器设置全攻略（五） | win2000服务器设置全攻略（二十五）
win2000服务器设置全攻略（六） | win2000服务器设置全攻略（二十六）
win2000服务器设置全攻略（七） | win2000服务器设置全攻略（二十七）
win2000服务器设置全攻略（八） | win2000服务器设置全攻略（二十八）
win2000服务器设置全攻略（九） | win2000服务器设置全攻略（二十九）
win2000服务器设置全攻略（十） | win2000服务器设置全攻略（三十）
win2000服务器设置全攻略（十一） | win2000服务器设置全攻略（三十一）
win2000服务器设置全攻略（十二） | win2000服务器设置全攻略（三十二）
win2000服务器设置全攻略（十三） | win2000服务器设置全攻略（三十三）
win2000服务器设置全攻略（十四） | win2000服务器设置全攻略（三十四）
win2000服务器设置全攻略（十五） | win2000服务器设置全攻略（三十五）
win2000服务器设置全攻略（十六） | win2000服务器设置全攻略（三十六）
win2000服务器设置全攻略（十七） | win2000服务器设置全攻略（三十七）
win2000服务器设置全攻略（十八） | win2000服务器设置全攻略（三十八）
win2000服务器设置全攻略（十九） | win2000服务器设置全攻略（三十九）
win2000服务器设置全攻略（二十） | win2000服务器设置全攻略（四十）


：：中华电脑书库：：http://www.pcbookcn.com—Win2000服务器设置全攻略

Win2000服务器设置全攻略（一）

前言

    目的：将一台装有Windows 2000 Advanced server的计算机设置成一个具有域名解析（DNS）、WWW浏览、FTP文件传输、Web页面聊天室、Web页面BBS、网络电话、电子邮件收发（E-mail）、ICQ、自动分配IP地址（DHCP）等的全功能服务器。

    其中：邮件服务器使用IMail Administrator Version 6.04 EVAL；ICQ服务器使用ICQ Groupware Server Ver. 1.12 Beta ；网络电话使用Netmeeting 2.1；Web页面的聊天室和BBS均使用相应的ASP程序。

    注意：1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。

    其他：

    一、添加DNS、IIS和DHCP

    1、IIS
    操作：控制面板→添加/删除程序→添加/删除Windows组件→Internet信息服务→全选

    2、DHCP和DNS
    操作：控制面板→添加/删除程序→添加/删除Windows组件→网络服务→选中“动态主机配置协议DHCP”和“域名服务系统DNS”

    二、网络属性设置
    操作：控制面板→网络和拨号连接→本地连接→属性→Internet协议(TCP/IP)→属性→使用下面的IP地址

    其中：
    1/2)IP地址为：192.168.0.1；子网掩码为：255.255.255.0；其他可不用改
    2/2)也可给服务器多设几个IP。比如再增加一个192.168.0.2，可选“高级→添加”；子网掩码为255.255.255.0
    三、DHCP（动态主机配置）

    1、调用DHCP
    操作：开始菜单→程序→管理工具→DHCP

    2、添加DHCP服务器
    操作：DHCP→右键→添加服务器→浏览→选中要增加的服务器名

    3、设置DHCP服务器
    操作：选中服务器名→右键→新建作用域

    其中：
    1/5)“作用域名”中，“名称”项，可任填一个名称
    2/5)“IP地址范围”中，“起始IP地址”项，如填写：192.168.0.10；“结束IP地 址”项，如填写：192.168.0.244；“子网掩码”项，　　如填写：255.255.255.0。如下图：

    3/5)“添加排除”中，如果有必要，可填写服务器不分配的地址或地址范围；如果不需，则直接“下一步”

    4/5)“租约期限”可设一年（即365天）。如下图：

    5/5)依次配置分配给工作站的默认的网关、DNS、WINS，均填写并添加如下IP：192.168.0.1

    ［关闭本窗口］


Win2000服务器设置全攻略（十）

前言

注意：1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。

八、聊天室

(一)关于本聊天室程序

1、本聊天室使用ASP编程实现

2、本聊天室程序选自“旗标系列图书”《Active Server Pages & Web数据库》（王国荣 著；朱琳杰、王伟 改编；人民邮电出版社）。为举例方便起见，我在一些末节上略作了修改

3、我99%不懂ASP，因此除了不能用之外，其他的修改，请不要问我

(二)使用说明

1、下载

1/2)压缩文件内包括1个源文件及本说明文件（readme.htm），共约54.6K

2/2)地址：http://nanshan.363.net/down/search.zip

2、安装

1/2)将得到的search.zip文件解压到C:\Inetpub\wwwroot（所设WWW的根目录）下任意一个文件夹中（比如放在根目录下）。文件名为search.asp

2/2)调用网址为：http://www.lianhe.com/search.asp

3、使用

1/3)修改search.asp

a、如果要改文件名，比如改成default.asp，则文件内容的相应部分应作改动，必须与文件名保持一致。如下图两个画红圈处：

b、如果是从WWW的根目录开始搜索，则画红线处为“/”；如果是从当前目录的下一级目录（比如abc）开始搜索，则画红线处为“abc”；如果abc是根目录下的一级子目录，则画红线处也可为“/abc”。如上图画红线处：

2/3)进入http://www.lianhe.com/default.asp后（“/default.asp”部分一般为默认调用的文件名，因此也可省略），即为该搜索引擎的主页面。如下图：

3/3)输入欲搜索的内容（如“轻舟已过万重山”），再按“搜索”（或敲回车键）即可找到含有相应字符串的HTML文件的标题，点击链接便进入相应页面。如下图：

(----待续----)


Win2000服务器设置全攻略（十一）

前言

注意：1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。

九、网上购物

(一)关于本网上购物程序

1、本网上购物程序使用ASP编程结合调用Access数据库来实现

2、本网上购物程序选自“旗标系列图书”《Active Server Pages & Web数据库》（王国荣 著；朱琳杰、王伟 改编；人民邮电出版社）。在具体使用中，我发现了一些问题，并作了相应的修改

1/4)原文选定欲购物品后(buy.asp)会进入一个近似空白的确认页面(add.asp)——改成自动转入购物袋(check.asp)的页面。如下图：

2/4)原文的购物袋(check.asp)中，当所有的复选框均未选中时，按“更改数量”按钮会有出错信息——改成直接跳转到空物袋(clear.asp)所在页。如下图：

3/4)原文的购物袋(check.asp)中，当“数量”输入<=0的数时，是没有任何更改效果的操作——改成删除相应记录。如下图：

以及下图：

4/4)原文当按了“退回所有物品”后，进入空物袋的页面，但Session并没有清除——改成清除所有Session。如下图：

3、我98%不懂ASP，因此除了不能用之外，其他的修改，请不要问我

(二)使用说明

1、下载

1/2)压缩文件内包括9个源文件及本说明文件（readme.htm），共约281K

2/2)地址：http://nanshan.363.net/down/sale.zip

2、安装

1/2)在C:\Inetpub\wwwroot（所设WWW的根目录）下建立一个名为sale的文件夹，将得到的sale.zip文件解压到sale中

2/2)调用网址为：http://www.lianhe.com/sale/main.asp

3、使用

1/4)进入http://www.lianhe.com/sale/main.asp后，即为该网上购物的主页面。如下图：

2/4)比如欲选“圣诞节礼物”。如下图：

3/4)进入购物袋后，可更改所选物品的数量、删除部分（将复选框的勾去掉或将“数量”设为0）或全部（选“退回所有物品”）物品等。如下图：

4/4)欲改商品编号、名称、单价、简介等，可用Access打开shopbag.mdb来实现。

(----待续----)


Win2000服务器设置全攻略（十二）

    前言

    注意：

    1/2)本文限在局域网中；

    2/2)本文未特定指出处，均使用其默认选项。

十一、Netmeeting

(一)安装装2K/NT/98时系统默认已经安装好了Netmeeting。如果需重新安装，选择“控制面板→添加/删除程序→Windows安装程序→通讯”。如下图：

    (二)使用

    1、第一次运行Netmeeting时系统会自动要求输入个人信息、配置耳机话筒等 2、两台机器联络 1/2)可以使用对方的IP地址来呼叫并建立通话。输入对方的IP地址后再回车（或单击电话的图标）即可发出呼叫请求。下图为已建立成功的屏幕：

     2/2)也可以使用对方的计算机名来呼叫并建立通话。输入对方的计算机名后再回车（或单击电话的图标）即可发出呼叫请求。下图为建立成功的屏幕：

     3、多台机器进行电话会议 1/2)任选一台机器作为“会议主持人”，并建立一个会议。选“呼叫→主持会议”，输入会议的名称（不
支持中文！）和加入会议所需的密码（也可不用）；还可以进行其他控制。如下图：

    2/2)用如上面“2、两台机器联络”的方法呼叫欲邀请入会者；或由要求入会者用此方法呼叫你。通过这种方法则可让多人加入会议，一起进行讨论。

    4、其他操作

    1/3)设置成自动接受呼叫。选“呼叫→自动接收呼叫”让它打上勾即可。如下图：

    2/3)修改个人信息。选“工具→选项”。如果只是想在局域内部使用，不要选中“在Netmeeting开始时登录一个服务器”；当确认退出
时提示“现在想登录吗”也选择“否”！如下图：

    3/3)如需经常跟某台机器联络，可将它设成一个快捷方式，放到桌面。以后当双击此快捷方式时，会自动调出Netmeeting ，并按设定与对方进行联络。选“呼叫→创建快捷拨号”，输入对方的计算机名或IP地址，选中“保存在桌面”一项。如下图：

    成功后桌面上会多出一个如下的图标：


Win2000服务器设置全攻略（十三）

前言

    注意：

    1/2)本文限在局域网中；

    2/2)本文未特定指出处，均使用其默认选项。

十二、终端服务-WBT

(一)服务器端安装

    1、选择“控制面板→添加/删除程序→添加/删除Windows组件”，选中“终端服务”和“终端服务授权”两项。如下图：

    2、安装成功，则可在“开始→程序→管理工具”中看到。如下图：

    3、制作客户端安装盘。选“终端服务器客户端生成器”（如上图）；共需两张软盘。如下图：

(二)客户端安装和使用

    1、客户端安装。执行第一张安装软盘中的setup.exe；各项均选默认选项即可。安装好后如下图：

    2、客户端登录

    1/5)选“终端服务客户端”（如上图），在“服务器”项输入2K服务器的IP地址或机器名；在“屏幕区域”中可选择将打开窗口的分辨率，再选“连接”。如下图：

    2/5)当出现登录的对话框时，输入用户账号和密码（必须是2K的有效用户），再选“确定”。如下图：

    3/5)下图为已成功建立连接后客户端的窗口（为服务器端的屏幕，其嵌套于客户端的屏幕中；全屏显示和窗口显示的切换键是:Ctrl+Alt+Break）：

    4/5)可像运行自己机器上的软件一样使用2K服务器中的内容了；可像关闭其他普通窗口一样关闭些连接窗口）

    5/5)做一次客户端安装盘好像只能装一台机器；要再装其他的机器，可以考虑重新作客户端安装盘


错误 404

HTTP 错误 404

404 找不到

Web 服务器找不到您所请求的文件或脚本。请检查 URL 以确保路径正确。

如果问题依然存在，请与服务器的管理员联系。


Win2000服务器设置全攻略（十五）

前言：

系统策略编辑器(2/2)

(一)以下功能均通过“系统策略编辑器”来实现。关于它的使用说明请见教程14

(二)系统策略编辑器的应用

    1、在“本地计算机”属性中

    1)目的：启动后自动执行某个程序（默认：无）

    ..操作：系统→运行→下面的窗口中输入欲执行程序的命令行

    2)目的：限制能容许客户机试图用非法的用户名／密码登录的次数（默认：无）

    ..操作：WindowsNT远程访问→不成功的身份难验证重试的最大数→下面的窗口中输入数字

    3)目的：允许自行修改共享文件夹的某些部分（默认：均有）

    ..操作：WindowsNT外壳界面→自定义共享文件夹→...

    ..说明：其下有多项。如下图：

    4)目的：登录时出现一个“警示”窗口（默认：有）

    ..操作：WindowsNT系统→登录→登录标记→下面的窗口中输入警示窗口的名称和内容

    5)目的：可以在登录窗口直接正常关机（默认：无）

    ..操作：WindowsNT系统→登录→允许从身份验证对话框中关机

    ..疑问：此项好像对NT有用，而好像对2K好像没用

    6)目的：显示上次登录的用户名（默认：有）

    ..操作：WindowsNT系统→登录→不显示上次登录的用户名

    2、在“本地用户”属性中

    1)目的：进入“控制面板→显示器”后，需要隐藏其中的“背景”、“屏幕保护程序”、“外观”、“设置”等选项或拒绝访问显示图标（默认：无）

    ..操作：控制面板→显示→限制显示→...

    ..说明：其下有多项。如下图：

    2)目的：（默认：均无）

    ....①删除开始菜单中指定的项目；

    ....②隐藏“我的电脑”中的驱动器；

    ....③隐藏“网上邻居”或网上邻居中的“整个网络”或工作组目录；

    ....④隐藏桌面上所有图标

    ....⑤退出时不保存设置

    ..操作：外壳界面→限制→...

    ..说明：其下有多项。如下图：

    3)目的：禁止使用注册表编辑工具来修改注册表（默认：无）

    ..操作：系统→限制→禁用注册表编辑工具

    4)目的：除了指定的Windows应用程序外，其他的都不允许运行（默认：无）

    ..操作：系统→限制→只运行许可的Windows应用程序→显示→添加→输入：程序名→确定

    ..说明：可输入一个或多个程序文件名。如下图：

    5)目的：允许自行修改某些文件夹的某些部分（默认：均有）

    ..操作：WindowsNT外壳界面→自定义文件夹→...

    ..说明：其下有多项。如下图：

    6)目的：隐藏开始菜单下的所有子文件夹（默认：无）

    ..操作：WindowsNT外壳界面→自定义文件夹→隐藏“开始菜单”子文件夹

    7)目的：删除或禁用一些内容（默认：均无）

    ..操作：WindowsNT外壳界面→限制→...

    ..说明：其下有多项。如下图：

    8)目的：禁止注销当前用户（默认：无）

    ..操作：WindowsNT系统→禁止注销

    9)目的：禁止使用任务管理器－－即按Ctrl+Alt+Del三键后可选的那个任务管理器（默认：无）

    ..操作：WindowsNT系统→禁用任务管理器


Win2000服务器设置全攻略（十六）

  安装和配置BBS——FreeBBS

(一)FreeBBS

    1、软件名称：FreeBBS for Acceess

    2、软件功能：BBS服务器端软件（98/NT/2K），功能非常完善

    3、软件类型：免费软件(ASP程序+Acceess数据库)

    4、c公司主页：http://free_bbs.soim.net/

    5、下载地址：点此处下载（bbsac.zip，102K）

(二)安装FreeBBS

    1、将bbsac.zip解压到任意目录下（如：/bbs1）

    2、在此目录下建立一个新的子目录（如：/bbs1/dbf），将名为bbs.mdb的文件移动到此目录下。如下图：

    3、用记事本打开commmon.inc文件，更改bbs.mdb文件的路径（如：\bbs1\dbf）。如下图选中处：

     4、调用地址：http://计算机名/主文件所在路径/default.asp。如下图：

（三）使用FreeBBS

    1、服务器端的前期准备工作

1/3)进入“系统登录”，以管理员的身份登录（默认用户名和密码均为：bbsadmin）成功后进入主页面。如下图：

    2/3)开辟新的讨论区。选“开辟新的分类”，输入新讨论区的名称和说明。如下图：

     3/3)开辟新的版面。进入某个讨论区，再选“申请新版”建具体的版面。如下图：

     2、客户端使用此BBS

     1/3)除管理员bbsadmin外，其他用户第一次使用前，需先进行注册，选“用户注册”一项，注册之后进行“系统登录”；也可不用注册，直接用任意未曾注册过的名字进行“系统登录”（不需密码） 2/3)“系统登录”完成后，即可进入相关“讨论区/版面”发贴子。如下图：

     3/3)查询贴子。在主页面选“查询”。如下图


Win2000服务器设置全攻略（十七）

安装和配置FTP——WFTPD

    (一)关于WFTPD

1、软件名称：WFTPD(Winsock FTP Demo) 32-bit (x86) version

2、软件功能：FTP服务器端软件（Win32/95/98/NT/2K)

3、软件类型：共享软件（传输类限制）

4、所属公司：Texas Imperial Software

5、公司主页：http://www.wftpd.com/

6、下载地址：点此处下载（32wfd241rc14.zip，442K）

(二)安装WFTPD

1、将32wfd241rc14.zip解压到任意目录下。如下图：

2、不需重新启动，直接执行wftpd.exe即可启动FTP服务。主屏幕如下图:

（三）使用FTPD 1、建立新的FTP用户

1/2)选“菜单Security→Users/rights”即进入用户属性窗口。如下图：

2/2)选“New User...”，按提示依次输入用户名、密码，则成功增加了新用户。如下图：

    其中：

    a、“Home”为此用户登录后的虚拟根目录；

    b、“Rights”下为此用户的操作权限；

    c、“Director”中如果保持为“*”，则下面的权限适用此用户根目录下的整个目录树，否则只对“Director”中指定目录起作用；

  d、“Restrict to home...”项必须选中，否则此用户的活动范围将不受虚拟根目录的限制。

    下图为一个名为“santai”的用户登录后，选中此项时的操作屏幕（DOS环境）：

  下图为一个名为“santai”的用户登录后，未选中此项时的操作屏幕（DOS环境）：

    2、登录FTP

    1/4)DOS环境下，格式：ftp 计算机名，输入用户名和密码并成功登录。如下图：

    2/4)Windows环境下，格式：ftp://计算机名，按提示输入用户名和密码。如下图：

    3/4)Windows环境下，也可用此格式：ftp://用户名@计算机名

    4/4)所有的“计算机名”均可用IP地址来替代

    3、接受匿名用户登录。选菜单“Security→General”，选中“Allow Anonymous”。如下图：

    4、如在上图中，不选中“Enable Security”，则所有用户均不需密码即可进入

    5、在菜单“View→Connected Users”中可查看FTP所有在线的用户


Win2000服务器设置全攻略(十八）

一、关于Web方式：

1、启动Web方式：

①8383端口：选“IMail Administrator→localhost→右边窗口→Web messageing Server→Start”。

运行格式为：http://域名:8383

②8181端口：再选“右边窗口→Monitor→WWW (Web Server）→Start”。

运行格式为：http://域名:8181

2、本文以8383端口为例。

    注意，刚进入主屏幕的时候，信箱链接是不可用的，如下图所示；要用Web方式接收邮件，必须要先给相应用户发至少一封信，见后文。


Win2000服务器设置全攻略(十九）

二、Web方式的基本操作：

1、撰写新邮件：选“Compose”则进入发邮件的屏幕。比如给自己发一封信，如下图：

其中：

①“Add all...”选项意思是将所有收件人地址加到“地址簿”(address book)；可在下图Options的Address Book处修改。

②“Save...”的意思是将此邮件副本保存到已“发送邮件箱”(Sent)中；可在主屏幕的Sent中看见。

③“Include...”的意思是包括“签名”(Signature)；可在下图Options的Change Signature处修改。

2、发送后再选“Menu”回到主屏幕，由于收件箱中已有内容，则信箱链接可以用了，如下图所示。其中的菜单和选项，Logoff退出Web方式；Compose写新邮件；Read Mail收新邮件；Summary相当于进入收件箱（Main）；Mail收件箱；Sent已发送邮件箱。


Win2000服务器设置全攻略（二）

    前言

    注意：1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。

    四、DNS（域名解析）

    1、分析：在建立DNS时，可作如下看待：
    1/6)www.lianhe.com：com是“区域”；lianhe是“域名”；www是“主机”
    2/6)ftp.lianhe.com：com是“区域”；lianhe是“域名”；ftp是“主机”
    3/6)www.qz.fj.cn：fj.cn是“区域”；qz是“域名”；www是“主机”
    4/6)public.qz.fj.cn：fj.cn是“区域”；qz是“域名”；public是“主机”
    5/6)uc2000.yeah.net：net是“区域”；yeah是“域名”；uc2000是“主机”
    6/6)lianhe.com：com是“区域”；lianhe是“主机”

    2、比如，可设一个www.lianhe.com的域名（用于作WWW服务器地址）；一个 ftp.lianhe.com（用于作FTP服务器地址）；一个lianhe.com的域名（作为SMTP和 POP3服务器地址）

    3、设置lianhe.com（对应192.168.0.1；3、4步不能颠倒！）
    1/2)建立com区域
    操作：开始菜单→程序→管理工具→DNS→控制台根节点→DNS→UC1（你的服务器名）→ 正向搜索区域→右键→新建区域→名称：com

    2/2)建立lianhe主机
    操作：com→右键→新建主机→名称：lianhe；IP地址：192.168.0.1

    3/3)建好后的样子如下图：

    4、设置www.lianhe.com和ftp.lianhe.com（均对应192.168.0.1）
    1/4)建立lianhe域名
    操作：com→右键→新建域→lianhe

    2/4)建立www主机
    操作：lianhe→右键→新建主机→名称：www；IP地址：192.168.0.1。如下图：

    3/4)建立ftp主机
    操作：步骤同“3)建立www主机”

    4/4)建好后的样子如下图：


Win2000服务器设置全攻略(二十）

3、进入收件箱。选“Main”或“Summary”。如下图：

4、在收件箱中点击邮件的标题即可看到邮件的正文。如下图：

5、默认的，当转发(Forward)邮件时不包括原邮件的附件，如欲改成包括，则在Option中选Preferences（主屏幕），再选中“Include attachments”即可。如下图：


Win2000服务器设置全攻略(二十一）

〖运行环境〗∶NT/2K

〖运行版本〗∶IMail 5.0/IMail 6.0

一、例如：只有一个IP为：192.168.0.1，现在需要利用它建立相互独立的两个邮件服务器：aaa.net和bbb.net。

二、设置：

1、DNS设置：

①aaa.net的设置。在“开始→程序→管理工具→DNS”中建立如下图的记录，顺序为先建aaa.net和mail.aaa.net的A记录，再建指向mail.aaa.net的MX（邮件转发）记录。

②bbb.net的设置。再建立如下图的记录，顺序为先建bbb.net的A记录，再建指向mail.aaa.net的MX（邮件转发）记录。


Win2000服务器设置全攻略(二十二）

2、Imail Administrator设置：

①aaa.net的设置。进入“Imail Administrator→Add Host→192.168.0.1→Official Host Name：mail.aaa.net→Aliases：aaa.net”。如下图所示：

②wywy.com和mail.wywy.com的设置。进入“Add→$virtual001→Official Host Name：mail.bbb.net→Aliases：bbb.net”（mail.bbb.net这个名字只是用来“中转”用的，没有且不需要在DNS中进行设置）。如下图所示：


Win2000服务器设置全攻略(二十三）

③建立好后便有如下图所示的两个独立的邮件服务器：（其中新建的两个用户santai分别属于aaa.net和bbb.net两个邮件服务器）

④停止再运行SMTP服务。选“SMTP→Stop→Start”。如下图：


Win2000服务器设置全攻略(二十四）

三、使用：（以在Outlook中为例）

1、比如在第一个邮件服务器中建立了一个名为santai的用户，则它的E-mail地址为santai@aaa.net，它的用户名为santai，POP3地址为aaa.net。如下图：

2、比如在第二个邮件服务器中建立了一个名为santai的用户，则它的E-mail地址为santai@bbb.net，它的用户名为santai@bbb.net，POP3地址为aaa.net。如下图：


Win2000服务器设置全攻略(二十五）

3、aaa.net的Web登录方式如下图：

4、bbb.net的Web登录方式如下图：


Win2000服务器设置全攻略(二十六）

一、别名的分类：

    IMail中的别名（alias）共分为五类“Standard 、Group、Program、Pager or Beeper、Host”，其中的“Host”为一个邮件主机的另一个名字；其他四个为邮箱别名，用于向指定地点转发邮件用户收到的信息。

二、Host alias（主机别名）的建立：

    方法1：进入“IMail Administrator”的主屏幕，选“左边窗口→localhost→右键→Add Host→欲建别名的主机→Aliases”，再输入新的别名即可。

    方法2：进入“IMail Administrator”的主屏幕，选“左边窗口→欲建别名的主机→Host Aliases”，再输入新的别名即可。

三、邮箱别名的建立：

    1、进入“IMail Administrator”的主屏幕，选“Aliases→右边窗口→Add Aliases”，再输入别名及选择别名的类型即可。如下图：

    2、一般类型选“Standard”（标准，1-4行）或“Group”（组5行以上）。具体类型可在“Alias Type”中看见；欲输入此别名包含的内容（E-mail地址），则在“Resolves To”中输入，一行一个。如上图。（当“Standard”下输入的E-mail地址多于四个／行时，保存时系统会自动将类型改为“Group”。）

四、使用邮箱别名：

1、别名建好后，就成了一个特殊的E-mail地址，可在能使用E-mail地址的任何地方使用它。

2、发信时“收件人”一栏格式为“别名@服务器名”（如上图：ddd@aaa.net）。

3、则在上图的“Resolves To”中所包含的E-mail地址都会收到这封信。

4、如果别名的名字和它所在的邮件服务器中的一个普通邮件帐号一样，则那个普通邮件帐号则失效。


Win2000服务器设置全攻略(二十七）

一、关于邮件列表：

1、可以将一封邮件同时发给邮件列表中的所有人；

2、可以通过发送包括相应命令行的邮件来自动加入或退出邮件列表，并可得到帮助信息及列表的内容等；

3、可以设定指定用户使用的邮件列晴，可以设置列表密码等。

二、建立和使用邮件列表：

1、建立邮件列表。

    选“左边窗口→mail.aaa.net（邮件服务器名）→Lists→Add list...”，再输入邮件列表名。比如建立一个名为“list-1”的邮件列表，之后在“Lists”（列表）中则可看到列表名“list-1”；同时在“Aliases”（别名）中，会相应地自动建立“imailsrv”、“list-1”、“list-1-owner”及“owner-list-1”四个别名。如下图所示：


Win2000服务器设置全攻略(二十八）

2、手动增加邮件列表包含的E-mail地址。上图中，选“Addresses”，按一行一个的格式输入欲增加的地址。结果如下图所示：

3、向邮件列表list-1发信。“收件人”一栏格式是“列表名@服务器名”（如：list-1@aaa.net）。则可同时将此邮件发给邮件列表list-1的Addresses中包含的所有E-mail地址。

4、加入／退出邮件列表或得到邮件列表的帮助、内容等信息。“收件人”一栏格式是“imailsrv@服务器名”（如：imailsrv@aaa.net）。在正文区放相应格式的命令（一行一个）：

①得到格式的帮助文件：Help

②得到指定列表的帮助文件：Help 列表名

③得到指定列表中所有已加入者的列表：List 列表名

④把自己加入到指定列表中：Subscribe 列表名 你的名字（不是E-mail地址）

⑤退出指定的列表：Unsubscribe 列表名 你的名字

5、向列表所有者发信。“收件人”一栏填入“列表名－owner@服务器名”（如：list-1-owner@aaa.net），则将发向此列表主屏幕的“Owner”单元中所包含的E-mail中去。


Win2000服务器设置全攻略(二十九）

三、邮件列表的其他设置：

1、邮件列表自动在收到的邮件标题前加上指定内容再转发给其下所包含的E-mail地址。

①如下图中，选中“Enable Sub...”，再在后面输入任意欲增加的内容。

②上步中设置后，收到的邮件如下图所示：


Win2000服务器设置全攻略（三）

前言
    注意： 1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。
五、WWW和FTP 1、设置WWW服务器。比如将它的根目录设置到C:\Inetpub\wwwroot下操作：开始菜单→程序→管理工具→Internet服务管理器→Internet信息服务→UC1（你的服务器名）→默认Web站点→右键→属性。如下图：

    其中： 1/3)“Web站点”中，“IP地址”选“192.168.0.1”。如下图：

    2/3)“主目录”中，“本地路径”填写：C:\Inetpub\wwwroot；或通过“浏览”完成对些目录的选择。如下图：

    3/3)“文档”中，可修改浏览器默认调用的文件名及调用顺序。如下图：

    2、设置FTP服务器。比如将它的根目录设置到C:\Inetpub\ftproot下操作：默认FTP站点→右键→属性其中： 1/4)“FTP站点”中，“IP地址”选“192.168.0.1”。如下图：

    2/4)“安全帐号”中，选中“允许IIS控制密码”。如下图：

    3/4)“消息”中，“欢迎”处输入FTP连接成功后欲显示的话；“退出”处输入FTP断开时欲显示的话。如下图：

    4/4)“主目录”中，“本地路径”填写：C:\Inetpub\ftproot；或通过“浏览”完成对些目录的选择。如下图：


Win2000服务器设置全攻略(三十）

2、为了防止用户滥用邮件列表，也可以为之设置密码。只有知道密码的人才可向此邮件列表发信。

①选中“Use Password”，输入相应的密码。如下图：

②则向此列表发邮件时，在“主题”一栏的格式是“[:密码:]主题内容”。如下图所示：


Win2000服务器设置全攻略(三十一）

③如果不知密码或密码不正确，则发出的邮件会被退回。如下图所示为退回的邮件，选中处即为“密码不正确”的错误提示：

3、如果想知道一个邮件列表（比如list-1）中包含的所有E-mail数，格式如下图，其中find为DOS下的查找文件内容的命令，list-1为要查的邮件列表名，实际上此命令的作用是查看文件中有多少个“@”符号！由于一个E-mail有且仅有一个此符号，所以“@”的数量即为Address的数量。


Win2000服务器设置全攻略(三十二）

一、邮件转发：

1、目的：将发往指定信箱的所有信件转发到其他信箱中（可选择是否在原信箱里保留）。

2、设置：选“左边窗口→santai（用户名）→右边窗口→General→Forward”，再输入欲转发的邮件地址。如下图选中处：

3、说明：

①多个信箱之间用逗号(,)分隔。

②倘需要转发的同时并在原信箱中保留一份，请在Forward框的最开始处顺序加上一个句号和一个逗号(.,)；如原信箱中不需要保留，则不用加。上图所示为要保留的情况。

③此处地址也可是邮件列表名(Lists)或别名(Aliases)。比如填入“Maillist-1@aaa.net”，则发向此信箱的信会转发到邮件列表Maillist-1所包含的所有邮件地址中。


Win2000服务器设置全攻略(三十三）

二、自动回复：

1、目的：发向指定信箱（邮件目录）的信将被自动回复（自定义邮件内容；并可选是否同时将收到的邮件转发到另一个信箱）。

2、回复所有的信：（利用默认的main目录）

①服务器端设置。选“Info. Manager→Sub-area→选main→Message：xxx（自动回复的信息）→Enable Info...”。如下图：

②客户端“收件人”一栏格式为“用户名@服务器名”（如：santai@aaa.net）。

③则所有邮件均将被自动回复。Message的第一行同时又是自动回复信件的主题。客户端如下图：


Win2000服务器设置全攻略(三十四）

③如果“...mail to:”后面有其他E-mail地址，则自动回复后还会将收到的信转发过去。倘若此E-mail地址和本E-mail为同一服务器，则邮件服务器部分可省略，只输用户名即可；如为不同邮件服务器，则必须输入完整的E-mail地址。下同。

3、根据不同的请求目的回不同内容的信：

①比如，有关于NT和2000及98的帮助文件，可以根据别人的请求发相应帮助内容过去。

②操作：（以有关2000的设置为例）

a、服务器端添加并设置一个名为“2000”的子区。在“Sub-area”中输入“2000”，然后在任意可输入内容处单击一下鼠标，则成功建立了此区。再选中“Enable Info...”，在“Message”中输入相应内容即可。如下图：

b、注意：仅如此服务器端将看不到客户端发过来的邮件，如想看到，必须设置将邮件转发到main子区中。方法是在“After...mail to:”后填入“用户名－main@邮件服务器名”。如上图。

c、客户端向2000子区发送邮件。“收件人”一栏格式为“用户名－子区名@邮件服务器名”。如下图：

d、客户端接收到的邮件如下图：

4、如要暂停自动回复，去掉“Enable Info...”前的小勾即可。


Win2000服务器设置全攻略(三十五）

三、假期自动回复：

1、目的：如果你去休假了，可通过此项自动回信给向你发信的所有人。

2、设置：选“Vacation”，在Message中输入自动回复的信息，再复选中Enable vacation使假期回复生效。如下图：

3、说明：

①设置好了Vacation后，欲让View recipients和Delete Old recipients生效，需停止再重新开始SMTP服务；其中，View recipients中可看到已进行了假期自动回复的邮箱名，Delete Old recipients则可以删掉所有已保存的邮箱。SMTP服务的位置如下图：

②欲暂停Vationg服务，只需去掉Enable vaction前的勾。

③假期回复邮件的主题是automated response。如下图：

④自动回复将回复任何一封发来的信；而假期回复则仅当启用了此项服务后，某个信箱第一次发信来时方回复（看已回复的信箱在View recipients处）。


Win2000服务器设置全攻略(三十六）

一、概述：

1、如果改变了本机的IP地址，则必须对IMail的原设置作相应的变更。

2、本文主要通过修改注册表来实现。

3、例如，本机原来的IP地址为“192.168.0.10”，在IMail中的其对应的邮件主机名为“mail.aaa.net”，别名为“aaa.net”，现在本机的IP地址改成了“192.168.0.1”。

二、具体操作：

1、打开注册表编辑器。选“开始→运行：regedit”。

2、找到IMail的域名存让地。选“HKEY_LOCAL_MACHINE→Software→Ipswitch→IMail→Domains”。

3、将旧的IP地址改成新的IP地址。选“192.168.0.10→右键→重命名”，然后改成新的IP地址“192.168.0.1”。如下图：


Win2000服务器设置全攻略(三十七）

4、将主机对应的旧的IP地址改成对应到新的IP地址。选“mail.aaa.net→右边窗口→Address→双击”，再改成新的IP地址“192.168.0.1”。如下图：

5、进入“IMail Administrator”，把“SMTP”服务“Stop”再“Start”后，修改即生效。如下图：

三、说明：

1、不要忘了在DNS中修改，让域名指向新的IP地址！

2、在2K中，从修改IP地址到修改DNS及修改注册表和做后面的步骤，过程中均不需重新启动计算机。

3、如果进入注册表后新的IP地址和已不用了的旧IP地址共存，则需要删除旧的IP地址。


Win2000服务器设置全攻略(三十八）

问：如何删除邮件服务器上保留的某个天数（含）之前的邮件？（窗口）

答：在主机名下选“Users”，再选“ Delete Msg"s by Date...”，之后输入天数或日期。如下图：

问：如何移动一个虚拟域名（Virtual Domain）的信箱？

答：比如欲一个虚拟域名“mail.bbb.net”的邮件主目录（Top Directory）为“d:\imail\bbbnet”，现欲把它移动到E盘去。

1、修改邮件主目录的指向。选“mail.bbb.net→Top Directory”，将它改成“e:\imail\bbbnet”。

2、在“localhost”中“Stop”再“Start”以下“SMTP、POP3、Web Messaging Server”服务。

3、移动邮箱目录。最后用资源管理器将“d:\imail\bbbnet\users”目录移动到“e:\imail\bbbnet\users”中去即可。


Win2000服务器设置全攻略(三十九）

问：IMail的一些限制是什么？

答：IMail的用户（User）数目不限；最大可同时有500个使用POP3的连接、400个使用IMAP4的连接、1000个使用SMTP的连接、500个使用Web方式登录的连接、256M用于交换数据的空间、1G的硬盘剩余空间。

问：如果限制某个邮件服务器的用户数和邮箱大小？

答：选中邮件服务器名，在“General”中即可修改相应数目。其中“Default Max Mailbox Size”可设置每个邮箱的总的容量；“Default Max Message Size”可设置每个邮箱可容纳的最多邮件的数量；“Single Message Max Size”可设置每个邮件的最大尺寸；“Maximum User Count”可设置最大的用户数。如果数字为“0”则为不限制。

修改完了之后再“Stop”和“Start”SMTP服务。

问：如何备份和利用备份恢复IMail？

答：首先你需要备份它的系统文件。方法是将“\imail”整个目录树复制下来。

其次还需要备份它的注册表。可选“localhost→General→Backup”来复制；或打开注册表编辑器，依次选“HKEY_LOCAL_MACHINE→Software→Ipswitch→IMail”，然后用“注册表”菜单中的“导出注册表文件”。

恢复时先将备份的“\imail”整个树将原来的目录覆盖，再进入注册表编辑器，选中“IMail”，然后用“导入注册表文件”将备份的文件导入即可。

问：IMail能使用动态的IP地址吗？

答：不行！


Win2000服务器设置全攻略（四）

  前言

    注意：1/2)本文限在局域网中；
          2/2)本文未特定指出处，均使用其默认选项。

    六、IMail(1/2)
    软件名称： IMail Administrator Version 6.04 EVAL
    软件环境：WinNT/Win2K 所属公司：Ipswitch Inc.
    公司网址：www.ipswitch.com
    下载地址：download.sina.com.cn(以imail为关键词搜索；5M)
    软件类型：共享软件（时间限制；三个月）

    1、安装　1/2)双击安装文件imtm_x86.exe，即可进行安装。除了在选择所安装的IMail服务中加选IMail Password和IMail Web Server外，其他均使用默认选项。
    2/2)安装完成后，会提示重新启动，启动完成后，就可在开始菜单－程序－IMail中找到相关文件

    2、增加邮件服务器(POP3)和邮件用户1/4)运行IMail Administrator 2/4)选择IMail Administrator－localhost－右键－新建主机。如下图：

      3/4)选择Add，就会在Local Address的窗口中增加一个名为virtual001的本地地址，选中它，将Official Host Name改成：lianhe.com；其他项目可不用改。再选择save保存后用Exit退出。如下图：

    4/4)选择Users－右键－Add users，可增加邮件用户。如下图：


Win2000服务器设置全攻略(四十）

问：如何只接受（或拒绝）一些或全部用户使用POP3方式收发邮件？

答：如果想停止所有用户使用POP3方式的权利，只需“Stop”POP3服务即可。

限制部分则可通过控制他们的IP地址来实现。选“localhost→POP3→Control”，如果选中“Granted Access”（接受），再“Add”指定用户的IP地址，则除了这些用户外其他的用户都能使用POP3方式；如果选中“Denied Access”（禁止），再“Add”指定用户的IP地址，则除了这些用户外其他的用户都不能使用POP3方式。

再“Stop”和“Start”POP3服务。

问：如何只接受（或拒绝）一些或全部用户使用SMTP服务？

答：如果想停止所有用户使用SMTP服务的权利，只需“Stop”它即可。

限制部分同上问，只需把其中的“POP3”换成“SMTP Security”即可，其他方法一样。

问：如何只接受（或拒绝）一些或全部用户使用Web方式收发邮件？

答：如果要停止所有用户使用Web方式的权利，则“Stop”Web Messaging Server服务即可。

限制部分则可通过选中指定用户名，在“General”属性中去掉“Allow Web Access”前的小勾即可。


Win2000服务器设置全攻略（五）

前言 注意：
六、IMail(2/2) 3、设置Web登录 1/4)更改默认的Web登录方式邮件服务器地址 a、192.168.0.1原来是指向uc1.wy.uc.com（计算机名）。如下图：

b、将它改成指向lianhe.com。如下图：

c、按Save保存后，再按Exit退出。 2/4)开启Web管理服务 操作：localhost→Monitor，选中：WWW（web server），再按Start。如下图：
3/4)Web登录网址： http://www.lianhe.com:8383 或： http://www.lianhe.com:8181 (不要忘了加上：http://)
4/4)Web登录示意图： a、http://www.lianhe.com:8383的Web主页面。如下图：
b、http://www.lianhe.com:8383的邮件主页面。如下图：
c、http://www.lianhe.com:8181的Web主页面。如下图：
d、 http://www.lianhe.com:8181的邮件主页面。如下图：
(----待续----)


Win2000服务器设置全攻略（六）

软件名称：ICQ Groupware Ver. 1.12 Beta 软件环境：WinNT/2K（服务器端）；Win95/98/NT/2K（客户端） 所属公司：Mirabilis Ltd. 公司网址：www.icq.com 下载地址：

1)服务器端： ftp://ftp.icq.com/pub/ICQ_Win95_98_NT4/GroupWare/icqgwserver.exe
2)客户端： ftp://ftp.icq.com/pub/ICQ_Win95_98_NT4/GroupWare/icqgwclient.exe

软件类型：免费软件 1、服务器端和客户端的安装 1/2)服务器端安装完成后如下图：（需重新启动计算机）

2/2)客户端安装完成后如下图：

2、客户端提出ICQ号码申请 1/2)运行ICQ Corp 2/2)Server:lianhe.com→Request Access→依次点1、2、3、4所对应的按钮，即向服务器端发出申请。如下图：

3、服务器端接受申请 1/3)运行ICQ Groupware Server 2/3)User Registration→提出申请的用户→Add User→去掉Send Registration Notice By...前的勾→OK/ADD。如下图：

3/3)User Management→Start Search即可看见此用户已被成功加入。如下图：
(----待续----)


Win2000服务器设置全攻略（七）

前言

注意：1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。

七、ICQ Groupware（2／3）

4、也可直接在服务器端申请

1/3)运行ICQ Groupware Server

2/3)User Management→New→修改常用信息→去掉Send Registration Notice By...前的勾→OK/ADD；如此反复，直到申请了够用的号码，再按Done退出。如下图：

3/3)已申请的号码可选User Management→Start Search察看。如下图：

5、客户端登录

1/5)输入服务器名，ICQ号码，密码（默认为“大写的”：ICQ），再按Login登录。如下图：

2/5)登录成功。如下图：

3/5)改登录密码。如下图：

4/5)确定→Cancel（可不用改个人信息）

5/5)出现ICQ的主画面。如下图：

(----待续----)


Win2000服务器设置全攻略（八）

前言

注意：1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。

七、ICQ Groupware（3／3）

6、服务器端常见操作

1/1)为ICQ Groupware Server设一个进入密码

a、Admin Settings→Password→...。如下图：

b、ICQ Groupware Server进入窗口。如下图：

7、客户端常见操作

1/4)增加用户

a、可通过ICQ号（UIN）、昵称（Nickname）等来寻找用户。如下图：

b、添加用户。如下图：

c、常见主窗口。如下图：

2/4)打开／关闭活动的status。如下图：

操作：Status "Floating" On/Off

3/4)发同一条信息给多个人

操作：More→修改欲发送给的对象→Send。如下图：

4/4)查看聊天的历史记录

操作：双击用户名即可。如下图：

(----待续----)


Win2000服务器设置全攻略（九）

前言

注意：1/2)本文限在局域网中；2/2)本文未特定指出处，均使用其默认选项。

八、聊天室

(一)关于本聊天室程序

1、本聊天室使用ASP编程实现

2、本聊天室程序是我以前一个同事copy给我的，为忠于原著，我未作任何修改

3、我99%不懂ASP，因此除了不能用之外，其他的修改，请不要问我

(二)使用说明

1、下载

1/2)压缩文件包括17个源文件及本说明文件（readme.htm），共约68.7K

2/2)地址：http://nanshan.363.net/down/chat.zip

2、安装

1/2)先在C:\Inetpub\wwwroot（所设WWW的根目录）下建立一个名为chat的文件夹，再将得到的chat.zip文件解压到里面。文件列表如下图：

2/2)调用网址为：http://www.lianhe.com/chat

3、使用

1/3)进入http://www.lianhe.com/chat后，即为聊天室的登录界面。如下图：

2/3)输入nikename（如“三台”），再选“确定”（或敲回车键）即进入聊天室的聊天界面。如下图：

3/3)据实验得知，“操作指南”一项不能使用

(----待续----)