首页

中 华 电 脑 书 库
http://www.pcbookcn.com
声明：本站所制作的书籍仅供个人学习,交流,研究之用。版权归原 作者和原出版物所有。如要作其它用途请直接与版权所有者联系。


安装IIS 5.0 DIY(上)

绿盟科技

在安装Windows2000的时候，如果你选择了安装IIS，那么在安装的时候系统将会你的%SystemDrive%里创建一个InetPub目录，而且还会在Inetpub目录下创建一个Scripts目录，IIS还会创建一个虚拟目录SCIPTS指向该目录，并且给这个目录执行权限。前段时间NSFocus安全小组研究发现的“Unicode解码目录遍历漏洞”大部分问题就是针对Web站点的可执行目录而言的，所以我们建议把该目录移到非系统盘在一定程度上可以保证一定的安全。

然而在我们选择安装系统组件的时候，无法自己定义IIS的安装盘符，所以才有了今天的这篇文章。：）

我们在安装系统的时候不选择安装IIS，等系统安装完成后手动来做，我们可以使用无人值守的方式自定义安装IIS 5.0。首先确认你的 Windows 2000的安装介质是可用的，本例中的安装介质是光盘，因此只要将安装光盘插入光驱即可，然后在你的硬盘或者软盘上创建一个无人值守安装文件，本例中我们将在D盘创建一个 IIS5install.txt 作为无人值守安装文件，下面我们看看该文件的内容：

[Components] 所安装的组件
iis_common = on 公用文件
iis_inetmgr = on IIS管理器
iis_www = on WWW服务
iis_ftp = on FTP服务
iis_htmla = on Web方式的IIS管理器

[InternetServer]
Path="D:\inetsrv" Common文件放置位置（如果你是卸载了IIS再手动装，公用文件还是会位置保持不变）
PathFTPRoot="D:\inetPub\FTPRoot" FTP的根路径
PathWWWRoot="D:\InetPub\wwwroot" WWW的根路径

将该文件存盘后，运行“sysocmgr /i:%windir%\inf\sysoc.inf /u:d:\iis5install.txt”，
不会有提示框出现，系统将自动的为你安装好IIS，而且Scripts目录将会在D盘，使用“Unicode解码目录遍历漏洞”也就失效了。

如果你需要安装更多的IIS组件，以下是一个比较详细的无人值守安装文件：

7 1 2 下一页


安装IIS 5.0 DIY （下）

绿盟科技

=========================================BEGIN============================

;This is an example Unattended installation file
;IIS, MTS, and Index Server are ON
;Target Path should be new directory
;Adminpassword is blank.

[Unattended]
Unattendmode = FullUnattended
OemPreinstall = NO
TargetPath = *
Filesystem = LeaveAlone

[UserData]
FullName = "Your User Name"
OrgName = "Your Organization Name"
ComputerName = "ComputerName"

[GuiUnattended]
TimeZone = "004"
AdminPassword = *
AutoLogon = Yes

[LicenseFilePrintData]
AutoMode = "PerServer"
AutoUsers = "0"

[Display]
BitsPerPel = 4
XResolution = 800
YResolution = 600
VRefresh = 70

[Networking]
InstallDefaultComponents = YES

[Identification]
JoinWorkgroup = Workgroup

;Turns NT Components (and their respective sections) ON or OFF
[Components]
iis_common = on
iis_inetmgr = on
iis_www = on
iis_ftp = on
iis_htmla = on
iis_doc = on
iis_pwmgr = on
iis_smtp = on
iis_smtp_docs = on
mts_core = on
msmq = off
terminalservices = off
reminst = off
certsrv = off
rstorage = off
indexsrv_system = on
certsrv_client = off
certsrv_server = off
certsrv_doc = off

[InternetServer]
;Without these keys specified IIS will use the default settings
; Note that the Path is location for INETSRV, the core IIS programs and files.
Path=D:\Securelocation
PathFTPRoot=E:\Inetpub\Ftproot PathWWWRoot=E:\Inetpub\Wwwroot

7 上一页 1 2