首页

中 华 电 脑 书 库
http://www.pcbookcn.com
声明：本站所制作的书籍仅供个人学习,交流,研究之用。版权归原 作者和原出版物所有。如要作其它用途请直接与版权所有者联系。


目录

FrontPage入门

很多人接触FrontPage都是从FrontPage97开始的，而不知道
还有一个FrontPage1.1。而FrontPage1.1作为Microsoft公司
收购FrontPage后推出的第一个版本，附带了一个让用户自学
的教程。教程通过创建一个介绍甜点制作的网站，讲述了如
何使用FrontPage制作主页，以及FrontPage独有的特性。
教程在FrontPage97中就没有了，但还保留了教程中所需的模
板和素材。而FrontPage98中连这些也没有了。不过不用担
心，我不但把教程改成在FrontPage98环境中运行，还把所有
的材料都放在这里，你可以直接下载。

准备工作：
1、下载教程所需要的模板(tuttemp.zip,6K)、素材(tutdata.zip,
25K)。
2、把tuttemp.zip中的文件释放到 YourFrontPagePath\webs
\vtitut1.tem目录，这样，在你下次建立新WEB时就会有一个教程
的模板。
3、释放素材文件到任意目录。
4、现在，让我们开始吧。

第一课 |
 | 创建新的WEB 使用FrontPage Explorer 启动FrontPage Editor 使用FrontPage Editor 关闭当前WEB
第二课 |
 | 打开WEB 使用FrontPage Editor 插入表格 列表 插入文件 完成
第三课 |
 | 创建表单 插入Include Bot
第四课 |
 | 建立连接 返回首页
第五课 |
 | 插入图像 图像连接 背景图 透明图像 创建Search Bot
测试 |
 | 启动浏览器 Search Feedback

太平洋电脑信息网


第一课

FrontPage入门 - 第一课

1、创建新的 Web

    · 启动Microsoft FrontPage, 在欢迎对话框中选择 Create a New Frontpage Web, OK.
    tut1-1.gif (5613 bytes)
    · 选择 Learning FrontPage, OK.
    · 在 Name of New FrontPage Web 中, 输入 Desserts, OK.
    tut1-1.gif (7211 bytes)
    · 输入姓名和密码, OK.
    ·FrontPage创建一个叫 Desserts的 Web.

2、使用 FrontPage Explorer

FrontPage Explorer当前是在Navigation视图 tut1-3.gif (1395 bytes),现在转换到
超连接视图状态 tut1-4.gif (1503 bytes) .

tut1-5.gif (2202 bytes) 左边的树状结构列出了所有的页面. 你可以按加号和减号来扩展和收缩.

右边列出当前页的连接.
tut1-6.gif (2427 bytes)

    · 按一下左边的 “Solution Page”, 查看该页的连接.
    · 按 “Solution Page”左面的加号, 展开.
    · 按 “Lesson 2”, 右边显示该页的连接.

3、启动 FrontPage Editor

    打开 FrontPage Editor, 菜单: “Tools” - “Show FrontPage Editor”. tut1-7.gif (3594 bytes)

    · 建新文件, 菜单: “File” - “New”.
    · 选择 “Normal Page”, OK.

4、使用 FrontPage Editor

    在格式工具栏选择“Heading 1”, 输入“Chocolate Chip Cookies”. tut1-9.gif (2714 bytes)

    · 菜单: “File” - “Save As...”
    · URL: “lesson1.htm”, Title: “Lesson 1”, OK.
    tut1-10.gif (8375 bytes)
    返回 FrontPage Explorer, “Lesson 1” 已经加入在树结构中.
                 tut1-10.gif (2362 bytes)

5、关闭当前 Web

    · 菜单: “File” - “Close Web”.

上一页 下一页

[返回]

[返回]

版权所有©2000 太平洋电脑网


第二课

FrontPage入门 - 第二课

1、打开 Web

    · 菜单: “File” - “Open FrontPage Web...”.

2、使用 FrontPage Editor

    · 选 “Lesson 2”, 双击右边的图标打开Editor.
    · 键盘: “End”, “Enter”.
    · 选 “Normal” 样式, 输入 “Feedback Form”, 回车.
    · 选 “Heading 2”, 输入 “Ingredients”, 不回车 tut2-1.gif (2405 bytes)

3、插入表格

    · 菜单: “Table” - “Insert Table”.
    ·Rows: 5, Cell Padding: 0, Cell Spacing: 0.
    ·Width: Specify Width: 50.
    tut2-2.gif (5508 bytes)
    · 输入下面的数据:
1 & 1/8 c. flour | 1/2 c. sugar
1/4 t. baking soda | 1 egg, beaten
1/2 t. salt | 1/2 t. vanilla
1/2 c. butter | 1/2 c. chopped walnuts
1/4 c. brown sugar | 1/2 lb. chocolate chips

4、列表

    · “Heading 2”, 输入 “Preparation”, 回车.
    · 工具栏: “Numbered List”. tut2-3.gif (918 bytes)
    · 输入 “Pre-heat oven to 350”, 不回车.
    · 菜单: “Insert” - “Symbol”, “° ”.“C”。
    tut2-4.gif (5061 bytes)

5、插入文件

    · 可插入 TXT, RTF, HTML 文件.
    · 插入c:\Program Files\Microsoft FrontPage\data\tutorial\prepare.rtf.
    tut2-5.gif (4836 bytes)
    · 删除中间的空行, 两个列表合并.
    ·CTRL+END, 结束列表.

6、完成

    · 输入 “Makes 50 cookies.”, 不回车.
    · 选择 “Address” 样式.
    · 选中全行, 按 “B” 按纽, 变黑.
    · 移到行尾, 回车. 存盘.
    · 选 “Heading 2”, 输入 “Your feedback goes here:”, 回车.
    · 样式自动变成 “Normal”, 输入 “Back to Home Page”.
    tut2-6.gif (1689 bytes)

上一页 下一页

太平洋电脑网


第三课

FrontPage入门 - 第三课

1、创建表单

    · 打开 “Lesson 3”.
    · 移到 “Your feedback goes here:” 的行尾.
    · 菜单 “Insert”, “Form Field”, “one-Line Text Box”.
    tut3-1.gif (1476 bytes)
    · 在编辑框上按右键, “Form Field Properties”, 或按 ALT+ENTER.
    · Name: “Cookies”, OK.
    tut3-2.gif (3787 bytes)
    · 移到编辑框后回车.
    · 菜单: “View”, “Forms Toolbar” 打开表单工具栏.
    · 打开按纽"Submit"的属性.
    ·Value/Label: “Submit Feedback”.
    tut3-3.gif (3872 bytes)
    · 按 “Form...” 按纽打开表单属性.
    tut3-4.gif (5643 bytes)
    ·OK,OK.

2、插入 Include Page.

    · 移到 “Makes 50 Cookies.” 行尾.
    · 菜单: “Insert”, “FrontPage Component...”.
    · 选 “Include Page”, OK.
    tut3-5.gif (4242 bytes)
    · 按 “Browse...”, 选 “hrule.htm”, OK, OK.
    tut3-6.gif (7637 bytes)
    tut3-7.gif (2731 bytes)
    · 双击Bot可查看属性.

上一页 下一页


第四课

FrontPage入门 - 第四课

1、建立连接

    · 打开 “Lesson 4”.
    · 选中 “Your feedback goes here:”.
    · 菜单: “Edit”, “Bookmark”.
    · Bookmark Name: “feedback”, OK.
    tut4-1.gif (3312 bytes)
    ·CTRL+HOME回页首.
    · 选中 “Feedback Form”.
    · 菜单: “Edit”, “Hyperlink”.
    · URL: “Lesson 4”, Bookmark: “feedback”, OK.
    tut4-2.gif (9684 bytes)
    · 跟随连接: 按住[CTRL]按 “Feedback Form” .

2、返回首页

    · 到文件尾.
    · 选中 “Back to Home Page”.
    · 菜单: “Edit”, “Hyperlink”.
    · 选 “index.htm”, OK.
    tut4-3.gif (9844 bytes)
    · 菜单: “File”, “Close”, 确定存盘.

上一页 下一页


第五课

FrontPage入门 - 第五课

1、插入图象

    · FrontPage Editor: 菜单: “File”, “Open...”.
    · “index.htm”, OK.
    · 移到两行之间.
    · 菜单: “Insert”, “Image...”. tut5-1.gif (8081 bytes)
    tut5-2.gif (6140 bytes)
    · 按URL后面的文件夹按钮。
    · 选 your_data_path\desserts.gif, “Open”.
    tut5-3.gif (5002 bytes)

tut5-5.gif (9943 bytes) 2、图象连接

    · 选中图象, 显示图象工具栏.
    tut5-4.gif (2450 bytes)
    · 选 矩形 tut5-7.gif (861 bytes) 工具, 画一个覆盖左边部分的矩形.
    · 放开鼠标后显示 建立连接 对话框.
    · “brownies.htm”, OK.
    · 同上把右边部分连接到 “lesson4.htm”.

3、背景图

    · 菜单: “File”, “Page Properties...”.
    tut5-6.gif (8801 bytes)
    · “Background”, “Specify Background and Colors”, “Background Image”, “Browse...”.
    · 选 your_data_path\backgrnd.jpg. “Open”.
    ·Hyperlink Color: “Maroon”.

4、透明图象

    · 选中图象.
    · 选择 “Make Transparent” 按纽 tut5-8.gif (888 bytes).
    · 在图象中的白色背景上按左键.
    · 存盘. 按 “Change Folder...”把目录改在"/images",OK.
    tut5-9.gif (10521 bytes)

5、创建 Search Bot.

    · 移到 “Solution Page” 行下.
    · 菜单: “Insert”, “Active Elements”, “Search Form”, OK.
    tut5-10.gif (5591 bytes)
    · 存盘。

上一页 下一页


测试

FrontPage入门 - 测试

1、启动浏览器

    · 打开浏览器, 输入地址: http://my_server/Desserts.
    tut6-1.gif (67239 bytes)

2、Search

    · 在Search的输入框中输入 “Margarine”, 按 “Start Search”.
    · 查询结果显示在一个表格中, 带连接.
    tut6-2.gif (4853 bytes)

3、Feedback 表单

    · 按图象的右边部分, 显示 “Chocolate Chip Cookiees”.
    · 按 “Feedback Form” 到表单部分.
    · 写一段话, 如 “Cool!”, 按 “Submite Feedback”.
    tut6-3.gif (2772 bytes)
    · 按 “Return to the Form”.
    · 返回 FrontPage Explorer, 打开 “Results from form0 of Page Lesson4.htm”.
    · 输入的 Feedback 显示在 FrontPage Editor 中.
    tut6-4.gif (1654 bytes)

上一页


|><| 太平洋电脑网 -> 网络学院 -> 设计教室

FrontPage入门

很多人接触FrontPage都是从FrontPage97开始的，而不知道还有一个FrontPage1.1。而FrontPage1.1作为Microsoft公司收购FrontPage后推出的第一个版本，附带了一个让用户自学的教程。教程通过创建一个介绍甜点制作的网站，讲述了如何使用FrontPage制作主页，以及FrontPage独有的特性。教程在FrontPage97中就没有了，但还保留了教程中所需的模板和素材。而FrontPage98中连这些也没有了。不过不用担心，我不但把教程改成在FrontPage98环境中运行，还把所有的材料都放在这里，你可以直接下载。

准备工作：
1、下载教程所需要的模板(tuttemp.zip,6K)、素材(tutdata.zip,25K)。
2、把tuttemp.zip中的文件释放到 YourFrontPagePath\webs\vtitut1.tem目录，这样，在你下次建立新WEB时就会有一个教程的模板。
3、释放素材文件到任意目录。
4、现在，让我们开始吧。

第一课 |
 | 创建新的WEB 使用FrontPage Explorer 启动FrontPage Editor 使用FrontPage Editor 关闭当前WEB
第二课 |
 | 打开WEB 使用FrontPage Editor 插入表格 列表 插入文件 完成
第三课 |
 | 创建表单 插入Include Bot
第四课 |
 | 建立连接 返回首页
第五课 |
 | 插入图像 图像连接 背景图 透明图像 创建Search Bot
测试 |
 | 启动浏览器 Search Feedback

webmaster@pconline.com.cn