首页

中 华 电 脑 书 库
http://www.pcbookcn.com
声明：本站所制作的书籍仅供个人学习,交流,研究之用。版权归原 作者和原出版物所有。如要作其它用途请直接与版权所有者联系。


破解文库——专门收集破解教程，及一切与破解有关的资料，现有文章数千篇

编号 | 题目 | 类型
1 | 俞煌男破解入门教程（01/17） | 教程
2 | 俞煌男破解入门教程（02/17）
3 | 俞煌男破解入门教程（03/17）
4 | 俞煌男破解入门教程（04/17）
5 | 俞煌男破解入门教程（05/17）
6 | 俞煌男破解入门教程（06/17）
7 | 俞煌男破解入门教程（07/17）
8 | 俞煌男破解入门教程（08/17）
9 | 俞煌男破解入门教程（09/17）
10 | 俞煌男破解入门教程（10/17）
11 | 俞煌男破解入门教程（11/17）
12 | 俞煌男破解入门教程（12/17） 【例子】
13 | 俞煌男破解入门教程（13/17）
14 | 俞煌男破解入门教程（14/17）
15 | 俞煌男破解入门教程（15/17） 【例子】
16 | 俞煌男破解入门教程（16/17） 【例子】
17 | 俞煌男破解入门教程（17/17）


俞煌男破解入门教程（含１７篇）

俞煌男破解入门教程（１／１７）
俞煌男

 ＨＩ．．．！  各位好：
        本人来解说一下如何进入 ＤＥＢＵＧ 的世界里ｏ

 一般人（初学者）若想要进入 ＤＥＢＵＧ 世界中 当然都必须俱备有以下等东东
   １．ＤＥＢＵＧ或ＴＵＲＢＯ　ＤＥＢＵＧ或Ｓ－ＩＣＥ等强力的除错程式
   ２．基本组合语言的功力，若您还是一位初学者的话，那麽我建议您马上买一本
       组合语言的书来看吧！
   ３．要有无比的毅力及耐心 （最好多读有关组合语言的书籍，天下没有白吃的午餐
       凡事靠自己最好罗！　功力是自己多摸索而来的经验）
   ４．当然最後要拿（程式来开刀罗）

（Ｉ）破解目的：
      来谈谈破解游戏的密码吧，我想这是一般人最初的目的，也是最热衷的想知道
      相信大家都有恼人的经验，常常努力日夜不休的玩电脑游戏，但每次都要因
      （密码）而大伤脑筋，现在大多游戏都是用密码＆读母片来做为保护的方式
      使原版使用者苦脑不已，况且那密码又那麽的小，有的还要用玻璃纸之类的才
      能看个清楚，大伤使用者的眼睛及不必要的麻烦，本人之所以写了这个说明档
      目的是为了（保障正版的使用不便），希望大家一起努力将台湾（海盗王国之
      名）给洗刷掉.

（ＩＩ）如何有效的利用（除错程式）：
        我们先来谈谈　ＤＯＳ　所提供的　ＤＥＢＵＧ　程式的使用方法吧！

   指令：     说　明　意　义          使　用　的　格　式
         Ａ　组译组合语言程式        Ａ　（为记忆体中的位址）
         Ｃ  将二区段的记忆体内容    Ｃ （为区段范围）（为区段位址）
             做个比较
             Ｅｘ：Ｃ　１００　Ｌ２０　２００
             说明：将　ＤＳ：１００　的３２位元（１６进位法则是　２０）与
                       ＤＳ：２００  开始的３２位元资料互相来比较
                   注：Ｌ２０　为区段的范围
         Ｄ　显示记忆体的内容　　　　Ｄ　（记忆体位址）或　（区段的范围）
           注：此方法是显示（机器码）
         Ｅ　修改记忆体资料          Ｅ　（记忆体的位址）
           注：此方法为修改（机器码）
         Ｆ  将资料或位元输入到您指定 Ｆ　（指定的区段范围）
             的记忆体区段中
         Ｇ　执行程式                 Ｇ  （为某一区段）：（到某一区断中）
           Ｅｘ：　Ｇ　？？？？：？？？？
         Ｈ  将二个１６进位的数值　做 Ｈ  （运算值）（运算值）
             加／减　的运算，并在同
             一列显示　（和／差）
         Ｉ  将（ＰＯＲＴ）输入资料并显示  Ｉ （ＰＯＲＴ记忆体位址）
         Ｌ  载入某个档案或是自设的磁轨＆  Ｌ （记忆体位址）或
             磁区                             （磁碟机　磁轨　磁区）
         Ｍ　将某一个区段内容搬移到自设的  Ｍ （区段范围）（记忆体位址）
             位置中
         Ｎ  命名档案名称                  Ｎ （档案名称）
         Ｏ  输入某个位元输出到（ＰＯＲＴ）Ｏ （ＰＯＲＴ区段位址）
         Ｑ  结束ＤＥＢＵＧ回ＤＯＳ中
         Ｒ  显示暂存器中或旗号内容        Ｒ
             也可以加以改变其内容          Ｒ （暂存器的名称）
           Ｅｘ：Ｒ　ＩＰ
                 ＩＰ＝？？？？ （您可以修改内容，不改则按ＥＮＴＥＲ）
         Ｓ  搜寻记忆区段中的串列          Ｓ （记忆体区段的范围）
         Ｔ  执行一个指令或同时执行多个指令 Ｔ （记忆体区段）或 （数值范围）
         Ｕ  将机器码反组译成组合语言      Ｕ （记忆体位址）或 （范围）
         Ｗ　写入到档案中（限ＣＯＭ档）或  Ｗ （记忆体区段）或 （指定范围）
             将资料写入到指定的磁碟机．磁轨．磁区上

             最後注明：（）中的项目可有可无　全凭您自己的需要而定.
                        以上功能繁多　麻烦您自己多买书来参考之
                        并亲自操作演练一番　方知我在说什麽．
     告一段落：
           当然若您想学会如何破解的同时　请记得务必要将上述的功能熟记
           就像若给你一套好用的工具您不会使用的话．那也是枉然的　您说
           是不是呢？

           一般的除错程式大多都是这样使用的　下次为您补述　目前最强的
           Ｓ－ＩＣＥ除错程式的新增功能 敬请下次再会了.

    作者：俞煌男  （目前仍在补习中，所以大概一星期内尽量拨空来写一篇）
          ６２／０８／２４  作者功力也不是说很好，大多也都是靠自己来
          努力学成的，若有笔误或是言不答意，敬请来涵指教ｏ

    动机：本人写这篇文章主要是提供自己一些心得来帮助大家快速进入破解
          的领域中，让不得其门而入的朋友，一同来努力研究ｏ

                    欢迎拷贝流传，但勿将本文私自修改

                                      ＹＵ　ＨＷＡＮＧ留    期待再相会！
                            目前用的  ＦＵＨ　ＳＯＮＧ

    E-mail: rygshen@nease.net


俞煌男破解入门教程（２／１７）
俞煌男

嗨...我们又再一次的相会了:
     现在所要讨论的是 目前广受好评及目前无人能比之的 超强Ｓ－ＩＣＥ除错程式
（Ｉ）使用的配备限制：
      注意：若你想用这套超强的Ｓ－ＩＣＥ除错程式的朋友们　请务必要注意听啦！
      １．必须要是３８６－ＳＸ２５以上者
      ２．必须要有２ＭＢ　ＲＡＭ以上者
      ３．不可以加挂ＱＥＭＭ或ＥＭＭ３８６的记忆体管理程式

    若您的电脑配备跟上述相同或是更好时 很高兴您能使用目前最强的Ｓ－ＩＣＥ
    除错程式，反之若您的电脑还是比上述还（烂）者，很抱歉．你将不能执行这
    个程式，当然更别说一睹（Ｓ－ＩＣＥ）的风采了，可惜呀！

（ＩＩ）使用方法须知：
        步骤：
            １．您要跑此东东前，先确定您有没有此软体
              ＰＳ：若没有的话，可以到ＭＩＤＩ－２或瑞智四站（小可爱）拿
                    若您等级不够　可以留信给（小可爱）说您要那Ｓ－ＩＣＥ
                    ．ＡＲＪ档　我想他会让你Ｄ／Ｌ回去的
            ２．放在ＨＤ中执行　ＥＭＭＳＥＴＵＰ．ＥＸＥ此程式
                不要动他的参数，直接按（Ｆ１０）存档吧！
                Ｅｘ：本人是解压缩到Ｓ－ＩＣＥ子目录
                      若您不是跟我一样的话　那麻烦你改下面我所列出的
                      ＣＯＮＦＩＧ．ＳＹＳ路径要设对　不然会找不到
                      Ｓ－ＩＣＥ．ＥＸＥ档喔！
            ３．您的原先ＣＯＮＦＩＧ．ＳＹＳ必须要先改名罗！
            ４．将（Ｓ－ＩＣＥ）挂在ＣＯＮＦＩＧ．ＳＹＳ中
                Ｅｘ：本人列出Ｍｅ　ＣＯＮＦＩＧ．ＳＹＳ
                     ＤＥＶＩＣＥ＝Ｃ：＼Ｓ－ＩＣＥ＼Ｓ－ＩＣＥ．ＥＸＥ
                     ＤＥＶＩＣＥ＝Ｃ：＼ＨＩＭＥＭ．ＳＹＳ
                     ＤＯＳ＝ＨＩＧＨ
                     ＦＩＬＥＳ＝２５
                     ＢＵＦＦＥＲＳ＝２５

                 相信大家都会改吧！可别说您这个看不懂喔．．！

       若您上述步骤都已经弄好而且没问题的话，那麽你就重新（开机）吧！

（ＩＩＩ）如何进入Ｓ－ＩＣＥ程式中
          您可以按（Ｃｔｒｌ＋Ｄ）就进入啦！恭喜您已经可以正常使用罗！
          若您还不行的话，请检查是否路径有无设错，最好是在ＡＵＴＯＥＸＥＣ
          ．ＢＡＴ档中加入　ＰＡＴＨ＝Ｃ：＼Ｓ－ＩＣＥ 不然ＤＯＳ会找不到
          档案喔！（ＰＳ：还有最好不要将　扫毒／防毒　等程式载入进去，不然
          可能会导致记忆体位址或是记忆体空间的不够喔！当然此程式不含任何病
          毒，请各位安心使用吧！）

          若各位遇到不懂的指令时，可以进入Ｓ－ＩＣＥ中按（Ｆ１）即有显示出
          一些指令的用法，由於太多指令了，实在是没什麽时间可以一一列出用法
          格式，所以若不懂时，请查（英文字典来帮助阅读），实在抱歉　请各位
          原谅

     ＰＳ：下次预告　如何简单的破解ＧＡＭＥ　ＰＡＳＳＷＯＲＤ（游戏密码）
           保证让您很有成就感喔！
           这次将举例（大宇－雷射坦克的快速破解法　一分钟内即告破解）
           相信您也可以试试看，保证一学就会

      说明：本举例是为了让各位清楚的知道破解过程　但碍於版权问题请各位
            若破解之後　勿将破解档四处流传！谢谢合作！！

      感言：本人一直希望带动宜兰的ＢＢＳ风气并想提高宜兰的素质，所以请各
            位多多爱护（本土的软体）不要乱拷没版权的软体喔！
            破解的技巧　将在下次中解说　保证让初学者易懂！

            别忘了．．多多来信捧场喔！ 有问题欢迎写信到网路区来问我
            或是上本站　（朋友俱乐部）近期开放　请期待

            请各位切勿将本说明档修改ＩＤ好吗？毕竟这也是我辛苦所ＫＥＹ　ＩＮ
            出来的，谢谢各位合作罗！

                                朋友俱乐部　站长：ＹＵ　ＨＷＡＮＧ


俞煌男破解入门教程（３／１７）
俞煌男

各位好:
       很高兴的又是 （俞煌男）时间到了，笔者的口才不知好不好，若有写错的地方
或是太模糊不清楚．．等地方，本人皆欢迎您来信批评指教，也欢迎你我一起加入讨论
的行列，别忘了．．多多来信鼓励唷！可以到瑞智网或是瑞智四站中的破解游戏信区中
写信给　ＹＵ　ＨＷＡＮＧｏ

 讨论主题（１）：实例破解说明
       本人大多都采用（Ｓ－ＩＣＥ）来破解密码或是ＫＥＹＰＲＯ，ＫＥＹＤＩＳＫ
       相信你使用它之後，会更得心应手，此软体真是不错，强力推荐ｏ

      操作指令讲解：
           大多使用者还是对（Ｓ－ＩＣＥ）的指令用法不清楚，但笔者家中又没列表
           机，所以要用手写然後再ＫＥＹ　ＩＮ上去，实在不便，所以不可能一次全
           部将指令的用法一一列出，只好靠一次讲一些来满足各位的需要，但有一点
           的就是（还是请初学者多多熟记指令的用法好吗？？并请买本书来看吧！）
           我不是在教（组合语言）（若有可能的话，我会考虑的，疑．．．怎麽没人
           要求呢？）（没有人要求那就算了，那不是一下子可以讲完的，所以多多看
           书来学习是比较实际一些）

       指令                                 中　文　意　义

       BMP,BPMB,BPMW,BPMD                   中断记忆体区段
       BPR                                  中断记忆体范围
       BPIO                                 中断I/O PORT范围
       BPINT                                中断干扰 INTxx
       BPX                                  中断执行
       CSIP                                 设定CS:IP范围限定
       BPAND                                总合中断点在一起使用
       BPE                                  编辑中断
       BPT                                  自设中断点的模式
       BL                                   列出现在的中断点位置
       BC                                   清除所有中断点
       BD                                   关闭中断点
       MAP                                  列出目前记忆体的使用状况
       INT?                                 列出中断点－编号

       先讲到这罗...指令用法 下次会在继续为您补述的  请耐心等候好吗??

 讨论主题（２）：破解实例操作法

   步骤（Ｉ）

       开始先将 （大宇－雷射坦克）ＩＮＳＴＡＬＬ　到ＨＡＲＤ　ＤＩＳＫ中
       完全载入ＯＫ之後，请参考第二集，驱动执行Ｓ－ＩＣＥ程式（系统设定档
       ＣＯＮＦＩＧ．ＳＹＳ记得要改喔！）

   步骤（ＩＩ）

       进入（大宇－雷射坦克）ＧＡＭＥ中，执行ＴＡＮＫ１．ＢＡＴ　开始游戏
       等到问密码时，嘿嘿．．．．还等什麽，按（Ｃｔｒｌ＋Ｄ）就进入密码比
       对程式罗！（由於笔者家中没列表机，所以简单带过去，除非有人借我列表
       机，不然实在懒得一边用手写然後再ＫＥＹ　ＩＮ进去）简单列出来：

       你进去到（密码比对程式後，可以看见以下的组合语言）
       机  ３Ｃ８０            ＣＭＰ　ＡＬ，８０
           ７４０Ｃ            ＪＺ　　５３Ａ７     若输入正确　就进入游戏
           Ａ１８９５１        ＭＯＶ　ＡＸ，〔５１８９〕
           ．．．．．．        ＳＵＢ　ＡＸ，〔５１８Ｂ〕
       器  ．．．．．          ＣＭＰ　ＡＸ，０００１
           ．．．．            ＪＬＥ　５３９２
           ．．．．．．        ＭＯＶ　ＡＸ，〔５１８９〕
       码  ．．．．．．        ＭＯＶ　〔５１８Ｂ〕，ＡＸ
           ．．                ＲＥＴ

       若你刚开始找不到时　别担心，按　Ｔ　一直追踪　即可以找到上述的密码比对
       程式罗！

       将３Ｃ８０７４０ＣＡ１８９５１用笔抄起来，然後用ＰＣＴＯＯＬＳ ＦＩＮＤ

       将７４＝＝ＥＢ 改成ＥＢ即可破解啦！

   大概说明：

       ＪＺ　５３Ａ７　原来＝＝＝＝改成　ＪＭＰ　５３Ａ７

       ＪＭＰ　的机器码就是　ＥＢ

       意思就是说　不管输入正确或不正确的密码　都跳到（游戏中）

       这样您懂吗？？以上的比对程式（初学者，请参考组合语言相关书籍）

 讨论主题（３）：告一段落

       本人写这篇　破解入门（１，２，３）集，纯粹是服务性质，并非我的义务

       主要的目的还是教你抓鱼，并非给你鱼吃，所以凡事靠自己最好，不要一直

       依赖别人破解，那终究还是不会ｏ

       其实本人之所以列出　（大宇－雷射坦克）破解法，是因为这对初学者破解

       密码算是最简单的一个罗！　所以我才列出快速破解法，只要你参考我的破

       解方法，一定不出一分钟，即可将此密码（砍）掉ｏ

   声明启事：

       本人不是教您（组合语言），所以请自己学习，请勿将破解版的ＧＡＭＥ乱

       传到ＢＢＳ或．．．．等，最重要是保障（原版使用方便）并不鼓励您盗拷

       非法软体ｏ

   补充说明：

       一般的密码有的很简单，有的蛮复杂的，所以你可以参考我的方式，然後试

       试破解看看，但最重要的事　最好在（硬碟中执行），不然要是您太（肉脚）

       的话，破解不成又要花钱寄磁片去修理了ｏ（若你破解不成，请联络我吧！）

 下期精彩预告：

      下一集的说明中，将为您介绍一些（破解密码的技巧＆快速破解法则）

             下      期      再      会           ＢＹＥ－ＢＹＥ！！

   若您是位站长的话，您若想要我帮您解决一些问题者，请在您的站上帮我开个ＩＤ

   ＹＵ　ＨＷＡＮＧ　　之後，并在　天罗３０００网中写信给　ＩＬＡＮ　ＢＯＹ

   我就收得到罗！ （限台北，宜兰　１４４００以上等站，并替我开２ＭＢ的Ｋ数）

   密码设为：ＳＹＳＯＰ－ＹＨＮ即可

 声明启事：

   本人在补习中，所以下期可能会晚一点出来请耐心等候，因模拟考将近，所以无法抽
   空来写罗！我已经尽快出了，请各位放过我吧，若没考上二专的话，找您们算帐喔！

   原本要继续开站　但家母反对我占用家中电话，专线在台北没迁回来，所以等考上二
   专後再继续到台北开站，抱歉了各位宜兰的朋友及瑞智站长ｏ

                       俞煌男　ＹＵ　ＨＷＡＮＧ　９３／０５／０３笔


俞煌男破解入门教程（４／１７）
俞煌男

嗨...各位爱护的朋友们您好:

    ＰＤ：Ｓ－ＩＣＥ（为共享软体，您可以在一般站上Ｄ／Ｌ即可以取得之程式，若
    您不知道哪里拿的话　可以去ＭＩＤＩ－２站，方向点都有，目前最新版本是
    ２．６２版的）更正：目前已经由国内（智邦）代理此软体，所以现在是有版权的！

 您应俱备以下东东比较好（欲先善其事，必先利其器）：

    １．ＥＸＥＳＨＡＰＥ 好像这样（此东东可以解　某程式加以编码　进而回写成未
        编码或未压缩，请自个参考内附的说明档用法，建议：希望你对组合语言有一定
        的功力，不然还是别玩它吧！）

        跟此软体相类似的有　ＥＸＥＷＲＩＴＥ　也是跟上述一样，这是Ｓ／Ｗ软体
        需注册才可以使用全部功能，若没注册也可以使用啦！都是国人写的软体ｏ

    ２．ＧＡＭＥＴＯＯＬ　３．２１版（目前最新－由香港人所写的　需注册的软体）
        功能有：ＵＰ．ＥＸＥ　是用来解像ＰＫＬＩＴＥ，ＬＺＥＸＥ，ＤＩＥＴ，
        ＥＸＥＰＡＣＫ，ＣＯＭＰＡＣＫ等压缩软体ｏ
               ＧＸ３．ＥＸＥ　是常注型的除错程式，可用来帮助你破解ＧＡＭＥ
        密码．．．等工具ｏ

        以上还有许多功能　请自行研究参考　说明档　吧！

    ３．ＵＮＰ３１１  此东东是目前今天为止还不错的自解压缩软体，可解好多喔！
        你可以到各网路的ＰＤ软体区中可以找到（不会用ＥＸＥＳＨＡＰＥ的朋友
        我建议你用用看喔！）

  如何有效利用各种工具呢？这就要看你自己习惯用什麽了．．．

破解入门第四集 ：用ＬＤＲ．ＥＸＥ　来破密码（此软体附在Ｓ－ＩＣＥ中）

      此次是有位Ｕｓｅｒ传给我（小鬼当家）要我帮它破，所以这次就拿此来当作破解
题材：
      第一：先判断此程式是哪一个当比对主档
            ＨＡ．ＥＸＥ（小鬼当家密码主档）
      第二：先用ＵＮＰ  ＨＡ．ＥＸＥ来看看次程式是否有被其它的软体压缩过
            若有被压缩过的话，此软体会自动帮你还原成原来的档案长度ｏ

  步骤：１．用ＵＮＰ已得知是程式被ＰＫＬＩＴＥ压过，所以我们还原它

        ２．用ＬＤＲ．ＥＸＥ载入ＨＡ．ＥＸＥ开始除错抓出密码地方
            方法：ＬＤＲ　ＨＡ．ＥＸＥ（就进入Ｓ－ＩＣＥ模式）

        ３．常用指令Ｇ，Ｔ，ＨＥＲＥ，ＥＣ．．．要熟记
            Ｇ 执行
            Ｔ 追踪
            ＨＥＲＥ 可下令从ｘｘｘｘ：ｘｘｘｘ执行到哪一行
            ＥＣ   可以在讯息框中上下游标移动

          若有不懂请参考　Ｓ－ＩＣＥ中文说明档 请到各站去找．．．

  更正：原本要用ＬＤＲ来教各位破解，但因用Ｓ－ＩＣＥ无法抓下破解过程的画面

        只好改用ＤＥＢＵＧ来将此程式列出

C:\>DEBUG HA.EXE
-U
251B:0000 BA6E44        MOV     DX,446E
251B:0003 2E            CS:
251B:0004 89160602      MOV     [0206],DX
251B:0008 B430          MOV     AH,30
251B:000A CD21          INT     21
251B:000C 8B2E0200      MOV     BP,[0002]
251B:0010 8B1E2C00      MOV     BX,[002C]
251B:0014 8EDA          MOV     DS,DX
251B:0016 A37B00        MOV     [007B],AX
251B:0019 8C067900      MOV     [0079],ES
251B:001D 891E7500      MOV     [0075],BX
-U
251B:0021 892E8D00      MOV     [008D],BP
251B:0025 E80D01        CALL    0135
251B:0028 C43E7300      LES     DI,[0073]
251B:002C 8BC7          MOV     AX,DI
251B:002E 8BD8          MOV     BX,AX
251B:0030 B9FF7F        MOV     CX,7FFF
251B:0033 FC            CLD
251B:0034 F2            REPNZ
251B:0035 AE            SCASB
251B:0036 E33C          JCXZ    0074
251B:0038 43            INC     BX
251B:0039 26            ES:
251B:003A 3805          CMP     [DI],AL
251B:003C 75F6          JNZ     0034
251B:003E 80CD80        OR      CH,80
-U
251B:0041 F7D9          NEG     CX
251B:0043 890E7300      MOV     [0073],CX
251B:0047 B90200        MOV     CX,0002
251B:004A D3E3          SHL     BX,CL
251B:004C 83C310        ADD     BX,+10
251B:004F 83E3F0        AND     BX,-10
251B:0052 891E7700      MOV     [0077],BX
251B:0056 8CD2          MOV     DX,SS
251B:0058 2BEA          SUB     BP,DX
251B:005A 8B3E1639      MOV     DI,[3916]
251B:005E 81FF0002      CMP     DI,0200
-U
251B:0062 7307          JNB     006B
251B:0064 BF0002        MOV     DI,0200
251B:0067 893E1639      MOV     [3916],DI
251B:006B B104          MOV     CL,04
251B:006D D3EF          SHR     DI,CL
251B:006F 47            INC     DI
251B:0070 3BEF          CMP     BP,DI
251B:0072 7303          JNB     0077
251B:0074 E97901        JMP     01F0
251B:0077 8BDF          MOV     BX,DI
251B:0079 03DA          ADD     BX,DX
251B:007B 891E8500      MOV     [0085],BX
251B:007F 891E8900      MOV     [0089],BX
-U
251B:0083 A17900        MOV     AX,[0079]
251B:0086 2BD8          SUB     BX,AX
251B:0088 8EC0          MOV     ES,AX
251B:008A B44A          MOV     AH,4A
251B:008C 57            PUSH    DI
251B:008D CD21          INT     21
251B:008F 5F            POP     DI
251B:0090 D3E7          SHL     DI,CL
251B:0092 FA            CLI
251B:0093 8ED2          MOV     SS,DX
251B:0095 8BE7          MOV     SP,DI
251B:0097 893E1639      MOV     [3916],DI
251B:009B FB            STI
251B:009C 33C0          XOR     AX,AX
251B:009E 2E            CS:
251B:009F 8E060602      MOV     ES,[0206]
-U
251B:00A3 BF6A3A        MOV     DI,3A6A
251B:00A6 B99267        MOV     CX,6792
251B:00A9 2BCF          SUB     CX,DI
251B:00AB FC            CLD
251B:00AC F3            REPZ
251B:00AD AA            STOSB
251B:00AE B400          MOV     AH,00
251B:00B0 CD1A          INT     1A
251B:00B2 89167F00      MOV     [007F],DX
251B:00B6 890E8100      MOV     [0081],CX
251B:00BA 33ED          XOR     BP,BP
251B:00BC B86C44        MOV     AX,446C
251B:00BF 8ED8          MOV     DS,AX
251B:00C1 BE0000        MOV     SI,0000
-U
251B:00C4 BF1800        MOV     DI,0018
251B:00C7 E8DB00        CALL    01A5
251B:00CA 2E            CS:
251B:00CB 8E1E0602      MOV     DS,[0206]
251B:00CF 2E            CS:
251B:00D0 C606B70172    MOV     BYTE PTR [01B7],72
251B:00D5 2E            CS:
251B:00D6 C606A60100    MOV     BYTE PTR [01A6],00
251B:00DB FF367100      PUSH    [0071]
251B:00E7 FF366B00      PUSH    [006B]
251B:00EB FF366900      PUSH    [0069]
251B:00EF 9A0800D92B    CALL    2BD9:0008  <----进入开始密码点 并跳到2BD9:0008
251B:00F4 50            PUSH    AX
251B:00F5 9A27061B25    CALL    251B:0627
251B:00FA B86D44        MOV     AX,446D
251B:00FD 8ED8          MOV     DS,AX
251B:00FF BE0800        MOV     SI,0008
251B:0102 BF0800        MOV     DI,0008
251B:0105 E89D00        CALL    01A5
-GEB

AX=FF07  BX=0018  CX=5003  DX=0018  SP=0FF6  BP=1002  SI=0000  DI=0018
DS=446E  ES=F000  SS=4AE8  CS=251B  IP=00EB   NV UP EI PL ZR NA PE NC
251B:00EB FF366900      PUSH    [0069]                             DS:0069=0001
-T2

AX=FF07  BX=0018  CX=5003  DX=0018  SP=0FF4  BP=1002  SI=0000  DI=0018
DS=446E  ES=F000  SS=4AE8  CS=251B  IP=00EF   NV UP EI PL ZR NA PE NC
251B:00EF 9A0800D92B    CALL    2BD9:0008

AX=FF07  BX=0018  CX=5003  DX=0018  SP=0FF0  BP=1002  SI=0000  DI=0018
-U
2BD9:0008 55            PUSH    BP
2BD9:0009 8BEC          MOV     BP,SP
2BD9:000B 83EC0C        SUB     SP,+0C
2BD9:000E 56            PUSH    SI
2BD9:000F C646FB05      MOV     BYTE PTR [BP-05],05
2BD9:0013 9A5C241B25    CALL    251B:245C
2BD9:0018 8846F9        MOV     [BP-07],AL
2BD9:001B 9A860BBE42    CALL    42BE:0B86  <---进入密码程式比较区中
2BD9:0020 33C0          XOR     AX,AX
2BD9:0022 BA2500        MOV     DX,0025
2BD9:0025 50            PUSH    AX
2BD9:0026 52            PUSH    DX
2BD9:0027 33D2          XOR     DX,DX
-G18

AX=0002  BX=0018  CX=5003  DX=0018  SP=0FE0  BP=0FEE  SI=0000  DI=0018
DS=446E  ES=F000  SS=4AE8  CS=2BD9  IP=0018   NV UP EI PL NZ NA PE NC
2BD9:0018 8846F9        MOV     [BP-07],AL                         SS:0FE7=FF
-U
2BD9:0018 8846F9        MOV     [BP-07],AL
2BD9:001B 9A860BBE42    CALL    42BE:0B86
2BD9:0020 33C0          XOR     AX,AX
2BD9:0022 BA2500        MOV     DX,0025
2BD9:0025 50            PUSH    AX
2BD9:0026 52            PUSH    DX
2BD9:0027 33D2          XOR     DX,DX
2BD9:0029 50            PUSH    AX
2BD9:002A 52            PUSH    DX
2BD9:002B 9ACB1A1B25    CALL    251B:1ACB
2BD9:0030 83C404        ADD     SP,+04
2BD9:0033 52            PUSH    DX
2BD9:0034 50            PUSH    AX
2BD9:0035 9A15401B25    CALL    251B:4015
-E 2BD9:001B
2BD9:001B  9A.90 <--90是填入值 NOP的意思
-E 2BD9:001C
2BD9:001C  86.90
-E 2BD9:001D
2BD9:001D  0B.90
-E 2BD9:001E
2BD9:001E  BE.90
-E 2BD9:001F 42.90
2BD9:001F 42.90
-G 破解完成进入GAME

小鬼当家
HA.EXE (PKLITE) /反压缩 用UNP 3.11版
找 9A860BBE42
改 9090909090  即可  没密码画面

或是将下列存成PLAY档  内容如下:

G EB             <-----|
T2                     |
G18                    |
E CS:1B 90             |
E CS:1C 90             破解过程.....DEBUG
E CS:1D 90             |
E CS:1E 90             |
E CS:1F 90             |
G                <-----|

及存一个 PLAY.BAT 档  内容如下

 DEBUG < PLAY > NUL

             即可直接玩了...记得...需要DEBUG来配合使用喔!

  若要我代破密码的 可上下列站台

   台北 机动警察 19-6 02-9587269 14400  ID:FUH SONG
        红辣椒   24HR 02-3941414 14400  ID:FUH SONG
        熊座     24HR 02-9344309 14400  ID:FUH SONG

   宜兰 外星游龙 24HR 039-353950 19200  ID:YU HWANG
                                        ^^^^^^^^^^^这是本人上站ID

  请於各站中的信件区中留信给我,并传到该站中的待破解区中 并留封信给我就可以了

                        俞煌男 ０８／２３／８２笔

                本文欢迎拷贝流传　　但勿将本文修改
                若有问题欢迎来信    多多指教罗!
                上传档案时          请送完整来


俞煌男破解入门教程（５／１７）
俞煌男

嗨...您好:
       想必有看过1-4集的人都不莫生吧..我就是(俞煌男)啦! 小弟写的不太好
 敬请多多原谅包涵...小弟写(破解入门)目的是为了让 不会破解但又想学破解的人
提供了一个管道...当然.我会尽量的告诉您 若您是一位破解高手的话 那麽你就可以
不必看了...破解入门就是教人破解的方法 并不是告诉你改哪些HEX值就将密码砍掉的
高手自有人在 我算不上是位高手 我只想让学破解的朋友们能更快速的将破解技巧熟练
及提供一些本人在破解方面的一些小技巧罢了 或许对高手而言是太没建设性 但对初学者
来说 我相信一定会对您有所帮助的 o
   我所写的(破解入门)是一项服务性质 随个人意愿 来打发时间
并希望能对想学破解之人 有所助益 当然也希望各位朋友能对此(破解心得)提出一些建议
或是批评及您希望增加的内容 皆欢迎你来信告诉我 可以参考第四集中的各站中写信给我

  本人将於９月１０日－９月１５日内复站，但是在宜兰开站 到时欢迎来本站指教罗！
电话在下集告知．请耐心的等待好吗？

 目前本人手上没有什麽东东可做为这次题材,本人考上二专(呦喝..)所以没什麽钱可以
买GAME...所以请各位若有新GAME或是不要的GAME 都可
寄来 宜市镇平路4-57号 俞煌男收即可 (嘻!..这样将可省下一笔钱罗! 若你觉得本人写
得还不错的话 就送GAME来吧! 本人最爱玩GAME了 请各位多多益善)

 哎...目前想玩GAME却没$$请各位寄些好玩的GAME来吧...
      (等开站之後 必定嘉奖 本人会以 CD-ROM+1.2G HD+ZYXEL+24HR来侍候)
           怎麽都没人写信给我呢??唉....或许是自己在自言自语吧!

    常上的站是ＭＩＤＩ－２站 ０２－６２７９０３０ （３线１４４００）自动跳号
      每天都会去抓信包　ＩＤ：ＦＵＨ　ＳＯＮＧ写给我就可以罗！
      或是在９０－ＣＯＰＹ拷贝心得区中写给我就可以

 密码篇:
      密码破解的难易度可分为下列几种较常见到的

     １．在一执行就问密码型的 像小鬼当家．．．等
         ＨＡ．ＥＸＥ密码主档 一执行就问密码

         此种较容易被破解者所破解

     ２．密码在ＧＡＭＥ中执行比较　也就是说你要玩到某种阶段才会被问密码
        像　最近的　幻象雷电 就是这种罗！

         此种只是增加破解者的麻烦来拖延被破解的时间 当然你要玩到要问密码
         时再切入即可罗！

     ３．好像没有了．．想不起来

 初学技巧篇:
      若您遇到第一种时,那我建议您用S-ICE中的LDR.EXE将密码主档先载入记忆体中
      好方便您破解 例:像HA.EXE 我就用 C:\>LDR HA.EXE 就进入了S-ICE模式中
      并请熟记指令o
      请不要急着破解 先一步步的跟我一起作
        进入了S-ICE模式後 请先下个指令 EC 此时你可以用上/下 PAGE/UP OR PAGE/DN
      来流览整个程式 是不是方便了许多呢?

      然後你必须准备 一只笔 一张空白纸(好方便记录自己已追踪到哪里 若当机..等,可
      以重新到刚刚那里 最好是像 破解入门第四集那样 记录  Gxx 等
                                                         Txx
                                                         Gxx
                                                         Pxx
      若你对组合语言基础不是很够的话,那也请你去买本放在旁边 若不懂时 可以查看

      在来就先找一下 CALL xxxx:xxxx的地方 用指标移到 CALL xxxx:xxxx 的下行
      并下个指令 HERE 我举例 HA.EXE小鬼当家的部份 来告诉你吧!

C:\>DEBUG HA.EXE
-U
251B:0000 BA6E44        MOV     DX,446E    <----刚将HA.EXE 用LDR载入时 你可看到
251B:0003 2E            CS:                     反白条状 也就是还没执行
251B:0004 89160602      MOV     [0206],DX
251B:0008 B430          MOV     AH,30
251B:000A CD21          INT     21
251B:000C 8B2E0200      MOV     BP,[0002]
251B:0010 8B1E2C00      MOV     BX,[002C]
251B:0014 8EDA          MOV     DS,DX
251B:0016 A37B00        MOV     [007B],AX
251B:0019 8C067900      MOV     [0079],ES
251B:001D 891E7500      MOV     [0075],BX
-U
251B:0021 892E8D00      MOV     [008D],BP
251B:0025 E80D01        CALL    0135
251B:0028 C43E7300      LES     DI,[0073]  <-----现在我已将游标移到此位置 并下
251B:002C 8BC7          MOV     AX,DI           (HERE) S-ICE便执行从251B:0000到
251B:002E 8BD8          MOV     BX,AX            251B:0028位址中
251B:0030 B9FF7F        MOV     CX,7FFF       阿哈..你可以下 RS 看看DOS下的状况
251B:0033 FC            CLD                   疑..还没出现密码画面 再找下一个试
251B:0034 F2            REPNZ                 试看
251B:0035 AE            SCASB
251B:0036 E33C          JCXZ    0074
251B:0038 43            INC     BX
251B:0039 26            ES:
251B:003A 3805          CMP     [DI],AL
251B:003C 75F6          JNZ     0034
251B:003E 80CD80        OR      CH,80
-U
251B:0041 F7D9          NEG     CX
251B:0043 890E7300      MOV     [0073],CX
251B:0047 B90200        MOV     CX,0002
251B:004A D3E3          SHL     BX,CL
251B:004C 83C310        ADD     BX,+10
251B:004F 83E3F0        AND     BX,-10
251B:0052 891E7700      MOV     [0077],BX
251B:0056 8CD2          MOV     DX,SS
251B:0058 2BEA          SUB     BP,DX
251B:005A 8B3E1639      MOV     DI,[3916]
251B:005E 81FF0002      CMP     DI,0200
-U
251B:0062 7307          JNB     006B
251B:0064 BF0002        MOV     DI,0200
251B:0067 893E1639      MOV     [3916],DI
251B:006B B104          MOV     CL,04
251B:006D D3EF          SHR     DI,CL
251B:006F 47            INC     DI
251B:0070 3BEF          CMP     BP,DI
251B:0072 7303          JNB     0077
251B:0074 E97901        JMP     01F0
251B:0077 8BDF          MOV     BX,DI
251B:0079 03DA          ADD     BX,DX
251B:007B 891E8500      MOV     [0085],BX
251B:007F 891E8900      MOV     [0089],BX
-U
251B:0083 A17900        MOV     AX,[0079]
251B:0086 2BD8          SUB     BX,AX
251B:0088 8EC0          MOV     ES,AX
251B:008A B44A          MOV     AH,4A
251B:008C 57            PUSH    DI
251B:008D CD21          INT     21
251B:008F 5F            POP     DI
251B:0090 D3E7          SHL     DI,CL
251B:0092 FA            CLI
251B:0093 8ED2          MOV     SS,DX
251B:0095 8BE7          MOV     SP,DI
251B:0097 893E1639      MOV     [3916],DI
251B:009B FB            STI
251B:009C 33C0          XOR     AX,AX
251B:009E 2E            CS:
251B:009F 8E060602      MOV     ES,[0206]
-U
251B:00A3 BF6A3A        MOV     DI,3A6A
251B:00A6 B99267        MOV     CX,6792
251B:00A9 2BCF          SUB     CX,DI
251B:00AB FC            CLD
251B:00AC F3            REPZ
251B:00AD AA            STOSB
251B:00AE B400          MOV     AH,00
251B:00B0 CD1A          INT     1A
251B:00B2 89167F00      MOV     [007F],DX
251B:00B6 890E8100      MOV     [0081],CX
251B:00BA 33ED          XOR     BP,BP
251B:00BC B86C44        MOV     AX,446C
251B:00BF 8ED8          MOV     DS,AX
251B:00C1 BE0000        MOV     SI,0000
-U
251B:00C4 BF1800        MOV     DI,0018
251B:00C7 E8DB00        CALL    01A5
251B:00CA 2E            CS:                 <------跟上面相同步骤 下HERE 执行到
251B:00CB 8E1E0602      MOV     DS,[0206]          这一行 用 RS 来看 还是没有
251B:00CF 2E            CS:
251B:00D0 C606B70172    MOV     BYTE PTR [01B7],72
251B:00D5 2E            CS:
251B:00D6 C606A60100    MOV     BYTE PTR [01A6],00
251B:00DB FF367100      PUSH    [0071]
251B:00E7 FF366B00      PUSH    [006B]
251B:00EB FF366900      PUSH    [0069]
251B:00EF 9A0800D92B    CALL    2BD9:0008
251B:00F4 50            PUSH    AX         <------下HERE 哇...就出现密码了 所以
251B:00F5 9A27061B25    CALL    251B:0627         肯定是 这一个CALL有问题 没关
251B:00FA B86D44        MOV     AX,446D           系 先用笔记起来 重新载入 直接
251B:00FD 8ED8          MOV     DS,AX             执行到这个CALL 2BD9:0008的上
251B:00FF BE0800        MOV     SI,0008           方,(因为要进入 CALL 2BD9:0008
251B:0102 BF0800        MOV     DI,0008          中找出哪个是真正呼叫密码的地方
                                                 ) 所以将游标放在 251B:00EB 中
251B:0105 E89D00        CALL    01A5             下 HERE 然後下 RS 疑..刚刚有密
-GEB                                             码,现在却没有 所以肯定是这个
                                                 CALL 2BD9:0008 有问题 下T2 追
                                                 进去里面
                              程式入下列表
-U
2BD9:0008 55            PUSH    BP
2BD9:0009 8BEC          MOV     BP,SP
2BD9:000B 83EC0C        SUB     SP,+0C
2BD9:000E 56            PUSH    SI
2BD9:000F C646FB05      MOV     BYTE PTR [BP-05],05
2BD9:0013 9A5C241B25    CALL    251B:245C
2BD9:0018 8846F9        MOV     [BP-07],AL   <----慢慢找出来罗..当然也要做笔记
                                                  同上 下HERE, RS疑..还是没事

2BD9:001B 9A860BBE42    CALL    42BE:0B86
2BD9:0020 33C0          XOR     AX,AX        <----哇.一执行到这就问密码罗...
2BD9:0022 BA2500        MOV     DX,0025           没关系 重新来过 这次我们知道
2BD9:0025 50            PUSH    AX                这个CALL有问题 我们将这都改
2BD9:0026 52            PUSH    DX                为 NOP 可用 E 2BD9:001B 直接
2BD9:0027 33D2          XOR     DX,DX             将9A860BBE42改为9090909090试
-G18                                              试看 改好後 下G执行看看...
                                                  呜...呜..终於大功告成 而且又
                                                  没密码画面耶...

只要你多多试 就一定会懂的...我随本破解入门内放有 HA.EXE 未破解之主档 供研究
 我会将此信UPLOAD到90网拷贝心得区中 若信区的朋友们想找HA.EXE来练练 可以到
   ＭＩＤＩ－２　ＯＲ　ＭＩＤＩ－１ 中的ＵＳＥＲ　ＵＰＬＯＡＤ区中传

        ＤＥＢＵＧ－５．ＡＲＪ  即是本档罗．．．．！

 大概说明 CALL 42BE:0B86 里的内容 有很多 CALL xxxx:xxxx 有兴趣 也可试试看喔!
 你将会得到结果

 後序：
       请多多送ＧＡＭＥ来吧！好让我下次有个主题 也顺便可以玩一玩来打发时间

       本破解入门这次的内容你觉得如何呢？有没有较充实一些呢？？

       希望我写的每一集都能获得你的喜欢及对你有所帮助 抓到鱼的感觉不错吧！

       把握这个要领 我相信总有一天你会变成高手ｏ

   下集会更深入的讨论喔．．别走开喔．．．！

       只要我一有新的破解入门 您可以去ＭＩＤＩ－２　ＯＲ　ＭＩＤＩ－１

               皆可找到喔．．．请留意．．．

 作者：俞煌男        ９３／０８／２７完笔
                                           ９月１０－１５日内复站


俞煌男破解入门教程（６／１７）
俞煌男

哇..哈哈...我又来罗!....
         我是 YU HWANG 若您们想写信给我时 到90-拷贝心得区留信
              俞煌男(本名)

    或到本站 朋友俱乐部 24HR 039-281739 2400MB HD 给SYSOP
                             宜兰

  请 於 以 上 站 联 络 (我) ....要代破或是建议(破解入门的内容)皆可

     请 各 位 看 官 .....拜 托 了....请 在 以 上 站 中 留 信 给 上 述 ID

  若 你 是 第 一 次 看 本 ( 破 解 入 门 ) 的 话  请 去 抓 完 整 吧!

     我 都 会 放 在 MIDI站 和 MIDI-2站 中

 １．序言：
        目前高手真的是越来越多了..台湾真是卧虎藏龙..我还是那句话[高手自有人在]
        以前刚刚学破解真是不得其门而入,所以都靠摸索而累积来的(功力),(高手)是靠
        自己努力学习及阅读相关书籍而来,  不管你是(高手 或 初学者) 希望你记住一
        句话,请购买原版,毕竟台湾的盗拷风气是很(盛),希望靠大家多多努力罗!但也希
        望一些代理或是写软体的公司,能够考虑到(学生)及(一般收入者)的$$$$,合理的
        利润是无可厚非,但若恶意将软体卖的(吓死人)的话,那麽贵公司的软体一定会被
        四处漫延开来,所以适当的价钱 应该可以让人负担的起是最重要不过了o

  ２．声明：
        以前有某User反应说..我未经作者书面同意而公怖了其程式码 所以..为了以後
        不再发生此问题 我会将此改为 破解技巧入门好了..如果要举例子的话 那麽我
        不会公怖出是以哪软体做为题材 本破解入门要教各位的是破解技巧而非您四处
        找寻的破解码 我不会将最近上市近１个月内的软体破解法公怖 只会大概讲出
        破解技巧 其馀的我就无法帮各位的忙罗! 除非您是购买原版者 不然实在是无法
        告诉您破解法 或是您可以将原版寄来我家罗(附邮资喔..请自理) 或是上我的站
        上吧! 朋友俱乐部 039-281739 24HR Zyxel U1496E 写信给站长罗! 这样也是可
        以的 毕竟我还不想那麽年轻就要去『吃』没钱饭 。

  ３．说明：
       为了怕侵犯着作版权的问题 原本是 1-10讲密码 11-20 讲KeyPort 21-30 讲Key
       Disk 所以迟迟....不敢动手再写下去罗! 所以您若有较好的建议 也欢迎您来本
       站告诉站长喔o

  ４．破解技巧：
       目前有个蛮不错的方法 就是『中断向量表 大搬移』也是90网中的拷贝区讲的
       乾x大挪移啦...这其实也不会太难的 留到下一集再为您们叙述 有些人就是不
       愿意见到别人比您强 所以都将一些技巧给藏了起来 所以多看一些讨论信 多多
       问一些高手 若没人要跟您讲的话 再来我站上问我吧! 虽然我比不上 软体蛀虫
       站长写的好 功力那麽高强 但是我一定尽量用我所知道的告诉您 (若是讲的有所
       偏差 或是 有误导的话 那麽还请来信指教纠正一下罗)

       相信还每一种软体??要能上保护模式的话　那麽大概就没几人会破解罗 当然罗!
       也是可以延长软体寿命。因为保护模式说真的没有很多人真正懂的如何写 更别
       说是会破解的人罗 不过我也会提出一个实例来帮助大家了解一下 在下也写了小
       东东 可以将保护模式转为真实模式 的小TOOLS 不知道用到别种软体可不可以
       不过至少我有试过(我所有一种软体是可以将它返回真实模式的) 若您要的话
       可以拿去试试..没效不要打我喔! 抱歉...本站不接受 FRE/Q 所以请来敝站跟
       我要罗..若要 原程式 也欢迎您上站索取o 当然此TOOLS 不保证不会对您的电
       脑造成任何伤害 这点我先声明一下 到时候若有闪失 请自行负责。(PS:我用是
       没什麽问题 看您要不要冒险罗!)

  ５．结束：
       上次叫我破解那 牙x管理系统者 请来本站拿回去破解档吧! 还有那 破解第五集
       上面所举例的 小鬼当家 某User跟我反应没破解好 很抱歉上次 HD 真的没什麽
       空间可以 INSTALL 所以没注意到...请自行追进去 再不远的前方喔! ---
       2BD9:001B 9A860BBE42    CALL    42BE:0B86    <-------------------

       顺便让您练习一下 不会太难的...

  ６．後续：
       这次没有讲解任何东西　实感抱歉．．．也不知道要写些什麽 东东
       请多多原谅

                 并欢迎来本站 指导.....

                                朋友俱乐部 039-281739 24HR 2400MB 高速
                                              93/10/04      Yu Hwang笔


俞煌男破解入门教程（７／１７）
俞煌男

真讨厌...我又来占用您的宝贵时间了

 最近都被『逼』的叫我赶紧写出下一集 目的只有一个 那就是要问那 『乾x大挪移』
到底是怎麽个移法,步骤怎样呢??唉...又要被偷学走了 不知道以後大家都比我厉害的
话 还会不会记得我的大恩大德呢??<开玩笑的啦!> 还有最近我站上也蛮多对此方式感
到兴趣的User们 都不辞千里一线牵的远从『高雄&台中&新竹&台北』等地拨来一问究竟
我想以後我这『破解入门』不会再发送到台北去罗! 毕竟我电话费都太多 我以後只会放
在我的站上 向各位说声Sorry啦! 以後新的破解入门要看的话 就只好来我站上D/L罗!
或者是等我加入了90 网时 再到拷贝心得区中发表罗!<目前不知道为何 站号都没下来
所以我也没法度> 若有任何疑问 皆欢迎您来本站的 破解软件讨论区中 留信发表一下
您的问题及高见 目前因本人电脑只有一台 所以有许多人要我代破解软体 但又要开站又
要破解实属困难 等我再装一台时 再努力的『破』以达各位对我的厚爱 并会固定每月以
一种做为主题的『破解入门来发表』 希望多捧场唷!这不收钱的...<希望我以後开个破解
补习班 以响各位初学者罗!嘻....慢慢等吧!>

切入主题１：

     乾x大挪移 步骤:
         要大搬家前 先问一下您对DEBUG 有很了解吗??希望您已经对 DEBUG或是相关的
         除错软体有一定的认识 若您不懂的话 很抱歉!若要再回到开始教起 那只怕要花
         更多时间 所以目前我只好当做您都已蛮了解了。再来您对一些中断向量表的功
         能熟吗??都知道其功用何在吗??若不懂 请买本书好好Ｋ一下罗!

         中断向量表是在 0:0 位址中 你可以用 DEBUG 来看...
D:\TOOLS>DEBUG
-D0:0
0000:0000  8A 10 23 01 F4 06 70 00-16 00 BA 0C F4 06 70 00   ..#...p.......p.
0000:0010  F4 06 70 00 03 01 24 C8-43 EB 00 F0 EB EA 00 F0   ..p...$.C.......
0000:0020  06 01 24 C8 10 00 FC 18-57 00 BA 0C 6F 00 BA 0C   ..$.....W...o...
0000:0030  87 00 BA 0C 9F 00 BA 0C-B7 00 BA 0C F4 06 70 00   ..............p.
0000:0040  0C 01 24 C8 4D F8 00 F0-41 F8 00 F0 74 07 70 00   ..$.M...A...t.p.
0000:0050  6B 0B F3 09 1B 01 24 C8-0F 01 24 C8 12 01 24 C8   k.....$...$...$.
0000:0060  00 E0 00 F0 2F 00 2F 0D-6E FE 00 F0 9F 01 EC 08   ...././.n.......
0000:0070  D7 01 03 C8 22 1E 00 C0-22 05 00 00 3C 5F 00 C0   ...."..."...<_..
-
         以上就是我的0:0中断向量表的位址 这是您首先要知道的

       再来要做什麽呢??为了怕不会此步骤的朋友们 我下次会写个常驻程式来帮助各位
       来自设搬移绝对位址中。请利用 INT 15 AH=87 就可以达到上述之功能。

       为了避免您使用上的不便 我不列出用DEBUG来搬移的方法 我会尽快的将常驻搬移
       程式写好 并将原程式公布出来 以利各位方便去修改。

       但请各位注意一点 也就是当您将『中断向量表』搬移了之後 您在破解的时候也要
      注意 当有程式码要呼叫 中断向量表的时候 请务必要指向您所搬移的绝对位址之中
      并留意相关可能的程式码 以免造成一些要中断向量表的程式 找不到该中断等功能

       我再简单重覆搬移步骤:
            首先将那 中断向量表 搬移到 记忆体中的任一绝对位址中<自行设定>
            再来就是将中断向量表或是DEBUG 指向您新搬移的中断向量位址中
            请留意一些正常呼叫的中断功能 并指向新设定的中断向量位址

          1.我将那中断向量表的位址 推入暂存器中
          2.并将旗标也推入到 堆叠暂存器之中
          3.取出 推入的中断向量表的位址 并放在指定的绝对位址中
          4.取出 推入堆叠 旗标
          5.将DEBUG 指向新设定的中断向量表 绝对位址中
          6.并留意一些 像 FAR [0:20] 呼叫 等..适当加以修正

              以上大概就是那样罗! 若您已知道我的意思 相信你可以自行搬移
              若还是不懂 则代表您对 组合语言 的概念及程式写作可说是不太懂
              只要利用 MOV POPF PUSHF PUSH POP INT15 等指令即可完成。

结束:
       由於被逼出来的 并没有花太多心思去考虑详细的解说 因太花时间了 所以我不打
       算真的一一写出来 但别担心 我会尽快的将 常驻搬移中断向量表的程式写好 以後
       您可以不用去知道如何搬法 只管去设定您自设的中断位址 即可顺利使用。

             有关任何问题 欢迎您来本站 破解讨论区中 留信给站长即可

              朋友俱乐部        ０３９－２８１７３９ ２４ＨＲ   高速

                                        ＹＵ　ＨＷＡＮＧ留


俞煌男破解入门教程（８／１７）
俞煌男

我又来教各位破解入门啦! 好讨厌喔...都没人寄好玩GAME来..当心下次不写罗!所以快寄!
凡有任何疑问或是要代破 皆可到 友谊网中的破解讨论区写信给我Yu Hwang记住喔!
最近都较少去接９０网ＣＯＰＹ区罗！因为太乱了 都是问破解码 真没意思..况且又少人
在讨论破解技术方面的 所以我都很少写信了 信管要多努力啦! 许多高手都不去接那区罗!
反而一些求助於人的一大堆 问一些烂东东 都是我xxGAME密码表不见了 请告知破解法..
哇...那请90网站长开个 破解码公怖区要来的好多了 以免大家都是乱丢信 这是我小小的
建议啦..当然!本站也想尽快接９０网 但都好像没人理我似的 我也有传到软体蛀虫站那边
但一直连个消息都没有 所以本站打算建个新网路 取90网之优点 避之缺点 当然有兴趣的
站长们 请来本站索取申请表格 打个小广告 请多多包涵。若有不小心得罪之处 多多包涵

 １．破解技巧:

   额外篇:

       最近太无聊啦..拿飞x传说来解说一下破解过程 当然在此重覆一遍 你若是不会用
       Ｓ－ＩＣＥ Ｏｒ ＧａｍｅＴｏｏｌ Ｏｒ Ｄｅｂｕｇ 请参考前几集说明 在此不
       再重覆讲罗!

     先将那GAME INSTALL 到硬碟中,然後挂好S-ICE 以方便我们去追踪 再来就是执行
        ＦＬＹ．ＢＡＴ档罗！ 请注意你先用ＵＮＰ３．１５来反压缩主档
        好像是ＳＴＡＲＴ．ＥＸＥ吧！反正要先解压缩喔！

      然後就是进入GAME啦!就可以看到一些动画...等 选择好之後 就问密码罗!

        在此教各位一个我常用的方法 保证都可以唷!这对初学者来说是蛮好用的方法唷!

       当问密码的时候 那个GAME好像是按 『空白键』来输入密码的 也就是说 你当按下
       『空白键』之後 便快速的按 Ctrl+D 切入S-ICE画面中 应该就不难找到密码比较
       之所在了...我破了这GAME花五分钟内即告破解..太好解了嘛! 所以我都不太喜欢
       公怖破解码 以免遭人非议 请多试几次一定就可以破了 当找到破解码之候 就将
       机器码抄起来 用PCTOOLS 找来修改就可以了。

       还有你输入密码错误 共有叁次机会 若叁次都错了 就会出现 SORRY.xxxxxx这时候
       你别灰心 还有的救 快按Ctrl+D 就会出现 JZ xxxx 的指令啦! 也就是说当你密码
       若输入错误的时候 是否错误 是的话就跳出来罗! 不是的话就进入GAME 你只要改
       成NOP NOP 90 90 就是说 你叁次都错 那就不跳出来了 你就可以在画面上看到
       Sorry xxxx和 谢谢同时出现 就进入GAME中了...这样懂吗??

       当然啦..若你真的很喜欢我所写的 破解入门 别忘啦!叫您站长加入 本人所创的网
       路喔..那麽本人就可以跟你空中相会啦! 039-281739 24HR 朋友俱乐部 3GB 高速

       我会的有什麽??我也不太知道耶..反正就是硬要解开就对啦! 努力一定会使你有收
       获的 永远靠别人问破解码 那根本没用。所以尊重智慧财产权 是靠大家努力的!
       若你也都是破解高手 就请您别乱公怖 破解码 那麽不会破解又盗拷软体的人就不
       能用了 当然拿了也是白拿! 这样至少能减少一些 软体流通速度 以免又刚出来 马
       上就 四处乱飞 到处可见。这样好软体谁要拿出来与大家分享呢? 好技术都不愿意
       公怖 这就是原因。希望共勉之...。

 预告:
        想学破KEYPROT的人有福啦! 从DEBUG-10到DEBUG-20 集 我会举例说明如何快速的
        破解KEYPROT 让想学的人 有些概念! 我破过的KEYPROT 我也忘了有多少?所以不
        容你错过喔...当然再写二集就不写 破密码的 说明罗! 相信我以前所讲的 一定
        可以让你有足够的功力来解一些较简单的密码 及简单的GAME 。当然还有许多破
        解密码的技术没公怖 但怕涉及太深 一般初学者看不懂 所以不讨论 有问题欢迎
        你来本站问吧!我会的我尽量跟你讲罗!

        还有那向量大搬移 我已在我站上公怖过了 你可以用最简单的 A E 来做 也可以
        用M 来做 更可以像我写的常驻搬移方式来做 全靠你喜欢罗! 常驻方式是较简便
        的.若你对写程式还有点基础的话 不妨写个来用用啦! 搬移方法我有五种以上
        所以说..这并非太难的! 不要想的太多了...真搞不懂有什麽好藏的! 谁要知道问
        我吧!..保证到你一定会。要有代价喔..送GAME来吧!...嘻!

        有个朋友传来 古城风情-模拟城市 那下次就讲这个好啦 ..最近没什麽空可以破
        所以下次再讲解罗!o

        本说明档 着作权:嘻...本人俞煌男所有 不得贩卖 修改内容。

            朋友俱乐部 ０３９－２８１７３９  ２４ＨＲ  ＺｙＸＥＬ  ３ＧＢ

                                   10日/11月/93年          Ｙｕ  Ｈｗａｎｇ笔


俞煌男破解入门教程（９／１７）
俞煌男

嗨..各位好!
      在下就是 俞煌男罗! 每次总是难免打一下自己的知名度...嘻! 写的那麽辛苦 这点
应该可以原谅才对吧! 写破解密码 只剩下一集..写到第十集将不再写罗! 所以请各位好好
去领会我所讲的事吧! 相信对你有所助益 你若是看不懂 拜托好吗?花点钱买本书去看吧!
没有人是没有看书去学的 一本才不过几百元 所以相信一定很值得你去买的啦!

   其实破解密码原本就不算是什麽高『深』的技术 并非会破解密码的人都是高手 这一点
大多人都误解了 相信只要你有心想去学的话 那麽就一定没什麽困难之处了。 最重要是看
你自己的努力与否罗! 最近都听到一些初学者 能有点斩获 相信这是你好的开始 别忘了要
多多努力唷! 不要太过自满 以免遭人&^*^*^我就管不着了。当然也不要乱流传一些破解码
以免...别人心血得不到合理的报酬 那麽就真的是罪过了。 真的希望你我来共同勉励之并
保障之好吗?? 『处处为人着想』

 １． 现在我较少去90网写信 所以请到破解网破解技术交流区找我吧!ID:Yu Hwang 写
      信给我就可以罗!你可以就近去写信给我。或是直接来我的站上讨论都可以。

      站名:朋友俱乐部 039-281739 24HR  <破解网总站>

      本站新创.. 破解技术交流网 ..诚意邀请一些站长加入及徵各县市HUB&HOST...

 ２． 破解技术交流网  申请表格:

      站台<英文名称>:
      站台<中文名称>:
      系统操作员:
      建站系统:
      是<私人站>或<公开站>:
      开站时间:
      最高速率:
      站台电话:
      家中电话:
      公司电话:
      系统操作员<中文姓名>:
      系统配备:
      魔电厂牌:
      系统操作员<生日.年龄>:
      职业:
      网路时间:
      预定什麽时候开始接信:
      是否要担任HUB得职务:
      建议:

      请有心加入新网的站台 填写好之後 送来本站即可。

      ECHO KEY           共 ２２区
      ------------------------------------------------------------------------
      破解码公怖区       CRACK-CODE
      破解技术讨论区     CRACK-CRACK
      一般信件讨论区     CRACK-GENERAL
      建站实务讨论区     CRACK-BBS
      中文系统讨论区     CRACK-CHINESE
      软体讨论区         CRACK-SOFT
      新站广告区         CRACK-NEWBBS
      中古买卖区         CRACK-SALE
      硬体讨论区         CRACK-HARD
      音乐/音效讨论区    CRACK-MUSIC
      快信讨论区         CRACK-MESSAGE
      打屁瞎掰讨论区     CRACK-TALK
      热门职棒讨论区     CRACK-BALL
      病毒讨论区         CRACK-VIRUS
      交友专区           CRACK-FRIEND
      心情讨论区         CRACK-MOOD
      站长讨论区         CRACK-SYSOP         ;不开放给User
      网路测试区         CRACK-TEST          ;不开放给User
      HUB xxxx区         CRACK-HUBxxxx       ;由HUB 自定信区
      魔电讨论区         CRACK-MODEM
      游戏攻略心得发表区 CRACK-GAME
      程式语言讨论区     CRACK-LANGUAGE

      欢迎有兴趣的站台来加入本网的行列。

      可以丢到 朋友俱乐部...总站来 039-281739 24HR ZYXEL

 破解技术交流网      加 入 站 名 列 表     站 台 电 话     开放时间    速   率
------------------------------------------------------------------------------
HOST     39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        19200
HUB100   39:39/100     外星游龙资讯站    TEL:039-353950      24HR        19200
         39:39/101     天蝎星资讯站      TEL:039-357940      24HR        14400
         39:39/102     瑞智资讯交流站    TEL:039-778657      24HR        14400
         39:39/103     雷鸟资讯交流站    TEL:039-322865    23:00-07:00    2400
         39:39/104     伊甸园资讯站      TEL:039-889981      24HR        14400

台北地区
HUB200   39:39/200     友谊资讯交流站    TEL:02-7236293    16:00-08:00    9600
         39:39/201     熊座资讯交流站    TEL:02-9344309      24HR        14400
HUB300   39:39/300   遨游鹏资讯交流站    TEL:02-8747279      24HR        14400
         39:39/301     魔法王国交流站    TEL:02-5991763      24HR        19200
         39:39/302     BAD BOYS BLUE     TEL:02-2190318      24HR        14400
HUB500   39:39/500     麦帅资讯交流站    TEL:02-9512743    17:00-21:00   14400
PVT<私>  39:39/501     光台资讯交流站    TEL:02-222xxxx      xxxx        14400
         39:39/502 佩雅达恒星交流广场    TEL:02-9201852      24HR        14400
         39:39/503 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/504   超时空资讯交流站    TEL:02-8752787      24HR        14400

桃园地区
HUB400   39:39/400     东方快车交流站    TEL:03-3352798      24HR        14400

  ３．由於太多人反应不知如何找到密码判断点 还是不解 所以我再提出来大家一起讨论
      建议:刚开始学破解密码的初学者 请找一些较易上手来破解 以免减少自己的信心
           可找像:失落封印.叁国志III<中文版>.飞翔传说.雷射坦克.小鬼当家...等
           易於破解 刚开始学习破解者 请不要好高骛远 最好是从简单开始做起 以免又
           使自己信心大挫。凡事要务实 没有一步登天的道理。
      建议:请买本 组合语言的书 最好是有解说指令的用法及功能 像 施威明 组合语言
           实务<旗标出品 非广告> 或是 解名人翻译 活用组合语言 <松岗出版 非广告>
           这二本也都不错喔! 最主要都有指令的解说 对初学者来说 是蛮不错的书啦!
           当然还有许多好书 太多啦!请自个选择较易於自己研读的书。

   找出密码比较点方法如下:

     <1> 由於程式非自己所写 所以要破解密码一定要自己去追踪 方可知道比较点之所在
         所以不可能一眼就看出比较地方 除非自己的程式 不然较难知道比较点。

         许多人苦找寻 S-ICE 的中文说明 我於此先引出 以利於你指令的[运用]
         请好好将S-ICE指令Ｋ熟点 好方便破解喔!

                   启动 Soft-ICE 的 Hot Key 是 Ctrl-D
                       可不可举出最常用的指令....
                       上面写的都是英文，弟看不懂....
                       这跟DEBUG的指令一不一样????
          有几个指令 (如 U, A, G, T, P, S, F, M, C, R) 是一样的
          其他的指令就比 DEBUG 强太多了, 其实我也还没有完全
          搞清楚 (手边没有资料, 只有靠自己 try), 下面几个是
          我比较常用到的指令:
          BMPB, BPMW, BPMD : 当程式对某一个位址做存取时产生
                             中断, 叁个分别是 Byte, Word,
                             Dword, 可以指定是在读或写的时候
                             产生中断, 如:
                                 BPMB DS:DX R
                             当对 DS:DX 读取时产生中断
          BPINT : 当程式要做某一个 Interrupt 时产生中断, 如
                      BPINT 16
                  当程式要做 INT 16H 时中断
          BPX   : 当程式执行到某一个地方时中断, 如:
                      BPX CS:IP
          BPIO  : 这个是破 KeyPro 用的, 拦截 I/O PORT
          其他像 BL (列出目前的中断点), BC (清除中断点),
          BD (Disable 中断点), BE (Enable 中断点) 也都
          是非常方便的指令。

 [介绍]
   2.1 磁片内容
   2.2 载入 Soft-ICE
   2.2.1 无 Extended Memory 时的载入方法
   2.2.2 有 Extended Memory 时的载入方法
   2.2.3 如何调�
 Soft-ICE 使能依您的设定启动
   2.3 脱离 Soft-ICE
   2.4 重新载入 Soft-ICE

2.1 磁片内容

Soft-ICE 原本装在一片5又1/4英寸或一片3又1/2英寸的磁片中。

当您执行S-ICE时，S-ICE注册所有人的大名将会被[险]示於萤幕上，以制止着作权被
侵害。 S-ICE磁片本身为了您方便起见，并未实际做防拷措施。同样，为了我们的
便利，我们感激您对我们的许可协约有着高度的尊敬。为免原版磁片损毁而制作一
份备份程式乃非常重要的一件事。

Soft-Ice磁片的目录中应当含有下列档案:
   S-ICE.EXE
   S-ICE.DAT
   LDR.EXE
   MSYM.EXE
   EMMSETUP.EXE
   UPTIME.EXE
   README.SI
   SAMPLE.EXE
   SAMPLE.ASM
   SAMPLE.SYM

S-ICE.EXE    为 Soft-ICE 主程式。
S-ICE.DAT    为 Soft-ICE 启始参数设定档。 LDR.EXE      为 Soft-ICE
主程式及符号档(symbol file)的载入程式。 MSYM.EXE     为 Soft-ICE
符号档的产生程式。 EMMSETUP.EXE 为 供使用者自定扩展记忆体(expanded
memory)使用方式的程式。 UPTIME.EXE   为 修正时间调[拯]的程式。 README.SI
为 一文字档，其中包含有Soft-ICE使用手册未提及的事项。 SAMPLE.EXE   为
使用者指南中所使用的一个示范(DEMO)程式。 SAMPLE.ASM   为 SAMPLE.EXE
的组合语言原始程式。 SAMPLE.SYM   为 SAMPLE.EXE 的符号档。

2.2 载入Soft-ICE

在执行Soft-Ice之前，先将磁片中所有的档案拷贝至硬碟机中。 �
o些档案应当放置於您的档案路径所能存取到的目录中。 S-ICE.EXE 能以DEVICE
DRIVER的形式载入抑或以一般程式於DOS 命令行下执行。 如果想�
n使用Soft-Ice的特点的话，则SICE.EXE必须在CONFIG.SYS中以DEVICE DRIVER
的方式载入。

注解 :
如果您没有extended memory的话,则Soft-ICE 无法以device driver的形式载入。
也就是说您必须在DOS prompt下载入它。

2.2.1 无 Extended Memory 的载入方法:

当您没有extended memory时，Soft-ice将尽量将自己本身载入到记忆体最高位置。
而被Soft-ice所使用的记忆体将会被排除在外(map out)。因此DOS记忆体的可视范围
将比载入前为少，建议您在其他任何常驻程式前载入 S-ICE。 如果您没有 extended
memory, 只要键入:

    S-ICE

2.2.2 使用 Extended Memory 来载入的方法:

以Extended Memory来载入S-ICE可以下列两种方法达成:
  1. 在 CONFIG,SYS, 中将S-ICE.EXE以driver的形式载入:
     如果您将使用下列的功能，则必须是此种方法。
      * 与经由ROM BIOS CALLS来存取记忆体的程式，共享记忆体。
         (如 VDISK,SYS, RAMDRIVE.SYS,HIMEM.SYS,cache programs, 等等).
      * 使用Soft-ICE EMM 4,0 相容能力。
      * 使用Soft-ICE 作为符号或原始程式阶段的除错。
      * 使用back trace ranges.
      * 与其它Nu-Mega 的产品如MagicCV,共同使用S-ICE。

      当以DRIVER形式载入时，Soft-Ice将配置一部份的Evtended memory以作为
      自己本身及其附属程式使用，因此不会有记忆体冲突发生。S-ICE.EXE必须
      在其它会配置Extended memory的程式之前载入。(例如:VDISK.SYS,
      RAMDRIVE.SYS)。通常如果Soft-Ice在CONFIG.SYS中第一个载入时，能得到
      最好的效果。

      对於那些新进使用Soft-Ice的使用者而言，在CONFIG.SYS中以下列叙述来将
      Soft-Ice当作第一个载入的程式是很明智的:

      device = drive: \path\S-ICE.EXE /SYM 50

      Drive 及 path 须指派为S-ICE.EXE 所在的目录.该项叙述会在系统重置後
      将Soft-Ice载入，适合作为入门指引。无论如何，Soft-ICE将不会载入更为
      强大的功能(如EMM 4.0)。在您使用有一些心得後，您可以重新调[拯]Soft-Ice
      来使用诸如此类的功能。如果您已熟悉Soft-Ice或想要立即调[拯]设定以使用
      其功能的话，请参阅第六章(Soft-ICE 初始设定选项)。

小心!! :
当您的系统於第一次安装新的DEVICE DRIVER时，事先准备一张可开机的磁片是一项
明智的措施。此种预先的警戒，乃是为了防范诸如内定的设定与您的系统不相容等的
突发事件发生。
      如果您并不确定如何编辑您的CONFIG.SYS档，请参考您的系统使用手册，或是
      您的文字编辑器的使用指引。在您修改完CONFIG.SYS档後，您必须重新启动您
      的系统以使先前的修改生效。
   2. 於DOS Prompt 下键入S-ICE. 在实际载入前Soft-ICE将会提示一段讯息，如要
      避免的话，则须将 "EXTENDED" 这个字放於S-ICE.DAT档案中，请参阅第6.4节
      有关S-ICE.DAT的部份来取得更多的资讯。使用此法将使S-ICE.EXE自动载入至
      extended memory最高位置，无论是否已有其它程式在那儿。如果您可以确定
      没有其它的程式在使用 Extended memory，则可使用该法。当以此法载入时，
      Soft-ICE 将不占传统记忆体(conventional memory)。您所应下的指令为:

      S-ICE

注解:
当您在命令列下载入Soft-Ice时，您将无法使用Soft-Ice的所有特异功能。如果您想
把Soft-Ice当成是唯一的除错器的话，建议您由CONFIG.SYS中载入Soft-Ice。
如果您想将Soft-Ice以DEVICE DRIVER的形式载入，但不想让Soft-ice一直常驻的话。
您应当使用 /UN 该选项来解除。请参阅第6.3.1节来取得更多的资讯。

 2.2.3 调[拯]Soft-ICE 使能依您的设定启动

您可以於Soft-Ice位於CONFIG.SYS中的载入选项开关及Soft-Ice的启始设定档
S-ICE.DAT 来自定启动方式。选项开关允许您自定该保留多少Extended memory给
Soft-Ice使用。启始设定档S-ICE.DAT允许您指定调[拯]的选项、功能键的安排及定义
一个自动启始的字串。所谓自动启始字串乃是每次安装Soft-Ice後，一系列自动执行
的命令序列。更多有关自定Soft-Ice的资讯，请参阅第六章。

 2.3 解除 Soft-ICE

有时候，您也许需要解除Soft-Ice。通常的解除的理由是要执行一个使用80286
或80386保护模式指令的程式。要解除Soft-Ice，请输入:

   S-ICE /U

这个指令将使的机器回复到真实模式，如果Soft-Ice是由CONFIG.SYS载入的话，则原
先所占用的记忆体将依然被保留给Soft-Ice，且无法给其它的程式所使用。如果Soft
-ice是由命令列下所启动的话，解除的动作将会把原先所占用的记忆体释回。

注意 :
如果您的系统中有任何会回填的记忆体(backfilled memory)或是expanded memory
仍在使用中，解除的动作将会使您的系统瘫痪。

 2.4 重新载入 Soft-ICE

即使您是由CONFIG.SYS中启动Soft-Ice的，您仍能随时重新载入Soft-Ice。
如果Soft-Ice是由CONFIG.SYS中启动的话，则原本调[拯]选项的设定(EMM 4.0, 符号及
原始程式等...)仍然有效。想重新载入 Soft-Ice 键入:

   S-ICE

===============================================================================
    以上请熟读 一定有益於你破解的方便喔! 多操作 不是纸上谈兵 请实地练习!!

   <2> 若你找到你认为可疑的判断点时 可先修改记忆体资料 试试看就可知道是否真的是
       密码判断点所在。

       例: 2334:1234      CMP AX,AF
           2334:1236 74B1 JZ  0108

        下指令 E 2334:1236  将74 B1 中的74改成EB 就是JMP<无条件跳跃>
        改好之後下 G 输入密码<乱打> 就可知道是否有改成功了! 任何高手也一定都是
        这样一次次的试出来的。所以请一边追踪一边写笔记 以防不小心重新开机或当机
        以免又要重新追踪的不便。

   <3> 我原本是想再举出实例来帮大家更易於了解 但又实在不想再让有『版权的软体』
       又遭到流传的命运 所以只好将有关技术性的方面提出讨论 至於实例破解解说可能
       将在第十集中再次举例说明 有关任何问题皆可於 『破解技术交流网』中讨论。

 後序:
      其实最近都较没什麽主题 大部份GAME的破解已有许多高手已经公怖出破解码 所以
      我就没有再破解的必要了! 最主要是破解密码也是没有什麽好讲的 破解密码算是
      最简单的一门课程 接下来就较精彩了 像 KEYPROT & KEYDISK & 序号保护...等
      不过我认为 若你对破解密码还是不太懂的话 以後我若讲解 KEYPROT 时 你一定更
      不懂啦! 所以KEYPROT & KEYDISK & 序号保护 是属於进阶中上的人学习的 劝初学
      者若想更进步的话 无非是多读书多操作及熟记指令 别无他法。

          作者:俞煌男      朋友俱乐部 专业站 ３ＧＢ Ｚｙｘｅｌ ２４ＨＲ
                           ＴＥＬ：０３９－２８１７３９ 欢迎莅临指教。


俞煌男破解入门教程（１０／１７）
俞煌男

哇...我又来啦! 请多多捧场喔...不收费啦!免惊<台语>:

    唉..我现在想了一下...嗯!记既然有『破解入门』 就应该谈谈『破解进阶』吧! 於是
我又开始走向遥遥无期的破解文件写作罗!

   目的: 是为了让已经 每期都看的User 从破解入门1-9集中已经学习到一些破解的理念
         接下去再写一些『破解进阶』 的技术方面来讨论 好让已有基础的朋友们 更进
         一步的走向更高技术 将不再局限於简单的密码破解说明 更举例出密码的保护方
         式及针对此密码破解时 应该注意的事项 并告知针对此密码快速破解的经验谈。

   说明: 本文开始将不引出 软体名称 只会将程式某段较具有讨论性质的地方引出来 并
         稍做解说保护手段及破解方式 不懂请自个翻书或查资料 在此不再多加序述。
         并会深入探讨其方式及解决方法。

  正题:  <1> 讨论一些密码防破手段 方式有下列几种:
           １．现在一些软体较俱有防破手段的无非是 重设 8259 IC 来造成连 『S-Ice
               GameTools,Debug,GameBuster,Fpe .....等多项除错软体及游戏辅助软体
               均无法动作 而会造成当机,或是游戏中断...等问题。

               为何重设 8259 IC 会造成这样的问题呢?
               第一点 请去找有关电脑硬体的书籍参考其动作方式
               第二点 重设8259 IC 若电脑环境发生错误时 会产生一些硬体中断 就会
                      与现在的环境所不同 而造成除错软体的失效。<大概是这麽样子
                      我不太会讲就是啦!>

               如何预防这类的防破手段呢??
               一般采用重设 8259IC来达到让除错软体失效 不只用在防密码破解 也都
               被广范的用到像:KEYDISK,KEYPROT...等 无非是不想让别人破解之软体。
               破解的方法当然是有罗..凡事有保护的软体 一定可以被破解出来的 只是
               时间的多寡罢了!
               您可以用『中断搬移方式』 来针对此项保护方式来破解 当然不是只有单
               单搬移就可以啦! 还要左闪右闪的躲地雷 蛮麻烦就是了! 你搬移中断向
               量表需重新将DEBUG 所指的中断向量表的位置重新指向你新搬移的绝对位
               址中方可 以後在除错的时候 也要留意一些呼叫 旧的中断向量表的一些
               功能也要稍加修改并指向你新般移的绝对位址中方可正常执行。

               附上一小程式  是将 0:0 搬移到 5000:0000 位址中
               请自个编辑成COM...利用EXE2BIN.EXE 转换成 COM 档
;------------------------------------------------------------------------------
CSEGBL          SEGMENT
                ASSUME  CS:CSEGBL,DS:CSEGBL
                ORG 100H

START:
                JMP     INT        ;跳到中断向量表的搬移动作

                .DATA
DESC_TABLE      LABEL   WORD
DUMMY           DW      4 DUP(0)
GDT_LOC         DW      4 DUP(0)
SOURCE_GDT      DW      0FFFFH
                DW      0000H
                DB      00H
                DB      93H
                DW      0000H
TGET_GDT        DW      0FFFFH
                DW      0000H
                DB      05H
                DB      93H
                DW      0000H
BIOS_CS         DW      4 DUP(0)
BIOS_SS         DW      4 DUP(0)
;=============================================================================

INT:
                ASSUME  CS:CSEGBL,DS:CSEGBL
                MOV     AX,CS
                MOV     ES,AX
                MOV     SI,OFFSET DESC_TABLE
                MOV     CX,200H
                MOV     AH,87H
                INT     15H
                INT     20H    ;结束并常驻
CSEGBL          ENDS
                END     START
;=============================================================================

   列出本人 中断向量表 在DEBUG 的状况...
C:\TOOLS>DEBUG
-D0:0
0000:0000  DB 0F 8F 33 F4 06 70 00-16 00 0D 18 F4 06 70 00   ...3..p.......p.
0000:0010  F4 06 70 00 03 01 D2 1F-43 EB 00 F0 EB EA 00 F0   ..p.....C.......
0000:0020  3F 01 44 33 10 00 73 33-57 00 0D 18 6F 00 0D 18   ?.D3..s3W...o...
0000:0030  87 00 0D 18 9F 00 0D 18-B7 00 0D 18 F4 06 70 00   ..............p.
0000:0040  0C 01 D2 1F 4D F8 00 F0-41 F8 00 F0 FC 17 5D 19   ....M...A.....].
0000:0050  6B 0B 3B 15 1B 01 D2 1F-0F 01 D2 1F 12 01 D2 1F   k.;.............
0000:0060  00 E0 00 F0 C7 18 5D 19-6E FE 00 F0 9F 01 34 14   ......].n.....4.
0000:0070  D7 01 A6 1F 22 1E 00 C0-22 05 00 00 3C 5F 00 C0   ...."..."...<_..
-D 5000:0000
5000:0000  DB 0F 8F 33 F4 06 70 00-16 00 0D 18 F4 06 70 00   ...3..p.......p.
5000:0010  F4 06 70 00 03 01 D2 1F-43 EB 00 F0 EB EA 00 F0   ..p.....C.......
5000:0020  3F 01 44 33 10 00 73 33-57 00 0D 18 6F 00 0D 18   ?.D3..s3W...o...
5000:0030  87 00 0D 18 9F 00 0D 18-B7 00 0D 18 F4 06 70 00   ..............p.
5000:0040  0C 01 D2 1F 4D F8 00 F0-41 F8 00 F0 FC 17 5D 19   ....M...A.....].
5000:0050  6B 0B 3B 15 1B 01 D2 1F-0F 01 D2 1F 12 01 D2 1F   k.;.............
5000:0060  00 E0 00 F0 C7 18 5D 19-6E FE 00 F0 9F 01 34 14   ......].n.....4.
5000:0070  D7 01 A6 1F 22 1E 00 C0-22 05 00 00 3C 5F 00 C0   ...."..."...<_..

           ２．第二种方法是 当掉『INT1 OR INT3....等』中断服务常式 来防破解
               目的是为了当掉DEBUG

               解决方式 用 搬移向量表 就可以通行无阻的顺利破解完成罗!

           ３．第叁种方法是 程式被外部程式压缩过 像PKLITE,LZEXE,EXEPACK....等
               目的是为了让你无法用PCTOOLS修改原程式码 不过若直接在记忆体中修改
               也是可以的。

               解决方式 可用UNP 反压缩回来就可以罗! 格式:UNP 档名.附属档名 即可

           ４．第四种方式 程式在编写过程中 已经有经过编码处理过
               目的是为了让你无法用PCTOOLS修改原程式码 不过若直接在记忆体中修改
               也是可以的。

               解决方法 可用EXESHAPE 来反写回去就可以罗!  我引出EXESHAPE 的用法
                        可让大家学习。

     ＥＸＥＳＨＡＰＥ Ｎｏｎ－Ｒｅｇｉｓｔｅｒｅｄ Ｖｅｒｓｉｏｎ １．２０
              （ Ｃ ）Ｃｏｐｒ． Ｍｉｎ Ｊｅｉ Ｃｈｅｎ
                 Ａｌｌ Ｒｇｉｈｔｓ Ｒｅｓｅｒｖｅｄ

        本版修改部份简介：
                (A) 可处理超过 64K 的执行档重新定位表
                (B) 可处理刚好夹於 64K 与 64K 之间的定位部份
                (C) 增加内建字型
                (D) 画面重新规划
                (E) 档案输入长度增长
                (F) 增强防止被 Trace 出原档

 EXEWRITE, EXEBACK, EXEMAKER, S-WRITE...等, 这些都是因为商业版压缩所产生
 的反压缩工�
, 但这些软体不是效率太差, 就是使用者界面不�
亲和力等.
 如：输入过的暂存器值不能够再修改或是档案覆盖等问题. 现在您将不用担心这
 些问题, 因问 EXESHAPE 1.20 全部包办啦 !!

 EXESHAPE, 一个用 Assembly 写成的反压缩工�
, 无论是速度, 正确率, I/O 效
 率, 强化使用者界面... 都比上述的反压缩工�
更胜一畴, 而且加上自动判断档
 案长度是否相同; 自动判断 EXE 档的长度, 因为 (SS*10H+SP) - (DS*10H+100H)
 所算出来的档案长度不是很准, 此项功能可帮您算出最精确的 EXE 档长度.

__________________________________________________________
_____________________ _
测试档案: XPREAD.EXE (3.0)

STEP 1:
        用 DEBUG 或 SYMDEB 载入 XPREAD.EXE

C:\XPRESS>DEBUG XPREAD.EXE
-U
241C:0012 06            PUSH    ES   <-- LZEXE 的开头
241C:0013 0E            PUSH    CS
241C:0014 1F            POP     DS
241C:0015 8B0E0C00      MOV     CX,[000C]
241C:0019 8BF1          MOV     SI,CX
241C:001B 4E            DEC     SI
241C:001C 89F7          MOV     DI,SI
241C:001E 8CDB          MOV     BX,DS
241C:0020 031E0A00      ADD     BX,[000A]
241C:0024 8EC3          MOV     ES,BX
241C:0026 B400          MOV     AH,00
241C:0028 31ED          XOR     BP,BP
241C:002A FD            STD
241C:002B AC            LODSB
241C:002C 01C5          ADD     BP,AX
241C:002E AA            STOSB
241C:002F E2FA          LOOP    002B
241C:0031 8B160E00      MOV     DX,[000E]
-U
241C:0035 8AC2          MOV     AL,DL
241C:0037 29C5          SUB     BP,AX
241C:0039 8AC6          MOV     AL,DH
241C:003B 29C5          SUB     BP,AX
241C:003D 39D5          CMP     BP,DX   <--- 检查 CRC, 用意在防止追踪
241C:003F 740C          JZ      004D
241C:0041 BA9101        MOV     DX,0191
241C:0044 B409          MOV     AH,09
241C:0046 CD21          INT     21
241C:0048 B8FF4C        MOV     AX,4CFF
241C:004B CD21          INT     21
241C:004D 53            PUSH    BX
241C:004E B85300        MOV     AX,0053
241C:0051 50            PUSH    AX
241C:0052 CB            RETF            <--- 解压缩程式进入点
241C:0053 2E            CS:
241C:0054 8B2E0800      MOV     BP,[0008]
-G3F

AX=00FE  BX=3C50  CX=0000  DX=FE0D  SP=007E  BP=FE65  SI=FFFF  DI=FFFF
DS=241C  ES=3C50  SS=3E62  CS=241C  IP=003F   NV DN EI PL NZ AC PO NC
241C:003F 740C          JZ      004D
-RF
NV DN EI PL NZ AC PO NC  -ZR
-G52

AX=0053  BX=3C50  CX=0000  DX=FE0D  SP=007A  BP=FE65  SI=FFFF  DI=FFFF
DS=241C  ES=3C50  SS=3E62  CS=241C  IP=0052   NV DN EI PL ZR AC PO NC
241C:0052 CB            RETF
-T

AX=0053  BX=3C50  CX=0000  DX=FE0D  SP=007E  BP=FE65  SI=FFFF  DI=FFFF
DS=241C  ES=3C50  SS=3E62  CS=3C50  IP=0053   NV DN EI PL ZR AC PO NC
3C50:0053 2E            CS:
3C50:0054 8B2E0800      MOV     BP,[0008]
CS:0008=17C7
-U16F
3C50:016F 8BC3          MOV     AX,BX
3C50:0171 8B3E0400      MOV     DI,[0004]
3C50:0175 8B360600      MOV     SI,[0006]
3C50:0179 01C6          ADD     SI,AX
3C50:017B 01060200      ADD     [0002],AX
3C50:017F 2D1000        SUB     AX,0010
3C50:0182 8ED8          MOV     DS,AX
3C50:0184 8EC0          MOV     ES,AX
3C50:0186 31DB          XOR     BX,BX
3C50:0188 FA            CLI
3C50:0189 8ED6          MOV     SS,SI
3C50:018B 8BE7          MOV     SP,DI
3C50:018D FB            STI
3C50:018E 2E            CS:                 <--- 解压缩完毕, 准备跳到原始程式
3C50:018F FF2F          JMP     FAR [BX]         开头.
-G18E

AX=0C45  BX=0000  CX=0000  DX=F000  SP=4E20  BP=0000  SI=3FCD  DI=4E20
DS=0C45  ES=0C45  SS=3FCD  CS=3C50  IP=018E   NV UP EI PL ZR NA PE NC
3C50:018E 2E            CS:
3C50:018F FF2F          JMP     FAR [BX]
CS:0000=0034
-T

AX=0C45  BX=0000  CX=0000  DX=F000  SP=4E20  BP=0000  SI=3FCD  DI=4E20
DS=0C45  ES=0C45  SS=3FCD  CS=0C55  IP=0034   NV UP EI PL ZR NA PE NC
0C55:0034 9A00006B36    CALL    366B:0000   <--- 原始程式开头
-U
0C55:0034 9A00006B36    CALL    366B:0000
0C55:0039 9A1A0BF033    CALL    33F0:0B1A
0C55:003E 9ABA066B31    CALL    316B:06BA
0C55:0043 9AC2010531    CALL    3105:01C2
0C55:0048 9A0D28332E    CALL    2E33:280D
8C55:004D 9A940A892D    CALL    2D89:0A94
0C55:0052 9AEE248824    CALL    2488:24EE
-R
AX=0C45  BX=0000  CX=0000  DX=F000  SP=4E20  BP=0000  SI=3FCD  DI=4E20
DS=0C45  ES=0C45  SS=3FCD  CS=0C55  IP=0034   NV UP EI PL ZR NA PE NC
0C55:0034 9A00006B36    CALL    366B:0000

追踪到程式解压缩之後, 以 (SS*10H+SP) - (DS*10H+100H) 算出档案长度或自己猜一个
较大的长度并存档, 并且记下 CS,IP,SS,SP,DS 等暂存器的值 !!
例如此程式:
             (3FCD*10H+4E20) - (0C45*10H+100H) = 385A0 (HEX)
                                                 ^^^^^ 此长度记下来, 等一下还
                                                       要用一次.
-RBX      <--- 将 HIGH WORD 填入 BX
BX 0000
:3

-RCX      <--- 将 LOW WORD  填入 CX
CX 0000
:85A0

-N PASS1  <--- EXE 档不能直接写入, 所以另更名为 PASS1

-W DS:100   <--- PSP 底部紧接着程式码, 此时 DS 指向 PSP 开头, PSP 占 100H
                 Bytes, 所以从 DS:100 开始写起

Writing 385A0 bytes  <--- 共写入的 Bytes

-Q   <--- 跳出 DEBUG

__________________________________________________________
_____________________ _
STEP 2:
        随便执行一个常驻程式(或是执行比 DEBUG 大的除错程式, 如 SYMDEB), 用意在
改变记忆体环境, 如此 EXESHAPE 才可找出相异之处, 再重覆 STEP 1, 但此次只须存档.
(Registered Only), 若您手中的 EXESHAPE 为 Non-Registered 则需再记下 CS 的值.

C:\XPRESS>PAGEMAKE   <--- 笔者写的画面辅助功�
, 可用於 BBS,
修改程式码等,您刚看
                          到的 DEBUG 画面就是它抓下来的, 它是一个常驻程式

C:\XPRESS>DEBUG XPREAD.EXE
-G3F
-RF
NV DN EI PL NZ AC PO NC  -ZR
-G52
-T
-G18E
-T
AX=0DF4  BX=0000  CX=0000  DX=F000  SP=4E20  BP=0000  SI=417C  DI=4E20
DS=0DF4  ES=0DF4  SS=417C  CS=0E04  IP=0034   NV UP EI PL ZR NA PE NC
0E04:0034 9A00001A38    CALL    381A:0000

此时将刚刚记下来的档案长度再填入 BX:CX, 若您的 EXESHAPE 为注册版就不需要
再记任何暂存器的值, 若为未注册版则需再记下 CS 的值.

-RBX
BX 0000
:3
-RCX
CX 0000
:85A0
-N PASS2
-W DS:100
Writing 385A0 bytes
-Q

__________________________________________________________
_____________________ _
STEP 3:
        1. 记忆体需求量: 200K
        2. 执行 EXESHAPE
        3. 未注册版的 EXESHAPE 前面会有一段 Delay, 笔者跟 4DOS 学的.

                           EXESHAPE 注册版的主画面
+---------------------------------------------------------
--------------------+
|      =========== ===   === =========== ------------ SHARE-WARE
-------------+
|     ===         ===   === ===         ------------------
--------------------+
|    ===          === ===  ===         ======= ==   ==  =====  =======
=======|
|   ===========    ===    =========== ==      ==   == ==   == ==   == ==
|
|  ===          === ===  ===         ======= ======= ======= ======= =======
|
| ===         ===   === ===              == ==   == ==   == ==      ==
|
|=========== ===   === =========== ======= ==   == ==   == ==      ======= +
|
+++++++++++++---------------------------------------------
--------+++++++++++++
||||||||||||| * Shape of Executive Files Interface Version 1.20 *
|||||||||||||
+++++++++++++---------------- Files Process Area ---------
--------+++++++++++++
| The First     Filename : PASS1         <-- 刚刚第一次写入的档案
|
| The Second    Filename : PASS2         <-- 第二次写入的档案
|
| The EXEcutive Filename : XPREAD.EXE    <-- 所要建立的 EXE 档的档名
|
+-------------------------- Segment Registers Area -------
--------------------+
|       CS Register : C55 H   IP Register : 34  H   DS Register : 0C45H
|
|       SS Register : 3FCDH   SP Register : 4E20H 刚刚所记下来的暂存器值
|
|    * New method for segment registers area to registered version only *
|
|  Use Keys : [TAB] Toggle & Enter Key  [ENTER] Enter Key  [ESC] Exit to Dos
|
|       Thanks for your registration. Registered to (   Min Jei Chen   )
|
|   (c)Copyright >> Min Jei Chen << 1992~95 all rights reserved. 11/27/1992
|
+----------------------------- Message Echo Area ---------
--------------------+
| Message echo : Set filename and registers value .....
|
+---------------------------------------------------------
--------------------+

附注:
        1. 在 EXESHAPE 输入的任何时後皆可按 ESC 回到 DOS.

        2. 在输入暂存器值时, 可按 TAB 键切换您所要输入的暂存器值, 若不输入, 而
           直接按 ENTER 键, 程式会以 0 计算, 若已有输入则以输入值计算.
           若您输入满四位数, 则程式会自动帮您切换暂存器.
           如: 上述的 IP 值为 34, 您可以输入 0034 或 034 或 34 等表示法, 唯一
           不同的是第一个 0034 因为满四位数, 程式会自动帮您切换暂存器, 省去您
           按 ENTER 键的步骤, 其馀两个均要按 ENTER 键确定.

        3. 在全部暂存器输入完之後, 请将游标移到 SP Register 的地方, 若是未注册
           版则移到 2st CS Value 的地方, 再按 ENTER 键, 程式会问您是否确定, 按
           N 表不确定, 则继续修改暂存器值, 若按 Y 表确定则执行反压缩工作.

        4. 稍等一下後, Message echo (讯息回应栏) 会出现:
           Expand a compressed file successfully. (此时表示反压缩成功)
-------------------------------------------------------------------------------

               附带一题就是 若程式有利用一些 INT ? 服务常式来进行解编码的动作时
               若您不注意的话 将导致 程式码不正确 或是 造成当机....等状况发生。

               解决方法 可配合 搬移中断向量表的功能 来顺利反编码 找到程式进入点

  其实尚有蛮多保护方式....留到下次再为您补述。这集先到此为止...请期待下集推出。

    朋友俱乐部 站长:Yu Hwang <破解技术交流网 总站> TEL:039-281739 24HR 高速

    欢迎流传 请勿修改本文件           ０１／１７／１９９４  作者:俞煌男

    诚意邀请各站台加入 『破解技术交流网』 请填好之後 利用就近的HUB 送来即可。

 破解技术交流网  申请表格:

 站台<英文名称>:
 站台<中文名称>:
 系统操作员:
 建站系统:
 是<私人站>或<公开站>:
 开站时间:
 最高速率:
 站台电话:
 家中电话:
 公司电话:
 系统操作员<中文姓名>:
 系统配备:
 魔电厂牌:
 系统操作员<生日.年龄>:
 职业:
 网路时间:
 预定什麽时候开始接信:
 建议:

 请有心加入新网的站台 填写好之後 送来本站即可。

 ECHO KEY           共 ２２区            信管人员ID
 ------------------------------------------------------------------------
 破解码公怖区       CRACK-CODE
 破解技术讨论区     CRACK-CRACK          Yu Hwang(朋友俱乐部)
 一般信件讨论区     CRACK-GENERAL
 建站实务讨论区     CRACK-BBS
 中文系统讨论区     CRACK-CHINESE
 软体讨论区         CRACK-SOFT
 新站广告区         CRACK-NEWBBS
 中古买卖区         CRACK-SALE
 硬体讨论区         CRACK-HARD
 音乐/音效讨论区    CRACK-MUSIC
 快信讨论区         CRACK-MESSAGE
 打屁瞎掰讨论区     CRACK-TALK
 热门职棒讨论区     CRACK-BALL
 病毒讨论区         CRACK-VIRUS
 交友专区           CRACK-FRIEND         Steve You(朋友俱乐部)
 心情讨论区         CRACK-MOOD
 站长讨论区         CRACK-SYSOP         ;不开放给User
 网路测试区         CRACK-TEST          ;不开放给User
 HUB xxxx区         CRACK-HUBxxxx       ;由HUB 自定信区 若跟总站接 都自定100
 魔电讨论区         CRACK-MODEM          也就是你要设 CRACK-HUB100 其它HUB自设
 游戏功略心得发表区 CRACK-GAME
 程式语言讨论区     CRACK-LANGUAGE

 欢迎有兴趣的站台来加入本网的行列。

 破解技术交流网      加 入 站 名 列 表     站 台 电 话     开放时间    速   率
------------------------------------------------------------------------------
HOST     39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        19200
HUB100   39:39/100     外星游龙资讯站    TEL:039-353950      24HR        19200
         39:39/101     天蝎星资讯站      TEL:039-357940      24HR        14400
         39:39/102     瑞智资讯交流站    TEL:039-778657      24HR        14400
         39:39/103     雷鸟资讯交流站    TEL:039-322865    23:00-07:00    2400
         39:39/104     伊甸园资讯站      TEL:039-889981      24HR        14400

台北地区
HUB200   39:39/200     友谊资讯交流站    TEL:02-7236293    16:00-08:00    9600

HUB300   39:39/300   遨游鹏资讯交流站    TEL:02-8747279      24HR        14400
         39:39/301     魔法王国交流站    TEL:02-5991763      24HR        19200
         39:39/302   坏小子资讯交流站    TEL:02-2190318      24HR        14400
         39:39/303     熊座资讯交流站    TEL:02-9344309      24HR        14400
HUB500   39:39/500     麦帅资讯交流站    TEL:02-9512743    17:00-21:00   14400
PVT<私>  39:39/501     光台资讯交流站    TEL:02-222xxxx      xxxx        14400
         39:39/502 佩雅达恒星交流广场    TEL:02-9201852      24HR        14400
         39:39/503 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/504   超时空资讯交流站    TEL:02-8752787      24HR        14400

桃园地区
HUB400   39:39/400     东方快车交流站    TEL:03-3352798      24HR        14400

花莲地区
HUB600  39:39/600  终极保镳资讯交流站    TEL:038-348267      24HR        14400

香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-6183163     24HR        14400

  请利用就近的HUB 送来您的申请表即可。


俞煌男破解入门教程（１１／１７）
俞煌男

哇....咧: 新年快乐....恭喜大家 ....红包拿来
     哇...考完试....又放假真好...想必仍在在学的人 一定也是高兴的不亦乐乎...
目前本人我 所写的 DEBUG 集 不晓得有没有造成轰动呢??哈....我也不知道要改进什麽
或是要加入什麽主题...所以我只好 照我意思写罗! 若您有任何意见 或是批评 请来本人
草创的 破解技术交流网 中写信就可以罗! 当然我一定尽量帮您服务的唷! 我引出来 您可
以就近到 加入本网站台中写信给我唷! 这麽好的机会您还等什麽呢?

 破解技术交流网      加 入 站 名 列 表     站 台 电 话     开放时间    速   率
------------------------------------------------------------------------------
宜兰地区
HOST总站 39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        19200
HUB100   39:39/100     外星游龙资讯站    TEL:039-353950      24HR        19200
         39:39/101     天蝎星资讯站      TEL:039-357940      24HR        14400
         39:39/102     瑞智资讯交流站    TEL:039-778657      24HR        14400
         39:39/103     雷鸟资讯交流站    TEL:039-322865    23:00-07:00   14400
         39:39/104     伊甸园资讯站      TEL:039-889981      24HR        14400
         39:39/105     欢乐肥龙资讯站    TEL:02-9161500      24HR        19200

台北地区
HUB200   39:39/200     友谊资讯交流站    TEL:02-7236293    16:00-08:00    9600
HUB300   39:39/300   遨游鹏资讯交流站    TEL:02-8747279      24HR        14400
         39:39/301     魔法王国交流站    TEL:02-5991763      24HR        19200
         39:39/302   坏小子资讯交流站    TEL:02-2190318      24HR        14400
         39:39/303     熊座资讯交流站    TEL:02-9344309      24HR        14400
HUB500   39:39/500     麦帅资讯交流站    TEL:02-9512743    17:00-21:00   14400
PVT<私>  39:39/501     光台资讯交流站    TEL:02-222xxxx      xxxx        14400
         39:39/502 佩雅达恒星交流广场    TEL:02-9201852      24HR        14400
         39:39/503 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/504   超时空资讯交流站    TEL:02-8752787      24HR        14400

桃园地区
HUB400   39:39/400     东方快车交流站    TEL:03-3352798      24HR        14400

花莲地区
HUB600  39:39/600  终极保镳资讯交流站    TEL:038-348267      24HR        14400

台中地区
HUB800  39:39/800      天使资讯交流站    TEL:04-7787048      24HR        16800
HUB900  39:39/900  天空之城资讯交流站    TEL:04-6578210      24HR        19200
                                         TEL:04-6578211      24HR        19200
                                         TEL:04-6578071      24HR        19200
                                         TEL:04-6578072      24HR        19200
                                         TEL:04-6578073      24HR        19200
香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-6183163     24HR        14400

本网创立至今 约有二个月的历史罗...也希望大家多多来本网写信唷! 好让同好一起讨论
并邀请各县市的站台 一起来加入本网的行列 本网没有规章 完全靠大家彼此的帮忙而成的
当然我也会 发出本人的 破解入门 集给各站台 并也会发出一些破解用的工具给站台。若
您觉得本网还可以的话 就请您填填站台资料 利用就近的HUB 送来就可以了 本网欢迎您热
情加入。若您是位User 也请您多来本网写信唷! 若也觉得本网不错 请多介绍朋友来此网
写信。

 破解技术交流网  申请表格:

 站台<英文名称>:
 站台<中文名称>:
 系统操作员:
 建站系统:
 是<私人站>或<公开站>:
 开站时间:
 最高速率:
 站台电话:
 家中电话:
 公司电话:
 系统操作员<中文姓名>:
 系统配备:
 魔电厂牌:
 系统操作员<生日.年龄>:
 职业:
 网路时间:
 预定什麽时候开始接信:
 建议:

 请有心加入新网的站台 填写好之後 送来本站即可。

 ECHO KEY           共 ２２区            信管人员ID
 ------------------------------------------------------------------------
 破解码公怖区       CRACK-CODE
 破解技术讨论区     CRACK-CRACK          Yu Hwang(朋友俱乐部)
 一般信件讨论区     CRACK-GENERAL
 建站实务讨论区     CRACK-BBS
 中文系统讨论区     CRACK-CHINESE
 软体讨论区         CRACK-SOFT
 新站广告区         CRACK-NEWBBS
 中古买卖区         CRACK-SALE
 硬体讨论区         CRACK-HARD
 音乐/音效讨论区    CRACK-MUSIC
 快信讨论区         CRACK-MESSAGE
 打屁瞎掰讨论区     CRACK-TALK
 热门职棒讨论区     CRACK-BALL
 病毒讨论区         CRACK-VIRUS
 交友专区           CRACK-FRIEND         Steve You(朋友俱乐部)
 心情讨论区         CRACK-MOOD
 站长讨论区         CRACK-SYSOP         ;不开放给User
 网路测试区         CRACK-TEST          ;不开放给User
 HUB xxxx区         CRACK-HUBxxxx       ;由HUB 自定信区 若跟总站接 都自定100
 魔电讨论区         CRACK-MODEM          也就是你要设 CRACK-HUB100 其它HUB自设
 游戏攻略心得发表区 CRACK-GAME
 程式语言讨论区     CRACK-LANGUAGE

 欢迎有兴趣的站台来加入本网的行列。

 朋友俱乐部  039-281739 24HR ZyXEL

   续DEBUG-10.DOC 的讨论主题:
               <1> 当软体有进入保护模式 来保护软体
                   解说:目前有进入保护模式来防止破解的软体 有日益增多驱势 最主
                        要的是因为 懂保护模式的人毕竟是太少罗!当然会破解保护模
                        式更是还.....太少 因为保护模式跟一般真实模式有很大的不
                        同点 就是程式若在保护模式下 所有动作皆跟真实模式不同
                        保护模式需要自行处理低阶动作及自行造个『中断向量表』请
                        注意:保护模式并不是呼叫真实模式的『中断向量表』 完全不
                             同於真实模式。
                        由於保护模式是跟真实模式并存 但互不相干 也就是保护模式
                        是属於独立的个体 况且保护模式的一些指令也不同於一般指令
                        所以这就是保护模式与一般真实模式最大的不同点。

                   破解方法:
                       若要破解保护模式的软体 当然是必须要有 可进入保护模式的除
                       错软体啦!像386DEBUG,MINDEBUG,EXTENDER 386....等皆可进入
                       保护模式来破解。当然这些软体都是要您自个去找啦!
                       其实用法也是跟一般DEBUG差不多啦! 只要多注意一些莫生的指
                       令就可以罗! 当然最好一定要对指令很熟 不然你是无法玩的啦!

               <2>当软体是读取 PORT 来保护软体的话
                  解说:这就是大家都知道的KeyPort 啦! 一般用此方式来保护的大多是
                       排版软体或是较昂贵的系统软体...等 均采用此方式来保护软体

                  目的:由於KeyPort方便性 让正版使用者较为便利 比一些读母片要好
                       多啦! 所以制作也方便 所以并不会造成使用者太大不便 目的当
                       然是防止软体被盗用啦! 由於软体都无保护 所以可以自由的备
                       份 当然在执行时 会去读取KeyPort值 来判断是否是正版使用者

                  破解方法:
                       可用SOFT-ICE 下指令来拦 I/O PORT 大多是 3BC 378 .....等
                       你可在 0:40 中就可以看到你的 PORT 值罗!
                       假设此软体是读取 3BC 的话 那你就下 BPIO 3BC RW 就可以罗!
                       也就是说当软体正在对3BC PORT 读写时 就会发生中断。

                 附注:若不懂时 可以问软体蛀虫站长 相信您一定可以获得到满意的答
                      覆 软体蛀虫站长对此也蛮有心得 他有出本书 叫软/硬体保护技
                      术手册 非广告唷!

               <3>当软体是读取 KeyCard 来保护软体的话
                  解说:就是您的扩充槽上要插一片 识别卡 当软体执行时 会自动去检
                       查是否是原版使用者。

                  缺点:又浪费了一个扩充槽。

                  目的:不外乎是防破解软体罗!这跟KeyPort 类似 软体本身也无保护
                       可以自行备份 主要跟KeyPort 插别是 一个是插在Print Port
                       而KeyCard则是插在扩充槽内。

                  附注:这已经过时的东东罗!所以目前已经被放弃不用了...所以现在很
                       少机会可以遇到罗!

               <4>当软体是用 序 号 来保护的话
                  解说:当软体要安装时 就会出现要您输入正确的序号 方可正常安装。
                       因为每个软体都有一组序号是正确的。<也就是称 流水号>
                  目的:是为了方便查出将此软体流出去的使用者 进而来提醒使用者不
                       要任意的将软体COPY给他人使用。
                  破解方法:
                       一般有序号保护的软体 都是经过 运算 来求出序号 所以要破解
                       序号有二种方式 一是追纵程式运算方式 自行修改序号 二是将
                       序号比对部份删除 即可正常使用软体 又不用怕被xx....。
-------------------------------------------------------------------------------
                就先写到这为止罗....好像比较常被使用的方式都有讲过了 若有遗漏
                请来信告知 我好下次为您补述。请期待下集。

    作者:俞煌男             １／２５／９４              请勿修改本文说明内容
    ＩＤ:Yu Hwang
                           朋友俱乐部 专业站    TEL:039-281739
                          破解技术交流网<总站>      24HR OPEN ZYXEL


俞煌男破解入门教程（１２／１７）
俞煌男

嗨..各位..好久不见了..您是否一样期待着『破解入门』的续集呢? 哈!.太久都没再破了
所以有时间就写一些来给各位初学者学习一下 虽然我并不是很强的高手啦! 不过我有这
份心意喔! 也希望各位请勿修改本文 让本人有点小名气啦! 着作权本人所有喔。

  谈谈破解技术吧!..简单又拿一套老GAME来试试看 看看各位是否有吸收到本人所讲的一
些技巧 我再带领大家复习一次吧! 这套老GAME 叫『立体俄罗斯方块』主档是:BL.EXE 想
必一定有听过吧! 简单略说一下 此GAME的破解方式 一开始载入 S-ICE 或 GAMETOOLS 都
可以只要你用的习惯就好了。 之後会有二个画面 不要理它 等到要出现密码询问画面时
快手一按 S-ICE(热键是 CTRL+D) GAMETOOL(热键是 PRINT SCREEN 或 * 笔者是用3.23版)
就会看到以下之程式码...我引出来供大家参考一下 。(程式码 如附图 2)
(如下图 1 密码询问画面 因使用抓图程式 抓下来不是很好 请多多见谅)

  图 1:

  图 2:
-U          1BCC:CE18          1BCC:CE19          1BCC:CE1A          1BCC:CE1B
            1BCC:CE1C          1BCC:CE1D          1BCC:CE1E          1BCC:CE21
            1BCC:CE24          1BCC:CE26          1BCC:CE29          1BCC:CE2C
            1BCC:CE2F          1BCC:CE32

-U          1BCC:CE39          1BCC:CE3C          1BCC:CE3F          1BCC:CE42
            1BCC:CE45          1BCC:CE47          1BCC:CE48          1BCC:CE4A
            1BCC:CE4B          1BCC:CE4C          1BCC:CE4F          1BCC:CE50
            1BCC:CE52          1BCC:CE53          1BCC:CE54          1BCC:CE56
            1BCC:CE57
  假设你快速按 『热键』 切入GAME中时 并没有看到我引出的程式码时 不要担心 多往下
追几次相信就可以找到啦! 别跟我说你不懂如何往下追喔..那麽就请您去参考 『破解入门
1-11集』 我不再重覆。

  结语:怎麽样..这样是不是比较有点信心呀 是否会很难呢? 我想应该不会有问题 只要多
多看一些组合指令的书籍以及多多下点功夫去找简单一点的程式下手 相信总有一天您一定
会比我还强的啦! 也希望在您看过 『破解入门 1-12集』 之後 能给我一些意见吧! 或是
你有一些疑问想问我 也可以到 『破解技术交流网』 中的 『破解技术讨论区』 发信给我
ID:YU HWANG 就可以罗! 『破解技术交流网』是本人所创立的..希望各位站长及USER们能
多多加入我们的行列 期待您的来信与加入。 我引出『破解技术交流网』的申请表及站台
资料供大家参考一下:

 破解技术交流网  申请表格:

 站台<英文名称>:
 站台<中文名称>:
 系统操作员:
 建站系统:
 家中地址:
 是<私人站>或<公开站>:
 开站时间:
 最高速率:
 站台电话:
 家中电话:
 公司电话:
 系统操作员<中文姓名>:
 系统配备:
 魔电厂牌:
 系统操作员<生日.年龄>:
 职业:
 网路时间:
 预定什麽时候开始接信:
 建议:

 请有心加入新网的站台 填写好之後 送来本站即可。

 ECHO KEY           共 ２２区            信管人员ID
 ------------------------------------------------------------------------
 破解码公怖区       CRACK-CODE
 破解技术讨论区     CRACK-CRACK          Yu Hwang(朋友俱乐部)
 一般信件讨论区     CRACK-GENERAL
 建站实务讨论区     CRACK-BBS            Andy Yu(狼族II站)
 中文系统讨论区     CRACK-CHINESE
 软体讨论区         CRACK-SOFT           Indiana Wang(欢乐屋-高雄站)
 新站广告区         CRACK-NEWBBS
 中古买卖区         CRACK-SALE
 硬体讨论区         CRACK-HARD
 音乐/音效讨论区    CRACK-MUSIC
 快信讨论区         CRACK-MESSAGE
 打屁瞎掰讨论区     CRACK-TALK           Jim Green(天蝎星)
 热门职棒讨论区     CRACK-BALL           Bj Chang(将相世家)
 病毒讨论区         CRACK-VIRUS
 交友专区           CRACK-FRIEND         Steve You(朋友俱乐部)
 心情讨论区         CRACK-MOOD           Feney Lin(天蝎星)
 站长讨论区         CRACK-SYSOP         ;不开放给User
 网路测试区         CRACK-TEST          ;不开放给User
 HUB xxxx区         CRACK-HUBxxxx       ;由HUB 自定信区 若跟总站接 都自定100
 魔电讨论区         CRACK-MODEM          也就是你要设 CRACK-HUB100 其它HUB自设
 游戏攻略心得发表区 CRACK-GAME
 程式语言讨论区     CRACK-LANGUAGE       D.s. Yan(朋友俱乐部)
-------------------------------------------------------------------------------
ECHO FILES KEY

 CRACKNET   网路资源
 CRACK-PD   公益软体发送区
密码皆是 12345678

 欢迎有兴趣的站台来加入本网的行列。

 朋友俱乐部  039-281739 24HR 28800 BPS

 破解技术交流网      加 入 站 名 列 表     站 台 电 话     开放时间    速   率
------------------------------------------------------------------------------
宜兰地区
HOST总站 39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        28800
HUB100   39:39/100     外星游龙资讯站    TEL:039-356106      24HR        19200
         39:39/101     天蝎星资讯站      TEL:039-357940      24HR        14400
         39:39/102     瑞智资讯交流站    TEL:039-778657      24HR        14400
         39:39/103     雷鸟资讯交流站    TEL:039-322865    23:00-07:00   14400
         39:39/104     伊甸园资讯站      TEL:039-889981      24HR        14400
         39:39/105     欢乐肥龙资讯站    TEL:02-9161500      24HR        19200
         39:39/106     放浪孤城资讯站    TEL:02-8200241    13:00-07:00   14400
         39:39/107   一贯道资讯交流站    TEL:04-3384895      24HR        19200
         39:39/109     阿达一族资讯站    TEL:038-321773      24HR        19200

台北地区
HUB200   39:39/200     李杰资讯交流站    TEL:02-8962836      24HR        19200
HUB300   39:39/300   遨游鹏资讯交流站    TEL:02-8747279      24HR        14400
         39:39/301     魔法王国交流站    TEL:02-5991763      24HR        19200
         39:39/302   坏小子资讯交流站    TEL:02-2190318      24HR        14400
         39:39/303     熊座资讯交流站    TEL:02-9344309      24HR        14400
         39:39/304     浑沌魔镜交流站    TEL:02-7668736      24HR        14400
         39:39/305     神行太保交流站    TEL:02-2362589      24HR        14400
         39:39/306   明汕寺资讯交流站    TEL:02-9690360      24HR        14400
         39:39/307   鹿鼎记资讯交流站    TEL:02-9771578      24HR        14400
         39:39/308     原始部落交流站    TEL:02-8224591    10:00-00:30   14400
PVT<私>  39:39/309   漫画俱乐部交流站    TEL:02-960xxxx      xxxx        16800
         39:39/310   魔法俱乐部交流站    TEL:02-9275781      24HR        14400
         39:39/311   梦幻屋资讯交流站    TEL:02-9866550      24HR        14400
         39:39/312     虹屋资讯交流站    TEL:02-9867374      24HR        14400
         39:39/313     将相世家交流站    TEL:02-6227053      24HR        14400
         39:39/314 狼之一族ＩＩ资讯站    TEL:02-7018906      24HR        19200

HUB500   39:39/500     麦帅资讯交流站    TEL:02-9512743    17:00-21:00   14400
PVT<私>  39:39/501     光台资讯交流站    TEL:02-222xxxx      xxxx        14400
         39:39/502 佩雅达恒星交流广场    TEL:02-9201852      24HR        14400
         39:39/503 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/504   超时空资讯交流站    TEL:02-8752787      24HR        14400
         39:39/505 狼??传说一站交流站    TEL:02-9978405      24HR        16800

桃园地区
HUB400   39:39/400     东方快车交流站    TEL:03-3352798      24HR        14400
HUB1100  39:39/1100      电玩小子II站    TEL:03-4561471      24HR        16800
PVT<私>  39:39/1101    灌蓝高手交流站    TEL:03-450xxxx      xxxx        14400
         39:39/1102    致命总站交流站    TEL:03-3654087    22:00-06:00    9600

新竹地区 39:39/1200  地球电子村交流站    TEL:035-200517      24HR        19200
         39:39/1201  紫色梦幻屋交流站    TEL:035-801886      24HR        16800

花莲地区
HUB600  39:39/600  终极保镳资讯交流站    TEL:038-348267      24HR        14400

台中地区
HUB800  39:39/800      天使资讯交流站    TEL:04-7787048      24HR        16800
        39:39/801    卧龙居资讯交流站    TEL:04-8294582      24HR        19200
        39:39/802    幸运事务所交流站    TEL:04-7271940      24HR        16800
HUB900  39:39/900  天空之城资讯交流站    TEL:04-6578210      24HR        19200
                                         TEL:04-6578211      24HR        19200
                                         TEL:04-6578071      24HR        19200
                                         TEL:04-6578072      24HR        19200
                                         TEL:04-6578073      24HR        19200
        39:39/902  毁天灭地资讯交流站    TEL:04-6321487      24HR        19200
        39:39/903      今天资讯交流站    TEL:049-251090      24HR        16800
        39:39/904    正一工作室交流站    TEL:04-2807877      24HR        14400

高雄地区
HUB1000 39:39/1000   欢乐屋资讯交流站    TEL:07-3152450    17:00-08:00   19200

香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-6183163     24HR        14400
        39:39/701      酒井法子专门站    TEL:852-7563536     24HR        19200
-------------------------------------------------------------------------------

 本网路需要靠大家的爱护 希望你也能成为我们的一份子 衷心期待您的到来。

  作者:俞煌男 ID:YU HWANG 生日:62/08/24
  BBS站: 039-281739 魔电:28800 BPS DataSystem 2814XA 开放时间:24HR OPEN
  BBS中文站名:朋友俱乐部 专业站 线上档案 5GB


俞煌男破解入门教程（１３／１７）
俞煌男

嗨..各位看官..我又来罗! 每日一破解讲课时间又到了 请各位同学座好喔! 要用心听
不然看不懂不要怪我咧..希望大家都能学的一技之长 把我给干掉喔! 我也希望能带给
您一些收获 不过最终的方法还是要靠您自个努力啦! 好了..多说无益 想学的人就会去
努力学 不想学的人就请您当作我在乱写一通一笑至之。

  现在主题是什麽呢? 我就写一些电脑内部中断用法及讲一些 8259 IC 是如何动作及如
何RESET 并说明为何 RESET 会造成 S-ICE OR GAMEBUTER AND GAMETOOLS等软体无法执行
请用心看喔!不然你会渐渐看不懂我的意思了..劝您最好用列表机印出来喔!

 图(一)
┌————┬————————┬———————————————————————┐
│位   址 │中  断  编  号  │  中      断      名       称                 │
├————┼————————┼———————————————————————┤
│  0-3   │  INT   0       │ 除零中断                                     │
│  4-7   │        1       │ 单步中断                                     │
│  8-B   │        2       │ 不可罩盖中断                                 │
│  C-F   │        3       │ 断点中断                                     │
│ 10-13  │        4       │ 溢位中断                                     │
│ 14-17  │        5       │ 萤幕列印中断                                 │
│ 18-1B  │        6       │ 保留                                         │
│ 1C-1F  │        7       │ 保留                                         │
│ 20-23  │        8       │ 计时中断 (8259 #1 IRQ 0)                     │
│ 24-27  │        9       │ 键盘介面中断 (8259 #1 IRQ 1)                 │
│ 28-2B  │        A       │ 保留 (8259 #1 IRQ 2)                         │
│ 2C-2F  │        B       │ 通讯 1 介面中断 (8259 #1 IRQ 3)              │
│ 30-33  │        C       │ 通讯 2 介面中断 (8259 #1 IRQ 4)              │
│ 34-37  │        D       │ 列表机介面 2 中断 (8259 #1 IRQ 5)            │
│ 38-3B  │        E       │ 磁碟机介面中断 (8259 #1 IRQ 6)               │
│ 3C-3F  │        F       │ 列表机介面 1 中断 (8259 #1 IRQ 7)            │
│ 40-43  │       10       │ 影像中断                                     │
│ 44-47  │       11       │ 设备检查中断                                 │
│ 48-4B  │       12       │ 记忆体大小中断                               │
│ 4C-4F  │       13       │ 磁碟 I/O 中断                                │
│ 50-53  │       14       │ 通讯 I/O 中断                                │
│ 54-57  │       15       │ 卡带 I/O 中断                                │
│ 58-5B  │       16       │ 键盘 I/O 中断                                │
│ 5C-5F  │       17       │ 列表机 I/O 中断                              │
│ 60-63  │       18       │ Basci 进入中断                               │
│ 64-67  │       19       │ 启动程式中断 (Boot strap)                    │
│ 68-6B  │       1A       │ 计时中断                                     │
│ 6C-6F  │       1B       │ 键盘 Break 中断                              │
│ 70-73  │       1C       │ 计时器滴声中断                               │
│ 74-77  │       1D       │ 影像参数中断                                 │
│ 78-7B  │       1E       │ 磁片参数中断                                 │
│ 7C-7F  │       1F       │ 影像图形字元中断                             │
│ 80-83  │       20       │ DOS 程式结束中断                             │
│ 84-87  │       21       │ DOS 功能呼叫中断                             │
│ 88-8B  │       22       │ DOS 结束位址中断                             │
│ 8C-8F  │       23       │ DOS CTRL+BREAK 出口位址中断                  │
│ 90-93  │       24       │ DOS 严重错误出口位址中断                     │
│ 94-97  │       25       │ DOS 绝对磁碟读取                             │
│ 98-9B  │       26       │ DOS 绝对磁碟写入                             │
│ 9C-9F  │       27       │ DOS 程式结束,但保留在记忆体中断              │
│ AO-FF  │     28-3F      │ DOS 保留                                     │
│100-17F │     40-5F      │ 保留                                         │
│180-19F │     60-67      │ 供使用者程式之中断                           │
│1A0-1BF │     68-6F      │ 不用                                         │
│1C0-1C3 │       70       │ 即时时脉中断 (8259 #2 IRQ 8)                 │
│1C4-1C7 │       71       │ 保留未用     (8259 #2 IRQ 9)                 │
│1C8-1CB │       72       │ 保留未用     (8259 #2 IRQ10)                 │
│1CC-1CF │       73       │ 保留未用     (8259 #2 IRQ11)                 │
│1D0-1D3 │       74       │ 保留未用     (8259 #2 IRQ12)                 │
│1D4-1D7 │       75       │ 80287 错误处理中断 (8259 #2 IRQ13)           │
│1D8-1DB │       76       │ 硬式磁碟机控制器 (8259 #2 IRQ14)             │
│1DC-1DF │       77       │ 保留未用 (8259 #2 IRQ15)                     │
│1E0-1FF │     78-7F      │ 不用                                         │
│200-217 │     80-85      │ Basic 保留                                   │
│218-3C3 │     86-F0      │ 执行 Basic 时 , 供 Basic 解译器使用          │
│3C4-3FF │     F1-FF      │ 不用                                         │
└————┴————————┴———————————————————————┘
             ＊ 以上是 ＰＣ ／ＡＴ  中断向量表的功能表 ＊

 再来就是讲 8259 IC 的一些动作方式及设定方法

 图(二)         ┌—————┐  ┌—————┐
            /CS │1         └—┘        28│VCC
            /WA │2                       27│A0
            /RD │3     ８２５９ Ａ       26│/INTA
        ┌   D7 │4                       25│IR7
  连接到│   D6 │5                       24│IR6
        │   D5 │6     主 　Ｉ  Ｃ       23│IR5
  ＣＰＵ┘   D4 │7                       22│IR4
        ┐   D3 │8                       21│IR3
    中  │   D2 │9     各接脚图说明      20│IR2
        │   D1 │10                      19│IR1
        └   D0 │11                      18│IR0
            CAS0│12                      17│INT
            CAS1│13                      16│/SP / /EN
             GND│14                      15│CAS2
                └—————————————┘

 电源     晶片选取
 接地          当此脚信号为『低电位』时,表示 8259被致能;反之,则是禁能
 读取
      当此脚为『低电位』时,CPU会要求 8259A 送出 IRR (中断要求到暂存器)
      ISR (中断服务暂存器),及 IMR (中断罩盖暂存器) 其中之一到 D0-D7上。
 写入
      当此脚为『低电位』时,CPU要送控制字组 ( control word) 给 8259A。
 资料线
        为跟 CPU 连接线
  存取线
      此信号与/R0,/WR,/CS合起来决定 CPU 要对那一个暂存器(IMR,IRR,ISR...)做读写
      动作
 中断
      此信号是用来通知CPU有周边设备要求中断服务,此线接到 80x86 的/INTA 接脚上
 中断认知
        为CPU认可一个中断请求的认知讯号,此信号须接到 80x86 /INTA 输出线上
 中断请求 0~7
          这八条讯号线是用来连接外部周边设备作为它们的中断要求信号线。
 主IC规划 及 缓冲致能
            此脚具二种功能 一是:若为缓冲型态时,此接脚是用来做为缓冲器的收发
                           二是:若不是缓冲型态,则是用来指定 8259 IC为主 (SP=1)
                                或仆 (SP=0)
 串接线
            这叁条是用来接多颗的 8259 IC,最多可以串接 5个喔! 每颗8259 IC可以处
            理八个中断请求,所以共可以使用 64 个中断请求。 在PC AT中有 16个中断
            请求。 如附图(叁)

图(叁) 8259 中断控制器方块图    ┌—┐
                                │  │
          ┌————————┐  │内│  ┌—————————————————┐
D7-D0 <-->│资料汇流排缓冲器│┌┤  ├—┤  控    制    逻   辑   单   元   │
          └————————┘││  │  └—————————————————┘
          ┌————————┐││部│    │         │         │
  /RD --->┤读/写 逻辑电路  │││  │    │         │         │
  /WR --->┤                ├┤│  └——————————————————┐
  A0  --->┤                │││汇                                      │
          └———┬————┘││  ┌——————————————————┘
                  │          ││  │    │         │         │
  /CS --->————┘          ││  │ ┌———┐   ┌——┐   ┌———┬ IR0
                              ││流│ │中暂  │   │优  │   │中暂  │ ...
          ┌————————┐││  │ │断存  │<->│先  │<->│断存  │ ...
 CAS0 --->┤串联缓冲器      │││  │ │处器  │   │调器│   │要器  │ ...
 CAS1 --->┤     /比较器    ├┘│排│ │理 ISR│   │解  │   │求 IRR│ ...
 CAS2 --->┤                │  │  │ └———┘   └——┘   └———┴ IR7
          └———┬————┘  │  │    │         │         │
/SP / /EN --->——┘            │  │┌—————————————————┐
                                └—┘│ 中  断  罩  盖  暂  存  器 (IMR) │
                                      └—————————————————┘

  中断请求暂存器 ( Interrupt Request Register 简称 IRR)
  中断罩盖暂存器 ( Interrupt Mask Register    简称 IMR)
  中断处理暂存器 ( Interrupt Service Register 简称 ISR)

-------------------------------------------------------------------------------
  再来跟各位说说 8259 初始值设定步骤 如附图 (四):

 图(四): 8259 ICWS 流程图
            ┌———┐
            │ ICW1 │  (Initialization Command Words 简称 ICW) 初始值命令字组
            └———┘
                ??      (Operation Command Words 简称 OCW) 作业命令字组
                ??
            ┌———┐
            │ ICW2 │  说明: 8259 必须要先送出 ICW1 接着再送 ICW2,二者顺序不可
            └———┘        以巅倒喔! 否则会有错误的。
                ??
                ??
                 《
              ／  　＼
       N    ／CASCADE ＼
      ┌— ＼    ?   ／
      │     ＼  　／
      │        》
      │SNGL=1  ?? Y (SNGL=0)
      │    ┌———┐
      │    │ ICW3 │
      │    └———┘
      │        ??
      └———> ??
                 《
              ／  　＼
       N    ／        ＼
     ┌——＼  ICW4  ／
     │      ＼  　／
     │ICW4=0   》
     │         ?? Y (ICW4=1)
     │     ┌———┐
     │     │ ICW4 │
     │     └———┘
     │         ??
     └———>  ??
        ┌———————┐
        │ NORMAL       │
        │    OPERATION │
        └———————┘

 我来讲解一下 ICW1,ICW2,ICW3,ICW4 实际的用法....:如附图(五)

    A0    D7    D6    D5    D4    D3    D2    D1    D0
 ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
 │ 0  │ A7 │ A6 │ A5 │ 1  │LTIM│ AD4│SNGL│ IC4│
 └——┴—┬┴——┴—┬┴——┴—┬┴—┬┴—┬┴—┬┘  ┌————————┐
           └——┬——┘          │    │    │    └——┤1: 需要 ICW4    │
                 │                │    │    │          │0: 不需要 ICW4  │
                 │                │    │    │          └————————┘
                 │                │    │    │          ┌————————┐
                 │                │    │    └—————┤1: 单一         │
                 │                │    │                │0: 串接模式     │
                 │                │    │                └————————┘
                 │                │    │                ┌————————┐
                 │                │    │                │呼 叫 位 址 间隔│
                 │                │    └————————┤1: 4个间隔      │
                 │                │                      │0: 8个间隔      │
                 │                │                      └————————┘
                 │                │                      ┌————————┐
                 │                └———————————┤1: 准位触发     │
                 │                                        │0: 边缘触发模式 │
                 │                                        └————————┘
                 │                                        ┌————————┐
                 └————————————————————┤A5-A7 中断向量位│
                                                           │址,只在MCS80/85 │
                                                           │模式下动作      │
                                                           └————————┘

     A9    D7    D6    D5    D4    D3    D2    D1    D0
  ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
  │ 1  │ A16│ A14│ A13│ A12│ A11│ A10│ A9 │ A8 │
  │    │ /T7│ /T6│ /T5│ /T6│ /T3│    │    │    │
  └——┴—┬┴—┬┴—┬┴—┬┴—┬┴—┬┴—┬┴—┬┘
            └——┴——┴——┴——┴——┴——┴——┴——┐
                                                            │
                                                 ┌————————————┐
                                                 │A8-A15 是中断向量的位址 │
                                                 │(MCS 80/85 模式下)      │
                                                 │T3-T7 是8086/8088 模式的│
                                                 │中断向量位址            │
                                                 └————————————┘

     A0    D7    D6    D5    D4    D3    D2    D1    D0
  ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
  │  1 │ S7 │ S6 │ S5 │ S4 │ S3 │ S2 │ S1 │ S0 │
  └——┴—┬┴—┬┴—┬┴—┬┴—┬┴—┬┴—┬┴—┬┘
            └——┴——┴——┴——┴——┴——┴——┴——┐
                                                            │
                                                 ┌————————————┐
                                                 │1: IR输入有一从元件     │
                                                 │0: IR输入没有从元件     │
                                                 └————————————┘

     A0    D7    D6    D5    D4    D3    D2    D1    D0
  ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
  │  1 │ 0  │ 0  │  0 │  0 │ 0  │ 1D2│ 1D1│1D0 │
  └——┴——┴——┴——┴——┴——┴—┬┴—┬┴—┬┘
                                          └——┼——┘
                                                │
                   ┌—┬—┬—┬—┬—┬—┬—┬—┐
                   │0 │1 │2 │3 │4 │5 │6 │7 │
                   ├—┼—┼—┼—┼—┼—┼—┼—┤
                   │0 │ 1│0 │ 1│ 0│1 │0 │1 │
                   ├—┼—┼—┼—┼—┼—┼—┼—┤
                   │0 │0 │1 │ 1│0 │0 │1 │1 │
                   ├—┼—┼—┼—┼—┼—┼—┼—┤
                   │0 │0 │ 0│ 0│1 │ 1│ 1│ 1│
                   └—┴—┴—┴—┴—┴—┴—┴—┘

     A0    D7    D6    D5    D4    D3    D2    D1    D0
  ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
  │ 1  │ 0  │  0 │  0 │SFNM│ SUF│M/S │AE01│ UPM│
  └——┴——┴——┴——┴—┬┴—┬┴—┬┴—┬┴—┬┘
                              │    └—┬┘    │    │  1=8086/8088 模式
                          ┌—┘      互│      │    └—
                          │          相│      │        0=MCS 80/85 模式
                          │          配│      │
                      1:特别巢状模式  合│      └————1=自动 E0I
                      0:不是特别巢状 ┌——┬—————┐ 0=正常 E0I
                        模式         │0 X │1.没有缓冲│
                                     ├——┤  模式    │
                                     │1 0 │2.缓冲模式│
                                     ├——┤  /从元件 │
                                     │1 1 │3.缓冲模式│
                                     ├——┘  /主元件 │
                                     └————————┘

  哇...我花了好多时间KEYIN喔..怎麽都没人写信给我感谢一下呢?? 哈 ..我83年6月20日
  要到成功岭暑训罗..这是之前的小礼物吧! 若下一集可能要等到 7月底罗!..所以希望各
  位好好的利用 暑假多K点书,也希望您真的喜欢我写的『破解入门』的话 请到破解技术
  交流网来写写信喔!..当然你有任何问题 可以写信给我 ID:YU HWANG 就可以了 本网要
  您的加入才会更加茁壮,当然来本网并非一定要高手才可以来的喔!..也有一些飙信大王
  的信管等着您来飙信,我希望藉着您对我的爱护,并对破解技术交流网草创不久给与鼓励
  与支持。

  讲了一些话..再来继续讲 OCW的指令用法..各位看官接招罗...如附图(六):

      A0    D7    D6    D5    D4    D3    D2    D1    D0
   ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
   │ 1  │ M7 │ M6 │ M5 │ M4 │ M3 │ M2 │ M1 │ M0 │
   └——┴——┴——┴——┴——┴——┴——┴——┴——┘

 (D7~M0)
    这些是用来设定及清除 IMR (中断罩盖暂存器) 中相对应的罩盖位元。
    其中 M0 控制 IR0,M1控制 IR1......依此类推 M7控制IR7。
    若 MX=1 表示相对应的 IRX 中断被禁能, 此时若有来自 IRX 的硬体中断 8259A 亦不
    会去理会中断请求,若反之 MX=0 则表示其对应的中断致能,此时若有中断产生时,CPU
    会跳到中断副程式去执行。

      A0    D7    D6    D5    D4    D3    D2    D1    D0
   ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
   │ 0  │ R  │ SL │ EOI│ 0  │ 0  │ L2 │ L1 │ L0 │
   └——┴——┴——┴——┴——┴——┴——┴——┴——┘

 (D2~D0)
     此叁个位元是决定中断序号,配合D5~D7使用形成8种组合。

 (D4~D3)
     此二位元必须设定为 0 ,为 OCW2 的识别码。
 (D7~D5)
     此叁位元是用来控制旋转模式,中断结束模式以及二者合并的模式,共有 8 种组合。
     当 8259A收到此一命令组时,它会自动将目前正在接受处理的IR输入所对应ISR的位
     元清除为0。

      A0    D7    D6    D5    D4    D3    D2    D1    D0
   ┌——┬——┬——┬——┬——┬——┬——┬——┬——┐
   │ 0  │ 0  │ESMM│SMM │ 0  │ 1  │ P  │ RR │ RIS│
   └——┴——┴——┴——┴——┴——┴——┴——┴——┘

 (D1,D0)
    此二位元是读取 ISR及IRR 暂存器中的内容。 共有四组组合方式...
     ┌——┬——┬——————┐
     │ RR │RIS │  功   能   │
     ├——┼——┼——————┤
     │ 0  │ 0  │不动作      │
     ├——┼——┼——————┤
     │ 0  │ 1  │不动作      │
     ├——┼——┼——————┤
     │ 1  │ 0  │读IRR暂存器 │
     ├——┼——┼——————┤
     │ 1  │ 1  │读ISR暂存器 │
     └——┴——┴——————┘

 (D2)
    此位元是 8259A为查询或中断 模式。 当P=1时,8259A 被设定为查询模式,反之为
    非查询模式。

 (D4~D3)
    此二位元没有用到。D3必须设定为1 (OCW3的识别位元),D4必须设定为0 。

 (D6~D5)
    此二位元是用来设定特殊罩盖模式(Special Mask Mode),共有四种组合,如下..
     ┌——┬——┬———————┐
     │ESMM│SMM │  功   能     │
     ├——┼——┼———————┤
     │ 0  │ 0  │不动作        │
     ├——┼——┼———————┤
     │ 0  │ 1  │不动作        │
     ├——┼——┼———————┤
     │ 1  │ 0  │清除罩盖暂存器│
     ├——┼——┼———————┤
     │ 1  │ 1  │清除罩盖暂存器│
     └——┴——┴———————┘

  哇...终於讲解完 8259A的一些命令组的用法及一些简单介绍...

 附图(七)
    8259A #1 (主)      8259A #1 (次)
 ┌——┬———┐   ┌——┬———┐  如附图(七)中,可以大概看出 8259A所要的暂存
 │位址│暂存器│   │位址│暂存器│    器超过 2个I/O位址所能提供的,解决的方法
 ├——┼———┤   ├——┼———┤    是必须以一定的规划流程及利用某些特定位
 │ 20H│ ICW1 │   │ A0H│ ICW1 │    元来决定暂存器。
 ├——┼———┤   ├——┼———┤
 │ 21H│ ICW2 │   │ A1H│ ICW2 │
 ├——┼———┤   ├——┼———┤
 │ 21H│ ICW3 │   │ A1H│ ICW3 │
 ├——┼———┤   ├——┼———┤
 │ 21H│ ICW4 │   │ A1H│ ICW4 │
 ├——┼———┤   ├——┼———┤
 │ 21H│ 0CW1 │   │ A1H│ 0CW1 │
 ├——┼———┤   ├——┼———┤
 │ 20H│ 0CW2 │   │ A0H│ 0CW2 │
 ├——┼———┤   ├——┼———┤
 │ 20H│ 0CW3 │   │ A0H│ 0CW3 │
 └——┴———┘   └——┴———┘

 我写一些范例让您知道一下规划方式:

     ┌ MOV     AL,11H ┐ICW1,8259主 需要ICW4 IR 中断输入为边缘触发模式
     │ OUT     20H,AL ┘
     │ MOV     AL,8   ┐ICW2,从中断向量表 TYPE 8 开始,可以参考 ICW2
     │ OUT     21H,AL ┘
8259主  MOV     AL,04H ┐ICW3,(主) 8259的IR2为仆 8259(次)的 中断输入
     │ OUT     21H,AL ┘
     │ MOV     AL,01H ┐ICW4,非缓冲模式,8086/8088
     │ OUT     21H,AL ┘
     │ MOV     AL,0FFH┐8259(主) 之OCW1,罩盖所有的中断输入
     └ OUT     21H,AL ┘

     ┌ MOV     AL,11H ┐ICW1,8259(次),需要ICW4 IR中断输入为边缘触发模式
     │ OUT     0A0H,AL┘
     │ MOV     AL,70H ┐ICW2,从中断向量表 TYPE 12 开始
     │ OUT     0A1H,AL┘
     │ MOV     AL,02H ┐ICW3,次 ID
8259次  OUT     0AH,AL ┘
     │ MOV     AL,01H ┐ICW4,没有缓冲模式,8088/8086 模式
     │ OUT     0A1H,AL┘
     │ MOV     AL,0FFH┐8259(次)之 OCW1,罩盖所有中断输入
     └ OUT     0A1H,AL┘

 若不懂的话,可以参考我前面的附图就可以罗! 以上我希望您能多用点心去研究,如果您没
 用些心去了解的话,那我也没那麽多时间可以一一为您解释,我相信我所写出来的这些一定
 可以让您了解 8259的概况,当然还有一些细节比较无关紧要,所以我就没列出来了.您可以
 去参考一些PC/AT内部硬体的书就可以罗!

 写那麽多当然也要打一下广告罗..嘻!不要见怪才好... 希望有兴趣的站长快来接『破解
 技术交流网』 本网需要您的加入 来加强本网的阵容 殷切期盼您的大驾光临本网 。

 破解技术交流网  申请表格:

 站台<英文名称>:
 站台<中文名称>:
 系统操作员:
 建站系统:
 家中地址:
 是<私人站>或<公开站>:
 开站时间:
 最高速率:
 站台电话:
 家中电话:
 公司电话:
 系统操作员<中文姓名>:
 系统配备:
 魔电厂牌:
 系统操作员<生日.年龄>:
 职业:
 网路时间:
 预定什麽时候开始接信:
 建议:

 请有心加入新网的站台 填写好之後 送来本站即可。

 ECHO KEY           共 ２２区            信管人员ID
 ------------------------------------------------------------------------
 破解码公怖区       CRACK-CODE
 破解技术讨论区     CRACK-CRACK          Yu Hwang(朋友俱乐部)
 一般信件讨论区     CRACK-GENERAL
 建站实务讨论区     CRACK-BBS            Andy Yu(狼族II站)
 中文系统讨论区     CRACK-CHINESE
 软体讨论区         CRACK-SOFT           Indiana Wang(欢乐屋-高雄站)
 新站广告区         CRACK-NEWBBS
 中古买卖区         CRACK-SALE           Danny Liu(天蝎星)
 硬体讨论区         CRACK-HARD
 音乐/音效讨论区    CRACK-MUSIC
 快信讨论区         CRACK-MESSAGE
 打屁瞎掰讨论区     CRACK-TALK           Bj Chang(将相世家)
 热门职棒讨论区     CRACK-BALL
 病毒讨论区         CRACK-VIRUS
 交友专区           CRACK-FRIEND         Steve You(朋友俱乐部)
 心情讨论区         CRACK-MOOD           Feney Lin(天蝎星) 女的
 站长讨论区         CRACK-SYSOP         ;不开放给User
 网路测试区         CRACK-TEST          ;不开放给User
 HUB xxxx区         CRACK-HUBxxxx       ;由HUB 自定信区 若跟总站接 都自定100
 魔电讨论区         CRACK-MODEM          也就是你要设 CRACK-HUB100 其它HUB自设
 游戏攻略心得发表区 CRACK-GAME
 程式语言讨论区     CRACK-LANGUAGE      Jim Green(天蝎星)
-------------------------------------------------------------------------------
ECHO FILES KEY

 CRACKNET   网路资源
 CRACK-PD   公益软体发送区
密码皆是 12345678

 欢迎有兴趣的站台来加入本网的行列。

 朋友俱乐部  039-281739 24HR 28800 BPS DATASYSTEM

 破解技术交流网      加 入 站 名 列 表     站 台 电 话     开放时间    速   率
------------------------------------------------------------------------------
宜兰地区
HOST总站 39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        28800
HUB100   39:39/100     外星游龙资讯站    TEL:039-356106      24HR        19200
         39:39/101     天蝎星资讯站      TEL:039-357940      24HR        14400
         39:39/102     瑞智资讯交流站    TEL:039-778657      24HR        14400
         39:39/103     雷鸟资讯交流站    TEL:039-322865    23:00-07:00   14400
         39:39/104     伊甸园资讯站      TEL:039-889981      24HR        14400
         39:39/105     欢乐肥龙资讯站    TEL:02-9161500      24HR        19200
         39:39/106     放浪孤城资讯站    TEL:02-8200241    13:00-07:00   14400
         39:39/107   一贯道资讯交流站    TEL:04-3384895      24HR        19200

台北地区
HUB200   39:39/200     李杰资讯交流站    TEL:02-8962836      24HR        19200
HUB300   39:39/300   遨游鹏资讯交流站    TEL:02-8747279      24HR        14400
         39:39/301     魔法王国交流站    TEL:02-5991763      24HR        19200
         39:39/302   坏小子资讯交流站    TEL:02-2190318      24HR        14400
         39:39/303     熊座资讯交流站    TEL:02-9344309      24HR        14400
         39:39/304     浑沌魔镜交流站    TEL:02-7668736      24HR        14400
         39:39/305     神行太保交流站    TEL:02-2362589      24HR        14400
         39:39/306   明汕寺资讯交流站    TEL:02-9690360      24HR        14400
         39:39/307   鹿鼎记资讯交流站    TEL:02-9771578      24HR        14400
         39:39/308     原始部落交流站    TEL:02-8224591    10:00-00:30   14400
PVT<私>  39:39/309   漫画俱乐部交流站    TEL:02-960xxxx      xxxx        16800
         39:39/310   魔法俱乐部交流站    TEL:02-9275781      24HR        14400
         39:39/311   梦幻屋资讯交流站    TEL:02-9866550      24HR        14400
         39:39/312     虹屋资讯交流站    TEL:02-9867374      24HR        14400
         39:39/313     将相世家交流站    TEL:02-6227053      24HR        14400
         39:39/314 狼之一族ＩＩ资讯站    TEL:02-7018906      24HR        19200
PVT<私>  39:39/315  Game_Design交流站    TEL:02-xxxxxxx      xxxx        14400
         39:39/316     疯狂超人交流站    TEL:02-3926054      24HR        16800
PVT<私>  39:39/317 彩色世界资讯交流站    TEL:02-xxxxxxx      xxxx        14400

HUB500   39:39/500     麦帅资讯交流站    TEL:02-9512743    17:00-21:00   14400
PVT<私>  39:39/501     光台资讯交流站    TEL:02-222xxxx      xxxx        14400
         39:39/502 佩雅达恒星交流广场    TEL:02-9201852      24HR        14400
         39:39/503 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/504   超时空资讯交流站    TEL:02-8752787      24HR        14400
         39:39/505 狼??传说一站交流站    TEL:02-9978405      24HR        16800

桃园地区
HUB400   39:39/400     神采飞扬交流站    TEL:03-4709883      24HR        19200
HUB1100  39:39/1100    电玩小子II站      TEL:03-4561471      24HR        16800
PVT<私>  39:39/1101    灌蓝高手交流站    TEL:03-450xxxx      xxxx        14400
         39:39/1102    致命总站交流站    TEL:03-3654087    22:00-06:00    9600

新竹地区 39:39/1200  地球电子村交流站    TEL:035-200517      24HR        19200
         39:39/1201  紫色梦幻屋交流站    TEL:035-801886      24HR        16800
         39:39/1202    今生有约交流站    TEL:035-200946      24HR        14400

花莲地区
HUB600  39:39/600     乱马资讯交流站    TEL:038-579968      24HR        14400
        39:39/601     阿达一族资讯站    TEL:038-321773      24HR        14400
        39:39/602     阿达二族资讯站    TEL:038-330498      24HR        14400
        39:39/603     阿达叁族资讯站    TEL:038-264387      24HR        14400

台中地区
HUB800  39:39/800      天使资讯交流站    TEL:04-7787048      24HR        16800
        39:39/801    卧龙居资讯交流站    TEL:04-8294582      24HR        19200
        39:39/802    幸运事务所交流站    TEL:04-7271940      24HR        16800
HUB900  39:39/900  天空之城资讯交流站    TEL:04-6578210      24HR        19200
                                         TEL:04-6578211      24HR        19200
                                         TEL:04-6578071      24HR        19200
                                         TEL:04-6578072      24HR        19200
                                         TEL:04-6578073      24HR        19200
        39:39/902  毁天灭地资讯交流站    TEL:04-6321487      24HR        19200
        39:39/903      今天资讯交流站    TEL:049-251090      24HR        16800
        39:39/904    正一工作室交流站    TEL:04-2807877      24HR        14400
        39:39/905  佳兴电传资讯交流站    TEL:04-5280719      24HR        16800

高雄地区
HUB1000 39:39/1000   欢乐屋资讯交流站    TEL:07-3152450    17:00-08:00   19200

香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-6183163     24HR        28800
        39:39/701      酒井法子专门站    TEL:852-7563536     24HR        19200
-------------------------------------------------------------------------------

 现在破一个算是有点水准的GAME来给大家学习...就是 『现代大战略 EX (DOS/V)』
 以下是破解过程的程式码..我引出来让大家学习并参考.. 此GAME是采用 KEYDISK方式去
 做的..所以我有试过用 S-ICE 好像无法进去喔! 会被GAME查到,若是用GAMETOOLS来破的
 话,那你就要拿注册版才比较省记忆体(非注册版约占75K),所以我试过可以进去。 劝你用
 古早的DEBUG 来破解就可以了 方法很简单..我将破解过程引出来给你看罗!

C:\CDGAME\GEXV>break on

C:\CDGAME\GEXV>debug gdaiex.exe
-u
0EF8:0000 B8240F        MOV     AX,0F24
0EF8:0003 8ED8          MOV     DS,AX
0EF8:0005 8CC0          MOV     AX,ES
0EF8:0007 8CD3          MOV     BX,SS
0EF8:0009 2BD8          SUB     BX,AX
0EF8:000B 83C320        ADD     BX,+20
0EF8:000E B44A          MOV     AH,4A
0EF8:0010 CD21          INT     21
0EF8:0012 7206          JB      001A
0EF8:0014 E8C000        CALL    00D7
0EF8:0017 E80602        CALL    0220
0EF8:001A B8004C        MOV     AX,4C00
0EF8:001D CD21          INT     21
0EF8:001F 0000          ADD     [BX+SI],AL
-u
0EF8:0021 0000          ADD     [BX+SI],AL
0EF8:0023 1E            PUSH    DS
0EF8:0024 2E            CS:
0EF8:0025 8C161F00      MOV     [001F],SS
0EF8:0029 2E            CS:
0EF8:002A 89262100      MOV     [0021],SP
0EF8:002E 8CD8          MOV     AX,DS
0EF8:0030 8EC0          MOV     ES,AX
0EF8:0032 B8004B        MOV     AX,4B00
0EF8:0035 CD21          INT     21
0EF8:0037 FA            CLI
0EF8:0038 2E            CS:
0EF8:0039 8E161F00      MOV     SS,[001F]
0EF8:003D 2E            CS:
0EF8:003E 8B262100      MOV     SP,[0021]
-u
0EF8:0042 FB            STI
0EF8:0043 1F            POP     DS
0EF8:0044 720B          JB      0051
0EF8:0046 B44D          MOV     AH,4D
0EF8:0048 CD21          INT     21
0EF8:004A 0AE4          OR      AH,AH
0EF8:004C 7405          JZ      0053
0EF8:004E F9            STC
0EF8:004F EB02          JMP     0053
0EF8:0051 B4FF          MOV     AH,FF
0EF8:0053 C3            RET
0EF8:0054 55            PUSH    BP
0EF8:0055 8BEC          MOV     BP,SP
0EF8:0057 57            PUSH    DI
0EF8:0058 56            PUSH    SI
0EF8:0059 1E            PUSH    DS
0EF8:005A 07            POP     ES
0EF8:005B FC            CLD
0EF8:005C 8B7E06        MOV     DI,[BP+06]
0EF8:005F B9FFFF        MOV     CX,FFFF
-u
0EF8:0062 33C0          XOR     AX,AX
0EF8:0064 F2            REPNZ
0EF8:0065 AE            SCASB
0EF8:0066 F7D1          NOT     CX
0EF8:0068 49            DEC     CX
0EF8:0069 880E1C00      MOV     [001C],CL
0EF8:006D 8B7606        MOV     SI,[BP+06]
0EF8:0070 BF1C00        MOV     DI,001C
0EF8:0073 47            INC     DI
0EF8:0074 8BDF          MOV     BX,DI
0EF8:0076 03D9          ADD     BX,CX
0EF8:0078 C6070D        MOV     BYTE PTR [BX],0D
0EF8:007B F3            REPZ
0EF8:007C A4            MOVSB
0EF8:007D 8B5604        MOV     DX,[BP+04]
0EF8:0080 BB0E00        MOV     BX,000E
-u
0EF8:0083 E89DFF        CALL    0023     ; 这里是读取 KEYDISK的进入点
0EF8:0086 5E            POP     SI
0EF8:0087 5F            POP     DI
0EF8:0088 8BE5          MOV     SP,BP
0EF8:008A 5D            POP     BP
0EF8:008B C3            RET
0EF8:008C 55            PUSH    BP
0EF8:008D 06            PUSH    ES
0EF8:008E 1E            PUSH    DS
0EF8:008F B452          MOV     AH,52
0EF8:0091 CD21          INT     21
0EF8:0093 26            ES:
0EF8:0094 8B5FFE        MOV     BX,[BX-02]
0EF8:0097 EB07          JMP     00A0
0EF8:0099 90            NOP
0EF8:009A 43            INC     BX
0EF8:009B 26            ES:
0EF8:009C 031E0300      ADD     BX,[0003]
0EF8:00A0 8EC3          MOV     ES,BX
0EF8:00A2 26            ES:
0EF8:00A3 803E00005A    CMP     BYTE PTR [0000],5A

-G 83     ; <----我就执行到 83 进入KEYDISK判断点

AX=0000  BX=000E  CX=0000  DX=01F2  SP=01F0  BP=01F4  SI=021D  DI=001E
DS=0F24  ES=0F24  SS=0F47  CS=0EF8  IP=0083   NV UP EI PL NZ NA PE NC
0EF8:0083 E89DFF        CALL    0023
-T       ; <----- 走罗!...大家一起去看看吧! 底下就是 KEYDISK程式段罗!

AX=0000  BX=000E  CX=0000  DX=01F2  SP=01EE  BP=01F4  SI=021D  DI=001E
DS=0F24  ES=0F24  SS=0F47  CS=0EF8  IP=0023   NV UP EI PL NZ NA PE NC
0EF8:0023 1E            PUSH    DS
-U
0EF8:0023 1E            PUSH    DS
0EF8:0024 2E            CS:
0EF8:0025 8C161F00      MOV     [001F],SS
0EF8:0029 2E            CS:
0EF8:002A 89262100      MOV     [0021],SP
0EF8:002E 8CD8          MOV     AX,DS
0EF8:0030 8EC0          MOV     ES,AX
0EF8:0032 B8004B        MOV     AX,4B00
0EF8:0035 CD21          INT     21
0EF8:0037 FA            CLI
0EF8:0038 2E            CS:
0EF8:0039 8E161F00      MOV     SS,[001F]
0EF8:003D 2E            CS:
0EF8:003E 8B262100      MOV     SP,[0021]
0EF8:0042 FB            STI
-U
0EF8:0043 1F            POP     DS
0EF8:0044 720B          JB      0051
0EF8:0046 B44D          MOV     AH,4D
0EF8:0048 CD21          INT     21
0EF8:004A 0AE4          OR      AH,AH
0EF8:004C 7405          JZ      0053
0EF8:004E F9            STC
0EF8:004F EB02          JMP     0053
0EF8:0051 B4FF          MOV     AH,FF
0EF8:0053 C3            RET
0EF8:0054 55            PUSH    BP
0EF8:0055 8BEC          MOV     BP,SP
0EF8:0057 57            PUSH    DI
0EF8:0058 56            PUSH    SI
0EF8:0059 1E            PUSH    DS
0EF8:005A 07            POP     ES
0EF8:005B FC            CLD
0EF8:005C 8B7E06        MOV     DI,[BP+06]
0EF8:005F B9FFFF        MOV     CX,FFFF
0EF8:0062 33C0          XOR     AX,AX

其实破解法很简单...只要将 0EF8:0083 E89DFF  CALL  0023  这改掉成 90 90 90
就可以玩啦! 这样让您没有KEYDISK的感觉喔! 简单吧!... 我就写到这罗!

------------------------------------------------------------------------------
 後序:
      由於本人将於 83年6月20日上成功岭,所以这集是特别的一个小礼物,希望您对这集
      的内容会感到满意。 有史以来写的最多的一次, 希望爱护小弟的朋友们继续给与小
      弟支持,并希望您有机会可以来『破解技术交流网』上与您认识, 本网也希望还没加
      入的站长们能给与本网肯定并支持 相信本网一定会越来越好的。

      由於要上成功岭暑训 所以算蛮赶出来的 本集有些尚未讲完的 我将於下集继续为大
      家补充 当然要您多多的鼓励及建议 我一定将我所知道尽量传授给各位。我下集会
      讲解十分详细 主题是(8259 IC 的预防方法及 乾坤大挪移 的完全步骤及细节) 到
      时候期待与您再次相见了。

      ID: Yu Hwang   姓名:俞煌男 (62/08/24)
      朋友俱乐部 专业站 24HR OPEN 28800BPS TEL:039-281739

             希望各位多多指教....           本集於83/06/17 凌晨: 3 点完成


俞煌男破解入门教程（１４／１７）
俞煌男

哇哈..我来啦!
        现在又来讲解破解技术啦! 希望大家都能学有所成才好 以免又有一大堆人
询问破解码了 这样就太不好了 毕竟还是要自个去破解才好玩不是吗? 当然还是不太
希望大家都将新的GAME破解公怖出来 以免程式设计师没饭吃 毕竟开发出一套产品是
很花时间及金钱的 所以希望大家共勉之。

解 妖魔道 追踪过程
C:\YMD>DEBUG ST.EXE (15968 BYTE 用UP.EXE 解压缩)
-U 08B2
28C7:08B2 8E1E1A00      MOV     DS,[001A]
28C7:08B6 33F6          XOR     SI,SI
28C7:08B8 33FF          XOR     DI,DI
28C7:08BA B9007D        MOV     CX,7D00
28C7:08BD F3            REPZ
28C7:08BE A5            MOVSW
28C7:08BF B8362B        MOV     AX,2B36
28C7:08C2 8ED8          MOV     DS,AX
28C7:08C4 833E910B01    CMP     WORD PTR [0B91],+01
28C7:08C9 7521          JNZ     08EC
28C7:08CB E88101        CALL    0A4F
28C7:08CE 833E930B01    CMP     WORD PTR [0B93],+01
28C7:08D3 7513          JNZ     08E8
28C7:08D5 C706910B0000  MOV     WORD PTR [0B91],0000
28C7:08DB C706930B0000  MOV     WORD PTR [0B93],0000
28C7:08E1 83061E0001    ADD     WORD PTR [001E],+01
28C7:08E6 EB02          JMP     08EA
28C7:08E8 EB1D          JMP     0907
28C7:08EA EB03          JMP     08EF
28C7:08EC E98FFE        JMP     077E
28C7:08EF 833E1E0003    CMP     WORD PTR [001E],+03

当进入妖魔道询问密码的地方时 也就是 画面上『请输入第一次密码』 按下 CTRL+D 中断
便会看到以上程式段 应该都停在 28C7:08BD F3  REPZ 这个指令位址上 等待您输入密码
往下找几行就是判断密码的地方罗! 也就是 28C7:08D3 7513  JNZ  08E8 罗! 聪明的您应
该知道如何修改了吧!                 PS:^^^^^^^^^以上这个位址会随记忆体而变动 所
                                                以请不用担心! 这是正常现象。

这套GAME画面不错.值得玩家购买唷! 请给大宇公司一些支持及鼓励 相信国内GAME会更好
当然也需要大家的认同罗! 附带一题:就是破解密码只是为了原版使用者的方便 请勿将破
解码随意散播 。本文件纯属讨论性质 请勿用在非法地方 本人保留着作权 请勿更改。
这套GAME很适合初学者一尝破解的快感 相信对您的信心一定可以大增。

8259补充说明:

    8259为一种可程式化的优先序岔断控制器，所有PC周边硬体的岔断均
必须透过这个元件来触发所对应的岔断处理程式。以下我们先说明8259的
硬体特性。8259共分成四个启始命令字组ICW和叁个操作命令字组OCW，前
者做为初始化时使用，後者则可供程式自行使用。8259初始化的过程为：

    送出ICW1
    送出ICW2
    if 串接模式 then 送出ICW3
    if 需要ICW4 then 送出ICW4

各启始命令字组的意义为：

1.ICW1
    位元7～5 = 岔断向量位址（只用在MCS-80模式）
    位元4    = 固定为1
    位元3    = 0为边缘触发（edge trigger）
               1为位准触发（level trigger）
    位元2    = 呼叫位址间隔（只用在MCS-80模式）
               0为呼叫位址间隔8
               1为呼叫位址间隔4
    位元1    = 0为串接模式（cascade mode）
               1为单一模式（single mode）
    位元0    = 0不需要ICW4
               1需要ICW4
说明：8259除了可供8088系列使用外，也可供MSC-80系列使用，因此当任
      何位元若标明只使用在MSC-80模式时，PC上均不需使用。另外，由
      於PC上使用的是8088系列的CPU，必须利用ICW4指定为8088模式，
      因此本启始命令的位元4、1均必须固定为1，位元7～5、2则可为0
      可为1。至於采用何种触发方式，则依电路特性而定，PC上通常采
      用边缘触发，因此位元3也大致固定为0。比较有争议的是位元1的
      值。在旧型的PC/XT上，由於只使用一个8259做为岔断控制用，因
      此必须使用单一模式，故它的初值为13h。但到了PC/AT时，由於系
      统功能加强，原来的一个8259已不敷使用，於是便扩增为两个8259
      串接在一起，因此这两个8259便都必须使用初值11h。

2.ICW2
    (1) MCS-80模式
        位元7～0 = 岔断向量位址
    (2) 8088模式
        位元7～3 = 岔断向量位址
        位元2～0 = 固定为0
说明：这个命令是用来设定硬体岔断时，所要执行的岔断向量启始值。
      PC/AT的第一个8259触发的岔断在08h～0Fh，因此初值为08h；第二
      个8259触发的岔断在70h～77h，因此初值为70h。这些初值若在不
      影响系统的岔断功能下，是可以随意改变的。

3.ICW3
    (1) 主控制器（master device)
        位元7～0 = 各位元分别表示IRQx是否有串接另一个8259控制器，
                   0表示没有，1表示有。
    (2) 次控制器（slave device）
        位元7～3 = 固定为0
        位元2～0 = 次控制器的识别码。
说明：这个初始命令必须有两个以上的8259串接在一起时才使用的，因此
      PC/XT并不使用这个初始命令。至於PC/AT上的两个8259，由於是串
      接在IRQ2上的，因此主控制器（也就是第一个8259）的初值便必须
      为04h。至於次控制器，由於必须配合所串接的IRQ来做编号，因此
      次控制器的初值便必须为02h，否则无法正常工作。

4.ICW4
    位元7～5 = 固定为0
    位元4    = 0为非特别全巢状模式
               1为特别全巢状模式
    位元3～2 = 0x 不带缓冲模式
               10 主控制器带缓冲模式
               11 次控制器带缓冲模式
    位元1    = 0表非自动结束岔断（EOI）
               1表自动结束岔断
    位元0    = 0表MSC-80模式
               1表8088模式
说明：特别全巢状模式（special fully nested mode），主要用在大系
      统中使用多个8259串接模式时，以便规划不同的岔断权限，详细资
      料请参阅相关书籍。通常我们均使用非特别全巢状模式，也就是初
      始化时以IRQ0优先权最高，IRQ7最低（这个优先权是可以改变的）。
      而在某个岔断发生处理时，优先权更高的岔断允许再发生，以岔断
      目前正在处理的岔断，而相同或较低优先权的岔断则不允许发生。
      至於是否要规划成缓冲模式，必须视所连接系统之Data Bus线路而
      定。对於是否使用自动结束岔断，则由作业系统或岔断处理程式的
      设置程式来决定。一般使用自动结束岔断对於岔断处理程式会比较
      方便些，不会因忘了送出EOI命令（参阅OCW2命令）而使得系统功
      能停止或当机。但是它最大的缺点是，如果相同的IRQ岔断一再发
      生，而该岔断程式又使用了STI命令允许岔断发生时（为了让更高
      优先权的岔断产生），则可能造成岔断程式再被岔断，导致重入问
      题，以及岔断顺序更动等问题。因此在绝大部份的情况下，大都会
      采用非自动岔断结束，在PC上亦然。不过若使用非自动EOI的结束
      方式时，岔断处理程式在处理完岔断後必须送出一个EOI命令给8259，
      表示岔断已处理完，否则8259便视为该岔断未结束而不再产生下个
      岔断了。
备注：关於本初始命令的初值，由XT的BIOS查得为09h，由286 AT的BIOS
      查得为01h，也就是前者采用缓冲模式，後者并不采用缓冲模式。
      经查阅有关8259零件的手册，其中说明缓冲模式主要用在具有BUS
      驱动缓冲区的Data Bus，由8259的SP/EN讯号来控制缓冲区。当不
      是缓冲模式时，这个讯号接脚在主控制器上必须接Vcc，而在次控
      制器上则必须接地。再查阅86 XT和286、386 AT的线路图，发现确
      实XT的设计电路是使用缓冲模式，而286、386 AT的设计电路则为
      非缓冲模式。因此在初始化时，必须依PC的种类而有不同的初始化
      值（事实上，XT只有一个8259，在初始化过程方面便一定会有不太
      一样的地方，必须与AT分别处理），如果未与设计的电路做好匹配
      的规划，则有当机之虞（但并不一定会当机。据作者实际测试过，
      在某些AT上将8259规划成缓冲模式会当机，而在某些AT上则不管是
      否规划成缓冲模式却仍都正常工作，这和主机电路板的线路设计有
      关）。

以下为各操作命令字组的意义：

1.OCW1
    位元7～0 = 分别表示IRQx是否启动，0表示允能（enable），1表示
               禁能（disable）。
说明：本命令也就是设定岔断的罩遮值（IMR，Interrupt Mask Register）。
      在使用时，通常先读取原值後，再设置所要处理的岔断所对应的位
      元，以避免影响到其他岔断。

2.OCW2
    位元7～5 = 000 取消自动EOI时旋转优先权模式
               001 不特别指定IRQx方式结束岔断
               010 无作用
               011 指定IRQx方式结束岔断
               100 设定自动EOI时旋转优先权模式
               101 不特别指定IRQx结束岔断时旋转优先权
               110 设定优先权
               111 指定IRQx结束岔断时旋转优先权
    位元4～3 = 固定为0
    位元2～0 = 指定的IRQx
说明：本命令是用来指定岔断优先权的处理方式（请参阅相关书籍），以
      及指示岔断是否处理完毕。一般在PC上大都使用20h做不特别指定
      IRQx方式来结束8259的岔断。所谓不特别指定IRQx方式，指的是要
      处理的IRQ编号并不由位元2～0来指定，而以目前已发生且优先权
      最高的岔断为准。

3.OCW3
    位元7    = 固定为0
    位元6～5 = 0x 无作用
               10 取消特殊罩值（reset special mask）
               11 设定特殊罩值（set special mask）
    位元4    = 固定为0
    位元3    = 固定为1
    位元2    = 0表使用岔断方式服务
               1表不使用岔断方式服务（poll command）
    位元1～0 = 0x 无作用
               10 读取岔断需求暂存器（IRR）
               11 读取内部服务暂存器（ISR）
说明：特殊罩值功能，主要是提供给需要任意改变岔断的禁能、允能，而
      又不希望因未送出EOI命令，而导致其他较低优先权的岔断无法发
      生的程式使用。当设定了特殊罩值後，则每次在OCW1重设罩值时，
      均会将所有未被罩遮掉的IRQ重新启用。IRR及ISR这两个暂存器的
      值可用来辨别各岔断的产生与否。IRR（Interrupt Request
      Register）记录了硬体已产生岔断需求，但8259尚未发出岔断讯号
      或CPU尚未回应确认讯号的岔断；ISR（Interrupt Service Register）
      则记录了CPU已接收到岔断讯号但处理程式尚未回应EOI命令的岔断。
      当要读取这两个暂存器值时，首先必须送出OCW3指定所要读取的暂
      存器，然後再由相同的输出入埠将之读取。
备注：不使用岔断服务的方式（poll command），依8259之零件说明为RD
      讯号会读取Priority Level值，其值意义如下：
          位元7    = 1表有岔断发生
          位元6～3 = 保留
          位元2～0 = 岔断发生的编号
      又说明Poll Command是使用在8259的岔断输出讯号不使用，或CPU
      线路已将岔断讯号输入禁能的情况。据作者实际测试结果，在PC上
      将OCW3修改成Poll Command形态，并不影响到原岔断的执行，读取
      而得的值也并非Priority Level的值。至於为何如此，作者遍寻相
      关书籍，也问过许多硬体设计从业人员，竟找不到答案。作者猜测
      可能是因PC CPU仍然接收并使用8259的岔断输出讯号，使得8259的
      岔断确认讯号并非由Poll Command的RD讯号确认所致，至於真正原
      因，则不得而知了。

    当8259重新初始化後，IMR的值均会重设为FFh（也就是允许所有的岔
断产生），并取消特殊罩值功能。因此当我们要重新初始化8259时，必须
记录原来的IMR值，并在初始化後将之设回，以免初始化後某些原已被禁
能的岔断再次产生而发生问题。当然，初始化後视情况也必须重新设定
OCW3的值。

    上述所有命令字组在PC上均透过I/O Port 20h、21h（第一个8259）
和A0h、A1h（第二个8259）来读写。I/O Port 20h和A0h做为ICW1、OCW2
和OCW3命令的输入，以及IRR、ISR暂存器值的输出。I/O Port 21h和A1h
则做为ICW2、ICW3、ICW4和OCW1命令的输入，以及IMR暂存器值的输出。
至於8259是如何去分辨送来的是那个命令字组，这倒不必我们费心，因为
这些命令字组中大都已安排好某些位元均固定为0或1。由这些固定位元，
8259便能轻易地辨别出所输入的命令种类。以下是目前在PC/AT中两个8259
所处理的16个硬体岔断内容：

                 ┌ IRQ0 计时岔断
                 │ IRQ1 键盘岔断
                 │ IRQ2 串接第二个8259
    第一个8259 —┤ IRQ3 次串列通讯埠（COM2）
                 │ IRQ4 主串列通讯埠（COM1）
                 │ IRQ5 印表机岔断（LPT2）
                 │ IRQ6 软碟岔断
                 └ IRQ7 印表机岔断（LPT1）
                 ┌ IRQ0 即时时脉岔断
                 │ IRQ1 保留
                 │ IRQ2 保留
    第二个8259 —┤ IRQ3 保留
                 │ IRQ4 保留
                 │ IRQ5 数学处理单元岔断
                 │ IRQ6 硬碟岔断
                 └ IRQ7 保留

以下为各岔断在本附录中所对应的硬体说明：

    计时岔断         = 8253、8254
    键盘岔断         = 8042、8255
    即时时脉岔断     = 146818
    数学处理单元岔断 = 8087、80287

解魔武王 追踪过程
C:\DKS>DEBUG DKS.EXE   (284965 BYTE 免解压缩)
-U BFF0
1052:BFF0 E8FF76        CALL    36F2
1052:BFF3 E69A          OUT     9A,AL
1052:BFF5 F3            REPZ
1052:BFF6 0BE3          OR      SP,BX
1052:BFF8 3F            AAS
1052:BFF9 83C414        ADD     SP,+14
1052:BFFC 48            DEC     AX
1052:BFFD 8946D4        MOV     [BP-2C],AX
1052:C000 8B46D4        MOV     AX,[BP-2C]     <---正确密码存放位址
1052:C003 3B46EE        CMP     AX,[BP-12]     <---比较输入密码
1052:C006 7523          JNZ     C02B           <---若不同 就跳到 C02B
1052:C008 68            DB      68
1052:C009 B004          MOV     AL,04
1052:C00B FF366822      PUSH    [2268]
1052:C00F FF366622      PUSH    [2266]
1052:C013 6A            DB      6A
1052:C014 006A01        ADD     [BP+SI+01],CH
1052:C017 8B46EC        MOV     AX,[BP-14]
1052:C01A 05E2FF        ADD     AX,FFE2
1052:C01D 50            PUSH    AX
1052:C01E FF76EA        PUSH    [BP-16]
1052:C021 9ACF19143B    CALL    3B14:19CF
1052:C026 83C40E        ADD     SP,+0E
1052:C029 EB2D          JMP     C058
1052:C02B 68            DB      68
1052:C02C B004          MOV     AL,04
1052:C02E FF366822      PUSH    [2268]
1052:C032 FF366622      PUSH    [2266]
1052:C036 6A            DB      6A
1052:C037 006A07        ADD     [BP+SI+07],CH
1052:C03A 8B46EC        MOV     AX,[BP-14]
1052:C03D 05E2FF        ADD     AX,FFE2
1052:C040 50            PUSH    AX

破解这套GAME只需掌握一些技巧 可揽INT 16 AH=00 即可顺利找到判断点的地方 如上图所
示的程式码 本人不想解释上面的程式作用 若不懂指令运作方式 可参考坊间的组合语言书
籍即可。
将上面比较的地方修改如下图所示:

1052:C000 8B46EE        MOV     AX,[BP-12]  ┐目的是将您正确密码位址跟您输
1052:C003 3B46EE        CMP     AX,[BP-12]  ┘入密码值改成都比较输入密码位
1052:C006 7523          JNZ     C02B          址 也就是说您输入的密码就等於
1052:C008 68            DB      68            是正确密码! 所以随便输入都正确。
1052:C009 B004          MOV     AL,04
1052:C00B FF366822      PUSH    [2268]
1052:C00F FF366622      PUSH    [2266]
1052:C013 6A            DB      6A
1052:C014 006A01        ADD     [BP+SI+01],CH
1052:C017 8B46EC        MOV     AX,[BP-14]
1052:C01A 05E2FF        ADD     AX,FFE2
1052:C01D 50            PUSH    AX
1052:C01E FF76EA        PUSH    [BP-16]

破解 叁国志牌战风云 追踪法
C:\SKMJ>DEBUG SKMJ.EXE  (159644 BYTE 用UP.EXE 反压缩)
1212:70B1 71FE          JNO     70B1
1212:70B3 C0            DB      C0
1212:70B4 A26871        MOV     [7168],AL
1212:70B7 EB00          JMP     70B9
1212:70B9 803E687109    CMP     BYTE PTR [7168],09     <---比较输入密码是否正确
1212:70BE 7508          JNZ     70C8                   <---不正确就跳到 70C8
1212:70C0 8B76E0        MOV     SI,[BP-20]
1212:70C3 C746DE0100    MOV     WORD PTR [BP-22],0001
1212:70C8 837EDE00      CMP     WORD PTR [BP-22],+00
1212:70CC 7503          JNZ     70D1
1212:70CE E9CBFE        JMP     6F9C
1212:70D1 9A501B6A16    CALL    166A:1B50
1212:70D6 3B76E0        CMP     SI,[BP-20]
1212:70D9 7440          JZ      711B
1212:70DB 6A            DB      6A
1212:70DC 06            PUSH    ES
1212:70DD 6A            DB      6A
1212:70DE 186A32        SBB     [BP+SI+32],CH
1212:70E1 6A            DB      6A
1212:70E2 60            DB      60
1212:70E3 68            DB      68
1212:70E4 A0009A        MOV     AL,[9A00]
1212:70E7 D202          ROL     BYTE PTR [BP+SI],CL
1212:70E9 231683C4      AND     DX,[C483]
1212:70ED 0A6A00        OR      CH,[BP+SI+00]
1212:70F0 6A            DB      6A
1212:70F1 0F            DB      0F
1212:70F2 8B5EEC        MOV     BX,[BP-14]
1212:70F5 C1            DB      C1
1212:70F6 E302          JCXZ    70FA
1212:70F8 FFB73E0B      PUSH    [BX+0B3E]
1212:70FC FFB73C0B      PUSH    [BX+0B3C]
1212:7100 6A            DB      6A
1212:7101 60            DB      60
1212:7102 68            DB      68
1212:7103 E8009A        CALL    0B06
1212:7106 E30E          JCXZ    7116
1212:7108 6A            DB      6A
1212:7109 16            PUSH    SS
1212:710A 83C40C        ADD     SP,+0C
1212:710D 68            DB      68
1212:710E C8            DB      C8
1212:710F 009A691B      ADD     [BP+SI+1B69],BL
1212:7113 6A            DB      6A
1212:7114 16            PUSH    SS
1212:7115 83C402        ADD     SP,+02
1212:7118 E99F02        JMP     73BA
1212:711B C746EEB095    MOV     WORD PTR [BP-12],95B0
1212:7120 C746F20000    MOV     WORD PTR [BP-0E],0000
1212:7125 EB40          JMP     7167
1212:7127 33FF          XOR     DI,DI
1212:7129 EB30          JMP     715B
1212:712B 57            PUSH    DI
1212:712C 9A47002316    CALL    1623:0047
1212:7131 83C402        ADD     SP,+02
1212:7134 6A            DB      6A
1212:7135 50            PUSH    AX
1212:7136 8BC7          MOV     AX,DI
1212:7138 C1            DB      C1
1212:7139 E002          LOOPNZ  713D
1212:713B C45EFC        LES     BX,[BP-04]
1212:713E 03D8          ADD     BX,AX
1212:7140 26            ES:
1212:7141 8B07          MOV     AX,[BX]
1212:7143 0346EE        ADD     AX,[BP-12]
1212:7146 26            ES:
1212:7147 FF7702        PUSH    [BX+02]
1212:714A 50            PUSH    AX
1212:714B 8B46EE        MOV     AX,[BP-12]
1212:714E 68            DB      68
1212:714F 00A0509A      ADD     [BX+SI+9A50],AH
1212:7153 6D            DB      6D
1212:7154 1912          SBB     [BP+SI],DX
1212:7156 1283C40A      ADC     AL,[BP+DI+0AC4]
1212:715A 47            INC     DI
1212:715B 83FF04        CMP     DI,+04
1212:715E 7CCB          JL      712B
1212:7160 FF46F2        INC     WORD PTR [BP-0E]
1212:7163 836EEE50      SUB     WORD PTR [BP-12],+50
1212:7167 817EF2E001    CMP     WORD PTR [BP-0E],01E0
1212:716C 7CB9          JL      7127
1212:716E 6A            DB      6A
1212:716F 006A0A        ADD     [BP+SI+0A],CH
1212:7172 8B5EEA        MOV     BX,[BP-16]
1212:7175 C1            DB      C1
1212:7176 E302          JCXZ    717A
1212:7178 FFB7B60A      PUSH    [BX+0AB6]
1212:717C FFB7B40A      PUSH    [BX+0AB4]
1212:7180 68            DB      68
1212:7181 A800          TEST    AL,00
1212:7183 68            DB      68
1212:7184 F8            CLC
1212:7185 009AE30E      ADD     [BP+SI+0EE3],BL
1212:7189 6A            DB      6A
1212:718A 16            PUSH    SS
1212:718B 83C40C        ADD     SP,+0C
1212:718E 6A            DB      6A
1212:718F 006A0A        ADD     [BP+SI+0A],CH
1212:7192 8B5EE6        MOV     BX,[BP-1A]
1212:7195 C1            DB      C1
1212:7196 E302          JCXZ    719A
1212:7198 FFB7DE0A      PUSH    [BX+0ADE]
1212:719C FFB7DC0A      PUSH    [BX+0ADC]
1212:71A0 68            DB      68
1212:71A1 A800          TEST    AL,00
1212:71A3 68            DB      68
1212:71A4 40            INC     AX
1212:71A5 019AE30E      ADD     [BP+SI+0EE3],BX
1212:71A9 6A            DB      6A
1212:71AA 16            PUSH    SS
1212:71AB 83C40C        ADD     SP,+0C
1212:71AE 6A            DB      6A
1212:71AF 006A0A        ADD     [BP+SI+0A],CH
1212:71B2 8B5EE8        MOV     BX,[BP-18]
1212:71B5 C1            DB      C1
1212:71B6 E302          JCXZ    71BA
1212:71B8 FFB7DE0A      PUSH    [BX+0ADE]
1212:71BC FFB7DC0A      PUSH    [BX+0ADC]
1212:71C0 68            DB      68
1212:71C1 8800          MOV     [BX+SI],AL
1212:71C3 68            DB      68
1212:71C4 58            POP     AX
1212:71C5 019AE30E      ADD     [BP+SI+0EE3],BX
1212:71C9 6A            DB      6A
1212:71CA 16            PUSH    SS
1212:71CB 83C40C        ADD     SP,+0C
1212:71CE 6A            DB      6A
1212:71CF 006A0F        ADD     [BP+SI+0F],CH
1212:71D2 8B5EE0        MOV     BX,[BP-20]
1212:71D5 C1            DB      C1
1212:71D6 E302          JCXZ    71DA
1212:71D8 FFB74E0B      PUSH    [BX+0B4E]
1212:71DC FFB74C0B      PUSH    [BX+0B4C]
1212:71E0 68            DB      68
1212:71E1 A800          TEST    AL,00
1212:71E3 68            DB      68
1212:71E4 58            POP     AX
1212:71E5 019AE30E      ADD     [BP+SI+0EE3],BX
1212:71E9 6A            DB      6A
1212:71EA 16            PUSH    SS
1212:71EB 83C40C        ADD     SP,+0C
1212:71EE 6A            DB      6A
1212:71EF 006A0A        ADD     [BP+SI+0A],CH
1212:71F2 FF363E0B      PUSH    [0B3E]
1212:71F6 FF363C0B      PUSH    [0B3C]
1212:71FA 6A            DB      6A
1212:71FB 60            DB      60
1212:71FC 68            DB      68
1212:71FD E8009A        CALL    0C00
1212:7200 E30E          JCXZ    7210
1212:7202 6A            DB      6A
1212:7203 16            PUSH    SS
1212:7204 83C40C        ADD     SP,+0C
1212:7207 FF76D4        PUSH    [BP-2C]
1212:720A FF76D6        PUSH    [BP-2A]
1212:720D B8DC00        MOV     AX,00DC
1212:7210 8946D8        MOV     [BP-28],AX
1212:7213 50            PUSH    AX
1212:7214 B8F000        MOV     AX,00F0
1212:7217 8946DA        MOV     [BP-26],AX
1212:721A 50            PUSH    AX
1212:721B 9A82036A16    CALL    166A:0382
1212:7220 83C408        ADD     SP,+08
1212:7223 8956FA        MOV     [BP-06],DX
1212:7226 8946F8        MOV     [BP-08],AX
1212:7229 33F6          XOR     SI,SI
1212:722B C746DE0000    MOV     WORD PTR [BP-22],0000
1212:7230 C746DC0100    MOV     WORD PTR [BP-24],0001
1212:7235 E92E01        JMP     7366
1212:7238 837EDC00      CMP     WORD PTR [BP-24],+00
1212:723C 7478          JZ      72B6
1212:723E C746DC0000    MOV     WORD PTR [BP-24],0000
1212:7243 FF76D8        PUSH    [BP-28]
1212:7246 FF76DA        PUSH    [BP-26]
1212:7249 FF76FA        PUSH    [BP-06]
1212:724C FF76F8        PUSH    [BP-08]
1212:724F 9AB4046A16    CALL    166A:04B4
1212:7254 83C408        ADD     SP,+08
1212:7257 FF76FA        PUSH    [BP-06]
1212:725A FF76F8        PUSH    [BP-08]
1212:725D 9A1A036A16    CALL    166A:031A
1212:7262 83C404        ADD     SP,+04
1212:7265 FF76D4        PUSH    [BP-2C]
1212:7268 FF76D6        PUSH    [BP-2A]
1212:726B 8BC6          MOV     AX,SI
1212:726D BB0400        MOV     BX,0004
1212:7270 99            CWD
1212:7271 F7FB          IDIV    BX
1212:7273 BA3000        MOV     DX,0030
1212:7276 F7EA          IMUL    DX
1212:7278 05DC00        ADD     AX,00DC
1212:727B 8946D8        MOV     [BP-28],AX
1212:727E 50            PUSH    AX
1212:727F 8BC6          MOV     AX,SI
1212:7281 99            CWD
1212:7282 F7FB          IDIV    BX
1212:7284 BB3000        MOV     BX,0030
1212:7287 8BC2          MOV     AX,DX
1212:7289 F7EB          IMUL    BX
1212:728B 05F000        ADD     AX,00F0
1212:728E 8946DA        MOV     [BP-26],AX
1212:7291 50            PUSH    AX
1212:7292 9A82036A16    CALL    166A:0382
1212:7297 83C408        ADD     SP,+08
1212:729A 8956FA        MOV     [BP-06],DX
1212:729D 8946F8        MOV     [BP-08],AX
1212:72A0 FF76F6        PUSH    [BP-0A]
1212:72A3 FF76F4        PUSH    [BP-0C]
1212:72A6 52            PUSH    DX
1212:72A7 50            PUSH    AX
1212:72A8 FF76D8        PUSH    [BP-28]
1212:72AB FF76DA        PUSH    [BP-26]
1212:72AE 9A510B6A16    CALL    166A:0B51
1212:72B3 83C40C        ADD     SP,+0C
1212:72B6 9AB31B6A16    CALL    166A:1BB3
1212:72BB 8946F0        MOV     [BP-10],AX
1212:72BE 3D004B        CMP     AX,4B00
1212:72C1 743C          JZ      72FF
1212:72C3 7F0C          JG      72D1
1212:72C5 3D0D00        CMP     AX,000D
1212:72C8 7462          JZ      732C
1212:72CA 3D0048        CMP     AX,4800
1212:72CD 740E          JZ      72DD
1212:72CF EB62          JMP     7333
1212:72D1 3D004D        CMP     AX,4D00
1212:72D4 743F          JZ      7315
1212:72D6 3D0050        CMP     AX,5000
1212:72D9 7413          JZ      72EE
1212:72DB EB56          JMP     7333
1212:72DD 83FE04        CMP     SI,+04
1212:72E0 7C75          JL      7357
1212:72E2 83EE04        SUB     SI,+04
1212:72E5 C746DC0100    MOV     WORD PTR [BP-24],0001
1212:72EA EB6B          JMP     7357
1212:72EC EB69          JMP     7357
1212:72EE 83FE04        CMP     SI,+04
1212:72F1 7D64          JGE     7357
1212:72F3 83C604        ADD     SI,+04
1212:72F6 C746DC0100    MOV     WORD PTR [BP-24],0001
1212:72FB EB5A          JMP     7357
1212:72FD EB58          JMP     7357
1212:72FF 8BC6          MOV     AX,SI
1212:7301 BB0400        MOV     BX,0004
1212:7304 99            CWD
1212:7305 F7FB          IDIV    BX
1212:7307 0BD2          OR      DX,DX
1212:7309 744C          JZ      7357
1212:730B 4E            DEC     SI
1212:730C C746DC0100    MOV     WORD PTR [BP-24],0001
1212:7311 EB44          JMP     7357
1212:7313 EB42          JMP     7357
1212:7315 8BC6          MOV     AX,SI
1212:7317 BB0800        MOV     BX,0008
1212:731A 99            CWD
1212:731B F7FB          IDIV    BX
1212:731D 83FA03        CMP     DX,+03
1212:7320 7435          JZ      7357
1212:7322 46            INC     SI
1212:7323 C746DC0100    MOV     WORD PTR [BP-24],0001
1212:7328 EB2D          JMP     7357
1212:732A EB2B          JMP     7357
1212:732C C746DE0100    MOV     WORD PTR [BP-22],0001
1212:7331 EB24          JMP     7357
1212:7333 837EF000      CMP     WORD PTR [BP-10],+00
1212:7337 741E          JZ      7357
1212:7339 A06871        MOV     AL,[7168]
1212:733C 98            CBW
1212:733D 8BD8          MOV     BX,AX
1212:733F 8A87900B      MOV     AL,[BX+0B90]
1212:7343 98            CBW
1212:7344 3B46F0        CMP     AX,[BP-10]
1212:7347 7404          JZ      734D
1212:7349 B000          MOV     AL,00
1212:734B EB05          JMP     7352
1212:734D A06871        MOV     AL,[7168]
1212:7350 FEC0          INC     AL
1212:7352 A26871        MOV     [7168],AL
1212:7355 EB00          JMP     7357
1212:7357 803E687109    CMP     BYTE PTR [7168],09    <---比较输入密码是否正确
1212:735C 7508          JNZ     7366                  <---不正确就跳到 7366
1212:735E 8B76E2        MOV     SI,[BP-1E]
1212:7361 C746DE0100    MOV     WORD PTR [BP-22],0001

此GAME共比较二次密码 所以我将全部比对程式列出 相信您应该会改了吧! 这GAME也不难
破解啦! 多练习就会顺手罗! 不要恢心...一定会成功的啦!

观看最近的GAME密码保护方式来看 大部份又可以分为以下几种方式:
1.简单型
  也就是没什麽防破手段 也没有任何隐藏地雷。
2.玩家型
  称不上有防破能力 但可以练功增加经验值。
3.进阶型
  有点防追踪的能力 尚不是太强。
4.挑战型
  虽然已俱防追踪的能力(属尚中) 但还是有隐藏机关 当然并不完全都有啦!
5.高手型
  防破能力十分强 外层保护多 并有编码 及当掉DEBUG..等能力 也暗设了一些隐藏的地雷
  要花费较久时间去TRACE。
  像 丛林战争 就是罗!
6.超强型
  此保护方式是采用 V86保护模式去做 并防破能力也是超强的棒 有时也会装地雷唷!
  PS:由於进入保护模式状态下 一般破解者大都很难去破解 况且也先要俱备一些可追踪保
     护模式的DEBUG才行 不然更别谈破解罗!

您可以依照自个程度去找来练功 当然有好的DEBUG程式 才会让您破解起来更得心应手 但
反观国内一大堆公司 一??的注重保护技巧上 完全忽视掉GAME本身的可玩性 以精x保护方
式最为厉害 其它公司皆属尚可 希望国内的GAME能早日赶上国外技术。

Ｓｏｆｔ－Ｉｃｅ
依照目前情势看来 S-ICE 早就已经没有用罗! 俗语说『人怕出名 猪怕肥』因为SICE可说
是国内许多破解者较常用的破解工具 其功能可说是非常的不错 一旦出名了之後 想必各家
公司一定都会刻意去防止SICE来追踪程式 所以可以肯定目前SICE已经渐渐被淘汰罗!

ＧａｍｅＴｏｏｌ
依照GameTool的功能来说 操作方式较为SICE容易接受 功能也可说是跟SICE差不了多少
当然若用在破解方面 也不失为一个好用的工具 其内附的一些小工具 着实让我们方便了不
少时间。
EX: UP.EXE 这可解压大部份的软体压缩程式 虽然可解压的程式没比UNP.EXE还多 但是有
           时候 却可以解UNP.EXE无法解开的档案 算是各有利弊吧!  像PKLITE.EXE 压
           缩过的执行档 只要把PLKITE识别码更改或涂掉的话 UNP.EXE 就无法解开罗!
           但UP.EXE 却可以解开。

   TSRCRACK.COM 这个小工具是用来帮您制作前导程式的。 或许您会问何谓『前导』?简
                单的说就是常驻程式。目的是用来破解或是修改记忆体的资料或内容啦
                举例来说: 假设您追踪到一个不知名的程式 此程式已被外加保护或是压
                缩过 无法使用UNP.EXE OR UP ....等解压缩程式解开 那麽您又找到程
                式判断点 用PCTOOLS却苦苦无法找到该码时 就可以用此程式来帮您制作
                前导程式罗! 其用法很简单请参考内附说明档即可。 若不懂可到破解技
                术交流网 中的破解技术讨论区 留信给 Yu Hwang 我就可以罗!

 破解技术交流网  申请表格:

 站台<英文名称>:
 站台<中文名称>:
 系统操作员:
 建站系统:
 家中地址:
 是<私人站>或<公开站>:
 开站时间:
 最高速率:
 站台电话:
 家中电话:
 公司电话:
 系统操作员<中文姓名>:
 系统配备:
 魔电厂牌:
 系统操作员<生日.年龄>:
 职业:
 网路时间:
 预定什麽时候开始接信:
 建议:

 请有心加入新网的站台 填写好之後 送来本站即可。

 ECHO KEY           共 ２３区            信管人员ID
 ------------------------------------------------------------------------
 破解码公怖区       CRACK-CODE
 破解技术讨论区     CRACK-CRACK          Yu Hwang(朋友俱乐部)
 一般信件讨论区     CRACK-GENERAL
 建站实务讨论区     CRACK-BBS            Andy Yu(狼族II站)
 中文系统讨论区     CRACK-CHINESE
 软体讨论区         CRACK-SOFT           Indiana Wang(欢乐屋-高雄站)
 新站广告区         CRACK-NEWBBS
 中古买卖区         CRACK-SALE
 硬体讨论区         CRACK-HARD           Maxwell Lin(新电子通信站)
 音乐/音效讨论区    CRACK-MUSIC
 快信讨论区         CRACK-MESSAGE
 打屁瞎掰讨论区     CRACK-TALK           Bj Chang(将相世家)
 热门职棒讨论区     CRACK-BALL
 病毒讨论区         CRACK-VIRUS
 交友专区           CRACK-FRIEND         Steve You(朋友俱乐部)
 心情讨论区         CRACK-MOOD
 站长讨论区         CRACK-SYSOP         ;不开放给User
 网路测试区         CRACK-TEST          ;不开放给User
 HUB xxxx区         CRACK-HUBxxxx       ;由HUB 自定信区 若跟总站接 都自定100
 魔电讨论区         CRACK-MODEM          也就是你要设 CRACK-HUB100 其它HUB自设
 游戏攻略心得发表区 CRACK-GAME
 程式语言讨论区     CRACK-LANGUAGE
 电视游乐器讨论区   CRACK-TVGAME
-------------------------------------------------------------------------------
ECHO FILES KEY

 CRACKNET   网路资源
 CRACK-PD   公益软体发送区
密码皆是 12345678

 欢迎有兴趣的站台来加入本网的行列。请将申请表送到附近HUB OR HOST 即可

 破解技术交流网      加 入 站 名 列 表   站  台  电  话    开放时间    速   率
------------------------------------------------------------------------------
宜兰地区
HOST总站 39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        28800
HUB100   39:39/100     外星游龙资讯站    TEL:039-356106      24HR        19200
PVT<私>  39:39/101       双子星工作室    TEL:039-xxxxxx      xxxx         2400
         39:39/102     瑞智资讯交流站    TEL:039-778657      24HR        14400
         39:39/103   柏宇工作室资讯站    TEL:04-2300479      24HR        19200
         39:39/104     晃晃资讯交流站    TEL:039-517921      24HR        14400
PVT<私>  39:39/105 台中市第一信用合作社  TEL:04-xxxxxxx      xxxx        19200
         39:39/106     放浪孤城资讯站    TEL:02-8200241    13:00-07:00   14400
         39:39/107     酒国英雄资讯站    TEL:02-2961696      24HR        19200
PVT<私>  39:39/108     1024资讯工作坊    TEL:039-xxxxxx      xxxx        14400

台北地区
HUB200   39:39/200     李杰资讯交流站    TEL:02-8962836      24HR        28800
PVT<私>  39:39/202     超帅型交流站      TEL:02-702xxxx      私人        14400
         39:39/203     梦??小??资讯站    TEL:02-3916175    08:00-24:00   14400
         39:39/204     叮当资讯交流站    TEL:02-2512974      24HR        16800
         39:39/205       幻??鹰交流站    TEL:02-9833779      24HR        19200
         39:39/206     星际航舰交流站    TEL:02-2300107      24HR        19200
         39:39/207     虚幻空间资讯站    TEL:02-2455457      24HR        28800
HUB500   39:39/500     麦帅资讯交流站    TEL:02-9512743      24HR        19200
PVT<私>  39:39/501     光台资讯交流站    TEL:02-222xxxx      私人        14400
         39:39/502 佩雅达恒星交流广场    TEL:02-9201852      24HR        14400
         39:39/503 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/504   超时空资讯交流站    TEL:02-8752787      24HR        28800
         39:39/505 狼??传说一站交流站    TEL:02-9978405      24HR        16800
PVT<私>  39:39/506 URUSEIYATUSRA_SBBS    TEL:02-xxxxxxx      私人        14400
PVT<私>  39:39/507     潇??人生交流站    TEL:02-xxxxxxx      私人        19200
         39:39/508     熊之家族资讯站    TEL:02-7789541      24HR        19200
         39:39/509     ＶＥＧＡ资讯站    TEL:02-3960363      24HR        28800
         39:39/510        超导体III站    TEL:02-6867030      24HR        14400
         39:39/511     堕落天使资讯站    TEL:02-9481859      24HR        28800
PVT<私>  39:39/512       Hidden BBS站    TEL:02-xxxxxxx      私人        14400

桃园地区
HUB400   39:39/400     神采飞扬交流站    TEL:03-4709883      24HR        19200
HUB1100  39:39/1100      电玩小子II站    TEL:03-4561471      24HR        16800
         39:39/1102    致命总站交流站    TEL:03-3654087    22:00-06:00    9600
HUB1300  39:39/1300      电玩小子总站    TEL:03-3353482      24HR        14400
HUB1600  39:39/1600    飙信小子专业站    TEL:03-4500312      24HR        14400
         39:39/1601      耀之龙资讯站    TEL:03-3566453    20:00-05:00   14400
         39:39/1602    摩登大圣资讯站    TEL:03-4664108      24HR        14400
HUB1700  39:39/1700    百战天龙资讯站    TEL:03-4578836      24HR        19200
         39:39/1701    MacGyver Ⅲ 站    TEL:03-XXXXXXX      私人        14400
         39:39/1702    巧翊商业资讯站    TEL:03-3507952      24HR        14400
         39:39/1703    吞食天地资讯站    TEL:03-XXXXXXX      私人        14400
         39:39/1704    东方战神资讯站    TEL:03-XXXXXXX      私人        19200
         39:39/1705    神行太保资讯站    TEL:03-3797802      24HR        14400
         39:39/1706    风城资讯站        TEL:03-5890755      24HR        28800
         39:39/1707    幸运女神资讯站    TEL:03-4651273      24HR        14400
         39:39/1708    破坏??王资讯站    TEL:03-3320091      24HR        19200
         39:39/1709    风之纺资讯站      TEL:03-3381913      24HR        14400
         39:39/1710    龙??世界资讯站    TEL:03-3337483      24HR        14400
         39:39/1711    超魔界资讯站      TEL:03-3813833    21:00-07:00   14400

新竹地区
HUB1200  39:39/1200  地球电子村交流站    TEL:035-728334      24HR        19200
         39:39/1201  紫色梦幻屋交流站    TEL:035-801886      24HR        16800
         39:39/1202    今生有约交流站    TEL:035-200946      24HR        14400
PVT<私>  39:39/1203    时空怪客交流站    TEL:035-222xxx      私人        14400
         39:39/1204    卡巴资讯交流站    TEL:037-667347      24HR        14400
         39:39/1205    魔茧资讯交流站    TEL:035-801872    19:00-03:00   16800
         39:39/1206    莲华都市交流站    TEL:037-691075      24HR        19200

花莲地区
HUB600  39:39/600     乱马资讯交流站    TEL:038-579968      24HR        28800
        39:39/601     阿达一族资讯站    TEL:038-321773      24HR        14400
        39:39/602     阿达二族资讯站    TEL:038-330498      24HR        14400
        39:39/603     阿达叁族资讯站    TEL:038-264387      24HR        14400
        39:39/604     阿达五族资讯站    TEL:038-226874      24HR        19200
        39:39/605     海涟资讯交流站    TEL:038-870533      24HR        28800
        39:39/606     星座资讯交流站    TEL:038-535777   六,日全天开放  14400
                                                         其它不开放
        39:39/607     阿达六族资讯站    TEL:038-540680      24HR        14400

台东地区
HUB1900 39:39/1900    台湾囝仔资讯站    TEL:089-227583      24HR        19200

台中地区
HUB800  39:39/800      天使资讯交流站    TEL:04-7787048      24HR        16800
        39:39/801    卧龙居资讯交流站    TEL:04-8294582      24HR        19200
        39:39/802    幸运事务所交流站    TEL:04-7271940      24HR        16800
HUB900  39:39/900  天空之城资讯交流站    TEL:04-6578210      24HR        19200
                                         TEL:04-6578211      24HR        19200
                                         TEL:04-6578071      24HR        19200
                                         TEL:04-6578072      24HR        19200
                                         TEL:04-6578073      24HR        19200
        39:39/902  毁天灭地资讯交流站    TEL:04-6321487      24HR        19200
        39:39/903      今天资讯交流站    TEL:049-251090      24HR        16800
        39:39/904    正一工作室交流站    TEL:04-2807877      24HR        14400
        39:39/905  佳兴电传资讯交流站    TEL:04-5280719      24HR        16800
HUB1400 39:39/1400   一贯道资讯交流站    TEL:04-3384895      24HR        19200
        39:39/1401   海盗船资讯交流站    TEL:04-3288509      24HR        28800
        39:39/1402   响尾蛇资讯交流站    TEL:04-2929817      24HR        14400
        39:39/1403   山与水资讯交流站    TEL:04-6319205      24HR        14400
Pvt<私> 39:39/1404     环宇资讯交流站    TEL:04-376xxxx      xxxx        14400
        39:39/1405     巨蛋资讯交流站    TEL:04-6910249      24HR        14400
        39:39/1406   诸罗山资讯交流站    TEL:05-2331264      24HR        19200
Pvt<私> 39:39/1407     学生之声交流站    TEL:04-xxxxxxx      xxxx        19200
        39:39/1408     长命百岁交流站    TEL:04-2781379      24HR        14400

台南地区
HUB1800 39:39/1800     无情荒岛有情天    TEL:06-6321555      24HR        14400

高雄地区
HUB1000 39:39/1000   欢乐屋资讯交流站    TEL:07-3164350    17:00-08:00   19200
        39:39/1001     尘封已久资讯站    TEL:07-7818588      24HR        19200

香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-6183163     24HR        28800
        39:39/701      酒井法子专门站    TEL:852-7563536     24HR        19200

台北 HOST 40
HOST40   39:40/1       遨游??鹏资讯站    TEL:02-8747279      24HR        14400
HUB100   39:40/100     遨游??鹏资讯站    TEL:02-8747279      24HR        14400
         39:40/102   坏小子资讯交流站    TEL:02-2190318      24HR        14400
         39:40/103     熊座资讯交流站    TEL:02-3776746      24HR        14400
         39:40/104     浑沌魔镜交流站    TEL:02-7668736      24HR        14400
         39:40/105     神行太保交流站    TEL:02-2362589      24HR        14400
         39:40/106   明汕寺资讯交流站    TEL:02-9690360      24HR        14400
         39:40/107   鹿鼎记资讯交流站    TEL:02-9771578      24HR        14400
         39:40/108     原始部落交流站    TEL:02-8224591    10:00-00:30   14400
PVT<私>  39:40/109   漫画俱乐部交流站    TEL:02-960xxxx      私人        16800
         39:40/110   魔法俱乐部交流站    TEL:02-9275781      24HR        14400
         39:40/111   梦幻屋资讯交流站    TEL:02-9866550      24HR        14400
         39:40/112     虹屋资讯交流站    TEL:02-9867374      24HR        14400
         39:40/113     将相世家交流站    TEL:02-6227053      24HR        14400
         39:40/114 狼之一族ＩＩ资讯站    TEL:02-7018906      24HR        19200
PVT<私>  39:40/115  Game_Design交流站    TEL:02-xxxxxxx      私人        14400
         39:40/116     疯狂超人交流站    TEL:02-3926054      24HR        16800
PVT<私>  39:40/117 彩色世界资讯交流站    TEL:02-xxxxxxx      私人        14400
         39:40/118     银河帝国交流站    TEL:02-2122986    21:00-07:00   14400
         39:40/119   加菲猫资讯交流站    TEL:02-2752743      24HR        14400
         39:40/120     彰仔资讯交流站    TEL:02-5030619      24HR        14400
         39:40/121     清风禅语交流站    TEL:02-8411352      24HR        14400
         39:40/122   邱比特资讯交流站    TEL:02-5863111      24HR        16800
         39:40/123   寻梦园资讯交流站    TEL:02-5922267      24HR        19200
         39:40/124     梦之小??交流站    TEL:02-3916175      24HR        14400
         39:40/125   百乐门资讯交流站    TEL:02-8200755      24HR        14400
         39:40/126 东方快车资讯交流站    TEL:03-3352798      24HR        14400
         39:40/127 霸王军团资讯交流站    TEL:02-8097433      24HR        19200
         39:40/128   微电子通信交流站    TEL:02-7712396      24HR        19200
HUB200   39:40/200     魔法王国交流站    TEL:02-5991763      24HR        19200
HUB300   39:40/300     欢乐肥龙资讯站    TEL:02-9161500      24HR        19200
PVT<私>  39:40/301    Navigator资讯站    TEL:02-xxxxxxx      xxxx        16800
PVT<私>  39:40/302     直到永远资讯站    TEL:02-xxxxxxx      xxxx        14400

桃园 HOST 41
HOST41   39:41/1         小地鼠工作室    TEL:03-4919307      24HR        14400
         39:41/101     百泰资讯交流站    TEL:03-4918534      24HR        14400
                                             03-4923761      24HR        14400
         39:41/102     四库资讯交流站    TEL:03-4623246    18:00-10:00   14400
PVT<私>  39:41/103     ＤＩＰ－ＩＩ站    TEL:03-XXXXXXX      私人        14400
         39:41/104   飞马座资讯交流站    TEL:03-4911960      24HR        14400
         39:41/105     龙族之星交流站    TEL:03-4900579      24HR        14400

高雄 HOST 42
        39:42/1      小魔星资讯交流站    TEL:07-6615254      24HR        28800
                                         TEL:07-6618873      24HR        16800
        39:42/100    小魔星资讯交流站    TEL:07-6615254      24HR        28800
                                         TEL:07-6618873      24HR        16800
        39:42/101      天使资讯俱乐部    TEL:07-2411911    22:00-06:00   28800
        39:42/102      梁山英雄资讯站    TEL:08-7660765      24HR        19200
        39:42/103    飞行船资讯交流站    TEL:07-7164002      24HR        14400
        39:42/104      熊猫资讯交流站    TEL:07-7911289      24HR        28800
        39:42/105      圣殿资讯交流站    TEL:07-2234372    16:00-11:00   19200
        39:42/106      似曾相识交流站    TEL:07-3808896      24HR        28800
HUB200  39:42/200      彗星资讯交流站    TEL:07-7020092      24HR        28800
------------------------------------------------------------------------------

ＨａｒｄＤｅｂｕｇ
这是目前我认为最好的一种DEBUG软体 是真实模式跟保护模式双用版本 此软体来自德国友
人所提供的 目前台湾及香港皆无此套DEBUG软体 当然像一般防GAMETOOLS OR SICE...等保
护手段皆无效 用来破解丛林战争可以说是易如反掌 五分钟内就告破解罗! 其功能超强 无
法尽述 可以说是跟 硬体除错器不相上下 可能这功能也差不多跟硬体除错器一样强 所以
才会命名为此吧!

ＴｕｒｂｏＤｅｂｕｇ
由於我没用过此套DEBUG软体 所以也无法告知其功能 不过听说吃记忆体蛮大的 所以罗!有
兴趣玩玩的朋友 可以去尝试看看。

．．．．尚有许多DEBUG软体 如 386DEBUG,SUPERDEBUG,MINIDEBUG.......等种类繁多...

破解 擂台美少女 追踪过程
C:\WA3>DEBUG WA3MAIN.EXE (450666 BYTE)
-U 4D10:A8C0
4D10:A8C0 59            POP     CX
4D10:A8C1 9A780EB333    CALL    33B3:0E78
4D10:A8C6 90            NOP
4D10:A8C7 0E            PUSH    CS
4D10:A8C8 E8C001        CALL    AA8B         <---- 密码进入点 只要将这 NOP 就可
4D10:A8CB 66            DB      66                 以免输入密码又没有输入密码画
4D10:A8CC 68            DB      68                 面
4D10:A8CD 0000          ADD     [BX+SI],AL
4D10:A8CF 0100          ADD     [BX+SI],AX
4D10:A8D1 6A            DB      6A
4D10:A8D2 009AD104      ADD     [BP+SI+04D1],BL
4D10:A8D6 872683C4      XCHG    SP,[C483]
4D10:A8DA 06            PUSH    ES
4D10:A8DB 8BF0          MOV     SI,AX
4D10:A8DD 83FEFF        CMP     SI,-01
-U 4D10:AA8B
4D10:AA8B C8            DB      C8
4D10:AA8C E80700        CALL    AA96
4D10:AA8F 56            PUSH    SI
4D10:AA90 57            PUSH    DI
4D10:AA91 1E            PUSH    DS
4D10:AA92 B8B377        MOV     AX,77B3
4D10:AA95 8ED8          MOV     DS,AX
4D10:AA97 1E            PUSH    DS
4D10:AA98 68            DB      68
4D10:AA99 D438          AAM     38
4D10:AA9B 1E            PUSH    DS
4D10:AA9C 68            DB      68
4D10:AA9D C8            DB      C8
4D10:AA9E 389A9735      CMP     [BP+SI+3597],BL
4D10:AAA2 27            DAA
4D10:AAA3 1F            POP     DS
4D10:AAA4 83C408        ADD     SP,+08
4D10:AAA7 8956FE        MOV     [BP-02],DX
4D10:AAAA 8946FC        MOV     [BP-04],AX
-U 4D10:AA96
4D10:AA96 D81E68D4              FCOMP   DWORD PTR [D468]
4D10:AA9A 381E68C8      CMP     [C868],BL
4D10:AA9E 389A9735      CMP     [BP+SI+3597],BL
4D10:AAA2 27            DAA
4D10:AAA3 1F            POP     DS
4D10:AAA4 83C408        ADD     SP,+08
4D10:AAA7 8956FE        MOV     [BP-02],DX
4D10:AAAA 8946FC        MOV     [BP-04],AX
4D10:AAAD 52            PUSH    DX
4D10:AAAE 50            PUSH    AX
4D10:AAAF 66            DB      66
4D10:AAB0 68            DB      68
4D10:AAB1 0100          ADD     [BX+SI],AX
4D10:AAB3 D007          ROL     BYTE PTR [BX],1
4D10:AAB5 16            PUSH    SS

破解 格斗拳王 追踪过程
C:\ACT>DEBUG ACT.EXE (1145 BYTE 用 UP.EXE 解压缩)
-U
2561:0000 B8AB25        MOV     AX,25AB
2561:0003 8BD8          MOV     BX,AX
2561:0005 8CC0          MOV     AX,ES
2561:0007 2BD8          SUB     BX,AX
2561:0009 B44A          MOV     AH,4A
2561:000B CD21          INT     21
2561:000D 7306          JNB     0015
2561:000F 90            NOP
2561:0010 90            NOP
2561:0011 90            NOP
2561:0012 E91103        JMP     0326
2561:0015 E83303        CALL    034B
2561:0018 B8004B        MOV     AX,4B00
2561:001B BAB800        MOV     DX,00B8
2561:001E BBC000        MOV     BX,00C0
-U
2561:0021 1E            PUSH    DS
2561:0022 07            POP     ES
2561:0023 CD21          INT     21
2561:0025 B80040        MOV     AX,4000
2561:0028 8EC0          MOV     ES,AX
2561:002A BE0000        MOV     SI,0000
2561:002D 26            ES:
2561:002E 8B04          MOV     AX,[SI]
2561:0030 3D4D54        CMP     AX,544D
2561:0033 7403          JZ      0038
2561:0035 E9EE02        JMP     0326
2561:0038 B8004B        MOV     AX,4B00
2561:003B BA4800        MOV     DX,0048
2561:003E BBC000        MOV     BX,00C0
-G23

AX=4B00  BX=00C0  CX=0279  DX=00B8  SP=0050  BP=0000  SI=0000  DI=0000
DS=2598  ES=2598  SS=25A6  CS=2561  IP=0023   NV UP EI PL NZ NA PE NC
2561:0023 CD21          INT     21    <----- 载入 密码 画面档
-U
2561:0025 B80040        MOV     AX,4000
2561:0028 8EC0          MOV     ES,AX
2561:002A BE0000        MOV     SI,0000
2561:002D 26            ES:
2561:002E 8B04          MOV     AX,[SI]
2561:0030 3D4D54        CMP     AX,544D     <---比较输入值是否跟 正确密码一样
2561:0033 7403          JZ      0038        <---若一样的话 就跳到 0038 执行GAME
2561:0035 E9EE02        JMP     0326
2561:0038 B8004B        MOV     AX,4B00
2561:003B BA4800        MOV     DX,0048
2561:003E BBC000        MOV     BX,00C0

由於这个GAME主档是ACT.EXE 况且只要一执行ACT就问密码 可见这个密码一定很好破解的
若有看过破解入门1-13集的朋友一定可以轻而易举的破掉这个密码 以前我已经举例破解过
程及一些简单的技术 相信这个一定可以简单的破解出来的 这个GAME 从破解到改码不需要
一分钟喔! 所以适合初学者学习的! 若是忘记像这类型的一开始就问密码的破解方式 我来
给您一些提示:
步骤: 1 当然先将SICE挂上罗!
      2 用SICE内附的LDR.EXE 将 ACT.EXE 载入除错
      3 若成功的话 就应该会进入SICE除错视窗 再来就用前几集中的技术就可以罗!

您只要将 2561:0023 CD21   INT  21       <----- 载入密码画面档 把他 NOP(90) 掉
  然後将 2561:0030 3D4D54 CMP  AX,544D  <---比较输入值是否跟 正确密码一样
         2561:0033 7403   JZ   0038     <---若一样的话 就跳到 0038 执行GAME
                                            把 74 改成 EB (JUMP) 不管输入是否正
                                            确都会进入GAME中就可以罗!

这样就没有输入密码的画面 是不是很棒呢? 或者单改 74 --> EB 也行啦! 不过要输入叁
次密码 若输入错误 虽然画面上会写『输入错误』但还是能进入GAME啦!

-------------------------------------------------------------------------------
後记:
     原本要全部列出 天使帝国 II 全部破解法 及 如何将主要档案从五个 SWF 档分离出
     来 但要花很多时间解说 本人实在没那麽多美国时间可以用 所以只好删掉罗! 虽然
     蛮可惜的 但也希望大家体谅本人苦衷 。

     在写这个破解入门时 总是难免会有错字 但我已经尽量将错字减到最小罗! 所以请大
     家多多包涵罗! 若有写的不对之处 敬请来信指教 或是 到本站 朋友俱乐部 一游。
     本人草创 『破解技术交流网』 垦请多多来本网写写信罗! 好让本网更加茁壮 当然
     更欢迎站长们一起加入本网行列。 申请表已在本文件内 请自个填好送到附近HUB 或
     HOST 即可。 诚心邀起您一起加入 破解技术交流网的行列...TKS!

附注: 请勿将本文件修改 请保持完整性 本人保留着作权。

作者: 俞煌男    62/08/24   Ｏ型    台湾省_宜兰县人

目前就读 国立宜兰农工二专部电子科

BBS TEL: (039)281-739
OPEN TIME: 24HR 全年无休
速率: 28800 VFC DATASYSTEM
站名: 朋友俱乐部 (破解技术交流网总站)


俞煌男破解入门教程（１５／１７）
俞煌男

             破 解 入 门 第 １５ 集        作者: Yu Hwang 破解技术交流网 总站
                                                 朋友俱乐部 TEL:039-281739
                                                 OPEN: 24 HR 28800 BPS /V34

             欢 迎 流 传   请 勿 修 改   谢 谢 !!

各位好...!
       不晓得各位的破解功力是否有再提升一些呢?? 不管如何..还是期待您有所斩获
老话一句 就是请多多练习 毕竟学会之後就再也没有人可以偷走的啦! 况且也不用再求
助别人 但还是希望您不要将破解档或破解码流出去 以免造成软体公司得不到应有的回
馈 而降低开发GAME的意愿 相信不是大家所乐意见到的。 不过话说回来 目前国内的保
护风气还是十分盛行 明知保护并不是决对可以防止盗拷风气 但还是一昧的去钻研新保
护方式以求自保。但是 道高一尺魔高一丈呀!..终究是无法逃出被破解的命运 有时候
刚发行的软体 一天内就被砍掉保护时有所闻 所以最好的方式是以软体好坏来决定销售
业绩 有很多国外的软体 像 WINDOWS,OS2.....等知名软体 也是没有任何保护 但确销售
成绩异常的好 这就是国内与国外的最大差别所在啦! 奉劝国内各软体商 最好以产品好坏
来决定销售量 并以适当的售价回馈给国人 相信国内盗拷风气就会慢慢消退了! 不过常看
到一些国内代理商去代理一些国外的软体回来後 还自行加了保护真是)($!*$# 不但价格
常比国外贵一些 又有保护增加原版使用者的不便 相信这不是一些人所愿意的 难道买原
版的人都是呆瓜吗?? 用破解版的人聪明?? 所以这是希望大家共同来体察的一个问题。

       若您想进一步学习跟高深的破解技术的话 请务必一定要熟组合语言的指令用法
及暂存器.堆叠...等观念 最好对 INT 中断都有一定程度的了解才可以 若您怕自己无法
记得那麽多的话 请一定要去购买一些书来参考 不然我也没办法让你懂那麽多呀! 当然
像一些电脑的低阶处理方式也是要去了解才行 例如:RESET 8259....等方式

       最近的破解工具蛮多的...当然也有许多新保护方式也出现了 大都针对新破解
工具而产生 所以说『保护/破解 是相辅相成的』 而且只要有电脑在的一天 相信保护
及破解 之间的战争是无法停止的 有电脑就有 保护及破解 的存在。

       其实最近的我已经很少再去破解密码了 总是觉得密码破解有点过时 况且现在
的密码保护也没有特别的方式 所以我想这麽久了 应该换一下主题了才是 所以我打算
先说一下一般软体注册的方式好了。

       一般注册有分好几种保护方式 先举一些较常遇到的保护方式:
===============================================================================

    第一种:
           输入ＩＤ＆注册码 将ＩＤ运算之後去比对您所输入的注册码
           是否跟运算後所得到的真正注册码一样
           若一样的话就是注册者(也就是合法使用者啦)
           若不一样当然就不是罗!
    第二种:
           输入软体序号 来判断是否是注册版或合法使用者
           PS:又俗称(流水号) 这样就可以查出此序号是由谁流传出去。
    第叁种:
           输入ＩＤ＆站名或公司名称＆注册码
           将ＩＤ&站名或公司名称运算之後去比对您所输入的注册码
           是否跟运算後所得到的真正注册码一样
           若一样的话就是注册者(也就是合法使用者啦)
           若不一样当然就不是罗!
    第四种:
           有些软体会去检查是否有注册档(俗称 KEY FILES) 来判断是否为
           合法使用者使用 若找到注册档的话 并会去检查是否为真正注册档
           若一切检查都正确的话 方能使用一些注册後的功能。
           像: BGFAX 1.50版,TIMED,PROBOARD,RA,FASTECHO....等就是都采用
               此方式去判断是否为真正合法使用者。
    第五种:
           没法子破解 因为大部份的注册功能都不含在试用版中 需向原作者缴费
           注册 方可拿到注册版本 像 GW (游戏巫师) 便是这种啦!

===============================================================================
          以上是一般常遇到的保护方式 当然也有一些奇奇怪怪的保护注册方式 在此
          就不再说明了。 因为也没那麽多时间再去找来研究了..所以...

              我举例破解 HJOKE.EXE 注册码破解方法给大家参考
              本程式公开破解注册过程 已取得作者本身同意罗!
              但请千万不要去修改 作者 ＩＤ 。切记 不然以後
              作者可不会在写出软体给大家分享了!

          HJOKE.CFG  线上笑话外部程式设定档    软体作者:Arthur Hse
          ;第一行请输入您的站名
          朋友俱乐部 专业站                    <---本站站名
          ;第二行请输入您的ＩＤ
          Yu Hwang                             <---本人ＩＤ
          ;第叁行请输入您的注册码
          28173900                             <---刚开始不知道注册码 所以就
          ;第四行请输入您所以产生的档案名称        先以本站电话当注册码
          C:\HJOKE\HJOKE.ANS

          先载入 S-ICE 之後

          C:\>CD HJOKE       <--- 按 ENTER 输入

          C:\HJOKE>HJOKE.EXE <--- 先按 CTRL+D 切入 S-ICE 除错画面之後
                                  输入指令BPINT 21 AH=3D 去拦开档的动作
                                  此时再下指令 BL 就可以看到如下画面:
                                  0)  BPINT 21 AH=3D C=01
                                  已经下了一个中断点罗!
                                  也就是说当程式有用到这个 INT 21 AH=3D 开档
                                  的动作时 就会产生中断啦!
                                  若上面动作都已完成的话 输入指令 G 执行

          C:\HJOKE>HJOKE.EXE <--- 也是会停到这个画面 按 ENTER 执行罗!

          就当按下 ENTER 之後..您应可发现 此时应该是产生中断 跳到S-ICE的除错画
          面 应可看到如下画面:
                              MOV AH,3D
                              INT 21   ;open a file    <--- 此时光棒停在这行

          再输入指令 E DS:DX 就可以看到 目前正开启的档案名称应该是 HJOKE.CFG

          再输入指令 S DS:0 L FFFF "28173900"  <--- 目的是为了在记忆体中找寻
                                                    我们刚刚所乱填的注册码的
                                                    位址。
                                                    应可找到在 DS:FEF0 的位址
                                                    如下图所示:
-D DS:FEF0
1D6C:FEF0  00 00 00 00 32 38 31 37-33 39 30 30 00 4A 4F 4B   ....28173900.JOK
1D6C:FF00  45 2E 43 46 47 00 00 00-00 00 00 00 00 00 00 00   E.CFG...........
1D6C:FF10  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
1D6C:FF20  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
1D6C:FF30  00 00 00 00 00 00 00 00-00 00 00 00 2E 38 30 0A   .............80.
1D6C:FF40  00 C1 AB E1 A5 4C A7 E2-A5 5D B8 CB A6 6E AA BA   .....L...]...n..
1D6C:FF50  A5 D6 BE 63 B0 65 A8 EC-B3 6F A6 EC A4 70 A9 6A   ...c.e...o...p.j
1D6C:FF60  AA BA A4 E2 A4 A4 A1 43-00 00 00 DC A1 48 A1 7A   .......C.....H.z

          再输入指令 BC 0    <--- 清除原先设定的中断点 BPINT 21 AH=3D
                                  因为我们已找到注册码所存放的记忆体位址啦!
                                  所以这个中断已不需要罗!

          再输入指令 BPM DS:FEF0  <---这行指令就是 当程式有去读取 DS:FEF0 的位
                                      址时 就发生中断罗! 也就是程式去动到注册
                                      码的位址。

          下好中断之後 我们再按 G 执行吧!
          此时会产生中断 如下图所示:

          CMP AL,[DI+01AD]          DS:01AD=00   <--- 此时光棒会停在此行
          JNZ 0362      <--- 比较注册码是否正确 若不正确就跳到 0362 去执行

          再下指令到 E DS:01AD 去看记忆体状况 往前找找就可以看到如下画面:

-D DS:0194
1D6C:0194              42 36 38 44-31 36 33 34 00 42 31 45     ..B68D1634.B1E
1D6C:01A0  39 33 43 34 37 44 32 46-36 30 38 41 35 00 31 32   93C47D2F608A5.12
1D6C:01B0  33 34 35 36 37 38 39 41-42 43 44 45 46 00 00 0A   3456789ABCDEF...
1D6C:01C0  00 0B 00 06 00 08 00 00-00 05 00 0E 00 0D 00 07   ................
1D6C:01D0  00 03 00 02 00 04 00 09-00 01 00 0C 00 08 00 06   ................
1D6C:01E0  00 00 00 0A 00 05 00 0F-00 0B 00 03 00 0C 00 07   ................
1D6C:01F0  00 02 00 0D 00 04 00 0E-00 09 00 01 00 06 00 01   ................
1D6C:0200  00 0A 00 00 00 0D 00 07-00 04 00 02 00 0E 00 0C   ................
1D6C:0210  00 09                                             ..

          看到了没呀! B68D1634 这就是真正注册码罗! 赶快抄起来吧!
          PS:因为每个人的ＩＤ会不一样 所以注册码当然都会不一样罗!
             所以你不用担心。

          您此时可以将注册码填到 HJOKE.CFG 的注册码栏试试 再执行一次看看
          哇哈!..由原本的 [未注册版本] 已改为 [已注册版本] 罗! 帅不帅呀!
          当然你也可以将 JNZ 0362 的地方改为 NOP 90 也是可以达到相同效果。
          最後再为我赞美一下吧!....嘻!

===============================================================================

          再举例一个破解范例给大家参考吧!
          底下是 蓝波快信 3.06 版 (架站用) 的设定画面
          就是执行 BWSETUP.EXE

???????? The Blue Wave Mail Door Setup Utility, v3.06 for ProBoard v2.10 ??????�
卤控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控捱
卤族阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐� General Information 醴控捱
卤掖 BBS Name:                                                             阴控�
卤掖 朋友俱乐部 专业站                                                     阴控�
卤掖 Your REAL Name (never seen by users) : Yu Hwang                       阴控�
卤掖 Name as SysOp (displayed to users)   : Yu Hwang                       阴控�
卤掖 Name of mail packets created by door : FRIEND                         阴控�
卤掖 Blue Wave Door Registration Number   : 281739                         阴控�
卤掖 阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐� 阴控�
卤掖 Default Network Address Information:                                  阴控�
卤掖 Zone: 39    Net: 39     Node: 1     Point: 0                          阴控�
卤掖 Origin: 朋友俱乐部专业站,24HR,28.8K,5GB,039-281739                    阴控�
卤掖 阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐阐� 阴控�
卤掖 Files displayed to the user when entering the READER:                 阴控�
卤掖           Filename      SecLvl    Flags                               阴控�
卤掖 File #1 :                    0        阴控�
卤掖 File #2 :                    0        阴控�
卤掖 File #3 :                    0        阴控�
卤掖 File #4 :                    0        阴控�
卤掖 File #5 :                    0        阴控�
卤推阐阐阐阐阐阐� Press F10 to save changes, or 'ESC' to abort. 阐阐阐阐阐嗫控捱
卤控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控捱
卤控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控捱
???????????????? Copyright (C) 1992-1995 by Cutting Edge Computing ????????????�

   Blue Wave Door Registration Number   : 281739    <--- 这个就是我刚开始随便
                                                         输入的注册码啦!

   我们延用上面的破解方式去试试看罗! PS:因此软体是架站用的 所以罗! 步骤如下:

   1. 先载入 S-ICE
   2. 跑 BBS 系统 ( LOCAL MODE )
   3. 跑外部 蓝波快信
   4. 切入 S-ICE 中 ( CTRL+D )
   5. 下指令 BPINT 21 AH=3D ( 拦开档动作 )
   6. 搜询记忆体中 存放注册码的位址 应该是 DS:84ED 这个位址 是存放注册码
   7. 下指令中断 BPM 5464:84ED  ( PS: 因我找到的记忆体位址是 5464:84ED )
   8. 下指令 BC 0 解除 拦开档中断
   9. 执行罗! 按 G ( 此时可以先下 E 5464:84ED 去观看 注册码 位址 )
   A. 执行了叁次中断後 应可看到以下画面:

         22AB:62DF  AC        LODSB                  ┐这些是用来读取注册码
         22AB:62E0  268A1D    MOV        BL,ES:[DI]  │当读到注册码的位址为
         22AB:62E3  0AC0      OR         AL,AL       │"00"时 就表示 已全部
         22AB:62E5  741C      JZ         6303        │读取完毕。此时就会跳
         22AB:62E7  AE        SCASB                  │跃 JZ 6303这个位址中
         22AB:62E8  74F5      JZ         62DF        ┘了!
         22AB:62EA  3AC5      CMP        AL,CH
         22AB:62EC  7206      JB         62F4

         22AB:6303  2BC3      SUB        AX,BX
         22AB:6305  8EDA      MOV        DS,DX
         22AB:6307  5F        POP        DI
         22AB:6308  5E        POP        SI
         22AB:6309  5D        POP        BP
         22AB:630A  CB        RETF                   <--- 追到此行就返回主程式

         443A:021D 9ACA62AB00 CALL       22AB:62CA   <--- 注册码读取副程式
         443A:0222 83C408     ADD        SP,+08
         443A:0225 0BC0       OR         AX,AX
         443A:0227 7505       JNZ        022E        <--- 若不是真正注册码就跳
                                                          到 002E
         443A:0229 B80100     MOV        AX,0001
         443A:022C EB02       JMP        0230
         443A:022E 33C0       XOR        AX,AX

         这样就破解啦!...简单吧! 只要将 JNZ 022E 改成 NOP NOP 或是 JNZ 0229

         7505 --> 90 90
         7505 --> 75 00
         就可以罗! 从此之後就是 注册版了耶!....高兴吗?? 来点掌声吧! 您看的是很
         轻松 但我可是打的要死又要引的老半天才能完成的耶! 所以有空来破解网中的
         破解技术讨论区 写信给 ID: Yu Hwang   我就可以了 鼓励一下吧!
         若要算注册码的话 请於 ( 底下说明 )

         626B:4DD6 是存放真正注册码之地方 也就是 SS:SP 所指的位址就是罗!
         抄起来重跑一次看看就知道罗!...嘻! 成功罗! 这样会破了吧!

===============================================================================

         大部份的注册软体都可以采用上面方式去破解就可以罗! 若您还是不懂的话
         请要检讨自己了 这就不是我可以帮你啦! 毕竟 『给鱼吃 只能饱餐一顿 请靠
         自己去学习 一技之长』。

         原本打算引出 序号&KEY FILES 软体破解法 若您有了解上面的技巧的话 那相信
         一定难不倒您了 毕竟我也只能尽量抽空写出来分享给大家 况且我写这个『破解
         入门 1-15 集』是为了谁?? 我又得到些什麽?? 所以罗!...只要我有空闲的话
         我会尽量引出破解过程给大家知道 但由於这又牵涉到一些『智慧财产权』等问
         题 所以写出来更会提心吊胆 这点希望大家能知道 并不是全部软体都能这样公
         开讨论破解过程及细节 。 若您有任何建议或技术方面的交流 可以到作者所创
         立的『破解技术交流网』写信给 ID:Yu Hwang 就可以罗! 若您不知道哪些站有
         接破解网的话 请参考如下:

         欢迎有空来本站逛逛 朋友俱乐部 TEL:039-281739 24HR 28800 BPS
         若您是站长的话本人欢迎有兴趣的站长加入 破解技术交流网 的行列。 若您是
         User的话 请赶紧叫您站长快去申请破解技术交流网吧! 不然您可就要落伍啦!!

         PS: 本网成立至今约有 １～２年的历史啦! 希望各位有空不妨到破解网写写信
             当然破解网还需要靠各位 站长&USER 多多支持及鼓励 才会更加茁壮。

 破解技术交流网      加 入 站 名 列 表   站  台  电  话    开放时间    速   率
------------------------------------------------------------------------------
宜兰地区
HOST总站 39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        28800
HUB 100  39:39/100     朋友俱乐部总站    TEL:039-281739      24HR        28800
         39:39/101     天使资讯交流站    TEL:038-563037      24HR        28800
         39:39/102     神鹰资讯交流站    TEL:089-810467      24HR        16800
PVT<私>  39:39/108     1024资讯工作坊    TEL:039-xxxxxx      xxxx        14400
         39:39/111     懒窝一站资讯站    TEL:02-7651639      24HR        28800
PVT<私>  39:39/112     战警游龙资讯站    TEL:039-xxxxxx      xxxx        19200
         39:39/114     魔力交流资讯站    TEL:02-3456302      24HR        28800
         39:39/115     飞侠阿达资讯站    TEL:039-568200      24HR        14400

台北地区
HUB200   39:39/200    Jay's BBS交流站    TEL:02-8962836      24HR        28800
         39:39/201     虹屋资讯交流站    TEL:02-9867374      24HR        14400
PVT<私>  39:39/202     超帅型交流站      TEL:02-702xxxx      私人        14400
         39:39/203     梦??小??资讯站    TEL:02-3916175    08:00-24:00   14400
         39:39/204     叮当资讯交流站    TEL:02-2512974      24HR        16800
         39:39/205       幻??鹰交流站    TEL:02-9833779      24HR        19200
         39:39/206     星际航舰交流站    TEL:02-2300107      24HR        19200
         39:39/208     颠峰资讯交流站    TEL:02-2157304      24HR        14400
         39:39/209     幻境资讯交流站    TEL:02-6222302      24HR        14400
         39:39/210       伟佳电传中心    TEL:02-9364372    18:00-23:30   16800
         39:39/211     超龙战士资讯站    TEL:02-2460122      24HR        14400
         39:39/213     堡哥资讯交流站    TEL:02-7124924      24HR        14400
         39:39/214     穿越时空交流站    TEL:02-6883301    17:00-07:00   28800
         39:39/215       侠客居交流站    TEL:02-9821296      24HR        28800
         39:39/216     森林之家资讯站    TEL:02-9031685    18:00-07:00   14400
         39:39/218       复活岛资讯站    TEL:02-6780526    19:00-24:00   19200

HUB 500  39:39/500 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/501 龙飞凤舞资讯交流站    TEL:02-6956076      24HR        14400
         39:39/502     熊之家族资讯站    TEL:02-7789541      24HR        19200
         39:39/503         未来资讯网    TEL:02-7884166      24HR        28800
         39:39/504   幻??谷资讯交流网    TEL:02-7827815      24HR        14400
         39:39/505         多多资讯站    TEL:02-xxxxxxx      私人        14400
         39:39/506         Hidden BBS    TEL:02-xxxxxxx      私人        14400
         39:39/507       轻松摇摆 BBS    TEL:02-2174675      24HR        28800
         39:39/508           柔情世界    TEL:02-6522060      24HR        14400
         39:39/509   亲亲我的宝贝 BBS    TEL:02-7615481      24HR        14400
         39:39/510             钓鱼人    TEL:02-xxxxxxx      私人        16800
         39:39/511       欢乐天地 BBS    TEL:02-6700461      24HR        28800
         39:39/512         颓废工作室    TEL:02-xxxxxxx      私人        14400
         39:39/513     肥窝超级资讯站    TEL:02-2450139      24HR        14400
         39:39/514     钟爱一生资讯站    TEL:02-9459135      24HR        14400
         39:39/515           KISS BBS    TEL:02-9867738      24HR        28800
         39:39/516       个性资讯广场    TEL:02-7849624      24HR        14400
         39:39/517           ９8 工程    TEL:02-9412155      24HR        14400
         39:39/518 伊奥勒斯资讯交流站    TEL:02-8930123      24HR        14400
         39:39/519   法兰克陈威力 BBS    TEL:02-xxxxxxx      私人        19200
         39:39/520           忆文晓??    TEL:02-9117594      24HR        14400
         39:39/521     甜蜜宝贝资讯站    TEL:02-6739047      24HR        28800
         39:39/522           VEGA BBS    TEL:02-3096444      24HR        14400
         39:39/523     浪漫一生资讯站    TEL:02-3375620      24HR        14400
         39:39/524         小茜资讯站    TEL:02-9756749      24HR        14400
         39:39/525     城市之鹰资讯站    TEL:02-6251118      24HR        28800

HUB2100  39:39/2100    酒国英雄资讯站    TEL:02-2961696      24HR        19200
PVT<私>  39:39/2101        飞翔??传说    TEL:02-xxxxxx       xxxx        14400
         39:39/2102      模型资讯广场    TEL:02-3657965      24HR        16800
         39:39/2103        龙虎资讯站    TEL:02-9586280      24HR        28800
         39:39/2104      另一个资讯站    TEL:02-4552421      24HR        28800
         39:39/2105    织梦空间资讯站    TEL:02-9940364      24HR        14400
         39:39/2107    ９８工程资讯站    TEL:02-9412155      24HR        14400

HUB1300  39:39/1300     IMAGINATION站    TEL:02-9124125      24HR        14400

新竹地区
HUB1200  39:39/1200  地球电子村交流站    TEL:035-728334      24HR        19200
         39:39/1201  紫色梦幻屋交流站    TEL:035-801886      24HR        16800
         39:39/1202    今生有约交流站    TEL:035-200946      24HR        14400
PVT<私>  39:39/1203  隐流小磨坊交流站    TEL:035-xxxxxx      私人        14400
         39:39/1204    卡巴资讯交流站    TEL:037-667347      24HR        28800
         39:39/1205    魔茧资讯交流站    TEL:035-801872    19:00-03:00   16800
         39:39/1206    莲华都市交流站    TEL:037-691075      24HR        19200
         39:39/1207      Bliss 交流站    TEL:035-339884    24:00-06:00   19200
         39:39/1208    PLAY BBS交流站    TEL:035-590526      24HR        28800
         39:39/1209    橘子王国资讯站    TEL:03-5785751      24HR        14400
         39:39/1210    幸运龙资讯站      TEL:035-599899      24HR        14400
         39:39/1211    大华工管资讯站    TEL:035-941233      24HR        28800
         39:39/1212        魔法修道院    TEL:035-903508      24HR        14400
         39:39/1213        祥云资讯站    TEL:035-424664      24HR        14400

花莲地区
HUB600   39:39/600     咖啡小店资讯站    TEL:038-321637      24HR        14400
         39:39/601     乱马1/2 资讯站    TEL:038-579968      24HR        28800
         39:39/602     良牙资讯交流站    TEL:038-534028      24HR        28800
         39:39/603     晴岚资讯交流站    TEL:038-540479      24HR        28800

HUB1100 39:39/1100    彩虹之梦交流站     TEL:038-571651      24HR        19200
HUB1500 39:39/1500      阿达一族总站     TEL:038-321773      24HR        28800
                                         TEL:038-360092      24HR        28800

台中地区
HUB800  39:39/800      天使资讯交流站    TEL:04-7787048      24HR        16800
        39:39/803    呆呆熊资讯交流站    TEL:04-8298434      24HR        28800
        39:39/804    Jadeite   交流站    TEL:04-8360023      24HR        14400
        39:39/805    好朋友资讯交流站    TEL:04-7276819      24HR        19200
HUB1400 39:39/1400   一贯道资讯交流站    TEL:04-3384895      24HR        19200
        39:39/1403   山与水资讯交流站    TEL:04-6319205      24HR        14400
        39:39/1404     新友电传资讯站    TEL:04-2349119      24HR        14400
        39:39/1405     青雯资讯交流站    TEL:04-6328161      24HR        14400
        39:39/1406     凯文资讯交流站    TEL:04-xxxxxxx      私人        14400
        39:39/1407     龙族资讯交流站    TEL:04-6317251      24HR        14400
        39:39/1408     长命百岁交流站    TEL:04-2958185      24HR        14400
        39:39/1409     毁天灭地情报站    TEL:04-6321487      24HR        14400

南投地区
HUB2000 39:39/2000     水的传说资讯站    TEL:049-452749      24HR        28800
        39:39/2001     今天资讯交流站    TEL:049-251090      24HR        14400
        39:39/2002     财神资讯交流站    TEL:049-655079      24HR        14400
        39:39/2003       迪士尼资讯站    TEL:049-910020      24HR        19200

嘉义地区
HUB1600 39:39/1600     今生有约资讯站    TEL:05-5849839      24HR        14400

台南地区
HUB1800 39:39/1800     无情荒岛有情天    TEL:06-6321555      24HR        19200
                                         TEL:06-6350021      24HR        14400
        39:39/1801       北极星资讯站    TEL:06-6564520      24HR        14400
        39:39/1802     老虎资讯交流站    TEL:06-2755159      24HR        16800
                                             06-2371284      24HR        16800
                                             06-2373015      24HR        16800
        39:39/1803     智泉资讯交流站    TEL:06-2345688      24HR        28800
        39:39/1805     太极联盟交流站    TEL:06-7820362      24HR        28800
PVT<私> 39:39/1806     乌龙工作室        TEL:06-XXXXXXX      XXXX        14400

香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-6183163     24HR        28800
        39:39/701      酒井法子专门站    TEL:852-7563536     24HR        19200

台北 HOST 40
HOST40   39:40/1       遨游??鹏资讯站    TEL:02-8747279      24HR        14400
HUB100   39:40/100     遨游??鹏资讯站    TEL:02-8747279      24HR        14400
         39:40/102   坏小子资讯交流站    TEL:02-2190318      24HR        14400
         39:40/103     熊座资讯交流站    TEL:02-3776746      24HR        14400
         39:40/109   漫画俱乐部交流站    TEL:02-9601633      24HR        16800
         39:40/110         魔法俱乐部    TEL:02-9275781      24HR        19200
         39:40/111   梦幻屋资讯交流站    TEL:02-9866550      24HR        14400
         39:40/112     虹屋资讯交流站    TEL:02-9867374      24HR        14400
         39:40/113     将相世家交流站    TEL:02-6227053      24HR        14400
         39:40/116     疯狂超人交流站    TEL:02-3926054      24HR        16800
PVT<私>  39:40/117 彩色世界资讯交流站    TEL:02-xxxxxxx      xxxx        14400
         39:40/118     银河帝国交流站    TEL:02-2122986    21:00-07:00   14400
         39:40/119   加菲猫资讯交流站    TEL:02-2752743      24HR        14400
         39:40/120     彰仔资讯交流站    TEL:02-5030619      24HR        14400
         39:40/121     清风禅语交流站    TEL:02-8411352      24HR        14400
         39:40/122   邱比特资讯交流站    TEL:02-5863111      24HR        16800
         39:40/125   百乐门资讯交流站    TEL:02-8200755      24HR        28800
         39:40/126 东方快车资讯交流站    TEL:03-3352798      24HR        14400
         39:40/127 霸王军团资讯交流站    TEL:02-8097433      24HR        19200
PVT<私>  39:40/128   微电子通信交流站    TEL:02-xxxxxxx      xxxx        19200
         39:40/129   皇家骑士团交流站    TEL:02-9877552      24HR        14400
PVT<私>  39:40/132     未来城市交流站    TEL:02-xxxxxxx      xxxx        19200
         39:40/133     幕府将军交流站    TEL:02-2316192      24HR        14400
         39:40/135     小马资讯交流站    TEL:02-6426462      24HR        19200
         39:40/136     悍卫雄鹰资讯站    TEL:02-9560533      24HR        19200
         39:40/137         ＧREEN BBS    TEL:02-7236730      24HR        19200
         39:40/138         提督??决断    TEL:02-4295957      24HR        14400
HUB200   39:40/200     魔法王国交流站    TEL:02-5991763      24HR        19200
HUB300   39:40/300     欢乐肥龙资讯站    TEL:02-9161500      24HR        19200
PVT<私>  39:40/301    Navigator资讯站    TEL:02-xxxxxxx      xxxx        16800
PVT<私>  39:40/302     直到永远资讯站    TEL:02-xxxxxxx      xxxx        14400
PVT<私>  39:40/303    破裂??人偶 II站    TEL:02-xxxxxxx      xxxx        16800
         39:40/304     皮皮电传资讯站    TEL:02-9186282      24HR        14400
PVT<私>  39:40/305     机器战警资讯站    TEL:02-xxxxxxx      xxxx        14400
         39:40/306   东部人资讯交流站    TEL:02-9354278      24HR        19200
         39:40/307   Tank World交流站    TEL:02-8969916      24HR        14400
         39:40/308     人偶资讯交流站    TEL:02-3320641      24HR        28800
         39:40/309   邱比特II电传中心    TEL:02-9450875      24HR        14400
PVT<私>  39:40/310     银河英雄资讯站    TEL:02-xxxxxxx      xxxx        14400
PVT<私>  39:40/311     第八访客资讯站    TEL:02-xxxxxxx      xxxx        14400
         39:40/312       ＧＵＳ俱乐部    TEL:02-7625418      24HR        14400
         39:39/313   超时空资讯交流站    TEL:02-8752787      24HR        28800
         39:39/314 狼??传说一站交流站    TEL:02-9978405      24HR        16800
私  39:40/315           鸭子的店    TEL:02-XXX-XXXX     xxxx        14400
         39:40/316           游戏天使    TEL:02-2838275      24HR        14400
         39:40/317         枪神资讯站    TEL:02-8476072      24HR        28800
         39:40/318         几何资讯站    TEL:02-9209690   18:00-24:00    14400
         39:40/319           Algo BBS    TEL:02-2015231      24HR        16800
         39:40/320           有趣男孩    TEL:02-4933905   22:00-08:00    28800
         39:40/322   创世纪资讯交流站    TEL:02-8161334       24HR       28800
         39:40/323     色情酒店资讯站    TEL:02-7414711      24HR        19200
         39:40/324       阿拉丁资讯站    TEL:02-7882498      24HR        19200
私  39:40/325           家资讯站    TEL:02-xxxxxxx      xxxx        19200
         39:40/326     梦幻音乐盒叁站    TEL:02-2362554      24HR        28800
HUB400   39:40/400     欢乐肥龙第七站    TEL:02-5237019      24HR        28800
                                             02-5678505      24HR        28800

高雄 HOST 42
        39:42/0        小魔星资讯站      TEL:07-6615254    24HR        28800
                                         TEL:07-6618873    24HR        28800
        39:42/100      小魔星资讯站      TEL:07-6615254    24HR        28800
                                         TEL:07-6618873    24HR        28800
        39:42/101      天使资讯俱乐部    TEL:07-7824827  23:00-10:00   14400
        39:42/102      梁山英雄资讯站    TEL:08-7660765    24HR        19200
        39:42/104      熊猫资讯交流站    TEL:07-7911289    24HR        28800
        39:42/105      圣殿资讯交流站    TEL:07-2234372  16:00-11:00   19200
        39:42/106      似曾相识交流站    TEL:07-3808896    24HR        28800
        39:42/107      职棒天地资讯站    TEL:08-7223622    24HR        14400
        39:42/109      新新人类          TEL:07-6432177    24HR        14400
        39:42/110      城市风情资讯站    TEL:07-7461129    24HR        19200
                                         TEL:07-7400225    24HR        19200
                                         TEL:07-7432163    24HR        19200
        39:42/111      北极星专业站台    TEL:07-5884530    24HR        28800
                                         TEL:07-3927025    24HR        28800
        39:42/112      创星资讯站        TEL:07-7170650  06:00-24:00   14400
        39:42/113      寻梦??星          TEL:07-3920787    24HR        16800
        39:42/116 G2001超纪元联合资讯中心TEL:07-2267827    24HR        16800
        39:42/117      飞鸟资讯交流站    TEL:07-3650870    24HR        14400
        39:42/118      德华有情资讯站    TEL:07-6437024    24HR        14400
        39:42/119      蓝色狂想          TEL:07-3330040    24HR        19200
        39:42/120      天下布武          TEL:07-3612312    24HR        28800
        39:42/121      天长地久          TEL:07-6423406    24HR        19200
        39:42/124      佛??门资讯交流站  TEL:07-6437094    24HR        28800
        39:42/125      勾引撒旦          TEL:不公开                    14400
        39:42/126      KISS_66.6_资讯站  TEL:07-3951972    24HR        14400
HUB 300 39:42/300      天使之俱乐部      TEL:07-3424649    24HR        16800
        39:42/302      烽火台资讯交流站  TEL:07-3847640    24HR        28800
HUB 400 39:42/400      天才园地资讯站    TEL:07-2267953    24HR        19200
        39:42/401      梦幻仙境资讯站    TEL:07-3855992  22:00-10:00   28800
HUB 500 39:42/500      神恩者_梦之国度   TEL:07-6563988    24HR        19200
                                         TEL:07-6564034    24HR        28800
                                         TEL:07-6564139    24HR        28800
                                         TEL:07-6561302    24HR        19200
        39:42/501      城市资讯站        TEL:07-7514558    24HR        14400
        39:42/502      流浪者资讯站      TEL:07-7130331    24HR        14400
        39:42/503      天使之翼          TEL:不公开                    14400
        39:42/504      美神令子          TEL:07-8117879    24HR        19200

屏东地区
HUB 200 39:42/200      慧星资讯交流站    TEL:08-7020092    24HR        28800
        39:42/201      拓荒者俱乐部      TEL:08-7235479  22:00-10:00   14400
        39:42/202      淘气阿丹资讯站    TEL:08-7521865    24hr        14400
        39:42/203      心情故事资讯站    TEL:08-7072249    24HR        14400
        39:42/204      卫斯理资讯站      TEL:08-XXXXXXX    私人站       2400
        39:42/205      神通情人梦        TEL:08-7384676    24HR        14400
HUB 700 39:42/700      琉璃仙境资讯站    TEL:08-7786070    24HR        28800

美国旧金山 HOST 43
         39:43/0      狼族资讯专业站  TEL:002-415-3426108   16:00-07:00   28800

桃园地区 HOST 300
Host300  39:300/0       百战天龙资讯站    TEL:03-4578836      24HR        28800
Hub 100  39:300/100     百战天龙资讯站    TEL:03-4578836      24HR        28800
         39:300/101     梦幻城市６１９    TEL:03-4507806      24HR        19200
         39:300/102     巧翊商业资讯站    TEL:03-3507952      24HR        14400
Pvt<私>  39:300/103     BREEZE  资讯站    TEL:03-XXXXXXX      私人        19200
         39:300/104     神行太保资讯站    TEL:03-3797802      24HR        19200
         39:300/105     风城资讯站        TEL:03-5890755      24HR        28800
         39:300/106     幸运女神资讯站    TEL:03-4651273      24HR        14400
         39:300/107     风之纺资讯站      TEL:03-3381913      24HR        14400
         39:300/108     龙??世界资讯站    TEL:03-3337483      24HR        28800
         39:300/109     耀之龙资讯站      TEL:03-4987335      24HR        19200
         39:300/110     内山之音资讯站    TEL:03-3907331    18:00-07:00   19200
         39:300/111     大  山资讯站      TEL:03-4628269      24HR        19200
         39:300/112     风城资讯II站      TEL:03-5892684      24HR        28800
         39:300/113     星际总部资讯站    TEL:03-3288961      24HR        28800
         39:300/113     星际总部资讯站    TEL:03-3288962      24HR        28800
         39:300/114     ＤＩＹ资 讯 站    TEL:03-3672894      24HR        19200
         39:300/115     巨蛋资讯站        TEL:04-6910249      24HR        28800
Hub 200  39:300/200     电玩小子总站      TEL:03-3353482      24HR        28800
         39:300/201     电玩小子总站      TEL:03-3353482      24HR        28800
         39:300/202     东京帝国资讯站    TEL:03-4637170      24HR        19200
         39:300/203     狂野之城资讯站    TEL:03-4556375      24HR        14400
Pvt<私>  39:300/204     不倒翁交流站      TEL:03-XXXXXXX      私人        19200
Hub 300  39:300/300     飙信小子专业站    TEL:03-4500312      24HR        14400
         39:300/301     飙信小子专业站    TEL:03-4500312      24HR        14400
Hub 400  39:300/400     飞马座工作室      TEL:03-4911960      24HR        14400
         39:300/401     飞马座工作室      TEL:03-4911960      24HR        14400
         39:300/402     梦幻大师资讯站    TEL:03-3656250      24HR        14400
         39:300/403     卡萨布兰加        TEL:03-3325352      24HR        28800
         39:300/404     异域资讯站        TEL:03-3254895      24HR        14400
         39:300/405     龙族之星          TEL:03-4900579      24HR        28800
         39:300/406     射手座工作室      TEL:03-3222884     19-06        14400
Hub 500  39:300/501     超魔界资讯站      TEL:03-3816343      24HR        28800
         39:300/501     超魔界资讯站      TEL:03-3816343      24HR        28800
         39:300/502     苹婆树下资讯站    TEL:04-3111283      24HR        28800
         39:300/505     软体屋资讯站      TEL:04-6980469      24HR        28800
                                          TEL:04-6995173      24HR        28800
         39:300/506     黄玫瑰资讯站      TEL:04-3609928      24HR        28800
                                          TEL:04-3605290      24HR        28800
                                          TEL:04-3604291      24HR        28800
         39:300/507     流浪天使资讯站    TEL:03-3642762      24HR        19200
                                          TEL:03-3639755      24HR        28800

彰化地区 HOST 44
HOST44  39:44/0       THE SOUND资讯站    TEL:04-7234264      24HR        19200
HUB100  39:44/101     THE SOUND资讯站    TEL:04-7234264      24HR        19200
        39:44/102      亚磬文化资讯站    TEL:04-6994915    23:00-07:00   14400
        39:44/103       漫画俱乐部_２    TEL:04-7284703      24HR        28800
HUB200  39:44/200        交流道资讯站    TEL:04-7617195      24HR        19200
        39:44/201        交流道资讯站    TEL:04-7617195      24HR        19200
        39:44/202          漫画俱乐部    TEL:04-7274591      24HR        19200
        39:44/203      山林小径资讯站    TEL:04-7254342      24HR        19200
        39:44/204      寂寞狼人资讯站    TEL:04-8833850      24HR        19200
        39:44/205    琉璃仙境资讯广场    TEL:04-8685663      24HR        19200
        39:44/206      宙斯资讯交流站    TEL:05-2378895      24HR        19200
HUB300  39:44/300        １６８资讯站    TEL:04-8951705      24HR        28800
        39:44/301        １６８资讯站    TEL:04-8951705      24HR        28800
        39:44/302        曼斐斯资讯站    TEL:04-8317190      24HR        28800
HUB400  39:44/400        好朋友资讯站    TEL:04-7276819      24HR        19200
        39:44/401        好朋友资讯站    TEL:04-7276819      24HR        19200
        39:44/402          肥龙资讯站    TEL:04-8725066      24HR        19200
        39:44/403          福气资讯站    TEL:04-8361003      24HR        19200
        39:44/404          爱的资讯站    TEL:05-5325431      24HR        14400
        39:44/405          ZOOM工作室    TEL:04-7871027      24HR        28800
HUB500  39:44/500            直拨卫星    TEL:04-7249128      24HR        19200
        39:44/501            直拨卫星    TEL:04-7249128      24HR        19200

台北地区 HOST45
HOST45   39:45/0     时代资讯交流广场    TEL:02-6251649      24HR        28800
         39:45/1     时代资讯交流广场    TEL:02-6204678      24HR        28800
         39:45/6     游侠俱乐部          TEL:02-9975594      24HR        19200
HUB100   39:45/100   时代资讯交流广场    TEL:02-6251649      24HR        28800
         39:45/101   时代资讯交流广场    TEL:02-6204678      24HR        28800
HUB600   39:45/600   褐雨燕资讯站        TEL:02-9217661      24HR        19200
         39:45/601   资讯叛客            TEL:02-8271366   20:00-06:00    14400
         39:45/602   巅峰资讯站          TEL:02-2157304      24HR        14400
         39:45/603   蓝色行星号          TEL:02-6780104      24HR        28800
         39:45/604   福尔摩沙资讯站      TEL:02-927-8823     24HR        14400
         39:45/605   万岁资讯交流站      TEL:02-822-6330     24HR        28800
         39:45/606   辅大电研社          TEL:02-902-1436     24HR        19200
         39:45/607   城市荒人音乐站      TEL:02-799-4464     24HR        28800
         39:45/608   芬妮资讯站台        TEL:02-732-6509     24HR        28800

台南地区 HOST 46
HOST46   39:46/0    为爱先锋资讯交流站    TEL:06-2913772      24HR        28800
HUB100   39:46/100  为爱先锋资讯交流站    TEL:06-2923888      24HR        14400
         39:46/101  为爱先锋资讯交流站    TEL:06-2923721      24HR        14400
         39:46/102  为爱先锋资讯交流站    TEL:06-2923722      24HR        28800
         39:46/103  蝙蝠资讯站            TEL:06-2726816      24HR        28800
         39:46/104  安平港了望台          TEL:06-2975159      24HR        28800
         39:46/105  快乐天堂资讯站        TEL:06-6355590      24HR        28800
         39:46/106  威力商业资讯站        TEL:06-6331258      24HR        28800
         39:46/107  福尔摩莎资讯站        TEL:06-2256836      24HR        28800
Pvt      39:46/108  猪宝宝个人资讯坊      TEL:06-XXXXXXX      私人        14400
Pvt      39:46/109  志明个人资讯工作室    TEL:06-XXXXXXX      私人        28800
Pvt      39:46/110  鼠窝个人资讯室        TEL:06-XXXXXXX      私人        14400
         39:46/112  红猪资讯站            TEL:06-2464447      24H         28800
Pvt      39:46/113  湘北资讯站            TEL:06-XXXXXXX      私人        14400
Hub200   39:46/200  咖啡资讯站            TEL:06-2893841      24HR        28800
         39:46/201  咖啡资讯站            TEL:06-2893841      24HR        28800
         39:46/204  虎克资讯站            TEL:06-2609800      24HR        28800
         39:46/205  龙龙资讯站            TEL:06-2722870      24HR        28800
Hub300   39:46/300  南台湾转信站          TEL:06-2907528      24HR        28800
         39:46/301  南台湾转信站          TEL:06-2907528      24HR        28800
Hub600   39:46/600  迪伦的店              TEL:06-2746230      24HR        28800
         39:46/601  迪伦的店              TEL:06-2746230      24HR        28800

==============================================================================

若您有兴趣加入 破解技术交流网 请填妥以下申请资料 并丢到附近的 Host Or Hub 即可

 破解技术交流网  申请表格:

 站台<英文名称>:
 站台<中文名称>:
 系统操作员:
 建站系统:
 家中地址:
 是<私人站>或<公开站>:
 开站时间:
 最高速率:
 站台电话:
 家中电话:
 公司电话:
 系统操作员<中文姓名>:
 系统配备:
 魔电厂牌:
 系统操作员<生日.年龄>:
 职业:
 网路时间:
 预定什麽时候开始接信:
 建议:

 请有心加入新网的站台 填写好之後 送来本站即可。

 ECHO KEY           共 ２６ 区            信管人员ID
 ------------------------------------------------------------------------
 破解码公怖区       CRACK-CODE           Yu Hwang(朋友俱乐部)
 破解技术讨论区     CRACK-CRACK          Chen-Long Ho(超时空资讯站)
 一般信件讨论区     CRACK-GENERAL        Gidar Lee(朋友俱乐部)
 建站实务讨论区     CRACK-BBS
 中文系统讨论区     CRACK-CHINESE
 软体讨论区         CRACK-SOFT           Maxwell Lin(微电子通信站)
 新站广告区         CRACK-NEWBBS         Justin L.(时代资讯交流广场)
 中古买卖区         CRACK-SALE
 硬体讨论区         CRACK-HARD           Maxwell Lin(微电子通信站)
 音乐/音效讨论区    CRACK-MUSIC
 快信讨论区         CRACK-MESSAGE
 打屁瞎掰讨论区     CRACK-TALK
 热门职棒讨论区     CRACK-BALL           Ru Long(朋友俱乐部)
 病毒讨论区         CRACK-VIRUS
 交友专区           CRACK-FRIEND         Steve You(战警游龙,私人站)
 心情讨论区         CRACK-MOOD           Feney Lin(朋友俱乐部)
 站长讨论区         CRACK-SYSOP          不开放给User
 网路测试区         CRACK-TEST           不开放给User
 HUB xxxx区         CRACK-HUBxxxx        由HUB 自定信区 若跟总站接 都自定100
 魔电讨论区         CRACK-MODEM          也就是你要设 CRACK-HUB100 其它HUB自设
 游戏攻略心得发表区 CRACK-GAME
 程式语言讨论区     CRACK-LANGUAGE       １０２４资讯工作坊,Shenq-Hong Lien
 电视游乐器讨论区   CRACK-TVGAME
 网路问题讨论区     CRACK-NETWARE
 信管&站长意见交流区 CRACK-MD&SYS        此区只开放给信管&站长接取 一般USER不开
                                         放此区读/写信件
 职务站台专用信区   CRACK-COORDINATOR    此区职务站台必接 一般NODE不开放使用
-------------------------------------------------------------------------------
ECHO FILES KEY

 CRACKNET   网路资源
 CRACK-PD   公益软体发送区
密码皆是 12345678

欢迎有兴趣的站台来加入本网的行列。可将申请表送至就近的 HUB OR HOST 即可

 破解技术交流网      加 入 站 名 列 表   站  台  电  话    开放时间    速   率
------------------------------------------------------------------------------
宜兰地区
HOST总站 39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        28800
HUB 100  39:39/100     朋友俱乐部总站    TEL:039-281739      24HR        28800

台北地区
HUB200   39:39/200    Jay's BBS交流站    TEL:02-8962836      24HR        28800

HUB 500  39:39/500 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200

HUB2100  39:39/2100    酒国英雄资讯站    TEL:02-2961696      24HR        19200

HUB1300  39:39/1300     IMAGINATION站    TEL:02-9124125      24HR        14400

新竹地区
HUB1200  39:39/1200  地球电子村交流站    TEL:035-728334      24HR        19200

花莲地区
HUB600   39:39/600     咖啡小店资讯站    TEL:038-321637      24HR        14400

HUB1100 39:39/1100    彩虹之梦交流站     TEL:038-571651      24HR        19200

HUB1500 39:39/1500      阿达一族总站     TEL:038-321773      24HR        28800
                                         TEL:038-360092      24HR        28800

台中地区
HUB800  39:39/800      天使资讯交流站    TEL:04-7787048      24HR        16800

HUB1400 39:39/1400   一贯道资讯交流站    TEL:04-3384895      24HR        19200

南投地区
HUB2000 39:39/2000     水的传说资讯站    TEL:049-452749      24HR        28800

嘉义地区
HUB1600 39:39/1600     今生有约资讯站    TEL:05-5849839      24HR        14400

台南地区
HUB1800 39:39/1800     无情荒岛有情天    TEL:06-6321555      24HR        19200

香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-6183163     24HR        28800

台北 HOST 40
HOST40   39:40/1       遨游??鹏资讯站    TEL:02-8747279      24HR        14400
HUB100   39:40/100     遨游??鹏资讯站    TEL:02-8747279      24HR        14400

HUB200   39:40/200     魔法王国交流站    TEL:02-5991763      24HR        19200

HUB300   39:40/300     欢乐肥龙资讯站    TEL:02-9161500      24HR        19200

HUB400   39:40/400     欢乐肥龙第七站    TEL:02-5237019      24HR        28800
                                             02-5678505      24HR        28800

高雄 HOST 42
        39:42/0        小魔星资讯站      TEL:07-6615254    24HR        28800
                                         TEL:07-6618873    24HR        28800
        39:42/100      小魔星资讯站      TEL:07-6615254    24HR        28800
                                         TEL:07-6618873    24HR        28800
HUB 300 39:42/300      天使之俱乐部      TEL:07-3424649    24HR        16800

HUB 400 39:42/400      天才园地资讯站    TEL:07-2267953    24HR        19200

HUB 500 39:42/500      神恩者_梦之国度   TEL:07-6563988    24HR        19200

屏东地区
HUB 200 39:42/200      慧星资讯交流站    TEL:08-7020092    24HR        28800

HUB 700 39:42/700      琉璃仙境资讯站    TEL:08-7786070    24HR        28800

美国旧金山 HOST 43
         39:43/0      狼族资讯专业站  TEL:002-415-3426108   16:00-07:00   28800

桃园地区 HOST 300
Host300  39:300/0       百战天龙资讯站    TEL:03-4578836      24HR        28800
Hub 100  39:300/100     百战天龙资讯站    TEL:03-4578836      24HR        28800

Hub 200  39:300/200     电玩小子总站      TEL:03-3353482      24HR        28800

Hub 300  39:300/300     飙信小子专业站    TEL:03-4500312      24HR        14400

Hub 400  39:300/400     飞马座工作室      TEL:03-4911960      24HR        14400

Hub 500  39:300/501     超魔界资讯站      TEL:03-3816343      24HR        28800

彰化地区 HOST 44
HOST44  39:44/0       THE SOUND资讯站    TEL:04-7234264      24HR        19200
HUB100  39:44/101     THE SOUND资讯站    TEL:04-7234264      24HR        19200

HUB200  39:44/200        交流道资讯站    TEL:04-7617195      24HR        19200

HUB300  39:44/300        １６８资讯站    TEL:04-8951705      24HR        28800

HUB400  39:44/400        好朋友资讯站    TEL:04-7276819      24HR        19200

HUB500  39:44/500            直拨卫星    TEL:04-7249128      24HR        19200

台北地区 HOST45
HOST45   39:45/0     时代资讯交流广场    TEL:02-6251649      24HR        28800

HUB100   39:45/100   时代资讯交流广场    TEL:02-6251649      24HR        28800

HUB600   39:45/600   褐雨燕资讯站        TEL:02-9217661      24HR        19200

台南地区 HOST 46
HOST46   39:46/0    为爱先锋资讯交流站    TEL:06-2913772      24HR        28800
HUB100   39:46/100  为爱先锋资讯交流站    TEL:06-2923888      24HR        14400

Hub200   39:46/200  咖啡资讯站            TEL:06-2893841      24HR        28800

Hub300   39:46/300  南台湾转信站          TEL:06-2907528      24HR        28800

Hub600   39:46/600  迪伦的店              TEL:06-2746230      24HR        28800

===============================================================================

後序:   首先当然很感谢一些忠实的『读者』 来信的建议及鼓励啦! 以至於作者才会再继
        续的写出 『破解入门 第十五集』 当然有时候难免会有一些不理想的地方 例如
        打错字呀! 内容不够充实....等 但请考虑一点 因这算是分享心得的文章 并不是
        去花钱购买的 所以请将就点看啦! 况且作者也并非一天到晚都没事做 所以罗!请
        大家多多体谅才是。
        PS:请勿修改本文章的ＩＤ及站名 违者...『死刑』...哈! 开玩笑的啦!
           至少看在我辛苦 KEY IN 的方面上嘛!...不然以後就做保护啦!...嘻!有点夸
           张了...。

下集预告: 我也不确定第十六集 什麽时候会出来 所以只好请耐心等待啦! 若有任何建议
          都可以在破解技术交流网中『破解技术讨论区』 写信给我就可以啦! 我会尽
          可能的告诉各位 若你问的我也不懂的话 那我就没办法了。

          下集已准备写目前一定会遇到的 KEY PROT 的破解过程及方法...请慢慢等吧!

ＩＤ：Ｙｕ　Ｈｗａｎｇ 朋友俱乐部 站长(破解技术交流网 总站)

BBS TEL: 039-281739 24HR 28800 BPS 欢迎光临指教!!

                                      俞煌男 於 84/09/30 完成


俞煌男破解入门教程（１６／１７）
俞煌男

               破 解 入 门     第 十 六 集      作 者: Yu Hwang 朋友俱乐部 站长
                                                            24HR TEL:039-281739
前言:                                                       28800 BPS /V34

哈罗! 各位好:
    不知各位破解入门第十五集中的内容是否能让您对破解注册方面的软体有所了解了呢?
也不知道是否因此让您又多学会如何破解这类的软体? 当然大部份的注册软体都可以依照
此方法去破解 至於能不能够了解或是破解 那就要看各位的功力啦! 当然功力是靠您这样
一点一滴的累积而成的啦! 没人敢说他天生就会破解吧! 所以说罗! 靠自己总比靠别人给
的破解码还要来的实在又有成就感 您说是不是呢??

    最近作者正在着手写书当中喔! 大致上会先写有关破解入门的技术&关念&软体应用等
内容 敬请期待 等我写好之後 才会拿出去出版 届时还请各位多多捧场喔! 当然到时候也
会告知出版厂商及书名给各位 因我还没写好 所以当然还没去跟出版商洽谈罗! 请耐心等
候 若有佳音 一定马上回报给大家知道罗!

==============================================================================
内容:

银版快信 ５．４Ｈ１（架站用）破解注册过程 (此次是算注册码 因为方便以後用嘛!
                                           若以後注册码算法不变的话 应可沿用下
                                           一版 省得下次出新版还要再破解一次。)
为了方便截取画面 所以这次改用 DEBUG 操作!!
若您用 S-ICE 也可以用 LDR XPADM.EXE 载入即可 在此不再累述。

D:\PROBOARD\XPRESS>DEBUG XPADM.EXE
-U
293F:001F 9A0000AE37    CALL    37AE:0000
293F:0024 9A970A6A35    CALL    356A:0A97
293F:0029 9A2507E433    CALL    33E4:0725
293F:002E 9A10162B32    CALL    322B:1610
293F:0033 9A86099231    CALL    3192:0986
293F:0038 9A0701C72F    CALL    2FC7:0107
293F:003D 9ABD00B92F    CALL    2FB9:00BD
293F:0042 9AE6008A2E    CALL    2E8A:00E6
293F:0047 9A4D02012E    CALL    2E01:024D
293F:004C 9AC004BF2C    CALL    2CBF:04C0
293F:0051 9A97004D2A    CALL    2A4D:0097
293F:0056 9A3A075329    CALL    2953:073A
293F:005B C8            DB      C8
293F:005C 0402          ADD     AL,02
293F:005E 008DBE00      ADD     [DI+00BE],CL
293F:0062 FF16576A      CALL    [6A57]
293F:0066 009A140D      ADD     [BP+SI+0D14],BL
293F:006A AE            SCASB
293F:006B 37            AAA
293F:006C 9A12003937    CALL    3739:0012
293F:0071 833E1C3000    CMP     WORD PTR [301C],+00
293F:0076 746D          JZ      00E5
293F:0078 8DBEFCFD      LEA     DI,[BP+FDFC]
293F:007C 16            PUSH    SS
293F:007D 57            PUSH    DI
293F:007E 8DBE00FF      LEA     DI,[BP+FF00]
293F:0082 16            PUSH    SS
293F:0083 57            PUSH    DI
293F:0084 6A            DB      6A
293F:0085 009A140D      ADD     [BP+SI+0D14],BL
293F:0089 AE            SCASB
293F:008A 37            AAA
293F:008B 8DBEFCFE      LEA     DI,[BP+FEFC]
293F:008F 16            PUSH    SS
293F:0090 57            PUSH    DI
293F:0091 BF0000        MOV     DI,0000
293F:0094 0E            PUSH    CS
293F:0095 57            PUSH    DI
293F:0096 9AC30FAE37    CALL    37AE:0FC3
293F:009B 9A7F071536    CALL    3615:077F
293F:00A0 9A12003937    CALL    3739:0012
293F:00A5 833E1C3000    CMP     WORD PTR [301C],+00
293F:00AA 7439          JZ      00E5
293F:00AC BF9880        MOV     DI,8098
293F:00AF 1E            PUSH    DS
293F:00B0 57            PUSH    DI
293F:00B1 8D7EE5        LEA     DI,[BP-1B]
293F:00B4 16            PUSH    SS
293F:00B5 57            PUSH    DI
293F:00B6 BF0400        MOV     DI,0004
293F:00B9 0E            PUSH    CS
293F:00BA 57            PUSH    DI
293F:00BB 9AC30FAE37    CALL    37AE:0FC3
293F:00C0 6A            DB      6A
293F:00C1 009ADB09      ADD     [BP+SI+09DB],BL
293F:00C5 AE            SCASB
293F:00C6 37            AAA
293F:00C7 A11C30        MOV     AX,[301C]
293F:00CA 99            CWD
293F:00CB 52            PUSH    DX
293F:00CC 50            PUSH    AX
293F:00CD 6A            DB      6A
293F:00CE 009A630A      ADD     [BP+SI+0A63],BL
293F:00D2 AE            SCASB
293F:00D3 37            AAA
293F:00D4 9A4008AE37    CALL    37AE:0840
293F:00D9 9AF404AE37    CALL    37AE:04F4
293F:00DE 31C0          XOR     AX,AX
293F:00E0 9A1601AE37    CALL    37AE:0116
293F:00E5 9A67053937    CALL    3739:0567
293F:00EA 9AF2013937    CALL    3739:01F2
293F:00EF B90200        MOV     CX,0002
293F:00F2 31DB          XOR     BX,BX
293F:00F4 9A9A0EAE37    CALL    37AE:0E9A
293F:00F9 52            PUSH    DX
293F:00FA 50            PUSH    AX
293F:00FB 9AA3013937    CALL    3739:01A3
293F:0100 9AF2013937    CALL    3739:01F2
293F:0105 B90300        MOV     CX,0003
293F:0108 31DB          XOR     BX,BX
293F:010A 9AD70EAE37    CALL    37AE:0ED7
293F:010F 52            PUSH    DX
293F:0110 50            PUSH    AX
293F:0111 9AFD013937    CALL    3739:01FD
293F:0116 B82005        MOV     AX,0520
293F:0119 BA5329        MOV     DX,2953
293F:011C A3847F        MOV     [7F84],AX
293F:011F 8916867F      MOV     [7F86],DX
293F:0123 C606020001    MOV     BYTE PTR [0002],01
293F:0128 6A            DB      6A
293F:0129 009AB70E      ADD     [BP+SI+0EB7],BL
293F:012D 53            PUSH    BX
293F:012E 299A2000      SUB     [BP+SI+0020],BX    ┐其实这是一段 CALL 喔!
293F:0132 5B            POP     BX                 │不要被骗啦! 好好看清楚吧!
293F:0133 2AC9          SUB     CL,CL              ┘
293F:0135 31C0          XOR     AX,AX
293F:0137 9A1601AE37    CALL    37AE:0116
293F:013C 0000          ADD     [BX+SI],AL
293F:013E 0000          ADD     [BX+SI],AL
293F:0140 C8            DB      C8
293F:0141 1400          ADC     AL,00
293F:0143 00C6          ADD     DH,AL
293F:0145 46            INC     SI
293F:0146 ED            IN      AX,DX
293F:0147 3E            DS:
293F:0148 8B4604        MOV     AX,[BP+04]
-G012F                                          <---- 执行到这行

AX=0500  BX=53E4  CX=0004  DX=2953  SP=53E8  BP=55EE  SI=0560  DI=000B
DS=3989  ES=0000  SS=41A8  CS=293F  IP=012F   NV UP EI PL NZ NA PE NC
293F:012F 9A20005B2A    CALL    2A5B:0020
-U
293F:012F 9A20005B2A    CALL    2A5B:0020
293F:0134 C9            DB      C9
293F:0135 31C0          XOR     AX,AX
293F:0137 9A1601AE37    CALL    37AE:0116
293F:013C 0000          ADD     [BX+SI],AL
293F:013E 0000          ADD     [BX+SI],AL
293F:0140 C8            DB      C8
293F:0141 1400          ADC     AL,00
293F:0143 00C6          ADD     DH,AL
293F:0145 46            INC     SI
293F:0146 ED            IN      AX,DX
293F:0147 3E            DS:
293F:0148 8B4604        MOV     AX,[BP+04]
293F:014B 8946EE        MOV     [BP-12],AX
293F:014E 8D7EEC        LEA     DI,[BP-14]
-T
                                                <---- 追进去看看罗!
AX=0500  BX=53E4  CX=0004  DX=2953  SP=53E4  BP=55EE  SI=0560  DI=000B
DS=3989  ES=0000  SS=41A8  CS=2A5B  IP=0020   NV UP EI PL NZ NA PE NC
2A5B:0020 CD3F          INT     3F
-U
2A5B:0020 CD3F          INT     3F
2A5B:0022 48            DEC     AX
2A5B:0023 2C00          SUB     AL,00
2A5B:0025 CD3F          INT     3F
2A5B:0027 5E            POP     SI
2A5B:0028 27            DAA
2A5B:0029 0000          ADD     [BX+SI],AL
2A5B:002B 0000          ADD     [BX+SI],AL
2A5B:002D 0000          ADD     [BX+SI],AL
2A5B:002F 00CD          ADD     CH,CL
2A5B:0031 3F            AAS
2A5B:0032 0000          ADD     [BX+SI],AL
2A5B:0034 60            DB      60
2A5B:0035 4B            DEC     BX
2A5B:0036 0000          ADD     [BX+SI],AL
2A5B:0038 A94CC8        TEST    AX,C84C
2A5B:003B 050D00        ADD     AX,000D
2A5B:003E 1C01          SBB     AL,01
-T                                              <---- 再追进去看看
AX=0500  BX=53E4  CX=0004  DX=2953  SP=53DE  BP=55EE  SI=0560  DI=000B
DS=3989  ES=0000  SS=41A8  CS=3739  IP=02E6   NV UP DI PL NZ NA PE NC
3739:02E6 55            PUSH    BP
-U
3739:02E6 55            PUSH    BP
3739:02E7 8BEC          MOV     BP,SP
3739:02E9 50            PUSH    AX
3739:02EA 53            PUSH    BX
3739:02EB 51            PUSH    CX
3739:02EC 52            PUSH    DX
3739:02ED 56            PUSH    SI
3739:02EE 57            PUSH    DI
3739:02EF 1E            PUSH    DS
3739:02F0 06            PUSH    ES
3739:02F1 B88939        MOV     AX,3989
3739:02F4 8ED8          MOV     DS,AX
3739:02F6 FB            STI
3739:02F7 C45E02        LES     BX,[BP+02]
3739:02FA 26            ES:
3739:02FB FF37          PUSH    [BX]
3739:02FD 836E0202      SUB     WORD PTR [BP+02],+02
3739:0301 7505          JNZ     0308
3739:0303 E83200        CALL    0338
-U 0330
3739:0330 5F            POP     DI
3739:0331 5E            POP     SI
3739:0332 5A            POP     DX
3739:0333 59            POP     CX
3739:0334 5B            POP     BX
3739:0335 58            POP     AX
3739:0336 5D            POP     BP
3739:0337 CF            IRET
3739:0338 FF062030      INC     WORD PTR [3020]
3739:033C 26            ES:
3739:033D 833E100000    CMP     WORD PTR [0010],+00
3739:0342 7409          JZ      034D
3739:0344 26            ES:
3739:0345 C70612000100  MOV     WORD PTR [0012],0001
3739:034B EB69          JMP     03B6
3739:034D FF062230      INC     WORD PTR [3022]
-G 337                                          <---- 返回 插断服务程式

AX=0500  BX=53E4  CX=0004  DX=2953  SP=53DE  BP=55EE  SI=0560  DI=000B
DS=3989  ES=0000  SS=41A8  CS=3739  IP=0337   NV UP EI NG NZ AC PE CY
3739:0337 CF            IRET
-T

AX=0500  BX=53E4  CX=0004  DX=2953  SP=53E4  BP=55EE  SI=0560  DI=000B
DS=3989  ES=0000  SS=41A8  CS=2A5B  IP=0020   NV UP EI PL NZ NA PE NC
2A5B:0020 EA482C0747    JMP     4707:2C48
-T                                              <---- 再追进去 JMP 4707:2C48

AX=0500  BX=53E4  CX=0004  DX=2953  SP=53E4  BP=55EE  SI=0560  DI=000B
DS=3989  ES=0000  SS=41A8  CS=4707  IP=2C48   NV UP EI PL NZ NA PE NC
4707:2C48 55            PUSH    BP
4707:2C49 89E5          MOV     BP,SP
4707:2C4B B89004        MOV     AX,0490
4707:2C4E 9A3005AE37    CALL    37AE:0530
4707:2C53 81EC9004      SUB     SP,0490
4707:2C57 C606783042    MOV     BYTE PTR [3078],42
4707:2C5C 9A39007C31    CALL    317C:0039
4707:2C61 9AB1008431    CALL    3184:00B1
4707:2C66 9A34005130    CALL    3051:0034

   .....   .........    ....     ..........    无 关 紧 要 所 以 略 过 罗!

-U 3B90
4707:3B90 F9            STC
4707:3B91 30BF1C61      XOR     [BX+611C],BH
4707:3B95 1E            PUSH    DS
4707:3B96 57            PUSH    DI
4707:3B97 9AB410AE37    CALL    37AE:10B4
4707:3B9C 7502          JNZ     3BA0
4707:3B9E EB38          JMP     3BD8
4707:3BA0 8DBE80FB      LEA     DI,[BP+FB80]
4707:3BA4 16            PUSH    SS
4707:3BA5 57            PUSH    DI
4707:3BA6 BF0B2B        MOV     DI,2B0B
4707:3BA9 0E            PUSH    CS
4707:3BAA 57            PUSH    DI
4707:3BAB 9AC30FAE37    CALL    37AE:0FC3
-G 3B97                                       <---- 追到 4707:3B97 这个 CALL
????????????????????????????????????????????????????????????????????????????????
AX=0008  BX=4E32  CX=0000  DX=3989  SP=4F4A  BP=53E2  SI=4E4D  DI=611C         �
DS=3989  ES=41A8  SS=41A8  CS=4707  IP=3B97   NV UP EI PL ZR NA PE NC          �
4707:3B97 9AB410AE37    CALL    37AE:10B4                          ????????????�
-T                                            <---- 一起进去看一下吧!
控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控控
AX=0008  BX=4E32  CX=0000  DX=3989  SP=4F46  BP=53E2  SI=4E4D  DI=611C  控控控控
DS=3989  ES=41A8  SS=41A8  CS=37AE  IP=10B4   NV UP EI PL ZR NA PE NC 控控控控控
37AE:10B4 FC            CLD                                        控控控控控控�
-U 10B0
37AE:10B0 5D            POP     BP                                 控控控控控控�
37AE:10B1 CA0800        RETF    0008                               控控控控控控�
37AE:10B4 FC            CLD                                        控控控控控控�
37AE:10B5 8BDC          MOV     BX,SP                              控控控控控控�
37AE:10B7 8CDA          MOV     DX,DS                              控控控控控控�
37AE:10B9 36            SS:                                        控控控控控控�
37AE:10BA C57708        LDS     SI,[BX+08]                         控控控控控控�
37AE:10BD 36            SS:                                        控控控控控控�
37AE:10BE C47F04        LES     DI,[BX+04]                         控控控控控控�
37AE:10C1 AC            LODSB                                      控控控控控控�
37AE:10C2 26            ES:                                        控控控控控控�
37AE:10C3 8A25          MOV     AH,[DI]                            控控控控控控�
37AE:10C5 47            INC     DI                                 控控控控控控�
37AE:10C6 8AC8          MOV     CL,AL                              控控控控控控�
37AE:10C8 3ACC          CMP     CL,AH
37AE:10CA 7602          JBE     10CE
37AE:10CC 8ACC          MOV     CL,AH
37AE:10CE 0AC9          OR      CL,CL
-G 10C2                                       <---- 执行到这行看看 就会看到
                                                    ES:611C 这个记忆体的位址

AX=0008  BX=4F46  CX=0000  DX=3989  SP=4F46  BP=53E2  SI=5163  DI=611C
DS=41A8  ES=3989  SS=41A8  CS=37AE  IP=10C2   NV UP EI PL ZR NA PE NC
37AE:10C2 26            ES:
37AE:10C3 8A25          MOV     AH,[DI]                            ES:611C=08

-D ES:611C                                    <---- 让我秀出来看看...oHＯH!
                                                    太棒啦! 让我找到注册码所
                                                    存放的记忆体位址啦! 赶快
                                                    抄起来重跑一次吧!..Ya Ｙａ
3989:6110                                      08 34 39 37               .497
3989:6120  46 31 43 36 44 00 00 00-00 00 00 00 00 00 00 00   F1C6D...........
3989:6130  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
3989:6140  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
3989:6150  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
3989:6160  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
3989:6170  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
3989:6180  00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00   ................
3989:6190  00 00 00 00 00 00 00 00-00 00 00 00               ............

这样就算出 银版快信的注册码了 高兴吧!...ＯＯＯＯＯＨ！ＳＯＮＧ！！
PS:若您的 ES:611C 不是跟我相同的话 请不要担心 这是正常的啦!
   因为每个人的电脑环境都不是相同的 所以就会这样子啦。

===============================================================================

 再来就是举例 ＫｅｙＰｒｏｔ 的破解实例给大家参考....嘿...嘿! 是否等很久了呢?
 由於这次举例的 KeyProt 无法全部附在本集中 所以只给一些必要档案练习用! 其它恕
 难提供。

 步骤如下:
          1. 当然是先载入 S-ICE 罗!
          2. 先下 BPIO 378          <--- 拦 LPT1 位址 也就是 KEYPROT 所在位址
                                         若您不确定您的 LPT1 位址是多少的话
                                         那可以重新开机就可以看到啦!
                                         再不懂我就.....不理你啦! 表示程度太低!
                                         无法沟通 请先自行加强再说吧!
          3. 执行程式罗! 语法如下:

           EX. C51 HELLO.C DEBUG CODE   <--- ENTER

               就会看到如下画面罗!

               C:\B>C51 HELLO.C DEBUG CODE
       尚      MS-DOS C51 COMPILER V4.01
               COPYRIGHT KEIL ELEKTRONIK GmbH 1988 - 1993
       未
               MISSING SECURITY DEVICE !
       破      THIS IS A C51-COMPILER DEMO-VERSION !

       解      C51 COMPILATION COMPLETE.  0 WARNING(S),  0 ERROR(S)

               若找不到 KEYPROT 的话 就是只有 DEMO-VERSION !

          4. 此时 S-ICE 会因程式执行到 I/O 378 而产生中断停止 如下画面:

                ADD  [DI-75],DL
                IN   AL,DX
                MOV  DX,[BP+06]
                MOV  AL,[BP+08]
                OUT  DX,AL
                ADD  [BX+SI],AL   <---- 此时 S-ICE 会停在此处
                POP  BP
                RETF              <——┐返回主程式中
                                       │
  读   ┌——>  ADD  SP,+04       <——┘就会看到如下画面罗!
       │       CALL 0000
  取   │       PUSH [BP+06]
       │       CALL 62BD:2020
  Ｋ   │       ADD  SP,+02
       │       AND  AX,00FD
  Ｅ   │       MOV  [BP-02],AX
       │       CALL 0000
  Ｙ   │       PUSH [BP-02]
       │       PUSH [BP-06]
  Ｐ   │       CALL 62BD:202E
       │       ADD  SP,+04
  Ｒ   │       CALL 0000
       │       PUSH [BP+06]
  Ｏ   │       CALL 62BD:2020
       │       ADD  SP,+02
  Ｔ   │       OR   AL,02
       │       MOV  [BP-02],AX
  值   │       CALL 0000
       │       PUSH [BP-02]
       │       PUSH [BP-06]
  并   │       CALL 62BD:202E
       │       ADD  SP,+04
       │       CALL 0000
  比   │       MOV  AX,[BP+06]
       │       DEC  AX
  较   │       PUSH AX
       │       CALL 62BD:2020
  是   │       ADD  SP,+02
       │       AND  AL,FC
  否   │       MOV  [BP-04],AL
       │       CALL 0000
  正   │       MOV  AL,[BP-04]
       │       SUB  AH,AH
  确   │       PUSH AX
       │       PUSH [BP+06]
       │       CALL 62BD:202E
  是   │       ADD  SP,+04
       │       MOV  AX,[BP-02]
 正式版│       XOR  AL,80
       │       MOV  CL,03
  不   │       SHR  AX,CL
       │       SHL  AX,CL
  是   │       LES  BX,[BP+08]
       │       INC  WORD PTR [BP+08]
 展示版│       MOV  CL,ES:[BX]
       │       SUB  CH,CH
       │       CMP  AX,CX
       └——>  JZ   014E        <----判断是否正确的返回值 若是的话就跳到014E
                                      可以改成 CMP CX,CX 或 JMP 014E 就顺利破
                                      解罗!

                此时画面如下:

      已        C:\B>C51 HELLO.C DEBUG CODE
                MS-DOS C51 COMPILER V4.01
      破        COPYRIGHT KEIL ELEKTRONIK GmbH 1988 - 1993

      解        C51 COMPILATION COMPLETE.  0 WARNING(S),  0 ERROR(S)

      啦
                这样就成功啦!..已顺利将 HELLO.C 产生 OBJ 档罗!

===============================================================================

结语:     由於本文只讨论 破解技术方面 所以并不打算解释所有列出的 组合语言 意思
          请自行参考坊间书籍即可。

          虽然这次解说的 ＫｅｙＰｒｏｔ 内容并不是很多 但我以後会尽量解说的更深
          入一些 或者也可参考作者以後出书上的内容即可。

          有些人可能会问 这麽简单的 您才引出来 但是就是简单的才要引出来呀! 毕竟
          这是 破解入门 并不是 进阶篇 也不是 高手篇 所以若您认为不值得一看的话
          请略过吧! 以免浪费您保贵时间。

          打算从 破解入门 第十六集 後 开始更改为 破解进阶篇-KeyProt破解讨论指引
          若程度跟不上的朋友 请自行加强罗!或是稍待一阵子等作者出书後 参考之。

後序:     由於最近可能都要忙於先写书 所以破解进阶篇 可能会要等一阵子了! 希望各
          位读者多多包涵罗! 倘若有空的话 我会尽量写出目前较特别的保护方式的破解
          技术及方法。 也请耐心等待作者出书(嘻! 这是我的心愿之一嘛!) 若有问题或
          指教 可到本站留信给我即可 或是到 破解技术交流网 破解技术讨论区 写信给
          Yu Hwang 也是可以喔!

          版权所有 翻印必究 哈!....不可以修改喔! 违者『喀嚓』...开玩笑的啦!

作 者 ：  俞 煌 男
Ｉ Ｄ ：  Yu Hwang
站 名 ：  朋友俱乐部 专业站
ＴＥＬ：  (039)281-739
Modem ：  ２８８００ Bps ／Ｖ３４
网 路 ：  破解技术交流网 总站 (39:39/1)

                                         1995/10/23  Yu Hwang 完成!

 破解技术交流网      加 入 站 名 列 表   站  台  电  话    开放时间    速   率
------------------------------------------------------------------------------
宜兰地区
HOST总站 39:39/1       朋友俱乐部总站    TEL:039-281739      24HR        28800
HUB 100  39:39/100     朋友俱乐部总站    TEL:039-281739      24HR        28800
         39:39/101     天使资讯交流站    TEL:038-563037      24HR        28800
         39:39/102     神鹰资讯交流站    TEL:089-810467      24HR        16800
PVT<私>  39:39/108     1024资讯工作坊    TEL:039-xxxxxx      xxxx        14400
         39:39/111     懒窝一站资讯站    TEL:02-7651639      24HR        28800
PVT<私>  39:39/112     战警游龙资讯站    TEL:039-xxxxxx      xxxx        19200
         39:39/114     魔力交流资讯站    TEL:02-3456302      24HR        28800
         39:39/115     飞侠阿达资讯站    TEL:039-568200      24HR        14400

台北地区
HUB200   39:39/200    Jay's BBS交流站    TEL:02-8962836      24HR        28800
         39:39/201     虹屋资讯交流站    TEL:02-9867374      24HR        14400
PVT<私>  39:39/202     超帅型交流站      TEL:02-702xxxx      私人        14400
         39:39/203     梦??小??资讯站    TEL:02-3916175    08:00-24:00   14400
         39:39/204     叮当资讯交流站    TEL:02-2512974      24HR        16800
         39:39/205       幻??鹰交流站    TEL:02-9833779      24HR        19200
         39:39/206     星际航舰交流站    TEL:02-2300107      24HR        19200
         39:39/208     颠峰资讯交流站    TEL:02-2157304      24HR        14400
         39:39/209     幻境资讯交流站    TEL:02-6222302      24HR        14400
         39:39/210       伟佳电传中心    TEL:02-9364372    18:00-23:30   16800
         39:39/211     超龙战士资讯站    TEL:02-2460122      24HR        14400
         39:39/213     堡哥资讯交流站    TEL:02-7124924      24HR        14400
         39:39/214     穿越时空交流站    TEL:02-6883301    17:00-07:00   28800
         39:39/215       侠客居交流站    TEL:02-9821296      24HR        28800
         39:39/216     森林之家资讯站    TEL:02-9031685    18:00-07:00   14400
         39:39/218       复活岛资讯站    TEL:02-6780526    19:00-24:00   19200

HUB 500  39:39/500 疯狂小子资讯交流站    TEL:02-8168353      24HR        19200
         39:39/501 龙飞凤舞资讯交流站    TEL:02-6956076      24HR        14400
         39:39/502     熊之家族资讯站    TEL:02-7789541      24HR        19200
         39:39/503         未来资讯网    TEL:02-7884166      24HR        28800
         39:39/504   幻??谷资讯交流网    TEL:02-7827815      24HR        14400
         39:39/505         多多资讯站    TEL:02-xxxxxxx      私人        14400
         39:39/506         Hidden BBS    TEL:02-xxxxxxx      私人        14400
         39:39/507       轻松摇摆 BBS    TEL:02-2174675      24HR        28800
         39:39/508           柔情世界    TEL:02-6522060      24HR        14400
         39:39/509   亲亲我的宝贝 BBS    TEL:02-7615481      24HR        14400
         39:39/510             钓鱼人    TEL:02-xxxxxxx      私人        16800
         39:39/511       欢乐天地 BBS    TEL:02-6700461      24HR        28800
         39:39/512         颓废工作室    TEL:02-xxxxxxx      私人        14400
         39:39/513         游侠俱乐部    TEL:02-9975594      24HR        28800
         39:39/514     钟爱一生资讯站    TEL:02-9459135      24HR        14400
         39:39/515           KISS BBS    TEL:02-9867738      24HR        28800
         39:39/516       个性资讯广场    TEL:02-7849624      24HR        14400
         39:39/517           ９8 工程    TEL:02-9412155      24HR        14400
         39:39/518 伊奥勒斯资讯交流站    TEL:02-8930123      24HR        14400
         39:39/519   法兰克陈威力 BBS    TEL:02-xxxxxxx      私人        19200
         39:39/520           忆文晓??    TEL:02-9117594      24HR        14400
         39:39/521     甜蜜宝贝资讯站    TEL:02-6739047      24HR        28800
         39:39/522           VEGA BBS    TEL:02-3096444      24HR        14400
         39:39/523     浪漫一生资讯站    TEL:02-3375620      24HR        14400
         39:39/524         小茜资讯站    TEL:02-9756749      24HR        14400
         39:39/525     城市之鹰资讯站    TEL:02-6251118      24HR        28800
         39:39/526       寻梦园工作室    TEL:02-5922267   13:00-11:00    19200

HUB2100  39:39/2100    酒国英雄资讯站    TEL:02-2961696      24HR        19200
PVT<私>  39:39/2101        飞翔??传说    TEL:02-xxxxxx       xxxx        14400
         39:39/2102      模型资讯广场    TEL:02-3657965      24HR        16800
         39:39/2103        龙虎资讯站    TEL:02-9586280      24HR        28800
         39:39/2104      另一个资讯站    TEL:02-4552421      24HR        28800
         39:39/2105    织梦空间资讯站    TEL:02-9940364      24HR        14400
         39:39/2107    ９８工程资讯站    TEL:02-9412155      24HR        14400

HUB1300  39:39/1300     IMAGINATION站    TEL:02-9124125      24HR        14400

新竹地区
HUB1200  39:39/1200  地球电子村交流站    TEL:035-728334      24HR        19200
         39:39/1201  紫色梦幻屋交流站    TEL:035-801886      24HR        16800
         39:39/1202    今生有约交流站    TEL:035-200946      24HR        14400
PVT<私>  39:39/1203  隐流小磨坊交流站    TEL:035-xxxxxx      私人        14400
         39:39/1204    卡巴资讯交流站    TEL:037-667347      24HR        28800
         39:39/1205    魔茧资讯交流站    TEL:035-801872    19:00-03:00   16800
         39:39/1206    莲华都市交流站    TEL:037-691075      24HR        19200
         39:39/1207      Bliss 交流站    TEL:035-339884    24:00-06:00   19200
         39:39/1208    PLAY BBS交流站    TEL:035-590526      24HR        28800
         39:39/1209    橘子王国资讯站    TEL:03-5785751      24HR        14400
         39:39/1210    幸运龙资讯站      TEL:035-599099      24HR        28800
         39:39/1211    大华工管资讯站    TEL:035-941233      24HR        28800
         39:39/1212        魔法修道院    TEL:035-903508      24HR        14400
         39:39/1213        祥云资讯站    TEL:035-424664      24HR        14400
PVT<私>  39:39/1214   回归线资讯工作站   TEL:035-xxxxxx      xxxx        28800

花莲地区
HUB600   39:39/600     咖啡小店资讯站    TEL:038-321637      24HR        14400
         39:39/601     乱马1/2 资讯站    TEL:038-579968      24HR        28800
         39:39/602     良牙资讯交流站    TEL:038-534028      24HR        28800
         39:39/603     晴岚资讯交流站    TEL:038-540479      24HR        28800

HUB1500 39:39/1500      阿达一族总站     TEL:038-321773      24HR        28800
                                         TEL:038-360092      24HR        28800

台中地区
HUB800  39:39/800      天使资讯交流站    TEL:04-7787048      24HR        16800
        39:39/803    呆呆熊资讯交流站    TEL:04-8298434      24HR        28800
        39:39/804    Jadeite   交流站    TEL:04-8360023      24HR        14400
        39:39/805    好朋友资讯交流站    TEL:04-7276819      24HR        19200
HUB1400 39:39/1400   一贯道资讯交流站    TEL:04-3384895      24HR        19200
        39:39/1403   山与水资讯交流站    TEL:04-6319205      24HR        14400
        39:39/1404     新友电传资讯站    TEL:04-2349119      24HR        14400
        39:39/1405     青雯资讯交流站    TEL:04-6328161      24HR        14400
        39:39/1406     凯文资讯交流站    TEL:04-xxxxxxx      私人        14400
        39:39/1407     龙族资讯交流站    TEL:04-6317251      24HR        14400
        39:39/1408     长命百岁交流站    TEL:04-2958185      24HR        14400
        39:39/1409     毁天灭地情报站    TEL:04-6321487      24HR        14400

南投地区
HUB2000 39:39/2000     水的传说资讯站    TEL:049-452749      24HR        28800
        39:39/2001     今天资讯交流站    TEL:049-251090      24HR        14400
        39:39/2002     财神资讯交流站    TEL:049-655079      24HR        14400
        39:39/2003       迪士尼资讯站    TEL:049-910020      24HR        19200

嘉义地区
HUB1600 39:39/1600     今生有约资讯站    TEL:05-5849839      24HR        14400

台南地区
HUB1800 39:39/1800     无情荒岛有情天    TEL:06-6321555      24HR        19200
                                         TEL:06-6350021      24HR        14400
        39:39/1801       北极星资讯站    TEL:06-6564520      24HR        14400
        39:39/1802     老虎资讯交流站    TEL:06-2755159      24HR        16800
                                             06-2371284      24HR        16800
                                             06-2373015      24HR        16800
        39:39/1803     智泉资讯交流站    TEL:06-2345688      24HR        28800
        39:39/1805     太极联盟交流站    TEL:06-7820362      24HR        28800
        39:39/1806     枫岚资讯交流站    TEL:06-6527646      24HR        28800

香港地区
HUB700  39:39/700      情信资讯交流站    TEL:852-26183163    24HR        28800
        39:39/701      酒井法子专门站    TEL:852-27563536    24HR        19200

台北 HOST 40
HOST40   39:40/1       遨游??鹏资讯站    TEL:02-8747279      24HR        14400
HUB100   39:40/100     遨游??鹏资讯站    TEL:02-8747279      24HR        14400
         39:40/102   坏小子资讯交流站    TEL:02-2190318      24HR        14400
         39:40/103     熊座资讯交流站    TEL:02-3776746      24HR        14400
         39:40/109   漫画俱乐部交流站    TEL:02-9601633      24HR        16800
         39:40/110         魔法俱乐部    TEL:02-9275781      24HR        19200
         39:40/111   梦幻屋资讯交流站    TEL:02-9866550      24HR        14400
         39:40/112     虹屋资讯交流站    TEL:02-9867374      24HR        14400
         39:40/113     将相世家交流站    TEL:02-6227053      24HR        14400
         39:40/116     疯狂超人交流站    TEL:02-3926054      24HR        16800
PVT<私>  39:40/117 彩色世界资讯交流站    TEL:02-xxxxxxx      xxxx        14400
         39:40/118     银河帝国交流站    TEL:02-2122986    21:00-07:00   14400
         39:40/119   加菲猫资讯交流站    TEL:02-2752743      24HR        14400
         39:40/120     彰仔资讯交流站    TEL:02-5030619      24HR        14400
         39:40/121     清风禅语交流站    TEL:02-8411352      24HR        14400
         39:40/122   邱比特资讯交流站    TEL:02-5863111      24HR        16800
         39:40/125   百乐门资讯交流站    TEL:02-8200755      24HR        28800
         39:40/126 东方快车资讯交流站    TEL:03-3352798      24HR        14400
         39:40/127 霸王军团资讯交流站    TEL:02-8097433      24HR        19200
PVT<私>  39:40/128   微电子通信交流站    TEL:02-xxxxxxx      xxxx        19200
         39:40/129   皇家骑士团交流站    TEL:02-9877552      24HR        14400
PVT<私>  39:40/132     未来城市交流站    TEL:02-xxxxxxx      xxxx        19200
         39:40/133     幕府将军交流站    TEL:02-2316192      24HR        14400
         39:40/135     小马资讯交流站    TEL:02-6426462      24HR        19200
         39:40/136     悍卫雄鹰资讯站    TEL:02-9560533      24HR        19200
         39:40/137         ＧREEN BBS    TEL:02-7236730      24HR        19200
         39:40/138         提督??决断    TEL:02-4295957      24HR        14400
HUB200   39:40/200     魔法王国交流站    TEL:02-5991763      24HR        19200
HUB300   39:40/300     欢乐肥龙资讯站    TEL:02-9161500      24HR        19200
PVT<私>  39:40/301    Navigator资讯站    TEL:02-xxxxxxx      xxxx        16800
PVT<私>  39:40/302     直到永远资讯站    TEL:02-xxxxxxx      xxxx        14400
PVT<私>  39:40/303    破裂??人偶 II站    TEL:02-xxxxxxx      xxxx        16800
         39:40/304     皮皮电传资讯站    TEL:02-9186282      24HR        14400
PVT<私>  39:40/305     机器战警资讯站    TEL:02-xxxxxxx      xxxx        14400
         39:40/306   东部人资讯交流站    TEL:02-9354278      24HR        19200
         39:40/307   Tank World交流站    TEL:02-8969916      24HR        14400
         39:40/308     人偶资讯交流站    TEL:02-3320641      24HR        28800
         39:40/309   邱比特II电传中心    TEL:02-9450875      24HR        14400
PVT<私>  39:40/310     银河英雄资讯站    TEL:02-xxxxxxx      xxxx        14400
         39:40/311   华声俱乐部资讯站    TEL:02-9717443      24HR        14400
         39:40/312       ＧＵＳ俱乐部    TEL:02-7625418      24HR        14400
         39:39/313   超时空资讯交流站    TEL:02-8752787      24HR        28800
         39:39/314 狼??传说一站交流站    TEL:02-9978405      24HR        16800
私  39:40/315           鸭子的店    TEL:02-XXX-XXXX     xxxx        14400
         39:40/316           游戏天使    TEL:02-2838275      24HR        14400
         39:40/317         枪神资讯站    TEL:02-8476072      24HR        28800
         39:40/318     醉月椰风资讯站    TEL:02-7390445      24HR        14400
         39:40/319           Algo BBS    TEL:02-2015231      24HR        16800
         39:40/320           有趣男孩    TEL:02-4933905   22:00-08:00    28800
         39:40/322   创世纪资讯交流站    TEL:02-8161334      24HR        28800
         39:40/323     色情酒店资讯站    TEL:02-7414711      24HR        19200
         39:40/324       阿拉丁资讯站    TEL:02-7882498      24HR        19200
私  39:40/325           家资讯站    TEL:02-xxxxxxx      xxxx        19200
         39:40/326     梦幻音乐盒叁站    TEL:02-2362554      24HR        28800
         39:40/327     五泰资讯交流站    TEL:02-4986024      24HR        19200
         39:40/333       奇幻岛资讯站    TEL:02-7134406      24HR        14400
HUB400   39:40/400     欢乐肥龙第七站    TEL:02-5237019      24HR        28800
                                             02-5678505      24HR        28800

高雄 HOST 42
        39:42/0        小魔星资讯站      TEL:07-6615254    24HR        28800
                                         TEL:07-6618873    24HR        28800
        39:42/100      小魔星资讯站      TEL:07-6615254    24HR        28800
                                         TEL:07-6618873    24HR        28800
        39:42/101      天使资讯俱乐部    TEL:07-7824827  23:00-10:00   14400
        39:42/102      梁山英雄资讯站    TEL:08-7660765    24HR        19200
        39:42/104      熊猫资讯交流站    TEL:07-7911289    24HR        28800
        39:42/105      圣殿资讯交流站    TEL:07-2234372  16:00-11:00   19200
        39:42/106      似曾相识交流站    TEL:07-3808896    24HR        28800
        39:42/107      职棒天地资讯站    TEL:08-7223622    24HR        14400
        39:42/109      新新人类          TEL:07-6432177    24HR        14400
        39:42/110      城市风情资讯站    TEL:07-7461129    24HR        19200
                                         TEL:07-7400225    24HR        19200
                                         TEL:07-7432163    24HR        19200
        39:42/111      北极星专业站台    TEL:07-5884530    24HR        28800
                                         TEL:07-3927025    24HR        28800
        39:42/112      创星资讯站        TEL:07-7170650  06:00-24:00   14400
        39:42/113      寻梦??星          TEL:07-3920787    24HR        16800
        39:42/115      大鼻子资讯站      TEL:07-8225210    24HR        19200
        39:42/116 G2001超纪元联合资讯中心TEL:07-2267827    24HR        16800
        39:42/117      飞鸟资讯交流站    TEL:07-3650870    24HR        14400
        39:42/118      德华有情资讯站    TEL:07-6437024    24HR        14400
        39:42/119      蓝色狂想          TEL:07-3330040    24HR        19200
        39:42/120      天下布武          TEL:07-3612312    24HR        28800
        39:42/121      天长地久          TEL:07-6423406    24HR        19200
        39:42/124      佛??门资讯交流站  TEL:07-6437094    24HR        28800
        39:42/125      勾引撒旦          TEL:不公开                    14400
        39:42/126      KISS_66.6_资讯站  TEL:07-3951972    24HR        14400
        39:42/127      漎 梦幻天地 漐    TEL:07-7427971    24HR        28800
        39;42/128      神恩者_梦之国度   TEL:07-6563988    24HR        28800
                                         TEL:07-6564034    24HR        28800
                                         TEL:07-6564139    24HR        28800
                                         TEL:07-6561302    24HR        28800
        39:42/129      城市资讯站        TEL:07-7514558    24HR        28800
HUB 300 39:42/300      天使之俱乐部      TEL:07-3424649    24HR        16800
        39:42/302      烽火台资讯交流站  TEL:07-3847640    24HR        28800
HUB 400 39:42/400      天才园地资讯站    TEL:07-2267953    24HR        19200
        39:42/401      梦幻仙境资讯站    TEL:07-3855992  22:00-10:00   28800

屏东地区
HUB 200 39:42/200      慧星资讯交流站    TEL:08-7020092    24HR        28800
        39:42/201      拓荒者俱乐部      TEL:08-7235479  22:00-10:00   14400
        39:42/202      淘气阿丹资讯站    TEL:08-7521865    24hr        14400
        39:42/203      心情故事资讯站    TEL:08-7072249    24HR        14400
        39:42/204      卫斯理资讯站      TEL:08-XXXXXXX    私人站       2400
        39:42/205      神通情人梦        TEL:08-7384676    24HR        14400
HUB 700 39:42/700      琉璃仙境资讯站    TEL:08-7786070    24HR        28800

美国旧金山 HOST 43
         39:43/0      狼族资讯专业站  TEL:002-415-3426108   16:00-07:00   28800

桃园地区 HOST 300
Host300  39:300/0       百战天龙资讯站    TEL:03-4578836      24HR        28800
Hub 100  39:300/100     百战天龙资讯站    TEL:03-4578836      24HR        28800
         39:300/101     梦幻城市６１９    TEL:03-4507806      24HR        19200
         39:300/102     巧翊商业资讯站    TEL:03-3507952      24HR        14400
Pvt<私>  39:300/103     BREEZE  资讯站    TEL:03-XXXXXXX      私人        19200
         39:300/104     神行太保资讯站    TEL:03-3797802      24HR        19200
         39:300/105     风城资讯站        TEL:03-5890755      24HR        28800
         39:300/106     幸运女神资讯站    TEL:03-4651273      24HR        14400
         39:300/107     风之纺资讯站      TEL:03-3381913      24HR        14400
         39:300/108     龙??世界资讯站    TEL:03-3337483      24HR        28800
         39:300/109     耀之龙资讯站      TEL:03-4987335      24HR        19200
         39:300/110     内山之音资讯站    TEL:03-3907331    18:00-07:00   19200
         39:300/111     大  山资讯站      TEL:03-4628269      24HR        19200
         39:300/112     风城资讯II站      TEL:03-5892684      24HR        28800
         39:300/113     星际总部资讯站    TEL:03-3288961      24HR        28800
         39:300/113     星际总部资讯站    TEL:03-3288962      24HR        28800
         39:300/114     ＤＩＹ资 讯 站    TEL:03-3672894      24HR        19200
         39:300/115     巨蛋资讯站        TEL:04-6910249      24HR        28800
Hub 200  39:300/200     电玩小子总站      TEL:03-3353482      24HR        28800
         39:300/201     电玩小子总站      TEL:03-3353482      24HR        28800
         39:300/202     东京帝国资讯站    TEL:03-4637170      24HR        19200
         39:300/203     狂野之城资讯站    TEL:03-4556375      24HR        14400
Pvt<私>  39:300/204     不倒翁交流站      TEL:03-XXXXXXX      私人        19200
Hub 300  39:300/300     飙信小子专业站    TEL:03-4500312      24HR        14400
         39:300/301     飙信小子专业站    TEL:03-4500312      24HR        14400
Hub 400  39:300/400     飞马座工作室      TEL:03-4911960      24HR        14400
         39:300/401     飞马座工作室      TEL:03-4911960      24HR        14400
         39:300/402     梦幻大师资讯站    TEL:03-3656250      24HR        14400
         39:300/403     卡萨布兰加        TEL:03-3325352      24HR        28800
         39:300/404     异域资讯站        TEL:03-3254895      24HR        14400
         39:300/405     龙族之星          TEL:03-4900579      24HR        28800
         39:300/406     射手座工作室      TEL:03-3222884     19-06        14400
Hub 500  39:300/501     超魔界资讯站      TEL:03-3816343      24HR        28800
         39:300/501     超魔界资讯站      TEL:03-3816343      24HR        28800
         39:300/502     苹婆树下资讯站    TEL:04-3111283      24HR        28800
         39:300/503     模型世界资讯站    TEL:03-350-6133     24HR        19200
         39:300/505     软体屋资讯站      TEL:04-6980469      24HR        28800
                                          TEL:04-6995173      24HR        28800
         39:300/506     黄玫瑰资讯站      TEL:04-3609928      24HR        28800
                                          TEL:04-3605290      24HR        28800
                                          TEL:04-3604291      24HR        28800
         39:300/507     流浪天使资讯站    TEL:03-3642762      24HR        19200
                                          TEL:03-3639755      24HR        28800

HOST44  39:44/0       THE SOUND资讯站    TEL:04-7234264      24HR        19200
HUB100  39:44/101     THE SOUND资讯站    TEL:04-7234264      24HR        19200
        39:44/102      亚磬文化资讯站    TEL:04-6994915    23:00-07:00   14400
        39:44/103       漫画俱乐部_２    TEL:04-7284703      24HR        28800
        39:44/104        曼斐斯资讯站    TEL:04-8317190      24HR        28800
        39:44/105          肥龙资讯站    TEL:04-8725066      24HR        19200
        39:44/106        山间鼠资讯站    TEL:04-8974012      24HR        19200
        39:44/107        台湾人资讯站    TEL:04-XXXXXXX      私人        19200
        39:44/108          搞笑资讯站    TEL:04-8330831      24HR        19200
        39:44/109          龙威资讯站    TEL:05-5978300      24HR        19200
        39:44/110          虎尾资讯站    TEL:05-6330953      24HR        19200
HUB200  39:44/200        交流道资讯站    TEL:04-7617195      24HR        19200
        39:44/201        交流道资讯站    TEL:04-7617195      24HR        19200
        39:44/202          漫画俱乐部    TEL:04-7274591      24HR        19200
        39:44/203      山林小径资讯站    TEL:04-7254342      24HR        19200
        39:44/204      寂寞狼人资讯站    TEL:04-8833850      24HR        19200
        39:44/205    琉璃仙境资讯广场    TEL:04-8685663      24HR        19200
        39:44/206      宙斯资讯交流站    TEL:05-2378895      24HR        19200
HUB300  39:44/300        １６８资讯站    TEL:04-8951705      24HR        28800
        39:44/301        １６８资讯站    TEL:04-8951705      24HR        28800
        39:44/402          误点工作室    TEL:04-XXXXXXX      私人        19200
HUB400  39:44/400        好朋友资讯站    TEL:05-5874809      24HR        19200
        39:44/401        好朋友资讯站    TEL:05-5874809      24HR        19200
        39:44/403          福气资讯站    TEL:04-8361003      24HR        19200
        39:44/405          ZOOM工作室    TEL:04-7871027      24HR        28800
HUB500  39:44/500            直拨卫星    TEL:04-7249128      24HR        19200
        39:44/501            直拨卫星    TEL:04-7249128      24HR        19200
HUB600  39:44/600          爱的资讯站    TEL:05-5325431      24HR        14400
HUB600  39:44/601          爱的资讯站    TEL:05-5325431      24HR        14400
        39:44/602      隆隆跨网资讯站    TEL:05-5326763      24HR        19200

台北地区 HOST45
HOST45   39:45/0     时代资讯交流广场    TEL:02-7053966      24HR        28800
         39:45/1     时代资讯交流广场    TEL:02-7053966      24HR        28800
         39:45/2     星站共享视讯        TEL:02-2313446      24HR        28800
         39:45/3     神经????            TEL:02-9988717      24HR        14400
         39:45/4     ??升网路资讯站      TEL:02-7113992      24HR        14400
HUB100   39:45/100   时代资讯交流广场    TEL:02-6251649      24HR        28800
         39:45/101   时代资讯交流广场    TEL:02-6204678      24HR        28800
HUB600   39:45/600   褐雨燕资讯站        TEL:02-9217661      24HR        19200
         39:45/601   资讯叛客            TEL:02-8271366   20:00-06:00    14400
         39:45/602   巅峰资讯站          TEL:02-2157304      24HR        14400
         39:45/603   蓝色行星号          TEL:02-6780104      24HR        28800
         39:45/604   福尔摩沙资讯站      TEL:02-927-8823     24HR        14400
         39:45/605   万岁资讯交流站      TEL:02-822-6330     24HR        28800
         39:45/606   辅大电研社          TEL:02-902-1436     24HR        19200
         39:45/607   城市荒人音乐站      TEL:02-797-1960     24HR        28800
         39:45/608   芬妮资讯站台        TEL:02-732-6509     24HR        28800

台南地区 HOST 46
HOST46   39:46/0    为爱先锋资讯交流站    TEL:06-2913772      24HR        28800
HUB100   39:46/100  为爱先锋资讯交流站    TEL:06-2923888      24HR        14400
         39:46/101  为爱先锋资讯交流站    TEL:06-2923721      24HR        14400
         39:46/102  为爱先锋资讯交流站    TEL:06-2923722      24HR        28800
         39:46/103  蝙蝠资讯站            TEL:06-2726816      24HR        28800
         39:46/104  安平港了望台          TEL:06-2975159      24HR        28800
         39:46/105  快乐天堂资讯站        TEL:06-6355590      24HR        28800
         39:46/106  威力商业资讯站        TEL:06-6331258      24HR        28800
         39:46/107  福尔摩莎资讯站        TEL:06-2256836      24HR        28800
Pvt      39:46/108  猪宝宝个人资讯坊      TEL:06-XXXXXXX      私人        14400
Pvt      39:46/109  志明个人资讯工作室    TEL:06-XXXXXXX      私人        28800
Pvt      39:46/110  鼠窝个人资讯室        TEL:06-XXXXXXX      私人        14400
         39:46/112  红猪资讯站            TEL:06-2464447      24H         28800
Pvt      39:46/113  湘北资讯站            TEL:06-XXXXXXX      私人        14400
         39:46/114  神经歪歪友情站        TEL:06-280-2651     24HR        28800
Pvt,     39:46/115  都市丛林??欢乐狗窝    TEL:06-XXXXXXX      私人        14400
         39:46/116  土地公资讯站          TEL:06-233-9587     24HR        14400
Hub200   39:46/200  咖啡资讯站            TEL:06-2893841      24HR        28800
         39:46/201  咖啡资讯站            TEL:06-2893841      24HR        28800
         39:46/204  虎克资讯站            TEL:06-2609800      24HR        28800
         39:46/205  龙龙资讯站            TEL:06-2722870      24HR        28800
Hub300   39:46/300  南台湾转信站          TEL:06-2907528      24HR        28800
         39:46/301  南台湾转信站          TEL:06-2907528      24HR        28800
Hub600   39:46/600  迪伦的店              TEL:06-2746230      24HR        28800
         39:46/601  迪伦的店              TEL:06-2746230      24HR        28800


俞煌男破解入门教程（１７／１７）
俞煌男

哈罗!...:
     好不容易又再度写 破解入门第十七集 出来给大家多多学习的机会.!

今天要讲的是 pc-cillin 97 的keyport破解步骤讲解..这是要keyport也就

是pc-cillin 97上的免役锁..当然您刚开始要安装的时候若没有keyport..

很抱歉..! 您就无法安装pc-cillin 97版了! 所以我会带您一起看看这个破

解步骤..一方面可以让您学习.二方面可以让您有点经验!

新闻公告(HOT NEWS):

   破解技术交流网的HOME-PAGE已经开放了!! 若没有去过的朋友请赶快过去看看

   说不定能解决您的一些问题唷! 当然若您是一位老手的CRACK那当然更不可以

   错过了!

   本网页内容包括:
   ===============================================

   破解码公怖篇

   HACK文件篇

   HACK工具篇

   CRACK文件篇

   CRACK工具篇

   软体序号篇

   好站推广篇

   ===============================================
   这麽好的网页哪里找?

   在 http://140.109.103.19/yuhwang
      http://192.192.120.226/yuhwang

   赶紧去看看唷!  部份施工中 预计 四月中可以全面完工

   若您本身有HOME-PAGE的话 也请记得将这麽好的站加上URL唷!

   好站需要您多多推广!! 本网页是纯技术交流为目的! 非商业站台!!

破解环境:
windows 95
soft-ice ver:3.0 for win95

步骤一:
       当然一开始您必需要拥有 soft-ice ver:3.0 for win95 罗! 而且也必需安装好

       启动soft-ice 之後 您可以试试按 ctrl+d 看看是否已经切换到s-ice的debug画面

       若您已成功的切换到s-ice画面那表示你已可以正常的使用s-ice了..! 若您按了之

       後没有任何的反应..那表示您没有载入或是载入失败..!

       一切准备就绪後! 先按 ctrl+d 切换到s-ice画面中 ! 照着我以下方式输入:

       ec   这是可以让您很方便的利用 上/下 方向键去浏览 程式码

       bpio 378   这是可以让您去下中断点 目的是为了拦 lpt1 378 的位址!
                         也就是说 要去拦截当程式有去读/写 该378的io位址时 就会
                         发生中断产生 竟而可以顺利回到s-ice来进行程式的除错

       g    回到 win95 画面

步骤二:
       开始安装pc-cillin 97版(setup.exe) 安装时该程式会自动去检查您是否有将(免

       役锁)插在lpt1也就是印表机port 当安装时就会去触发我们之前所下的中断点

       bpio 378 之後会跳到 s-ice的除错画面中..! 此时照我以下方式输入:

       BC *
       G 0176BE67
       T
       G 0176C163
       T
       G 0176C1E9
       T
       G 0176BC44
       T
       G 0176BC09
       T

       此时请睁大眼睛 您可以发现到以下的比较点 内容如下:

       xxxx:01752752    ADD    ESP,18
       xxxx:01752755    MOV    [EBP-04],EAX
       xxxx:01752758    CMP    DWORD PTR [EBP-04],00
       xxxx:0175275C    JNZ    01752780               <-- 比较点
       xxxx:01752762    MOV    ECX,[EBP-08]
       xxxx:01752765    AND    ECX,0000FFFF
       xxxx:0175276b    CMP    ECX,0000A55A
       xxxx:01752771    JNZ    01752780     <-- 比较点 不等於跳 01752780 不安装
       xxxx:01752777    MOV    AX,0001         <-- 找到keyport放入标记
       xxxx:0175277B    JMP    01752788        <-- 执行安装
       ^^^^
         |
         +-> 这位址随每个人执行的程式不同而有所差异 可以不用理会!

       再来照我以下方式修改即可顺利安装成功:

       e cs:01752758

       此时您可以看到机器码如下:

       83 7D FC 00 0F 85 1E 00 00 00

       修改成 66 B8 01 00 EB 2A

       修改完成之後....嘿嘿!..按 G  您就可以发现到..竟然可以顺利安装罗!

步骤叁:
       当您照上面破解好之後 确实已经可以顺利将PC-CILLIN 97安装完成了.!不过当您

       安装好了要去执行已安装好的 PC-CILLIN 97 也是会再去检查一次 KEYPORT

       那怎麽办才好哩!..不用担心 只要您用 PCTOOLS .OR. FH .OR. UEDIT 去修改

       SCAN32.DLL
       找  83 7D FC 00 0F 85 1E 00 00 00
       改  66 B8 01 00 EB 2A -- -- -- --

       改好之後...以後就可以不用KEYPORT 可以很顺利的执行了

       再也不会出现错误的讯息叫您插上KEYPORT了!  高兴吧!

结语:
       或许有人会问 SOFT-ICE 哪里找...? 很抱歉 这是有版权的软体唷! 我可无法提供

       给您这套软体..不过...嘿!聪明的您 不会发信问吗?..应该会有一堆的人发信告诉

       您的啦!

作者:
       俞煌男  ID:YU HWANG (破解技术交流网 总站)

               BBS TEL:(03)9281739 24HR 33600BPS 朋友俱乐部

       若有问题要找我可以透过以下方式跟作者取得联络:

           E-MAIL:yuhwang@cris.phys.sinica.edu.tw
        home-page:
                  http://140.109.103.19/yuhwang
                  http://192.192.120.226/yuhwang

     或者是到有加入 破解技术交流网的 bbs 站 到 破解技术讨论区发信给id:Yu Hwang
     就可以了!!  附上本网列表 提供您到就近的bbs站上!!

版权宣告:

       本文件的着作权为 俞煌男 所有 , 任何人不得任意修改.删除。
       本文件欢迎任何转载 不需告知原作者。
       唯有商业之行为 如要刊登部份或全部内容时 需先取得原作者之同意 不然您就犯法
       作者可以依法寻求法律途迳来要求赔偿!

破解网站名列表:

.........  破 解  技  术  交  流  网  Ｃｒａｃｋ  ...      .. Ｎｅｔ
.........   破  解  技  术  交  流  网  Ｃｒａｃｋ....     ..   Ｎｅｔ
..        .......     ......  ......... ..    ... .. ..    .. ....... .......
..        ..     .. ..     .. ..        ..   ..   ..  ..   .. ..         ..
..        ..     .. ..     .. ..        ..  ..    ..   ..  .. ......     ..
..        ......... ......... ..        .....     ..    .. .. ......     ..
......... ..    ..  ..     .. ..        ..  ..    ..     .... ..         ..
......... ..     .. ..     .. ......... ..    ... ..      ... .......    ..

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
职    务 站       号 站              名         开  站   电  话   时间 速 率
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
ZONE39   39:39/1     朋友俱乐部                 TEL:(03)9281739   24HR 33,6K
HOST39   39:39/0     朋友俱乐部                 TEL:(03)9281739   24HR 33,6K
<站  台> 39:39/1     朋友俱乐部                 TEL:(03)9281739   24HR 33,6K
HUB100   39:39/100   朋友俱乐部                 TEL:(03)9281739   24HR 33,6K
<站  台> 39:39/102   神鹰                       TEL:(08)9810467   24HR 14,4K
<站  台> 39:39/103   龙??战士资讯站             TEL:(03)9588779   24HR 33,6K
<私人站> 39:39/108   １０２４资讯工作坊         <私人站 不公开>   私人 14,4K
<站  台> 39:39/111   懒窝一站                   TEL:(02)7651639   24HR 33,6K
<站  台> 39:39/113   超级蛇王俱乐部             TEL:(03)9571395   信件 14,4K
<站  台> 39:39/114   魔力                       TEL:(02)3456302   24HR 33,6K
HUB200   39:39/200   胜星资讯工作室             TEL:(04)3112153   24HR 33,6K
<站  台> 39:39/1     胜星资讯工作室             TEL:(04)3112153   24HR 33,6K
HUB1200  39:39/1200  彩色世界                   TEL:(03)5941233   24HR 33,6K
<站  台> 39:39/1201  紫色梦幻屋                 TEL:(03)5801886   24HR 14,4K
<休站中> 39:39/1202  今生有约                   <休站中 不公开>   休站 14,4K
<私人站> 39:39/1203  隐流小磨坊                 <私人站 不公开>   私人 14,4K
<站  台> 39:39/1205  魔茧                       TEL:(03)5801872   未知 14,4K
<休站中> 39:39/1206  莲华都市                   <休站中 不公开>   休站 14,4K
<休站中> 39:39/1208  PLAY_BBS                   <休站中 不公开>   休站 28,8K
<休站中> 39:39/1209  橘子王国                   <休站中 不公开>   休站 14,4K
<站  台> 39:39/1210  幸运龙                     TEL:(03)5599099   24HR 33,6K
<站  台> 39:39/1213  祥云                       TEL:(03)5424664   24HR 14,4K
<私人站> 39:39/1214  回归线                     <私人站 不公开>   私人 33,6K
<私人站> 39:39/1215  巫师之家                   <私人站 不公开>   私人 33,6K
<站  台> 39:39/1218  绿色世界资讯站             TEL:(03)5529243   24HR 33,6K
<站  台> 39:39/1219  宏本资讯站                 TEL:(03)5995689   24HR 14,4K
<站  台> 39:39/1220  心情故事坊                 TEL:(03)5423592   24HR 14,4K
<站  台> 39:39/1221  库巴王国资讯站             TEL:(03)5598083   24HR 14,4K
<站  台> 39:39/1224  宇宙空间资讯交流站         TEL:(03)5562731   24HR 14,4K
<站  台> 39:39/1225  银狐工作室                 TEL:(03)7325492   24HR 14,4K
<休站中> 39:39/1226  顽皮家族资讯站             <休站中 不公开>   休站 14,4K
<站  台> 39:39/1228  快乐天堂资讯站             TEL:(03)5927431   24HR 14,4K
HUB800   39:39/800   天使资讯站                 TEL:(04)7787048   24HR 14,4K
<站  台> 39:39/803   呆呆熊资讯站               TEL:(04)8298434   24HR 14,4K
<站  台> 39:39/804   Jadeite_BBS                TEL:(04)8360023   24HR 14,4K
<站  台> 39:39/805   好朋友资讯站               TEL:(04)8360023   24HR 14,4K
HUB1800  39:39/1800  无情荒岛有情天             TEL:(06)6321555   24HR 14,4K
<站  台> 39:39/1801  北极星                     TEL:(06)6564520   24HR 14,4K
<站  台> 39:39/1802  老虎                       TEL:(06)2755159   24HR 14,4K
<站  台> 39:39/1803  智泉                       TEL:(06)2345688   24HR 33,6K
<站  台> 39:39/1805  太极联盟                   TEL:(06)7820362   24HR 33,6K
<站  台> 39:39/1806  枫岚                       TEL:(06)6527646   24HR 33,6K
HUB700   39:39/700   情信资讯站                 TEL:(852)26183163 24HR 33,6K
<站  台> 39:39/701   酒井法子专门站             TEL:(852)27563536 24HR 14,4K
<站  台> 39:39/702   鲸鱼网络                   TEL:(852)27926432 24HR 33,6K
HOST40   39:40/0     遨游??鹏站                 TEL:(02)3653475   24HR 14,4K
HUB100   39:40/100   遨游??鹏站                 TEL:(02)3653475   24HR 14,4K
<站  台> 39:40/102   坏小子资讯站               TEL:(02)2190318   24HR 14,4K
<站  台> 39:40/103   熊座资讯站                 TEL:(02)3776746   24HR 14,4K
<站  台> 39:40/104   浑沌魔镜资讯站             TEL:(02)7668736   24HR 14,4K
<站  台> 39:40/105   小叶的站                   TEL:(02)7094166   24HR 14,4K
<站  台> 39:40/106   电脑巴士                   TEL:(02)9446902   24HR 14,4K
<私人站> 39:40/107   蓝色雷克工作室             <私人站 不公开>   私人 14,4K
<私人站> 39:40/109   漫画俱乐部                 <私人站 不公开>   私人 14,4K
<站  台> 39:40/110   福尔摩沙工作城             TEL:(02)2865764   24HR 14,4K
<站  台> 39:40/111   梦幻屋                     TEL:(02)9866550   24HR 14,4K
<站  台> 39:40/112   浮云游子资讯站             TEL:(02)2684648   24HR 14,4K
<站  台> 39:40/113   将相世家资讯站             TEL:(02)6227053   24HR 14,4K
<私人站> 39:40/117   彩色世界                   <私人站 不公开>   私人 14,4K
<休站中> 39:40/118   银河帝国                   <休站中 不公开>   休站 14,4K
<站  台> 39:40/119   加菲猫                     TEL:(02)2752743   24HR 14,4K
<站  台> 39:40/120   彰仔                       TEL:(02)5030619   24HR 14,4K
<站  台> 39:40/121   清风禅语                   TEL:(02)5030619   24HR 14,4K
<站  台> 39:40/122   邱比特                     TEL:(02)5863111   24HR 14,4K
<站  台> 39:40/125   百乐门                     TEL:(02)8200755   24HR 33,6K
<站  台> 39:40/127   霸王军团                   TEL:(02)8097433   24HR 14,4K
<站  台> 39:40/128   微电子通信站               TEL:(02)7712396   24HR 14,4K
<站  台> 39:40/129   皇家骑士团                 TEL:(02)9877552   24HR 14,4K
<站  台> 39:40/135   小马                       TEL:(02)6426462   24HR 14,4K
<站  台> 39:40/137   ＧREEN_BBS                 TEL:(02)7236730   24HR 14,4K
<站  台> 39:40/138   提督决断                   TEL:(02)4295957   24HR 14,4K
<站  台> 39:40/139   天眼通资讯站               TEL:(02)3093378   24HR 14,4K
<站  台> 39:40/140   二十四小时资讯站～台北一站 TEL:(02)8219467   24HR 14,4K
<站  台> 39:40/141   超导体Ⅲ资讯广场           TEL:(02)6867030   24HR 14,4K
<站  台> 39:40/142   琉璃仙境                   TEL:(02)8051754   24HR 14,4K
<站  台> 39:40/144   勇者斗恶龙资讯城           TEL:(02)9649271   24HR 14,4K
HUB200   39:40/200   魔法王国                   TEL:(02)5991763   24HR 14,4K
<站  台> 39:40/202   SHADOW_CASTER_BBS          TEL:(02)7859795   未知 14,4K
<站  台> 39:40/203   Jurassic_BBS               TEL:(02)9867001   未知 14,4K
<站  台> 39:40/205   Yume_Boken_BBS             TEL:(02)9756749   未知 14,4K
<站  台> 39:40/206   Strange_Place_Sbbs         TEL:(02)2454773   未知 14,4K
HUB400   39:40/400   银河之星资讯站             TEL:(02)2652101   24HR 33,6K
HUB500   39:40/500   魔法俱乐部                 TEL:(02)9275781   24HR 14,4K
<站  台> 39:40/502   游戏磁场资讯站             TEL:(02)7316755   24HR 14,4K
<站  台> 39:40/504   金色家园资讯站             TEL:(02)9124820   24HR 14,4K
HUB600   39:40/600   悍卫雄鹰                   TEL:(02)9560533   24HR 33,6K
HUB700   39:40/700   勇者传说                   TEL:(02)2140466   24HR 33,6K
<站  台> 39:40/701   相聚一刻                   TEL:(02)9532759   24HR 14,4K
<站  台> 39:40/702   可爱??家                   TEL:(02)9464754   未知 33,6K
<站  台> 39:40/703   本站无名                   TEL:(02)6822733   信件 33,6K
<站  台> 39:40/704   陋室铭                     TEL:(02)6327637   未知 33,6K
<站  台> 39:40/705   ☆思萍学园☆               TEL:(02)2063053   未知 14,4K
<站  台> 39:40/706   XSiLHoueTTe                <电话不公开>      未知 14,4K
HUB800   39:40/800   24hr资讯站                 TEL:(02)8219467   24HR 14,4K
HUB900   39:40/900   天眼通资讯站               TEL:(02)3093378   24HR 33,6K
HUB1000  39:40/1000  加菲猫                     TEL:(02)2752743   24HR 33,6K
<站  台> 39:40/1001  Dysan_BBS                  TEL:(02)9435631   24HR 33,6K
<站  台> 39:40/1002  希欧资讯站                 TEL:(02)5683862   24HR 33,6K
HUB1100  39:40/1100  侏罗纪资讯站               TEL:(02)9867001   24HR 33,6K
<站  台> 39:40/1101  Dysan_BBS                  TEL:(09)435631    24HR 14,4K
<站  台> 39:40/1102  幻想天堂资讯站             TEL:(02)5367115   24HR 14,4K
HUB1200  39:40/1200  东海游龙                   TEL:(02)9972884   24HR 14,4K
<站  台> 39:40/1201  梦之??                     TEL:(02)XXXXXXX   信件 14,4K
<站  台> 39:40/1202  东海游龙二站               TEL:(02)9678072   24HR 14,4K
<站  台> 39:40/1203  家洋科技资讯站             TEL:(02)9216975   24HR 14,4K
HOST41   39:41/0     健健资讯交流站             TEL:(02)6436637   24HR 33,6K
<站  台> 39:41/1     健健资讯交流站             TEL:(02)6436637   24HR 33,6K
HOST42   39:42/0     小魔星资讯站               TEL:(07)6615254   24HR 33,6K
<站  台> 39:42/1     小魔星资讯站               TEL:(07)6615254   24HR 33,6K
HUB100   39:42/100   小魔星资讯站               TEL:(07)6615254   24HR 33,6K
<站  台> 39:42/102   梁山英雄                   TEL:(08)7660765   24HR 14,4K
<站  台> 39:42/105   圣殿                       TEL:(07)2234372   24HR 14,4K
<站  台> 39:42/106   高雄似曾相识               TEL:(07)3808896   24HR 28,8K
<站  台> 39:42/107   职棒天地资讯站             TEL:(08)7223622   24HR 14,4K
<站  台> 39:42/108   星期日俱乐部               TEL:(07)6414145   24HR 14,4K
<站  台> 39:42/109   新新人类                   TEL:(07)6432177   24HR 14,4K
<站  台> 39:42/110   城市风情资讯站             TEL:(07)7461129   24HR 19,2K
<站  台> 39:42/111   北极星专业站台             TEL:(07)5884530   24HR 33,6K
<站  台> 39:42/112   伤心小站_PART_2_BBS        TEL:(07)3515805   未知 14,4K
<站  台> 39:42/114   乔治网路实验室             TEL:(07)5850241   24HR 14,4K
<站  台> 39:42/115   大鼻子资讯站               TEL:(07)8225210   24HR 14,4K
<站  台> 39:42/119   蓝色狂想                   TEL:(07)3330040   24HR 14,4K
<站  台> 39:42/124   佛??门资讯交流站           TEL:(07)6437094   24HR 33,6K
<私人站> 39:42/125   勾引撒旦                   <私人站 不公开>   私人 14,4K
<站  台> 39:42/126   KISS_66.6_资讯站           TEL:(07)3951972   24HR 14,4K
<站  台> 39:42/127   梦幻天地                   TEL:(07)7427971   24HR 33,6K
<站  台> 39:42/128   神恩者_梦之国度            TEL:(07)6563988   24HR 14,4K
<私人站> 39:42/135   狂野之城                   <私人站 不公开>   私人 33,6K
<站  台> 39:42/138   伤心小站                   TEL:(07)6331148   24HR 33,6K
<私人站> 39:42/140   美神令子资讯站             <私人站 不公开>   私人 14,4K
HUB200   39:42/200   破解网屏东HUB(彗星资讯)    TEL:(08)7020092   24HR 14,4K
<站  台> 39:42/201   拓荒者俱乐部               TEL:(08)7235479   24HR 14,4K
<站  台> 39:42/204   卫斯理资讯站               TEL:(08)7705650   24HR 14,4K
<站  台> 39:42/205   神通情人梦                 TEL:(08)7384676   24HR 14,4K
<站  台> 39:42/206   ??秘=密=探=长=BBS??        TEL:(08)7384773   24HR 33,6K
<站  台> 39:42/207   叮当猫                     TEL:(08)7831342   24HR 14,4K
<站  台> 39:42/208   梦工场                     TEL:(08)8334519   24HR 33,6K
HUB400   39:42/400   天才园地资讯站             TEL:(07)2267953   24HR 14,4K
<站  台> 39:42/401   梦幻仙境资讯站             TEL:(07)3855992   信件 33,6K
HUB500   39:42/500   城市资讯站                 TEL:(07)7514558   24HR 14,4K
<站  台> 39:42/501   城市资讯站                 TEL:(07)7514558   未知 14,4K
HUB700   39:42/700   风中奇缘                   TEL:(07)2616641   24HR 14,4K
<站  台> 39:42/701   风中奇缘                   TEL:(07)2616641   24HR 14,4K
<站  台> 39:42/702   伊甸园                     TEL:(07)7023097   24HR 14,4K
<私人站> 39:42/703   育年资讯站                 <私人站 不公开>   私人 14,4K
<站  台> 39:42/704   技术兵资讯交流站           TEL:(07)7104619   24HR 14,4K
HUB600   39:42/600   入侵者资讯站               TEL:(08)7226097   24HR 33,6K
<站  台> 39:42/601   联合鉴队资讯站             TEL:(08)7557005   24HR 33,6K
<站  台> 39:42/602   女神事务所资讯站           TEL:(08)7525927   24HR 33,6K
<站  台> 39:42/603   ??龙天楼??bbS??            TEL:(04)9651155   24HR 33,6K
<站  台> 39:42/604   入侵者资讯站               TEL:(08)7226311   24HR 33,6K
<站  台> 39:42/605   入侵者Ⅱ站                 TEL:(08)7558784   24HR 33,6K
<站  台> 39:42/606   伊甸园资讯站               TEL:(07)7023097   24HR 33,6K
HUB800   39:42/800   少年叛徒                   TEL:(07)7610305   24HR 33,6K
<站  台> 39:42/801   少年叛徒                   TEL:(07)7610305   24HR 33,6K
HUB900   39:42/900   小圣子资讯联盟总站         TEL:(07)6167427   24HR 33,6K
<站  台> 39:42/901   狮子棒野球站               TEL:(07)6974104   24HR 33,6K
HUB1000  39:42/1000  龙迷俱乐部                 TEL:(07)6962571   24HR 14,4K
HUB1100  39:42/1100  米老鼠资讯站               TEL:(07)2417182   24HR 14,4K
<站  台> 39:42/1101  米老鼠资讯站               TEL:(07)2417182   信件 14,4K
HOST44   39:44/0     THE_SOUND_BBS              TEL:(04)7234264   24HR 14,4K
HUB100   39:44/100   THE_SOUND_BBS              TEL:(04)7234264   24HR 14,4K
<站  台> 39:44/101   THE_SOUND_BBS              TEL:(04)7234264   24HR 14,4K
<站  台> 39:44/102   亚磬文化资讯站             TEL:(04)6994915   24HR 14,4K
<站  台> 39:44/103   漫画俱乐部                 TEL:(04)7274591   24HR 14,4K
<站  台> 39:44/104   思念情怀资讯站             TEL:(04)8317190   24HR 14,4K
<站  台> 39:44/105   肥龙资讯站                 TEL:(04)8725066   24HR 14,4K
<站  台> 39:44/106   山间鼠资讯站               TEL:(04)8974012   24HR 19,2K
<私人站> 39:44/107   台湾人工作室               <私人站 不公开>   私人 19,2K
<站  台> 39:44/108   搞笑资讯站                 TEL:(04)8330831   24HR 19,2K
<站  台> 39:44/109   龙威资讯站                 TEL:(05)5978300   24HR 19,2K
<站  台> 39:44/111   魔王迷宫资讯站             TEL:(04)7564891   24HR 19,2K
<站  台> 39:44/112   陆战队资讯站               TEL:(04)8749084   24HR 14,4K
HUB200   39:44/200   交流道资讯站               TEL:(04)7617195   24HR 14,4K
<站  台> 39:44/201   交流道资讯站               TEL:(04)7617195   24HR 14,4K
<站  台> 39:44/203   山林小径资讯站             TEL:(04)7254342   24HR 14,4K
<站  台> 39:44/204   寂寞狼人资讯站             TEL:(04)8833850   24HR 14,4K
<站  台> 39:44/205   琉璃仙境资讯广场           TEL:(04)8685663   24HR 14,4K
<站  台> 39:44/206   宙斯资讯交流站             TEL:(05)2378895   24HR 14,4K
HUB300   39:44/300   168_BBS                    TEL:(04)8951705   24HR 33,6K
<站  台> 39:44/301   168_BBS                    TEL:(04)8951705   24HR 33,6K
<站  台> 39:44/302   找碴资讯小站               TEL:(04)8967487   24HR 33,6K
<站  台> 39:44/303   午夜情深资讯小站           TEL:(04)7765579   未知 14,4K
<站  台> 39:44/304   新石器动画工厂资讯站       TEL:(04)8355940   未知 33,6K
<站  台> 39:44/305   蓓儿丹迪知心交流站         TEL:(04)7569423   24HR 33,6K
<站  台> 39:44/306   红尘有爱资讯站             TEL:(04)8862663   24HR 33,6K
HUB400   39:44/400   好朋友资讯站               TEL:(05)5874405   24HR 14,4K
<站  台> 39:44/401   好朋友资讯站               TEL:(05)5874405   24HR 14,4K
<站  台> 39:44/402   普洛资讯交流站             TEL:(05)2335188   24HR 14,4K
<站  台> 39:44/403   福气资讯站                 TEL:(04)8361003   24HR 14,4K
<站  台> 39:44/405   ZOOM工作室                 TEL:(04)7871027   24HR 14,4K
HUB500   39:44/500   直拨卫星                   TEL:(04)7249128   24HR 14,4K
<站  台> 39:44/501   直拨卫星                   TEL:(04)7249128   24HR 14,4K
<站  台> 39:44/502   蓓儿丹迪知心交流站         TEL:(04)7569423   24HR 33,6K
<站  台> 39:44/503   胜星资讯工作室             TEL:(04)3112153   24HR 33,6K
HUB600   39:44/600   爱的资讯站                 TEL:(05)5325431   24HR 14,4K
<站  台> 39:44/601   爱的资讯站                 TEL:(05)5325431   24HR 14,4K
<站  台> 39:44/602   隆隆跨网资讯站             TEL:(05)5326763   24HR 14,4K
<站  台> 39:44/603   欣欣资讯站                 TEL:(05)5242538   24HR 14,4K
<站  台> 39:44/605   摇滚城市资讯站             TEL:(05)6333728   24HR 14,4K
<站  台> 39:44/607   难得有情人资讯站           TEL:(05)5340969   24HR 14,4K
HUB700   39:44/700   午夜主宰资讯城             TEL:(04)3710342   24HR 14,4K
<站  台> 39:44/701   午夜主宰资讯城             TEL:(04)3710342   24HR 14,4K
HUB800   39:44/800   虎克资讯站                 TEL:(05)5861207   24HR 19,2K
<站  台> 39:44/801   虎克资讯站                 TEL:(05)5861207   24HR 19,2K
<站  台> 39:44/802   虎尾资讯站                 TEL:(05)6330953   24HR 19,2K
HOST45   39:45/0     Lodoss_BBS                 TEL:(02)9338881   24HR 33,6K
<站  台> 39:45/1     Lodoss_BBS                 TEL:(02)9342207   24HR 33,6K
<站  台> 39:45/2     Star_BBS                   TEL:(02)2313446   24HR 33,6K
<站  台> 39:45/3     Neuro_BBS                  TEL:(02)9988717   24HR 14,4K
<站  台> 39:45/4     SunRise_BBS                TEL:(02)7113992   24HR 14,4K
<私人站> 39:45/5     Desert_Moon_BBS            <私人站 不公开>   私人 33,6K
<站  台> 39:45/6     Yu_Ming_Information_BBS    TEL:(02)2318973   信件 14,4K
<站  台> 39:45/7     Evil_House_BBS             TEL:(02)9069039   未知 14,4K
<站  台> 39:45/8     ICON_BBS                   TEL:(02)4664774   未知 33,6K
<私人站> 39:45/9     X_SiLHoueTTe               <私人站 不公开>   私人 33,6K
HUB100   39:45/100   时代资讯交流广场           TEL:(02)7053966   24HR 33,6K
<站  台> 39:45/101   TIME_SQUARE_BBS            TEL:(02)7053966   24HR 33,6K
HUB200   39:45/200   Lodoss_BBS                 TEL:(02)9338881   24HR 33,6K
<站  台> 39:45/201   Lodoss_BBS                 TEL:(02)9342207   24HR 33,6K
<站  台> 39:45/202   Snow_BBS                   TEL:(02)8936386   24HR 33,6K
HUB600   39:45/600   Swift_BBS                  TEL:(02)7355057   24HR 14,4K
<站  台> 39:45/601   CyberPunk_BBS              TEL:(02)8271366   24HR 14,4K
<站  台> 39:45/602   HILLTOP_CBCS               TEL:(02)2157304   信件 14,4K
<站  台> 39:45/603   The_AstroBlue              TEL:(02)6780104   24HR 33,6K
<站  台> 39:45/604   ForMoSa_BBS                TEL:(02)9278823   信件 14,4K
<站  台> 39:45/605   ViVa_BBS                   TEL:(02)8226330   24HR 14,4K
<站  台> 39:45/606   FUJEI_CRC                  TEL:(02)9021436   24HR 19,2K
<站  台> 39:45/607   City_Scoundrel_Studio      TEL:(02)7971960   24HR 33,6K
<站  台> 39:45/608   FANNY_BBS                  TEL:(02)3779132   24HR 33,6K
<站  台> 39:45/609   Game_Life                  TEL:(02)9206622   24HR 33,6K
<站  台> 39:45/610   Fanciful_Sea_BBS           TEL:(02)5771165   24HR 33,6K
<站  台> 39:45/611   Lanco_Boy_BBS              TEL:(03)3503678   未知 33,6K
<站  台> 39:45/612   Sunny_Air_Water_BBS        TEL:(02)5015383   未知 33,6K
<站  台> 39:45/613   TENTOP_COMIC_BBS           TEL:(03)4365954   24HR 33,6K
HOST46   39:46/0     为爱先锋资讯站             TEL:(06)2913772   24HR 14,4K
<站  台> 39:46/1     为爱先锋资讯站             TEL:(06)2913772   24HR 14,4K
<站  台> 39:46/2     为爱先锋资讯站             TEL:(06)2913772   24HR 14,4K
<站  台> 39:46/3     咖啡资讯站                 TEL:(06)2893841   24HR 14,4K
<站  台> 39:46/4     南台湾转信站               TEL:(06)2907528   信件 33,6K
<站  台> 39:46/5     迪伦的店                   TEL:(06)2590943   24HR 14,4K
HUB100   39:46/100   为爱先锋资讯站             TEL:(06)2913772   24HR 14,4K
<站  台> 39:46/101   为爱先锋资讯站             TEL:(06)2913772   24HR 14,4K
<站  台> 39:46/102   为爱先锋资讯站             TEL:(06)2913772   24HR 14,4K
<站  台> 39:46/103   蝙蝠资讯站                 TEL:(06)2726816   24HR 14,4K
<站  台> 39:46/104   安平港了望台               TEL:(06)2975159   24HR 14,4K
<站  台> 39:46/105   快乐天堂资讯站             TEL:(06)6355590   24HR 14,4K
<站  台> 39:46/106   威力商业资讯站             TEL:(06)6331258   24HR 14,4K
<站  台> 39:46/107   福尔摩莎资讯站             TEL:(06)2256836   24HR 14,4K
<私人站> 39:46/108   猪宝宝个人资讯坊           <私人站 不公开>   私人 14,4K
<私人站> 39:46/109   志明个人资讯工作室         <私人站 不公开>   私人 14,4K
<私人站> 39:46/110   鼠窝个人资讯室             <私人站 不公开>   私人 14,4K
<站  台> 39:46/112   红猪资讯站                 TEL:(06)2464447   未知 14,4K
<私人站> 39:46/113   湘北资讯站                 <私人站 不公开>   私人 14,4K
<站  台> 39:46/114   神经歪歪友情站             TEL:(06)2802651   未知 14,4K
<私人站> 39:46/115   都市丛林??欢乐狗窝         <私人站 不公开>   私人 14,4K
<站  台> 39:46/116   土地公资讯站               TEL:(06)2339587   信件 33,6K
<站  台> 39:46/117   狂人资讯站                 TEL:(06)2295454   24HR 14,4K
<站  台> 39:46/118   Bow_Wow_House_CBCS         TEL:(06)2907842   信件 33,6K
<站  台> 39:46/119   DRAGON_MIDI_CBCS           TEL:(06)2722870   24HR 16,8K
<站  台> 39:46/120   Ever_Green_BBS             TEL:(06)5852230   24HR 14,4K
<站  台> 39:46/121   CANDY_BBS_BBS              TEL:(06)2556121   24HR 14,4K
<站  台> 39:46/122   ZOO_BBS                    TEL:(06)2693055   24HR 14,4K
<站  台> 39:46/123   Nintendo_CBCS              TEL:(06)2247568   24HR 14,4K
<站  台> 39:46/124   Nintendo2_CBCS             TEL:(06)2917074   24HR 14,4K
<站  台> 39:46/125   Happy_Workshop_Dream_Retai TEL:(06)2086908   24HR 14,4K
<站  台> 39:46/126   A_SU_NA_RO_BBS             TEL:(06)2323123   24HR 14,4K
HUB200   39:46/200   咖啡资讯站                 TEL:(06)2893841   24HR 14,4K
<站  台> 39:46/201   咖啡资讯站                 TEL:(06)2893841   24HR 14,4K
<站  台> 39:46/202   咖啡资讯站                 TEL:(06)2893841   24HR 14,4K
<站  台> 39:46/204   虎克资讯站                 TEL:(06)2609800   24HR 14,4K
<站  台> 39:46/205   龙龙资讯站                 TEL:(06)2722870   24HR 16,8K
<站  台> 39:46/206   饿狼传说资讯站             TEL:(06)2337854   24HR 14,4K
<站  台> 39:46/207   良牙资讯站                 TEL:(03)8534028   24HR 14,4K
HUB300   39:46/300   南台湾转信站               TEL:(06)2907528   24HR 33,6K
<站  台> 39:46/301   南台湾转信站               TEL:(06)2907528   信件 33,6K
HUB400   39:46/400   皮皮七站                   TEL:(05)2257572   24HR 33,6K
<站  台> 39:46/401   皮皮七站                   TEL:(05)2291841   信件 19,2K
<站  台> 39:46/402   普洛资讯交流站             TEL:(05)2335188   信件 33,6K
<站  台> 39:46/403   黄金孔雀城资讯交流站       TEL:(05)2891830   24HR 19,2K
<私人站> 39:46/404   Leaf_K.'s_BBS              <私人站 不公开>   私人 33,6K
<站  台> 39:46/405   蓝色雷克资讯交流广场       TEL:(05)2765876   24HR 19,2K
<私人站> 39:46/406   黑狗兄??窝                 <私人站 不公开>   私人 33,6K
HUB500   39:46/500   神经歪歪友情站             TEL:(06)2802651   24HR 14,4K
<站  台> 39:46/501   神经歪歪友情站             TEL:(06)2802651   未知 14,4K
HUB600   39:46/600   迪伦的店                   TEL:(06)2590943   24HR 14,4K
<站  台> 39:46/601   迪伦的店                   TEL:(06)2590943   24HR 14,4K
HUB700   39:46/700   龙龙资讯站                 TEL:(06)2722870   24HR 16,8K
<站  台> 39:46/701   龙龙资讯站                 TEL:(06)2722870   24HR 16,8K
HOST47   39:47/0     疯狂小子                   TEL:(02)8168353   24HR 14,4K
<站  台> 39:47/1     疯狂小子                   TEL:(02)8168353   24HR 14,4K
HUB100   39:47/100   疯狂小子                   TEL:(02)8168353   24HR 14,4K
<站  台> 39:47/101   龙飞凤舞资讯站             TEL:(02)6956076   24HR 14,4K
<私人站> 39:47/106   Hidden_BBS                 <私人站 不公开>   私人 14,4K
<站  台> 39:47/107   千岁情人资讯站             TEL:(02)8219589   24HR 33,6K
<站  台> 39:47/108   柔情世界                   TEL:(02)6522060   24HR 14,4K
<站  台> 39:47/111   欢乐天地_BBS               TEL:(02)6700461   24HR 14,4K
<私人站> 39:47/112   颓废工作室                 <私人站 不公开>   私人 14,4K
<站  台> 39:47/113   游侠俱乐部                 TEL:(02)9975594   24HR 33,6K
<私人站> 39:47/114   蓝色雷克工作室             <私人站 不公开>   私人 14,4K
<站  台> 39:47/115   KISS_BBS                   TEL:(02)9867738   24HR 33,6K
<站  台> 39:47/119   法兰克陈威力BBS            <电话不公开>      未知 14,4K
<站  台> 39:47/121   甜蜜宝贝资讯站             TEL:(02)6739047   24HR 33,6K
<站  台> 39:47/122   嘎嘎资讯站                 TEL:(02)2464893   24HR 33,6K
<站  台> 39:47/126   寻梦园工作室               TEL:(02)5922267   未知 14,4K
<站  台> 39:47/129   天秤座资讯站               TEL:(02)9777990   信件 33,6K
<站  台> 39:47/130   火??一族                   TEL:(02)9368739   24HR 14,4K
<站  台> 39:47/132   千门客栈                   TEL:(02)2018205   24HR 14,4K
<站  台> 39:47/133   安达充视讯中心             TEL:(02)3086899   24HR 14,4K
<私人站> 39:47/134   魔镇                       <私人站 不公开>   私人 14,4K
<站  台> 39:47/135   女神事务所                 TEL:(02)7866548   24HR 33,6K
<站  台> 39:47/137   巴士二站                   TEL:(02)2018205   24HR 14,4K
<站  台> 39:47/138   蓝色永恒??星               TEL:(02)9278420   24HR 33,6K
<站  台> 39:47/139   天长地久资讯交流站         TEL:(02)2033559   24HR 33,6K
<站  台> 39:47/140   UgC_BBS                    TEL:(02)9308698   24HR 33,6K
<站  台> 39:47/141   逍遥游资讯站               TEL:(02)9873531   24HR 28,8K
<站  台> 39:47/142   穿越时空_BBS               TEL:(02)6883301   24HR 33,6K
<站  台> 39:47/144   土龙资讯站                 TEL:(02)9890132   24HR 33,6K
<私人站> 39:47/145   飞扬天使资讯站             <私人站 不公开>   私人 33,6K
<站  台> 39:47/146   蜀汉资讯交流广场           TEL:(02)2961402   未知 33,6K
HUB200   39:47/200   CrackNet_HOST47_HUB-200    TEL:(02)5957489   24HR 33,6K
<站  台> 39:47/201   Ching_Feng_LINE1           TEL:(02)5957489   24HR 33,6K
<站  台> 39:47/202   Ching_Feng_LINE2           TEL:(02)5910458   24HR 33,6K
<站  台> 39:47/203   Fire_Fox_CBCS              TEL:(02)4229456   24HR 14,4K
<站  台> 39:47/204   Fancy_World_BBS_II         TEL:(02)9475756   24HR 14,4K
HUB300   39:47/300   第拾站                     TEL:(852)24553582 24HR 33,6K
<站  台> 39:47/302   光明资讯站-第二站          TEL:(852)27884452 24HR 33,6K
<休站中> 39:47/303   小惊大怪资讯交流站         <休站中 不公开>   休站 33,6K
<站  台> 39:47/304   天马行空                   TEL:(852)25974784 信件 14,4K
<私人站> 39:47/305   ??头汤�/4u厂               <私人站 不公开>   私人 33,6K
<站  台> 39:47/306   小偷一族                   TEL:(852)27095209 24HR 14,4K
<站  台> 39:47/307   地狱门                     TEL:(852)24023162 24HR 14,4K
<站  台> 39:47/308   青云路                     TEL:(852)26121120 24HR 14,4K
<站  台> 39:47/309   醉心天地                   TEL:(852)26948480 未知 33,6K
<站  台> 39:47/310   诗韵乐音乐电子告示版       TEL:(852)25358459 24HR 33,6K
<站  台> 39:47/311   桃花源资讯交流站           TEL:(852)26693598 未知 14,4K
<站  台> 39:47/312   城市猎人                   TEL:(852)25471089 24HR 33,6K
<站  台> 39:47/317   幻影资讯交流站             TEL:(852)27903735 24HR 14,4K
<站  台> 39:47/318   ??情牵二线??               TEL:(852)27206610 24HR 33,6K
<站  台> 39:47/319   动感超人ＢＢＳ             TEL:(852)27992151 24HR 33,6K
HUB400   39:47/400   VEGA_BBS                   TEL:(02)3096444   24HR 28,8K
<站  台> 39:47/405   Vesa_Max_BBS               TEL:(02)9399022   24HR 14,4K
<站  台> 39:47/419   米老鼠资讯站               TEL:(07)2417182   24HR 28,8K
<站  台> 39:47/420   超导体资讯一站             TEL:(02)4279475   24HR 28,8K
<站  台> 39:47/427   海格拉斯                   TEL:(04)2035419   24HR 28,8K
<站  台> 39:47/435   欢喜城资讯站               TEL:(02)8473792   24HR 28,8K
<站  台> 39:47/447   领导者资讯站               TEL:(02)2873440   24HR 28,8K
HUB500   39:47/500   Cat's_BBS                  TEL:(02)9874805   24HR 33,6K
<站  台> 39:47/501   Cat's_BBS                  TEL:(02)9874805   24HR 33,6K
<站  台> 39:47/502   Romantic_Taiwan            TEL:(02)7237727   未知 14,4K
<站  台> 39:47/503   Tender_Anger_BBS           TEL:(02)8053295   24HR 14,4K
<站  台> 39:47/504   将相世家                   TEL:(02)6227053   24HR 33,6K
<站  台> 39:47/588   ForMoSa_BBs                TEL:(02)9896486   信件 33,6K
HUB600   39:47/600   钟爱一生资讯站             TEL:(02)9459135   24HR 14,4K
<站  台> 39:47/601   金龙资讯交流站             TEL:(02)9425477   24HR 14,4K
HUB700   39:47/700   Little_Mouse_BBS           TEL:(02)9574925   24HR 14,4K
<站  台> 39:47/708   Dream_BBS                  TEL:(02)6707236   24HR 14,4K
HUB800   39:47/800   提督??决断                 TEL:(02)4295957   24HR 33,6K
HUB900   39:47/900   Country_Boy_BBS            TEL:(03)3815377   24HR 14,4K
<站  台> 39:47/901   Country_Boy_BBS            TEL:(03)3815377   24HR 14,4K
<站  台> 39:47/902   Lao_Local_BBS              TEL:(03)3654811   24HR 14,4K
<私人站> 39:47/903   Kevin's_BBS                <私人站 不公开>   私人 14,4K
<站  台> 39:47/904   The_Lord_BBS               TEL:(03)3656711   24HR 19,2K
<站  台> 39:47/905   School-Star_BBS_Station    TEL:(03)3609673   24HR 19,2K
<站  台> 39:47/906   TOP_BBS                    TEL:(03)3815311   24HR 14,4K
<私人站> 39:47/907   3*3_EYES_BBS               <私人站 不公开>   私人 14,4K
<站  台> 39:47/908   Hook_BBS                   TEL:(03)4391062   24HR 28,8K
HUB2500  39:47/2500  24hr资讯站                 TEL:(02)8219467   24HR 14,4K
<站  台> 39:47/2501  24HrsBBS                   TEL:(02)8219467   信件 33,6K
<站  台> 39:47/2507  Prohibited_Land_BBS        TEL:(02)9683558   24HR 33,6K
HOST48   39:48/0     巨蛋资讯交流站             TEL:(04)6910249   24HR 33,6K
<站  台> 39:48/1     巨蛋资讯交流站             TEL:(04)6910249   信件 33,6K
<站  台> 39:48/2     苹婆树下资讯站             TEL:(04)3111283   24HR 14,4K
<站  台> 39:48/3     诸罗山资讯站               TEL:(05)2337348   24HR 14,4K
<站  台> 39:48/4     蝴蝶宫资讯站               TEL:(04)4813241   24HR 14,4K
HUB100   39:48/100   新友电传资讯站             TEL:(04)2349119   24HR 14,4K
<站  台> 39:48/101   新友电传资讯站             TEL:(04)2349119   24HR 14,4K
<站  台> 39:48/102   山羊座资讯站               TEL:(04)3846445   24HR 14,4K
<站  台> 39:48/103   乱世群英资讯站             TEL:(04)3929523   24HR 33,6K
<站  台> 39:48/104   卧龙岗资讯站               TEL:(04)2962074   24HR 14,4K
<站  台> 39:48/105   E.S_BBS                    TEL:(04)3912436   24HR 33,6K
<站  台> 39:48/106   阿花小熊资讯站             TEL:(04)2526976   24HR 33,6K
<站  台> 39:48/107   茶坊资讯站                 TEL:(04)2202791   24HR 14,4K
<站  台> 39:48/108   鹅妈妈资讯交流广场         TEL:(04)6238621   24HR 33,6K
<站  台> 39:48/109   横扫千军联盟               TEL:(04)4811971   24HR 33,6K
<站  台> 39:48/110   海格拉斯资讯站             TEL:(04)2035419   24HR 33,6K
<站  台> 39:48/111   水.沙.莲.资讯站            TEL:(04)6236188   24HR 33,6K
<站  台> 39:48/112   黄玫瑰资讯站               TEL:(04)2372125   信件 33,6K
<私人站> 39:48/113   蟠谷资讯站                 <私人站 不公开>   私人 14,4K
<站  台> 39:48/114   枪与玫瑰资讯交流站         TEL:(04)6632135   24HR 33,6K
<站  台> 39:48/115   雅族资讯交流站             TEL:(04)3895290   信件 33,6K
HOST60   39:60/0     Happy_Fat_Dragon_BBS       TEL:(02)9161500   24HR 33,6K
<站  台> 39:60/1     Happy_Fat_Dragon_BBS       TEL:(02)9161500   24HR 33,6K
<私人站> 39:60/2     Navigator_BBS              <私人站 不公开>   私人 14,4K
<站  台> 39:60/3     Forevery_BBS               TEL:(02)9650715   24HR 14,4K
<私人站> 39:60/4     Bnag_Doll_II               <私人站 不公开>   私人 14,4K
<站  台> 39:60/5     PiPi_BBS                   TEL:(02)9186282   24HR 14,4K
<站  台> 39:60/6     OcpCop_BBS                 TEL:(02)6519691   未知 33,6K
<站  台> 39:60/7     East_Man                   TEL:(02)9354278   24HR 14,4K
<站  台> 39:60/8     Tank_World_BBS             TEL:(02)8969916   24HR 14,4K
<站  台> 39:60/9     Bnag_Doll                  TEL:(02)3320641   24HR 33,6K
<私人站> 39:60/10    Ceic2_BBS                  <私人站 不公开>   私人 14,4K
<私人站> 39:60/11    SUPER-PVT                  <私人站 不公开>   私人 14,4K
<站  台> 39:60/12    The_8th_Guest_BBS          TEL:(02)9717443   未知 14,4K
<站  台> 39:60/13    GUS_CLUB                   TEL:(02)7625418   24HR 14,4K
<站  台> 39:60/14    Hyper_Space_BBS            TEL:(02)8752787   24HR 28,8K
<站  台> 39:60/17    Game_Angel_BBS             TEL:(02)2838275   24HR 14,4K
<站  台> 39:60/18    Gun_God-BBS                TEL:(02)8476072   24HR 33,6K
<站  台> 39:60/20    Algo_BBS                   TEL:(02)2015231   24HR 14,4K
<站  台> 39:60/21    Funny_Boy                  TEL:(02)4933905   24HR 33,6K
<私人站> 39:60/22    Destiny_BBS                <私人站 不公开>   私人 14,4K
<站  台> 39:60/23    Ultima_BBS                 TEL:(02)8161334   24HR 33,6K
<站  台> 39:60/24    ALADDIN_BBS                TEL:(02)7882498   24HR 14,4K
<站  台> 39:60/25    IMB-3                      TEL:(02)2362554   24HR 33,6K
<站  台> 39:60/26    WTIC_BBS                   TEL:(02)4986024   24HR 14,4K
<站  台> 39:60/27    Broken-Hearted_Club        TEL:(02)9104661   24HR 33,6K
<站  台> 39:60/28    FuturesCap_Financial_BBS   TEL:(02)2038074   24HR 33,6K
<私人站> 39:60/29    HeySo_BBS                  <私人站 不公开>   私人 14,4K
<站  台> 39:60/30    AV_PRO_BBS                 TEL:(02)2459137   24HR 14,4K
<站  台> 39:60/31    Humour_Boy's_BBS           TEL:(02)9919864   信件 33,6K
<站  台> 39:60/32    Game_Player_BBS            TEL:(02)2895558   24HR 33,6K
<站  台> 39:60/33    HUNTEK_STUDIO_BBS          TEL:(02)9133943   24HR 14,4K
<站  台> 39:60/34    Orange_Road_BBS            TEL:(02)6290559   24HR 14,4K
<站  台> 39:60/35    .oO_Apollyon_bbs_Oo.       TEL:(03)3816343   24HR 33,6K
<站  台> 39:60/36    Marine_WorkRoom_BBS        TEL:(02)32335943  24HR 19,2K
<站  台> 39:60/37    THE_KING_INFORMATION_BBS   TEL:(02)6829263   24HR 14,4K
<站  台> 39:60/39    Libra_BBS                  TEL:(02)9777990   信件 33,6K
<站  台> 39:60/40    W&J_CBCS                   TEL:(02)9364372   24HR 14,4K
<站  台> 39:60/41    Galaxy_BBS                 TEL:(02)2652101   24HR 33,6K
<站  台> 39:60/42    Bus_BBS_Two                TEL:(02)7491220   24HR 33,6K
<站  台> 39:60/43    Bear_Station               TEL:(02)5973269   24HR 14,4K
<站  台> 39:60/44    Peter_Huang                TEL:(02)5092331   24HR 14,4K
<私人站> 39:60/45    WuKu_Junior_High_School_BB <私人站 不公开>   私人 14,4K
<站  台> 39:60/46    MAGIC_AND_MIGHT            TEL:(02)6932560   24HR 33,6K
<站  台> 39:60/47    KING_BBS                   TEL:(02)9694141   24HR 14,4K
<站  台> 39:60/48    Loiter_BBS                 TEL:(02)9873531   24HR 28,8K
HUB300   39:60/300   Overlord_BBS               TEL:(02)8097433   24HR 33,6K
<站  台> 39:60/301   Overlord_BBS               TEL:(02)8097433   24HR 33,6K
HUB800   39:60/800   The_Duck's_BBS             TEL:(02)2572401   24HR 14,4K
<站  台> 39:60/801   The_Duck's_BBS             TEL:(02)2572401   24HR 33,6K
HUB900   39:60/900   The_Legend_of_Wolves_I_BBS TEL:(02)9978405   24HR 33,6K
<站  台> 39:60/901   The_Legend_of_Wolves_I_BBS TEL:(02)9978405   24HR 33,6K
HUB1000  39:60/1000  Hippo_BBS                  TEL:(03)5926372   24HR 14,4K
<站  台> 39:60/1001  Hippo_BBS                  TEL:(03)5926372   24HR 14,4K
<私人站> 39:60/1002  Soft_Group_BBS             <私人站 不公开>   私人 14,4K
<私人站> 39:60/1003  Century_BBS                <私人站 不公开>   私人 14,4K
<私人站> 39:60/1004  N.L.I.N_BBS                <私人站 不公开>   私人 14,4K
<站  台> 39:60/1005  YA-TO_BBS                  TEL:(03)5339865   24HR 14,4K
<站  台> 39:60/1006  PrOprOprO_BBS              TEL:(03)5316927   24HR 14,4K
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=